Jump to content

[KSP 1.11.0] Physics Range Extender v1.20.0 (20 Jan 2021)


Recommended Posts

47 minutes ago, DirtyVenomSteam said:

Ohp, found a bug, it either relates to KK or the fact I'm using KF Adjustable wheels for my vehicles, either way; Vehicles load inside of KK runways after extending ground loading range.

I recommend to start a new game and test the basics without KK, and then add a new KK static (ensure colliders is activated).

Link to post
Share on other sites
  • 2 weeks later...

Hello everyone! So I just installed the BDArmory mod and this one along, both great mods. Just wondering something: Is it normal that, whenever I launch a new vessel, or switch to another one using the map, the craft (when it´s landed) starts to hover off the ground, kind of cancel its physics for several seconds and proceeds to switch automatically between all vessels and debris in range, while displaying:

"[PhysicsRangeExtender] Extending terrain distance: entangling

[PhysicsRangeExtender] Extending terrain distance: condensing

[PhysicsRangeExtender] Extending terrain distance: releasing energies

[PhysicsRangeExtender] Extending terrain distance: complete" ?

Haven´t seen this issue mentioned nor displayed in any videos, that´s why I find it strange.

Link to post
Share on other sites
33 minutes ago, isaacracos said:

Hello everyone! So I just installed the BDArmory mod and this one along, both great mods. Just wondering something: Is it normal that, whenever I launch a new vessel, or switch to another one using the map, the craft (when it´s landed) starts to hover off the ground, kind of cancel its physics for several seconds and proceeds to switch automatically between all vessels and debris in range, while displaying:

"[PhysicsRangeExtender] Extending terrain distance: entangling

[PhysicsRangeExtender] Extending terrain distance: condensing

[PhysicsRangeExtender] Extending terrain distance: releasing energies

[PhysicsRangeExtender] Extending terrain distance: complete" ?

Haven´t seen this issue mentioned nor displayed in any videos, that´s why I find it strange.

It's not a bug, it's a feature

What is happening when you launch is that all landed vessels are having adjustments made to their altitude so that they do not crash through the surface when loading

This feature was developed to get around the exploding vessel bug that was occurring when vessels are placed at over the stock ground loading distance (15 to 20 km)

Edited by DoctorDavinci
Link to post
Share on other sites
52 minutes ago, DoctorDavinci said:

It's not a bug, it's a feature

What is happening when you launch is that all landed vessels are having adjustments made to their altitude so that they do not crash through the surface when loading

This feature was developed to get around the exploding vessel bug that was occurring when vessels are placed at over the stock ground loading distance (15 to 20 km)

Oh, I see, that clears it up. Thanks!

Link to post
Share on other sites

I just installed BD Armory together with Phyics Range Extender and now when I'm in orbit my vessel starts to wobble/flicker... any idea why? I happens only when Phyics Range Extender is installed.

I read some post above sth about flickering and I'm not sure if those where the same problems

Link to post
Share on other sites
2 minutes ago, Szeperator said:

I just installed BD Armory together with Phyics Range Extender and now when I'm in orbit my vessel starts to wobble/flicker... any idea why? I happens only when Phyics Range Extender is installed.

I read some post above sth about flickering and I'm not sure if those where the same problems

That is completely expected when you have loaded vessels that are at a great distance. With the latest version of PRE you will notice a massive improvement regarding the flickering effect. I recommend to check if you are using the latest version of PRE.

Link to post
Share on other sites
16 hours ago, Szeperator said:

Thx, any technical explanation why this is expected?

Sure, the flickering/shaking effect is the result of the lost of floating point precision with the distance

There is a great article here:

http://davenewson.com/posts/2013/unity-coordinates-and-scales.html

You will not notice this in the stock KSP because actually vessels are getting packed/unloaded as soon as they are 2-20km (depending if the vessel is landed or orbiting) from the active vessel.

Edited by jrodriguez
Link to post
Share on other sites

my apologies in advance if this has already been asked or mentioned, but was the feature to disable the mod removed on the most recent version... and why? I personally found it to be useful... especially on space missions when I am not using BDA/don't need PRE.

I'm sure there's a reason for the change, but I really wish toggling the mod in-game was still an option.

Link to post
Share on other sites

Considering the limitations of unity and KSP itself this is a fantastic mod... But I'm questioning it's practicality in a proper "space program" capacity. The flickering isn't just graphical; It also invokes the Kraken and induces tiny oscillations that, in atmosphere amount to nothing. But in orbital distances, and in space without friction, they get large enough to throw off manouvres, confuse SAS and RCS, and even destabilize the orbits of entities located in the orbit of a planet. Especially if they're small. More to the point, if I have any launched craft low orbit of a planet the glitching gets intense enough to make it difficult to perform manouvres.

However, it's a decidedly unique mod, so before I cull it from my install, I want to know if, and how, there is a way to reduce the physics range extension to levels that don't disrupt my gameplay!

Link to post
Share on other sites
15 hours ago, Cochise said:

my apologies in advance if this has already been asked or mentioned, but was the feature to disable the mod removed on the most recent version... and why? I personally found it to be useful... especially on space missions when I am not using BDA/don't need PRE.

I'm sure there's a reason for the change, but I really wish toggling the mod in-game was still an option.

Hi Cochise I made the decision to remove it because I thought it was something not used.  But to be honest if you reduce the range to 20km and click apply it would more or less "stock".

55 minutes ago, SalemMew said:

Considering the limitations of unity and KSP itself this is a fantastic mod... But I'm questioning it's practicality in a proper "space program" capacity. The flickering isn't just graphical; It also invokes the Kraken and induces tiny oscillations that, in atmosphere amount to nothing. But in orbital distances, and in space without friction, they get large enough to throw off manouvres, confuse SAS and RCS, and even destabilize the orbits of entities located in the orbit of a planet. Especially if they're small. More to the point, if I have any launched craft low orbit of a planet the glitching gets intense enough to make it difficult to perform manouvres.

However, it's a decidedly unique mod, so before I cull it from my install, I want to know if, and how, there is a way to reduce the physics range extension to levels that don't disrupt my gameplay!

Yes, you are right. If you have the default range ( I think it is 200 km?) orbits can be modified by the physics shaking. I suggest to reduce the range until you are happy with the precision.

Link to post
Share on other sites
55 minutes ago, jrodriguez said:

Yes, you are right. If you have the default range ( I think it is 200 km?) orbits can be modified by the physics shaking. I suggest to reduce the range until you are happy with the precision.

Thank you. I'm pretty sure I've found the file, but it reads 

PreSettings
{
	GlobalRange = 500
}

If this isn't the right one then point me to it, please... If not, is this in km or some other value? (EG this would be 500km default range) I want to get this right the first time, because I would love to keep this mod but managing this install has been a headache to the point where I have JUST found this as an issue, and thought my computer was dying!

Link to post
Share on other sites
1 hour ago, SalemMew said:

Thank you. I'm pretty sure I've found the file, but it reads 

PreSettings
{
	GlobalRange = 500
}

If this isn't the right one then point me to it, please... If not, is this in km or some other value? (EG this would be 500km default range) I want to get this right the first time, because I would love to keep this mod but managing this install has been a headache to the point where I have JUST found this as an issue, and thought my computer was dying!

Actually you can change the value from the UI in-grame :) You don't need to touch that file.

You should be fine reducing the range to 50 km.

Link to post
Share on other sites

For some reason the install of this version I had, had no menu in-game. A reinstall fixed that, and now I can adjust ranges on the fly which makes things so very much easier on me. Thank you for your support! Keep on making this mod wonderful; perhaps one day something can be done about the floating point loss limitations.

Link to post
Share on other sites
On 7/10/2018 at 12:35 PM, jrodriguez said:

Hi Cochise I made the decision to remove it because I thought it was something not used.  But to be honest if you reduce the range to 20km and click apply it would more or less "stock".

Yes, you are right. If you have the default range ( I think it is 200 km?) orbits can be modified by the physics shaking. I suggest to reduce the range until you are happy with the precision.

It's 500 default n one thing I can do with this mod is let my mun rover travel on autopilot when I'm on some survey mission in kerbin:D

Absolutely fantastic. 2in 1 missions.

Link to post
Share on other sites
  • 2 weeks later...
6 hours ago, DirtyVenomSteam said:

There seems to be odd stutter when using PRE, I'm not particularly sure why. My range is set to 25km, even at lower ranges (Including 1km) the stutter persists.

uhmm that is strange. If you set the range to 1 km that would make all vessels apart from the active one to get unloaded. I have never seen that effect when there is only one vessel loaded. 

Maybe you can try to switch to others vessels/debris when the range is set to a low value just to ensure that there are no other vessels loaded.

 

Link to post
Share on other sites
10 hours ago, DirtyVenomSteam said:

There seems to be odd stutter when using PRE, I'm not particularly sure why. My range is set to 25km, even at lower ranges (Including 1km) the stutter persists.

KSP.log please ... you can find this file in your KSP directory

Upload your KSP.log to a file sharing site from a game that this issue is happening in as the KSP.log is overwritten each time you start KSP

Off the top of my head ..... you say you have a stutter, do you have other mods installed? .... are you running KSP on a potatoe?

Honestly from the wealth of information you have provided the only thing I can think of is the KSP garbage collection is running overtime which points to a mod being the issue .... try retesting with just PRE installed (and BDAc if you so choose) and see if it continues to happen

I have a sneaky suspicion that running a barebones install with just PRE (and BDAc if you so choose) will cause the stutter you are experiencing go away which if this is the case then it isn't PRE causing you grief

Link to post
Share on other sites
6 hours ago, Project Cygnus said:

So anyway you could make it load the craft in just the launch scene to prevent a massive amount of parts while running while in flight?

Uhm I'm not sure I understood your question.

If a non-active vessel is not loaded then that vessel doesn't really exist from a physics point of view. Thus, that vessel will not be able to fly or to move on the ground.

The main feature that PRE provides is to allow loading all vessels within the range defined.

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...