Twitch2323

Which mods will work with 1.2.9?

Recommended Posts

 I recently purchased the game and after I installed it i realized that every mod i tried to install would cause the game to crash.  I have a friend whos had KSP for a while and I really like BDarmorys' mod. It was one of the deciding factors in purchasing the game.  If anybody knows which mods will work with the new ksp 1.2.9 and if and when BDarmory will be able to be used also, I;d love to hear back asap.  Thank you

 

Share this post


Link to post
Share on other sites
1 hour ago, Twitch2323 said:

 I recently purchased the game and after I installed it i realized that every mod i tried to install would cause the game to crash.  I have a friend whos had KSP for a while and I really like BDarmorys' mod. It was one of the deciding factors in purchasing the game.  If anybody knows which mods will work with the new ksp 1.2.9 and if and when BDarmory will be able to be used also, I;d love to hear back asap.  Thank you

1.2.9 is a pre-release version, i.e. a Beta.  No mods will officially work with it - though some, especially parts mods, might work in practice.  Most mod makers don't work on updates until it's officially released, as there could still be changes made in the version that would break a mod between now and when it is released.

I'd recommend playing with the latest release version, 1.2.2.

Share this post


Link to post
Share on other sites
2 hours ago, Twitch2323 said:

 I recently purchased the game and after I installed it i realized that every mod i tried to install would cause the game to crash.  I have a friend whos had KSP for a while and I really like BDarmorys' mod. It was one of the deciding factors in purchasing the game.  If anybody knows which mods will work with the new ksp 1.2.9 and if and when BDarmory will be able to be used also, I;d love to hear back asap.  Thank you

 

So BDAc has been updated for the KSP v1.2.9 pre-release

You can find the link in the OP of the following thread: 

 

Share this post


Link to post
Share on other sites
9 hours ago, Twitch2323 said:

 I recently purchased the game and after I installed it i realized that every mod i tried to install would cause the game to crash.  I have a friend whos had KSP for a while and I really like BDarmorys' mod. It was one of the deciding factors in purchasing the game.  If anybody knows which mods will work with the new ksp 1.2.9 and if and when BDarmory will be able to be used also, I;d love to hear back asap.  Thank you

Welcome to the forums :)

A frequent cause of mod-induced startup crashes is mistakes while installing the mods. And the most common installation mistake is forgetting dependencies. Since you are a new player, please doublecheck that you in fact installed everything correctly - that you followed the install instructions in the mod threads, grabbed all the dependencies (and followed their install instructions), have all mods reside only inside GameData, do not have multiple nested GameData folders, didn't try to sort your mods in self-created subfolders for ease of organization, and so on.

Share this post


Link to post
Share on other sites

Working for me: Achievements, BetterBurnTime, Chatterer, GravityTurn, ReentryParticleEffect, SmokeScreen, Module Manager 2.7.5

NOT Working: MechJeb 2 (release or dev) - game crashes, Engine Lighting (does nothing), Scatterer - ground breaks away in chunks, and floats around, Texture Replacer - crash on EVA, SpaceY Heavy Lifters - all the VAB part sub-sections are gone; all the parts are shown.

Edited by Balrog
added another mod

Share this post


Link to post
Share on other sites
1 hour ago, Balrog said:

Scatterer - ground breaks away in chunks, and floats around

that sounds amazing, can you interact with the pieces?

Share this post


Link to post
Share on other sites

Stop living in the future and get back to v1.2.2.

It usually takes atleast some time until most major mods have updated, especially since they have other dependencies. Many of them will work straight out of the box, a majority will be updated the next day. Then there are still a noticeable amount of mods that get updated within a month or two. And a few mods never get updated.
There are actually still a few mods out there that only work for v1.1.3 of ksp or even earlier versions. So I even have a downgraded version of ksp for such specific mods.

The v1.2.9 version is only there for 1 reason. For players to beta test the version so they can give feedback to the developers. Although you can also just play stock without mods.
 

Share this post


Link to post
Share on other sites
Quote

The v1.2.9 version is only there for 1 reason. For players to beta test the version so they can give feedback to the developers translate the game for Squad for free

Fixed

Share this post


Link to post
Share on other sites

Ha mods and 1.2.9.!  Im interested in playing only RSS/RO and that behemont of cluster of mods is still in work for updating for current game version. Il never update to 1.2.9+  once RO is 1.2 ready. 

Share this post


Link to post
Share on other sites
On 18.04.2017 at 2:16 AM, Balrog said:

Working for me: Achievements, BetterBurnTime, Chatterer, GravityTurn, ReentryParticleEffect, SmokeScreen, Module Manager 2.7.5

NOT Working: MechJeb 2 (release or dev) - game crashes, Engine Lighting (does nothing), Scatterer - ground breaks away in chunks, and floats around, Texture Replacer - crash on EVA, SpaceY Heavy Lifters - all the VAB part sub-sections are gone; all the parts are shown.

Gosh, not again.

Share this post


Link to post
Share on other sites

And so it begins again. :rolleyes:
Why do people not learn?
 

On 03/04/2017 at 10:27 AM, Twitch2323 said:

If anybody knows which mods will work with the new ksp 1.2.9

Officially: None. None at all.
 

Quote

and if and when BDarmory will be able to be used also, I;d love to hear back asap.

When BDarmory is ready, and not a moment before. See rule 2.2p, it applies to mods as well.
 

54 minutes ago, Ser said:

Gosh, not again.

This^^^

Can we not have this crapstorm again? Please?
Every update, hordes of impatient people start hassling modders for updates. :mad: This is why modders get liquided off and leave.
If I were supporting any mods, I'd be implementing a version lock to completely disable them on 1.2.9 right about now.
I'm fervently hoping someone in charge of one of the core dependency mods does this... like, say, ModuleManager for example...

1.2.9 is a prerelease. Don't mod it, and don't ask about mods for it. If to want to run mods, use a compatible released version of KSP. Right now that means 1.1.3 or 1.2.2.

Edited by steve_v

Share this post


Link to post
Share on other sites

Thas why i dont offer prerelase versions on SpaceDock.
Prereleases are, in my opinion, also for mod devs to get their mods working, so theyre ready when the "stable" version gets released.

I can understadn that some get carried away by all that shiny new stuff thats in prerelease versions and that they simply want shiny new mod versons to go with it. But yeah, i too want a 2027 PC now for the price of a 2007 one :)

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.