• 0
kolmansverre

Help ksp won't load

Question

Yo guys, I have a problem.

When I start my KSP up it won't load. It stuck always at "Loading Asset Bundle Definitions." I'm playing on Mac so i checked every folder like "parts" and "sounds" but there is nothing at all in it. So yeah idk what to do. I downloaded it a couple of times again, but every time I have the same problem. Does anyone know what to do?

Thanks!

Share this post


Link to post
Share on other sites

9 answers to this question

Recommended Posts

  • 0
16 minutes ago, Gameslinx said:

How did you fix it? I have the same issue, and a painful slow load time.

First go to your aplications folder. Then, do command, left click and drag the KSP folder out of the aplications folder. And than simply  drag it back in. If you've done that, it should work

Share this post


Link to post
Share on other sites
  • 0

Hi Kolmansverre, welcome to the forums, I'm moving this to the technical support subforum.

Share this post


Link to post
Share on other sites
  • 0
48 minutes ago, Noobton said:

Hi Kolmansverre, welcome to the forums, I'm moving this to the technical support subforum.

Alright thanks a lot :)

Share this post


Link to post
Share on other sites
  • 0

Can't provide a 100% solution to your problem, however please note similar issues with Mac OS are routinely shown and answered (e.g., this one could be matching your prob). Reading threads on Tech Support (unmodded) will let you find a lot others, quite probably your issue is already covered.

Should nothing in there help, please note we need more info to actually provide support: these guidelines give the basics on how to ask properly, as you see there's quite some amount of info suggested that should help us help you. However, what I always suggest with issues at loading time, is to also link a copy of the KSP.log file (under KSP root directory), that file has the unique benefit of showing exactly how each file is being treated while KSP loads and often allows to exactly spot a troublesome file.

Share this post


Link to post
Share on other sites
  • 0
47 minutes ago, diomedea said:

Can't provide a 100% solution to your problem, however please note similar issues with Mac OS are routinely shown and answered (e.g., this one could be matching your prob). Reading threads on Tech Support (unmodded) will let you find a lot others, quite probably your issue is already covered.

Should nothing in there help, please note we need more info to actually provide support: these guidelines give the basics on how to ask properly, as you see there's quite some amount of info suggested that should help us help you. However, what I always suggest with issues at loading time, is to also link a copy of the KSP.log file (under KSP root directory), that file has the unique benefit of showing exactly how each file is being treated while KSP loads and often allows to exactly spot a troublesome file.

Alright I will try that. Thanks a lot :))

 

Share this post


Link to post
Share on other sites
  • 0
2 hours ago, kolmansverre said:

I fixed it! Thanks for the help! Now I can finally go on killing kerbals :)))

 

How did you fix it? I have the same issue, and a painful slow load time.

Share this post


Link to post
Share on other sites
  • 0
2 minutes ago, kolmansverre said:

First go to your aplications folder. Then, do command, left click and drag the KSP folder out of the aplications folder. And than simply  drag it back in. If you've done that, it should work

Ah. I'm on windows. I'll just uninstall and reinstall - I'm getting slow loads and someone else is as well.

Might be a windows update breaking something

Share this post


Link to post
Share on other sites
  • 0

Hi @kolmansverre I have marked your self found answer as the solution. On MacOS Sierra, the security settings are more strict, and gatekeeper is blocking access to the files. By moving and then replacing these files, the filesystem now sees these as safe and does not quarantine them. 

This should no longer be an issue in KSP 1.2.9 on Sierra, but alas this workaround is still necessary on 1.2.2

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.