Jump to content

[1.11] CommNet Constellation v1.5.7 [10 January 2021] - Beta 4 of CNC+CNM for KSP 1.12.2!


TaxiService
 Share

Recommended Posts

I think I have found a minor visual bug...

4cuOQG2.png

In the above screenshot you see 3 sats of my Mun network. They have each one direct antenna, connected to the Kerbin network and one relay antenna to the Mun network.

Direct antennas  cannot connect to each other, so the green lines forming a triangle around the Mun should not exist.

 

RFQOpmM.png

2nd screenshot: Mun network visible when Kerbin Network is hidden.

 

I'm using the CKAN 1.5.7 version.

Link to comment
Share on other sites

On 7/14/2021 at 2:27 AM, maculator said:

I got a noob question:

If I make contact via two direct antennas at frequency 0 can I then forward the signal using a relay to ground/relay connection at another frequency? Or do I need to have relays all the way down the connection path?

Hi, yes, your understanding is correct. A relay will forward the signal from 1 frequency to another frequency.

It is actually not governed by CNC so it is nice bonus feature.

On 7/14/2021 at 2:27 AM, thunder175 said:

Tracking this question from the other day since I was curious about this also. I just tried doing as suggested on a modified cnc_settings.cfg file where I delete all the stock ground station sites, save for two custom entries. I started a new game to test, and indeed when clicking off extra ground stations, only KSC still appears. However, when turning this feature back on everything, including the stock sites (ie Baikerbanur, etc) return. I checked the persistent file and all those entries were added despite not being included in the cnc_settings file. It appears that the game is still inserting the ground station sites as 'extras' along with any defined in cnc_settings file. Is it possible to add a GUI option in the game settings for CNC to override any and all stock groundstations and only use what is defined in cnc_settings?

Yes, those stock stations are forcingly inserted by CommNet when the extra station setting is ticked. I cannot prevent this because it was hardcoded in CommNet behaviour. You will have to tick off this setting.

On 7/15/2021 at 11:43 PM, jinks said:

I think I have found a minor visual bug...

In the above screenshot you see 3 sats of my Mun network. They have each one direct antenna, connected to the Kerbin network and one relay antenna to the Mun network.

Direct antennas  cannot connect to each other, so the green lines forming a triangle around the Mun should not exist.

2nd screenshot: Mun network visible when Kerbin Network is hidden.

I'm using the CKAN 1.5.7 version.

I tested 3 vessels with direct antennas only and they don't make contact with each other, apart from connecting to KSC.

g7eGZK3.png

Can you double-check if you have any other CommNet mod installed?

Link to comment
Share on other sites

2 hours ago, TaxiService said:

Can you double-check if you have any other CommNet mod installed?

Only a contact pack and some extra antennas.

 

Can you test again with the direct antennas and some relays on another channel? - I don't think it creates wrong connections, I think I only colors the relay connection wrongly as the primary network.

Link to comment
Share on other sites

3 hours ago, TaxiService said:

Yes, those stock stations are forcingly inserted by CommNet when the extra station setting is ticked. I cannot prevent this because it was hardcoded in CommNet behaviour. You will have to tick off this setting.

So if using the commnet subsystem its either all or nothing from the backend code? Well that wasn't very nice of them. I'm guessing other mods like Kerbinside and RealAntennas get around that by effectively replacing the commnet system with their own? 

Link to comment
Share on other sites

23 hours ago, jinks said:

Only a contact pack and some extra antennas.

 

Can you test again with the direct antennas and some relays on another channel? - I don't think it creates wrong connections, I think I only colors the relay connection wrongly as the primary network.

From what I tested on direct and relay antennas, I think you are right on color. On full strength, it will show the chosen color but towards 1 strength bar, the redness will be shown. This is the behaviour of stock CommNet

This image shows on the outer comm ring, low-strength (more redness) direct connections between all 4 vessels, each with 1 direct antenna of 500k and 1 relay antenna of 5M on green-color channel "Two".

mfPvddI.png

If this is not correct, I need more details so that I can replicate on my side.

22 hours ago, thunder175 said:

So if using the commnet subsystem its either all or nothing from the backend code? Well that wasn't very nice of them. I'm guessing other mods like Kerbinside and RealAntennas get around that by effectively replacing the commnet system with their own? 

I took a look at the codebase of RealAntennas and it indeed replaces the commnet system with its own by deleting all stock ground stations and creating new stations. This is not something I would like to do because CNC is intended to enhance the stock commnet system.

Link to comment
Share on other sites

On 7/18/2021 at 6:24 PM, TaxiService said:

If this is not correct, I need more details so that I can replicate on my side.

It's not about the signal strength, it's about the constellation color.

Here's another picture where I avoided the green->yellow->red colors:

riFb0nU.png

Each of the three equatorial sats has 2 antennas:

g0t7BBK.png

The DTS-J1 is a 2.00G direct antenna connecting to my relay sats in Keostationary orbit.

The HG-32 is a relay antenna maintaining the Mun network.

 

What I don't get is, why the the three equatorial relays have pink lines between each other. Their pink antenna should only be able to connect back to the Kerbin constellation.

The unrelated polar satellite properly uses the purple constellation to relay through the mun network.

I would expect the relay sats to have pink lines back to Kerbin and purple lines to each other.

Edited by jinks
Link to comment
Share on other sites

On 7/21/2021 at 7:14 AM, jinks said:

It's not about the signal strength, it's about the constellation color.

Here's another picture where I avoided the green->yellow->red colors:

 

Each of the three equatorial sats has 2 antennas:

 

The DTS-J1 is a 2.00G direct antenna connecting to my relay sats in Keostationary orbit.

The HG-32 is a relay antenna maintaining the Mun network.

 

What I don't get is, why the the three equatorial relays have pink lines between each other. Their pink antenna should only be able to connect back to the Kerbin constellation.

The unrelated polar satellite properly uses the purple constellation to relay through the mun network.

I would expect the relay sats to have pink lines back to Kerbin and purple lines to each other.

Thanks for the screenshots. I replicated your exact scenario on my side.

I think these 3 relays actually have direct-relay (purple) or relay-relay (purple) connections between each other but are shown as wrong colour (pink) instead of purple.

I need more tests on this to be sure before I fix this.

Thanks

Link to comment
Share on other sites

14 minutes ago, TaxiService said:

I think these 3 relays actually have direct-relay (purple) or relay-relay (purple) connections between each other but are shown as wrong colour (pink) instead of purple.

YES! That's exactly what I thought. Sorry I couldn't word it better in the first place.

Curiously my satellites around Kerbin don't do that, they have pink lines between each other and blue (999, DSN constellation) lines down to the ground stations.

Link to comment
Share on other sites

23 hours ago, jinks said:

YES! That's exactly what I thought. Sorry I couldn't word it better in the first place.

Curiously my satellites around Kerbin don't do that, they have pink lines between each other and blue (999, DSN constellation) lines down to the ground stations.

Do share the antenna setup of those Kerbin satellites. I want to know what makes them different from the Mun ones.

Thanks!

Link to comment
Share on other sites

24 minutes ago, TaxiService said:

Do share the antenna setup of those Kerbin satellites. I want to know what makes them different from the Mun ones.

Sure, no problem.

tDm0plx.png

A bit cramped, but it should show what you need.

4 stationary sats with 2 "clients" in low orbit and the 3 Mun sats connecting. They use the "Kerbin" (1300) constellation among each other and talk to ground via a direct connect over the AX-04 (Near Future antenna, direct, 40k rating).

Edited by jinks
Link to comment
Share on other sites

On 7/24/2021 at 12:12 AM, jinks said:

Sure, no problem.

 

A bit cramped, but it should show what you need.

4 stationary sats with 2 "clients" in low orbit and the 3 Mun sats connecting. They use the "Kerbin" (1300) constellation among each other and talk to ground via a direct connect over the AX-04 (Near Future antenna, direct, 40k rating).

Thanks, I fixed this bug.

You can try out the latest build of CNC+CNM.

Link to comment
Share on other sites

  • 3 weeks later...

Hi I got a quick question:

Is it normal to not have to use any relay capable antennas?!

Spoiler

KfRrD80.png

In this picture the craft on the dark side of the mun only has a normal communotron wich is then "relayed" via a 88 above or below the mun and then from kerbins pole via a nother 88 to a keo relay (the only antenna in this path that actually is a relay capable antenna) wich bounces the signal to the ksc...

I always thought I had to use relays.

 

Edit:

This is in sandbox. In career it seems to need a relay?! I'm confused. Is there documentation to watch or read?

Edited by maculator
Link to comment
Share on other sites

Is ist possible that the game doesn't care about frequencies when determining the ranges?

It seems to me it handels that aspect as if all antennas contribute to all frequencies.

Here is my little test:

- 1. Groundstation (the only one) KSC at freq. 1

- 2. Vessel 1 on runway with RA-2 at freq. 1 and communotron 16 at freq. 0

- 3. Vessel 2 28Mm up in orbit with communotron 16 at freq 0

Result: a connection.

That looks like the RA-2 is helping the communotron "a fair bit".

Link to comment
Share on other sites

This mod rocks!

The stock behavior tends to prefer fewer hops to stronger signal or Kerbalism data rates, which is quite annoying for Kerbalism science transmission. Sometimes a LKO vessel at the backside is reluctant to connect through local KSO relays, it instead relays through Mun with very weak signal just because it takes only one less hop!

Maybe we can advertise this mod to the Kerbalism team?

Edited by Apricot
Link to comment
Share on other sites

10 hours ago, Apricot said:

Sometimes a LKO vessel at the backside is reluctant to connect through local KSO relays, it instead relays through Mun with very weak signal just because it takes only one less hop!

shouldn't those be on different channels then so they can't talk to each other?

Link to comment
Share on other sites

4 hours ago, Drew Kerman said:

shouldn't those be on different channels then so they can't talk to each other?

Totally. That's what this mod achieves. I was just complaining about stock CommNet behavior.

Link to comment
Share on other sites

  • 1 month later...

@TaxiService, I think I've found a bug on ground station upgrades applying across saves.  When I do the "free" upgrade of a ground station in a Sandbox save, it populates that upgrade across a previously existing Career mode save.  The frequency assignments are not carrying over (which is good, otherwise one save would screw up the assignments of others).

This anomaly does *not* carry over to a new Career mode save (one started after the last Sandbox ground station edits), but adding more upgrades in Sandbox will then apply to the newer Career save, but *not* the older one.  Which makes me think it's a Persistence file pathname bug.  I think it's applying the changes to the next opened save file.

It does not get cleared out by uninstalling CNC, running without it, and re-installing a clean copy of CNC (which I guess is good, so every in-save upgrade paid for doesn't get lost after a CNC mod upgrade).

I'm using KSP 1.12.2 x64 with MH 1.12.1 and BG 1.7.1 and CommNetConstellation_PatchedCommNetManager_26July2021.  I've got plenty of other mods (but not RemoteTech), and I haven't yet tried uninstalling to go mod-by-mod looking for an outside cause.  This should be fairly fast to replicate on any instance of KSP 1.12.2 with Expansions though.

STEP 1: Start a new Career save.  Check ground stations (none should be upgraded).

STEP 2: Start a new Sandbox Save.  Start upgrading a few ground stations.

STEP 3: Go back and check previous Career save; see if Sandbox ground stations have now carried over.

The simplest band-aid fix for this may be to have Sandbox mode always start with all ground stations fully upgraded, that way there are no upgrade modifications that can be applied to other save files.  But the cleaner solution may be force it to use the correct full pathname of the save when it's doing the upgrade, if that's possible.  I don't know if any of this applies to a Science mode save.

EDIT 1: Lacking a fix, is there a way to edit the appropriate file or, better yet, have a "cheat" mode window to arbitrarily remove (or add) upgrades to a save?

Edited by KSPrynk
Link to comment
Share on other sites

  • 2 weeks later...

OK. I read your tutorial on page ??, but I didn't understand how to set things up. Has anyone got a guide as to what to do?

I'm getting red text with "Specified cast is not valid".

--edit

Seems to have been a conflict with another mod. I didn't have RT, so, now adding back mods gradually...

Edited by SmarterThanMe
Link to comment
Share on other sites

  • 1 month later...
  • 3 weeks later...
On 11/3/2021 at 10:52 PM, Grimmas said:

Yes.

I'm not sure it does properly. I had alot of error messages and fps tanks with it in its current version. Not sure if it is a compatibility issue or not. Will need to investigate but I don't want to post bugs on a mod that is not up to date anyway. 

Edited by dave1904
Link to comment
Share on other sites

7 hours ago, dave1904 said:

I'm not sure it does properly. I had alot of error messages and fps tanks with it in its current version. Not sure if it is a compatibility issue or not. Will need to investigate but I don't want to post bugs on a mod that is not up to date anyway. 

1.12 was released in June. The most current version of CNC on GitHub was released in July. (which appears to be when @TaxiService was last on the forum) The userbase for this mod has been running it for several months without reports of issues, so it may be unique to your installation. The last full release was on 1.11, and there weren't a lot of breaking changes between 1.11 and 1.12 - now that there will be no more major versions of KSP,  most of the mod makers are in maintenance mode.  The issues you have in any mod aren't likely to be fixed if you wait for it to be updated before raising the issue in the thread or on GitHub. Providing logs in this thread would help, as other members might identify known incompatibilities.

and "clutter" in a thread isn't so much of an issue now that the main program development has wrapped up.

Link to comment
Share on other sites

Hi @panarchist, Thanks for the ping.

Hi all, sorry for my prolonged absence. My graphic card is dying since last August, and the integrated GPU in my 2015 Intel CPU is not great. I am not able to find a reasonable graphic card replacement in light of the on-going global chip shortage.

Basically, I had to pause my mod development and fixing on hold for the time being. But what I can do over this weekend is to re-compile, check if it starts with no error, and release another beta of CNC+CommNet Manager for latest KSP 1.12.2.

Also, do let me know if you would like another official CNC release without CommNet Manager i.e. 1.5.8 after last official version 1.5.7.

Thanks

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...