TaxiService

[1.7.1] CommNet Constellation v1.4 [5 June 2019]

Recommended Posts

On 3/4/2019 at 11:38 PM, DStaal said:

I don't necessarily think he was arguing that the mod itself should change model (and I'd argue against it, personally) - more he was writing a how-to if a player wanted to use the mod to create something more difficult for themselves.  It's a sign of a good mod that it can be used this way, even if it's not the main focus/configuration of the mod.

Oh, thanks for clarification. I need to read his post again and think about it.

On 3/16/2019 at 11:57 PM, Raccoon said:

A few questions! Can you set specific antennas to specific frequencies from the tracking station? I can see there's the radio buttons to select and deselect them but there's no way to change their frequency from the menu other than master frequency which isn't helpful. Would be extremely useful since switching to my satellites to do it manually screws up their perfect orbits achieved using StationKeeping.

Second question, as I'm quite a noob at this, if I set my Mun and Minmus networks to their respective frequencies and make them only talk to their members, how do I connect them back to KSC? I assume that I have to allow them to communicate with a second frequency to do that, thus the above question, but maybe I'm doing something stupid and not realising it. Setting them to allow talking to the Public constellation makes them just scream at every vessel in range and that's not what I'm looking for, so I'm assuming I need direct antennas set to 0 or whatever my Kerbin network is, then the relay antennas to whatever the Mun/Minmus network is?

Yes, you can change the frequency of each antenna to the tracking station's frequency. As shown in this picture below, right click the desired antenna and open up the antenna setup.
AsQoX0z.png Re0mAXR.png

For your second question, how about adding the Mun and Minmus frequencies to the KSC's frequency list? Your moon networks will directly connect to KCS if they have sufficient antenna power.Dhf2tZq.png

 

Share this post


Link to post
Share on other sites
2 minutes ago, TaxiService said:

Yes, you can change the frequency of each antenna to the tracking station's frequency. As shown in this picture below, right click the desired antenna and open up the antenna setup.
AsQoX0z.png Re0mAXR.png

I was wondering if there's a way to do this without switching to the vessel, from the Tracking Station constellations menu, but I assume not then. Would be extremely helpful to avoid precise satellite orbits from changing and messing up on load.

3 minutes ago, TaxiService said:

For your second question, how about adding the Mun and Minmus frequencies to the KSC's frequency list? Your moon networks will directly connect to KCS if they have sufficient antenna power.

Oh, that's a good idea. Won't work for further away networks but it's good enough for Mun and Minmus networks!

Share this post


Link to post
Share on other sites

My bad, I misread your first question. There isn't any way to edit the frequency of each antenna from Tracking Scene or another flight scene. However, if you are brave, you can edit Frequency under CNConstellationAntennaModule block of your vessel in your save file (persistent.sfs)

Share this post


Link to post
Share on other sites
20 minutes ago, TaxiService said:

Second question, as I'm quite a noob at this, if I set my Mun and Minmus networks to their respective frequencies and make them only talk to their members, how do I connect them back to KSC? I assume that I have to allow them to communicate with a second frequency to do that, thus the above question, but maybe I'm doing something stupid and not realising it. Setting them to allow talking to the Public constellation makes them just scream at every vessel in range and that's not what I'm looking for, so I'm assuming I need direct antennas set to 0 or whatever my Kerbin network is, then the relay antennas to whatever the Mun/Minmus network is?

What I do is have a few dedicated relay satellites that have antennas with both the local network and a network that connects back to Kerbin.  (Often through a 'relay' network that's just for them - and ends with a couple of sats with high-power antennas around Kerbin that then have antennas that can connect to the ground stations.)

Share this post


Link to post
Share on other sites
12 minutes ago, TaxiService said:

My bad, I misread your first question. There isn't any way to edit the frequency of each antenna from Tracking Scene or another flight scene. However, if you are brave, you can edit Frequency under CNConstellationAntennaModule block of your vessel in your save file (persistent.sfs)

It's alright, I appreciate the answers! Any chance for an update to allow changing antenna frequency? Worth a try asking!

3 minutes ago, DStaal said:

What I do is have a few dedicated relay satellites that have antennas with both the local network and a network that connects back to Kerbin.  (Often through a 'relay' network that's just for them - and ends with a couple of sats with high-power antennas around Kerbin that then have antennas that can connect to the ground stations.)

I'm thinking I'll have a relay network surrounding Kerbin that connects to all other networks and KSC, yeah. Seems the simplest solution and would hopefully look really nice too on top.

Share this post


Link to post
Share on other sites
On 3/18/2019 at 11:42 PM, Raccoon said:

It's alright, I appreciate the answers! Any chance for an update to allow changing antenna frequency? Worth a try asking!

Here you go. Enjoy!

Share this post


Link to post
Share on other sites
On 3/20/2019 at 4:14 PM, TaxiService said:

Here you go. Enjoy!

Holy crap woah, I did not expect my request to work, let alone have the update be perfect, thank you so much!

Share this post


Link to post
Share on other sites

Good day can anyone explain this mod to me? I'm looking for a more immersive experience. Stock comment gives me little to no reason to establish a network beyond a few satellites in orbit. How exactly does this mod work. Is there signal delay? Can satellites only communicate with their constellation? How does the frequency work? Can only a few travel long distances? Anyone got a video explaining it? Thanks :D

Share this post


Link to post
Share on other sites
24 minutes ago, The-Doctor said:

Good day can anyone explain this mod to me? I'm looking for a more immersive experience. Stock comment gives me little to no reason to establish a network beyond a few satellites in orbit. How exactly does this mod work. Is there signal delay? Can satellites only communicate with their constellation? How does the frequency work? Can only a few travel long distances? Anyone got a video explaining it? Thanks :D

No signal delay.  Antennas can only communicate with their constellation/frequency.  (Satellites can have multiple antennas.)  Frequency is set on a per-antenna basis, as is basically the same as constellation.  (There are tools to set on a shipwide basis as well - but that just sets all the antenna.)  Distance is by the antenna in question: Some have more power than others, but that's just stock.  ;)

I'm sure there's videos out there explaining it.  CommNet is more immersive than Stock, but less realistic than RemoteTech.  (Which includes signal delay, and antenna orientation among other features.)

Share this post


Link to post
Share on other sites

CommNet Constellation 1.3.2 is out for KSP 1.7

  • Color Picker can parse your hex color string
  • Fixed issue of CommNet Range Multiplier not affecting Antenna Power
  • New tool to edit individual antennas' frequencies without going into Flight Scene  

Linky 

Spoiler

What's new?

  • Recompiled for KSP 1.7
  • Updated ModuleManager to 4.0.2
  • Color Picker can parse your hex color string
  • Fixed issue of CommNet Range Multiplier not affecting Antenna Power
  • New tool to edit individual antennas' frequencies without going into Flight Scene

Requirements

  • ModuleManager
  • Kerbal Space Program 1.7

Known issues

  • Issue #2 - White connections caused by combinations of other mods
  • Issue #8 - Deteriorated performance on a large number of mods

 

Share this post


Link to post
Share on other sites
5 hours ago, TORCHFORMANKIND said:

Is it make RemoteTech EASY?or NOT?

It has nothing to do with RemoteTech. In fact, I think the 2 mods are incompatible with each other. 

Share this post


Link to post
Share on other sites

Hello! Been having an issue with this mod ever since I got it.

KSP Version: 1.7
Mod Version: 1.3.2
Consolehttps://pastebin.com/mkuJrhVv

My problem is I have zero connection to anything, at any given time, with any amount of parts, even when setting everything up in the VAB first. I am new to this mod but this has made my experience lackluster to say the least. Nothing will link up, on any frequency, and if I have anything on the launchpad, flying, in orbit, docked, that has the ability to RXTX the menu for the mod breaks entirely and it will not show anymore. Once I retrieve or destroy the ships, the menu works again, but it is all a lie since it isn't actually doing anything.

I have tried this with a fresh save, resetting KSP to defaults, to no avail.

If anyone can help me, that would be greatly appreciated! I look forward to hearing back soon, in the mean time, I will continue testing.

Share this post


Link to post
Share on other sites
11 hours ago, bulletrhli said:

Hello! Been having an issue with this mod ever since I got it.

KSP Version: 1.7
Mod Version: 1.3.2
Consolehttps://pastebin.com/mkuJrhVv

My problem is I have zero connection to anything, at any given time, with any amount of parts, even when setting everything up in the VAB first. I am new to this mod but this has made my experience lackluster to say the least. Nothing will link up, on any frequency, and if I have anything on the launchpad, flying, in orbit, docked, that has the ability to RXTX the menu for the mod breaks entirely and it will not show anymore. Once I retrieve or destroy the ships, the menu works again, but it is all a lie since it isn't actually doing anything.

I have tried this with a fresh save, resetting KSP to defaults, to no avail.

If anyone can help me, that would be greatly appreciated! I look forward to hearing back soon, in the mean time, I will continue testing.

Hi,

On your fresh save, how did you build a vessel with antennas in VAB? I greatly appreciate this if you can give reproducible steps on a fresh save.

The error dump you linked said the mod crashed when accessing the global vessel list (presumably with your vessel launched from VAB) from the game when you opened the constellation control panel in Tracking Station.

Share this post


Link to post
Share on other sites
1 hour ago, TaxiService said:

Hi,

On your fresh save, how did you build a vessel with antennas in VAB? I greatly appreciate this if you can give reproducible steps on a fresh save.

The error dump you linked said the mod crashed when accessing the global vessel list (presumably with your vessel launched from VAB) from the game when you opened the constellation control panel in Tracking Station.

On the new save I was building crafts as normal. I did do some testing with just a probe, power, and EVERY type of antenna, made sure I had the right frequencies, and yet, there was no connection.

Upon further testing, I may have solved the issue for myself. I had another mod which added delay to signals, so certain properties were modified on top of your modifications. Upon removing and resetting everything, your mod worked as intended. I had not realized at the time the interaction would be an issue since I thought the Comm Network system was separate and didn't touch any of the information inside the antenna modules

Share this post


Link to post
Share on other sites
12 minutes ago, bulletrhli said:

Upon further testing, I may have solved the issue for myself. I had another mod which added delay to signals, so certain properties were modified on top of your modifications. Upon removing and resetting everything, your mod worked as intended. I had not realized at the time the interaction would be an issue since I thought the Comm Network system was separate and didn't touch any of the information inside the antenna modules

For future reference, what was the other mod?

Share this post


Link to post
Share on other sites
22 hours ago, bulletrhli said:

For sure! Its called Signal Delay

Yup, I replicate your issue with Signal Delay.

It has own CommNetVessel subclass like CNC mod's own CommNetVessel subclass, causing mod conflict at your side.

I added a new generic error message telling mod conflict to the CNC codebase for easier diagnosis.

Thanks for reporting this mod conflict.

Share this post


Link to post
Share on other sites
1 hour ago, TaxiService said:

Yup, I replicate your issue with Signal Delay.

It has own CommNetVessel subclass like CNC mod's own CommNetVessel subclass, causing mod conflict at your side.

I added a new generic error message telling mod conflict to the CNC codebase for easier diagnosis.

Thanks for reporting this mod conflict.

You're welcome! Glad I could help.

Is there any chance signal delay will be added to your mod in the future? I understand RemoteTech has it but I don't want to use it (at this time).

Share this post


Link to post
Share on other sites
Posted (edited)
22 hours ago, bulletrhli said:

You're welcome! Glad I could help.

Is there any chance signal delay will be added to your mod in the future? I understand RemoteTech has it but I don't want to use it (at this time).

I am not sure about the error now. The error I replicated yesterday is happening in KSP Dev build only, and is different from your error. My error is about Signal Delay's FixedUpdate() not CommNetVessel nature.

On official KSP release build, both CNC 1.3.2 and Signal Delay 0.2.9 work fine together, as shown below.
wEC77h2.png

Can you check again at your end after downloading the latest CNC build (linky)?

Edited by TaxiService

Share this post


Link to post
Share on other sites
Posted (edited)
6 hours ago, TaxiService said:

I am not sure about the error now. The error I replicated yesterday is happening in KSP Dev build only, and is different from your error. My error is about Signal Delay's FixedUpdate() not CommNetVessel nature.

On official KSP release build, both CNC 1.3.2 and Signal Delay 0.2.9 work fine together, as shown below.

Can you check again at your end after downloading the latest CNC build (linky)?

I can't say I am having similar results. Upon testing, yes, the menu's did work again, but I have three issues that present themselves:

  1. Limited probe control 
  2. When using the part right click menu during flight, the CNC Communication button causes a total control lockout of the game and I must force close to regain control. Here is the console log (striped down for brevity) https://pastebin.com/awfrskeb
  3. Active vessels with a antenna, in line of sight, and multiple frequency's test test them all, do not appear in my menu. This plays possibly back into issue number 1. It doesn't recognize them. Technically there is no error, so no log can be provided.

== EDIT ==

It appears I had some logging off and I noticed that when switching between vessels I got this error. https://pastebin.com/LmLEFSXd

With that said, it KNOWS I have the vessels and they have power and the ability to txrx yet they are not populated in your mod gui and have limited control like I mentioned previously.

Edited by bulletrhli
Extra details

Share this post


Link to post
Share on other sites

@bulletrhli Your point 2 is not bug. This is the popup property of blocking everything except the popup area until the popup is dismissed.

What are your list of mods? It seems there is an external interference because I see no conflict between Signal Delay and CNC on my side (KSP+CNC+SD only) so far.

Share this post


Link to post
Share on other sites
Posted (edited)
6 hours ago, TaxiService said:

@bulletrhli Your point 2 is not bug. This is the popup property of blocking everything except the popup area until the popup is dismissed.

Understandable, however in my instance, there was no popup, so everything was blocked and unable to be corrected.

Quote

What are your list of mods? It seems there is an external interference because I see no conflict between Signal Delay and CNC on my side (KSP+CNC+SD only) so far.

RfzjxHE.png

Edited by bulletrhli

Share this post


Link to post
Share on other sites
11 hours ago, bulletrhli said:

Understandable, however in my instance, there was no popup, so everything was blocked and unable to be corrected.

RfzjxHE.png

FYI, you can export your installed mods to a shareable .ckan file
NzSJ1Lh.png

The error requires BetterBurnTime, CNC and Signal Delay to happen. If I remove BBT, CNC works fine. If I remove Signal Delay, CNC works fine.

I am not even sure if I can resolve this combination.

You may have to remove BBT.

Share this post


Link to post
Share on other sites
Posted (edited)
On 5/25/2019 at 2:21 AM, TaxiService said:

FYI, you can export your installed mods to a shareable .ckan file
NzSJ1Lh.png

Interesting, wasn't aware of this functionality.

Quote

The error requires BetterBurnTime, CNC and Signal Delay to happen. If I remove BBT, CNC works fine. If I remove Signal Delay, CNC works fine.

I am not even sure if I can resolve this combination.

You may have to remove BBT.

Alright, not a big loss. Will do further testing with your conclusion and report on my results later! Thanks for helping btw, this has been great support.

[ UPDATE ]

Upon further testing with your suggestion, things are working perfectly. Removing BBT from my list has thus far been the most effective.

Edited by bulletrhli
Update

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.