TaxiService

[1.7.1] CommNet Constellation v1.4 [5 June 2019]

Recommended Posts

4 hours ago, drtedastro said:

thanks for a great mod.

really good stuff.

Hey, is there anyway or any setting so that the comm-net does not use stations that require the signal to go through the planet / moon?

this happens with the stock, ksp comms, but i wanted to ask here as i thought if anyone would know, it would be y'all...

cheers and thanks again....

Do you mean this occlusion setting of CommNet? Set to the max value and connections will not penetrate planet/moon surface.

66ho7QL.png

Share this post


Link to post
Share on other sites

Hey, I'm trying to make a new type of antenna that will communicate only with others like itself and it seems like CommNet:SetNodeConnection() is the place to force it to deny other connections. But that would require me to make a subclass of CommNet with just the one override. What happens if there are multiple subclasses of CommNet running at the same time (i.e. this mod and my antenna installed simultaneously)? Does the game just check all of them?

Thanks!

Share this post


Link to post
Share on other sites

Could it be that setting the occlusion slider to max. make all antennas have "Status: Locked" ?

This is my problem actually ... ;.;

Searching the board and Google gives me old threads from 2015 ...

Share this post


Link to post
Share on other sites

Never seen this before...TAKE ALL MY REP! XD

p.s. this will make satellite managing 100 times easier, thanks!

Share this post


Link to post
Share on other sites
17 hours ago, Booots said:

Hey, I'm trying to make a new type of antenna that will communicate only with others like itself and it seems like CommNet:SetNodeConnection() is the place to force it to deny other connections. But that would require me to make a subclass of CommNet with just the one override. What happens if there are multiple subclasses of CommNet running at the same time (i.e. this mod and my antenna installed simultaneously)? Does the game just check all of them?

Thanks!

With two or more CommNet subclasses, there would be conflict among host mods and KSP will pick one out of those to run.

16 hours ago, Gordon Dry said:

Could it be that setting the occlusion slider to max. make all antennas have "Status: Locked" ?

This is my problem actually ... ;.;

Searching the board and Google gives me old threads from 2015 ...

I do not think your issue of antennas being locked is related to the occlusion. This occlusion tests on the line of sight between two points

It seems to there are multiple causes to lock antennas - RT, time acceleration, within fairing, part clipping, old UI bug :-/

Share this post


Link to post
Share on other sites

Neat. That means the chance of an antenna being locked is 90%.
Actually I guess it's the old bug.
But what's the trigger?

Ask the wise devs of Unity modding API... :sticktongue:

Share this post


Link to post
Share on other sites

Can You Set It Up So That When Naming And Setting Up A Vessel or Network, That Typing Only Affects The UI Because As Of Now, When I Hit 1 or 2, 3 etc, i trigger My action Groups or switch views and other fun stuff like that, also if this isnt already in and im just blind, PLEASE make it so we can set up the default Net for a vessel In the VAB or SPH 

 

Thanks for the great mod 

Sorry about spelling my autocorrect is drunk today

@TaxiService

Edited by Mark Kerbin

Share this post


Link to post
Share on other sites

I have tested this mod out, with Kerbalism. Kerbalism completely erases this mod

Share this post


Link to post
Share on other sites

Also In My Earlier Post I Mentioned The Need For A Build Screen UI. I Check And Its Not There So Im Not Blind, But Adding That Would Prevent NEEDING To Set Up Vessels After Launch. Until That Happens Im Going To Uninstall, Because i keep liquiding myself of trying to not trigger actions groups.

 

Still A Good Mod Tho

Share this post


Link to post
Share on other sites
15 hours ago, Mark Kerbin said:

Can You Set It Up So That When Naming And Setting Up A Vessel or Network, That Typing Only Affects The UI Because As Of Now, When I Hit 1 or 2, 3 etc, i trigger My action Groups or switch views and other fun stuff like that, also if this isnt already in and im just blind, PLEASE make it so we can set up the default Net for a vessel In the VAB or SPH 

 

Thanks for the great mod 

Sorry about spelling my autocorrect is drunk today

@TaxiService

Yup, I add the new ability to block all keyboard inputs in the coming release 1.1

 

13 hours ago, Gordon Dry said:

Click-through and type-through still is a bummer.

Dunno why each single mod dev has to deal with it.

Unity / KSP should deal with it.

--

Edit:

but why, oh why?
 

Log:
https://www.dropbox.com/s/jcd9srdbuwvs0i9/2017-07-11-1 KSP.log.zip?dl=1

This is an interface bug of unable to rebuild the frequency list under certain scenarios. I fixed it in the next pre-release version.

 

9 hours ago, The-Doctor said:

I have tested this mod out, with Kerbalism. Kerbalism completely erases this mod

Yup, this is a CommNet conflict which I lost to. Kerbalism has its own CommNet feature:

Spoiler

SIGNAL


An alternative to the stock CommNet system is provided. Theres is a difference between low-gain and high-gain antennas: the former used for short-range inter-vessel communications, the latter always implicitly pointing at DSN. Transmission rates are realistic, and scale with distance to the point that it may take a long time to transmit data from the outer solar system. Data transmission happen transparently in loaded and unloaded vessels, as usual. The resulting communication system is simple, yet it also results in more realistic vessel and mission designs. Tiny hypnotic science-blue spheres travel the link lines to represent data transmission. 

 

6 minutes ago, Mark Kerbin said:

Also In My Earlier Post I Mentioned The Need For A Build Screen UI. I Check And Its Not There So Im Not Blind, But Adding That Would Prevent NEEDING To Set Up Vessels After Launch. Until That Happens Im Going To Uninstall, Because i keep liquiding myself of trying to not trigger actions groups.

 

Still A Good Mod Tho

You are able to set up each antenna in VAB or SPH (assumed you are using CNC 1.0.2). Just right-click any antenna or probe core and configure away

Edited by TaxiService

Share this post


Link to post
Share on other sites

Announcement

Pre-release 5 of the coming CommNet Constellation 1.1 is available for public feedback. The remaining tasks are another code review and play-test to decide whether the official version 1.1 can be launched.

Please backup your saves before installing this potential-destruction version.

Link: https://github.com/KSP-TaxiService/CommNetConstellation/releases/tag/feedback.160717

Spoiler

Pre-release 5 of coming CNC 1.1 for public feedback

  • Code review
  • Preserve the stock Comm Power combination
  • Resolve antenna-data inconsistency
  • Few obvious data & interface bugs fixed
  • UI improvements

Things not done yet

  • Localisation support for text part strings

 

Share this post


Link to post
Share on other sites

hello to all, and thanks for all of the great work on this mod.

i am 'trying' to use kerbin side ground stations with this mod.  I have not been able to figure out how i get the additional ground stations into the commNet constellation control panel.  i have looked for some .cfg file that would have the stations listed, but no luck there either.

I hope that i have not missed something simple or listed in the posts, but any help for this would be greatly appreciated.

Cheers, and thanks again.

Share this post


Link to post
Share on other sites
3 hours ago, drtedastro said:

hello to all, and thanks for all of the great work on this mod.

i am 'trying' to use kerbin side ground stations with this mod.  I have not been able to figure out how i get the additional ground stations into the commNet constellation control panel.  i have looked for some .cfg file that would have the stations listed, but no luck there either.

I hope that i have not missed something simple or listed in the posts, but any help for this would be greatly appreciated.

Cheers, and thanks again.

Hi, I haven't researched into this feature of adding extra ground stations besides the stock ground stations yet. This is one of the RT-related things I planned to do on this CommNet testbed after releasing this coming major version 1.1.

Share this post


Link to post
Share on other sites
On 4/30/2017 at 8:17 AM, TaxiService said:

The interface for editing ground stations is committed to the codebase. What is your feedback on this?

AuOxbRU.png

By the way, I am re-reading your posts on the frequency & antenna functions.

Ok, thanks for reply.

I 'thought' that this must have been added already as some of the earlier posts had pic's showing the multiple ground stations in the GUI.

Share this post


Link to post
Share on other sites

Loving the idea of this mod, thanks! I'm using the pre-release 5. I've noticed that staging doesn't seem to rebuild the frequency list on a vessel. I've got an Communitron 16S on my lifter talking to KSC on its channel, and my payload has a Communitron 16 (the deployable one) which should talk to my satellites in orbit (but not KSC) once it's deployed. I notice on launch that the frequency list shows the probe core and surface mounted antenna working (as it should), but after separation and deployment of the probe antenna, the list should change, yet it doesn't until I go to map view and disable, then re-enable one of the antenna in the Vessel Setup window. Happy to provide screenshots if needed.

Edit: also I notice that deploying the Communitron 16 from an action group didn't rebuild the frequency list.

Edited by Sidelia
Additional info

Share this post


Link to post
Share on other sites
10 hours ago, Sidelia said:

Loving the idea of this mod, thanks! I'm using the pre-release 5. I've noticed that staging doesn't seem to rebuild the frequency list on a vessel. I've got an Communitron 16S on my lifter talking to KSC on its channel, and my payload has a Communitron 16 (the deployable one) which should talk to my satellites in orbit (but not KSC) once it's deployed. I notice on launch that the frequency list shows the probe core and surface mounted antenna working (as it should), but after separation and deployment of the probe antenna, the list should change, yet it doesn't until I go to map view and disable, then re-enable one of the antenna in the Vessel Setup window. Happy to provide screenshots if needed.

Edit: also I notice that deploying the Communitron 16 from an action group didn't rebuild the frequency list.

Hi, thanks for letting me know on the action group of deploying. I am fixing up on the vessel staging event.

Edited by TaxiService

Share this post


Link to post
Share on other sites

Announcement

Pre-release 6 of the coming CommNet Constellation 1.1 is available for public feedback. Further play-test may be required to be sure there are no more big bugs.

Please backup your saves before installing this potential-destruction version.

Link: https://github.com/KSP-TaxiService/CommNetConstellation/releases/tag/feedback.300717

nTlV7aW.png

Spoiler

Pre-release 6 of coming CNC 1.1 for public feedback

  • UI Improvements
  • Move away from LINQ (memory intensive)
  • Indicate which frequency of each vessel is the strongest
  • Fix the issue of the freq list not rebuilt when staging
  • Fix the issue of the freq list not rebuilt when extending/retracting antennas
  • Control panel now has tabs

Things not done yet

  • Localisation support for text part strings (on hold until language fixes in next KSP patch)

 

Edited by TaxiService

Share this post


Link to post
Share on other sites
On 7/31/2017 at 4:24 AM, Gordon Dry said:

Using Pre-Release 6 on a career start test.
An unknown object (Asteroid Class C) got an antenna and its future name is already revealed:
i4M44Pp.png

Log:
https://www.dropbox.com/s/dl7nb7hzhh2kfra/2017-07-30-1 KSP.log.zip?dl=1

That's interesting. You are right, your asteroid has a valid CommNet instance, likely supported by one of your mods. I add extra check to exclude all vessels of the unknown type.

Share this post


Link to post
Share on other sites

I've found a potential mod conflict between Science Relay, Commnet Constellation & (possibly) MOLE. If all three are installed, attempting to get a science report from the craft freezes the system. Uninstalling either Science Relay or CC resolves the issue; for now, I find Science Relay more useful, so that's what I'm sticking with.

To test: install just SR, CC & MOLE (with its dependencies). Create a 'ship' using the Backseat command pod & launch. Right-click and click Crew Report.

There are no errors in the logs; the game just stops responding altogether and has to be force-quit.

Edited by Bombaatu

Share this post


Link to post
Share on other sites
13 hours ago, Bombaatu said:

I've found a potential mod conflict between Science Relay, Commnet Constellation & (possibly) MOLE. If all three are installed, attempting to get a science report from the craft freezes the system. Uninstalling either Science Relay or CC resolves the issue; for now, I find Science Relay more useful, so that's what I'm sticking with.

To test: install just SR, CC & MOLE (with its dependencies). Create a 'ship' using the Backseat command pod & launch. Right-click and click Crew Report.

There are no errors in the logs; the game just stops responding altogether and has to be force-quit.

Hmmm, my KSP (with CC 1.0.2) does not get locked up when opening up or submitting Crew Report in either Career or Sandbox. I wonder if I missed out something when installing MOLE & Science Relay.

fDDQYVq.png

uH5cijl.png

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.