TaxiService

[1.9.1] CommNet Constellation v1.5.4 [14 June 2020]

Recommended Posts

4 minutes ago, jimmymcgoochie said:

After a long time spent tolerating some really dreadful game performance in my heavily modded 1.8.1 game, I have found that CNC is a real performance drain and makes the game run considerably slower and with worse FPS, regularly dropping to 3-5FPS and running at 1/2 or even 1/3 speed for me.

I thought it was due to some combination of other mods I was using like EVE or scatterer, or JNSQ, but removing EVE/scatterer didn't fix the problem and a totally fresh save game in the same KSP instance ran quite happily at normal speed and 60FPS. I also saw a lot of inexplicable occasions where the game would suddenly speed up to near-normal speed and 20-odd FPS and couldn't work out why.

My career save has nearly a hundred vessels in flight and that's obviously having some effect, but when I removed CNC the average frame rate doubled and the only time the game runs slower than real speed is when flying really large vessels and/or in atmosphere. I do like this mod, but the performance penalty I get with it is just too high to keep using it. I haven't gone as far as trying to recreate this problem in a clean KSP install, but from my observations I have to conclude that this is the cause.

https://github.com/KSP-TaxiService/CommNetConstellation/issues/8

Share this post


Link to post
Share on other sites

My satellites all disapear after install the vision 1.4 of CommNet Constellation;and lots of bugs appearly stop I lunch from VAB and build;

Any suggestion?

Share this post


Link to post
Share on other sites
Posted (edited)

EDIT_2: Alright, did some troubleshooting. I needed my antennas little sooner than expected. I started a fresh install and started adding mods that I suspected might conflict. Looks like Signal Delay and CNC are no longer compatible (at least with latest versions, supposedly they were compatible at some point looking at both forum posts, maybe Signal Delay 1.8 version is not compatible with 1.9). Anyhow, this sucks, ill post this on their forum.

EDIT_1: It looks like input-locks are being triggered ("CNCLockStaging","CNCLockAction","CNCLockKeyboard") but no dialog. I have a feeling there is some major non-compatibility going on since I have tried using a Communotron 8 to transfer some data. It is fully extended, freq 0 and still no connection/input-freeze on "CNC: Communication" button. This means that its not a simple no antenna bug. I really hope its not a compatibility issue with Kerbalism, its THE core mod.

I have a bug report. When hitting "CNC: Communication" most game inputs freeze, can't use ESC, WASD, etc., and mouse viewport rotation doesn't work either. Most left click buttons work. All parts are stock afaik. My game is modded. Recently installed this mod, haven't been able to use it yet, this first attempt to figure out  the mod froze my game... bug might have possibly been triggered because the craft doesn't have an antenna? I can progress my career without this for now, might not be an issue once I have antennas installed.

Video (available for 90 days): https://streamable.com/0in7uq

Logs:

- ksp.log: https://www.dropbox.com/s/3f9ps0t4rtmqxfj/KSP.log?dl=0

- output_log.txt (idk how this one is supposed to be relevant but you have requested it in the past, file last modified on 4/1/2020): https://www.dropbox.com/s/gg2k5d919f97zro/output_log.txt?dl=0

- Player.log: https://www.dropbox.com/s/0h2ty400zwvxjlc/Player.log?dl=0

 

Mods possibly of Interest:Kerbalism, Signal Delay, SCANSat?

Edited by EvWoN
edit_2

Share this post


Link to post
Share on other sites
Posted (edited)

@TaxiService still getting 1.9.1 setup but in redownloading mods I saw the test release of the new ground station editing. THANK YOU! But just FYI there's a ton of NRE spam in the space center when using DMagic's MakingLessHistory mod. I guess it removes something related to the ground stations that is needed. Just be sure to note in the actual release that it shouldn't be used in conjunction with CNC (log details)

Edited by Drew Kerman

Share this post


Link to post
Share on other sites
Posted (edited)
49 minutes ago, Drew Kerman said:

@TaxiService still getting 1.9.1 setup but in redownloading mods I saw the test release of the new ground station editing. THANK YOU! But just FYI there's a ton of NRE spam in the space center when using DMagic's MakingLessHistory mod. I guess it removes something related to the ground stations that is needed. Just be sure to note in the actual release that it shouldn't be used in conjunction with CNC (log details)

yeap the Ground stations from MH are disabled when using Making Less History that's why all the NRE in the log, maybe @TaxiService can add some exclusion for those using Making Less history

Edited by dtoxic

Share this post


Link to post
Share on other sites
Posted (edited)

QyRZh9t.png

okay some first impression feedback @TaxiService - basic setup for the ground stations looks good but seems the coloring is off - every station should be a unique color. Also, what is the altitude? I assume it is in meters. Here is my config:

GroundStations
{
  GroundStation
  {
    ID = Kerbin: Desert Launch Facility
    Color = 72,0,255,1
    OptionalName = Kravass
    TechLevel = 0
    OverrideLatLongAlt = True
    CustomLatitude = 32.589942230641498
    CustomLongitude = -82.366046934496794
    CustomAltitude = 5560
    CustomCelestialBody = 
    Frequencies
    {
      Frequency = 0
    }
  }
  GroundStation
  {
    ID = Kerbin: Baikerbanur
    Color = 255,106,0,1
    OptionalName = Sheltered Rock
    TechLevel = 0
    OverrideLatLongAlt = True
    CustomLatitude = 27.8969599293372
    CustomLongitude = -46.725537590567498
    CustomAltitude = 6195
    CustomCelestialBody = 
    Frequencies
    {
      Frequency = 0
    }
  }
  GroundStation
  {
    ID = Kerbin: Crater Rim
    Color = 255,216,0,1
    OptionalName = Ockr
    TechLevel = 0
    OverrideLatLongAlt = True
    CustomLatitude = 35.038199785642703
    CustomLongitude = -30.094848565185899
    CustomAltitude = 4773
    CustomCelestialBody = 
    Frequencies
    {
      Frequency = 0
    }
  }
  GroundStation
  {
    ID = Kerbin: Harvester Massif
    Color = 76,255,0,1
    OptionalName = Umbarg
    TechLevel = 0
    OverrideLatLongAlt = True
    CustomLatitude = -3.70121984389462
    CustomLongitude = -78.438434273664299
    CustomAltitude = 467
    CustomCelestialBody = 
    Frequencies
    {
      Frequency = 0
    }
  }
  GroundStation
  {
    ID = Kerbin: KSC
    Color = 1,0,0,1
    OptionalName = Kerbal Space Center
    TechLevel = 1
    OverrideLatLongAlt = True
    CustomLatitude = -0.13133150339126601
    CustomLongitude = -74.594841003417997
    CustomAltitude = 75
    CustomCelestialBody = 
    Frequencies
    {
      Frequency = 0
    }
  }
  GroundStation
  {
    ID = Kerbin: Mesa South
    Color = 0,255,255,1
    OptionalName = Arekibo
    TechLevel = 0
    OverrideLatLongAlt = True
    CustomLatitude = 8.4197140000000008
    CustomLongitude = 179.6987
    CustomAltitude = 1639.71141787129
    CustomCelestialBody = 
    Frequencies
    {
      Frequency = 0
    }
  }
  GroundStation
  {
    ID = Kerbin: North Station One
    Color = 0,38,255,1
    OptionalName = DSN Central
    TechLevel = 0
    OverrideLatLongAlt = True
    CustomLatitude = 9.3214433075262004
    CustomLongitude = 31.568863121596898
    CustomAltitude = 3758.9672940594601
    CustomCelestialBody = 
    Frequencies
    {
      Frequency = 0
    }
  }
  GroundStation
  {
    ID = Kerbin: Nye Island
    Color = 255,0,220,1
    OptionalName = Ockr Relay
    TechLevel = 0
    OverrideLatLongAlt = True
    CustomLatitude = 33.232382812499999
    CustomLongitude = -21.661093749999999
    CustomAltitude = 5200
    CustomCelestialBody = 
    Frequencies
    {
      Frequency = 0
    }
  }
  GroundStation
  {
    ID = Kerbin: Larkes
    Color = 127,51,0,1
    OptionalName = Kongo River
    TechLevel = 0
    OverrideLatLongAlt = True
    CustomLatitude = 28.024314112068701
    CustomLongitude = -133.723841883993
    CustomAltitude = 3531
    CustomCelestialBody = 
    Frequencies
    {
      Frequency = 0
    }
  }
}

final question for now is what does TechLevel refer to? If I want to adjust the range of various stations how would I do it? I'm guessing via CustomBarnKit and patching this:

TRACKING
{
  levels = 3
  upgradesVisual = 1, 2, 3
  upgrades = 38000, 150000, 563000
  unlockedSpaceObjectDiscovery = 3
  // None=0 CelestialBodyOrbits=1 AllOrbits=2 PatchedConics=3
  orbitDisplayMode = 2, 3, 3
  patchesAheadLimit = 0, 2, 4
  trackedObjectLimit = 0, 8, -1
  DSNRange = 2000000000, 50000000000, 250000000000
  DSNRangeCurve
  {
    key = 0 0 0 0
    key = 1 1 0 0
  }
  DSNPowerCurve
  {
    key = 0 1 0 0
    key = 1 0.1 0 0
  }
  DSNScienceCurve
  {
    key = 0 0 0 0
    key = 0.5 0.1 0 0
    key = 1 0.75 0 0
  }
}

to modify the DSNRange property. Right now it has 3 levels but I can add more right? TechLevel = 0 would be 2000000000 and TechLevel = 2 would be 250000000000?

Edited by Drew Kerman

Share this post


Link to post
Share on other sites
Posted (edited)
On 4/23/2020 at 11:51 AM, zxzx said:

My satellites all disapear after install the vision 1.4 of CommNet Constellation;and lots of bugs appearly stop I lunch from VAB and build;

Any suggestion?

Hi, my apology for delayed response.

Please provide output_log.txt at

C:\Users\%USERNAME%\AppData\LocalLow\Squad\Kerbal space Program

Your problem description indicates a massive mod-version difference on KSP version between since the version 1.4 is for KSP 1.7.x.

On 5/8/2020 at 1:53 AM, Drew Kerman said:

@TaxiService still getting 1.9.1 setup but in redownloading mods I saw the test release of the new ground station editing. THANK YOU! But just FYI there's a ton of NRE spam in the space center when using DMagic's MakingLessHistory mod. I guess it removes something related to the ground stations that is needed. Just be sure to note in the actual release that it shouldn't be used in conjunction with CNC (log details)

Making Less History disables 2 ground stations (Dessert and Larkes), causing NRE spam when CNC tried to read those stations. As per dtoxic recommended, I pushed the fix yesterday to exclude any disabled ground station.

Many thanks for your impression details. You can try the latest build with the new interface of upgrading a ground station.

Briefly, when you start a new game, all ground stations are at Tech Level 0, except for KSC which starts at Tech Level 1 and is upgraded via KSC scene.

Through the new interface, it costs Funds to upgrade a ground station (except for KSC):

  • Tech Level 0 - 0 DNS power
  • Tech Level 1 - 3.1M DNS power and Funds 100,000 to upgrade from 0 to 1
  • Tech Level 2 - 20M DNS power and Funds 300,000 to upgrade from 1 to 2
  • Tech Level 3 - 60M DNS power and Funds 900,000 to upgrade from 2 to 3

UpgradeableGroundStationCosts, UpgradeableGroundStationPowers and default ground-station list are configurable in the CNC setting file.

For some of your questions, I do not touch the altitude of a ground station and it seems like meters from sea level. I keep the tech level to max 3 in alignment with KSC's tracking station levels (1 to 3).

Hope this clarifies.

Edited by TaxiService

Share this post


Link to post
Share on other sites
Posted (edited)

@TaxiService I'm finally getting a chance to use this mod, I like it! :) I do have a question about retrofitting an existing save. I notice that many of my craft are (understandably) not showing an active channel:

TRF1Yg6.png

It seems that the only way to set them up is to visit each one in flight before I can assign frequencies. How does CommNet Constellation handle vessels with no assigned frequency? Is there some way for existing craft to default to the public frequency without needing to visit each one in flight? I'm kinda guessing the answer is no, you have to visit each one, because the unloaded craft doesn't have the appropriate part module(s)...

Edited by Angel-125

Share this post


Link to post
Share on other sites

Want to actually get into satellite and relay stuff in KSP but don't like the amount of abstraction in stock CommNet.

Having trouble catching up with all the different threads and posts how does this mod play with RemoteTech in 1.8/1.9?

Share this post


Link to post
Share on other sites
16 hours ago, Angel-125 said:

@TaxiService I'm finally getting a chance to use this mod, I like it! :) I do have a question about retrofitting an existing save. I notice that many of my craft are (understandably) not showing an active channel:

It seems that the only way to set them up is to visit each one in flight before I can assign frequencies. How does CommNet Constellation handle vessels with no assigned frequency? Is there some way for existing craft to default to the public frequency without needing to visit each one in flight? I'm kinda guessing the answer is no, you have to visit each one, because the unloaded craft doesn't have the appropriate part module(s)...

Sorry, you are correct. You will need to visit each unloaded vessel in flight so that KSP can update and save that vessel with missing part modules, include CNC ones.

32 minutes ago, Deathninja said:

Want to actually get into satellite and relay stuff in KSP but don't like the amount of abstraction in stock CommNet.

Having trouble catching up with all the different threads and posts how does this mod play with RemoteTech in 1.8/1.9?

Hi, RemoteTech is not compatible with CNC so you can only choose either CNC (improved CommNet) or RemoteTech (higher player control and difficulty)

Share this post


Link to post
Share on other sites

I'm attempting to create a patch for the RSS commnet stations, so I'm not certain if anyone had done this already; if so please make me aware.

Using the version 1.5.3 on KSP-1.8.1 I am editing the CommNet stations in the Tracking station, changing their name and so forth, but when "updated", exit and reload the tracking station, the changes I make do not continue. Any help?

Share this post


Link to post
Share on other sites
Posted (edited)
On 6/12/2020 at 11:11 PM, wallum61 said:

I'm attempting to create a patch for the RSS commnet stations, so I'm not certain if anyone had done this already; if so please make me aware.

Using the version 1.5.3 on KSP-1.8.1 I am editing the CommNet stations in the Tracking station, changing their name and so forth, but when "updated", exit and reload the tracking station, the changes I make do not continue. Any help?

Hi, up to version 1.5.3, the ground stations shown were locked to the stock ground stations only. You can try out the latest dev build with the new customization functionality for ground stations, or wait for the upcoming release 1.5.4.

You should be able to patch the default ground station list in cnc_settings.cfg there.

Edited by TaxiService

Share this post


Link to post
Share on other sites

 CommNet Constellation 1.5.4 is out for KSP 1.9.1

  • New functionality and interface for customizing and/or adding ground stations
    • Warning: All existing ground stations, except for Kerbal Space Center, will be Tech Level 0 (DSN power 0) and require Funds to upgrade to Tech Level 3 (DSN power 80G).
    • Warning: Default list of customized ground stations in cnc_settings.cfg will be only loaded in new games
  • Newer vessels will be on top when sorting by launch time

Linky 

  Hide contents

What's new?

  • New functionality and interface for customizing or adding ground stations
    • Warning: All existing ground stations, except for Kerbal Space Center, will be Tech Level 0 (DSN power 0) and require Funds to upgrade.
    • Warning: Default list of customized ground stations in cnc_settings.cfg will be only loaded in new games
  • Newest vessels will be on top when sorting by launch time
  • Minor support config change for NearFutureExploration due to ModuleManager FOR behaviour

Requirements

  • ModuleManager
  • Kerbal Space Program 1.9.1

Known issues

  • Issue #2 - White connections caused by combinations of other mods
  • Issue #8 - Deteriorated performance on a large number of mods

 

Share this post


Link to post
Share on other sites
Posted (edited)

I might have found a bug. I installed your mod yesterday, and I was developing a plane in sandbox game. 

Yesterday everything was fine, but today (after the update) when I returned to the very same vessel a strange bug started occuring. Whenever I revert the flight to the hangar, I can't do anything. Neither of "launch", "load vessel" "exit hangar" buttons work. Clicking them does nothing. The only thing I could do was ALT + F4.

I do use a dozen or two of mods, but after some troubleshooting I deleted CNC, and the bug stopped occurring.

Now, I initially installed 1.5.3 version of your mod yesterday, but yesterday everything was fine. I don't know if it automatically updated itself to 1.5.4 (I installed from spacedock) but I assume it did, as the problem started today, which is after the update.

The bug wasn't caused by the vessel itself, as the same thing happened with stock vessels.

_____
Edit.
Okay, I did some more testing. I deleted whole CNC mod folder, redownloaded clear isntall of 1.5.4. and started a new (3rd already) sandbox game. The bug is not happening. Then I  loaded 2nd sandbox again, the one I started today in the morning, and reverting the flight yet again causes the bug. That is very strage. In both games I use exactly the same vessel, copied from one save to another.

It may be some incompability with old 1.5.3 modules loaded into the vessel. That is very frightening, as in my main career save I have already used the 1.5.3 mod.

Edited by Failer

Share this post


Link to post
Share on other sites
Posted (edited)
16 hours ago, TaxiService said:

Hi, up to version 1.5.3, the ground stations shown were locked to the stock ground stations only. You can try out the latest dev build with the new customization functionality for ground stations, or wait for the upcoming release 1.5.4.

You should be able to patch the default ground station list in cnc_settings.cfg there.

Been tweaking about further today but still haven't had any desired outcomes.

in the settings.cfg, may I ask what ID references to? I see that the ID in your stock config has instances where both "Kerbin: <groundstation>" and "<groundstation>"?

 

EDIT(S):

Testing with stock but with Kopernicus is still okay and adds the default custom GS's

Testing with stock, Kopernicus and RealisticAscension (for a lightweight Kopernicus added body) successfully adds a GS onto it's surface

Whenever RSS is added into the mix, none of the GS show up. I'm not sure if there is any workaround.

 

Edited by wallum61

Share this post


Link to post
Share on other sites
12 hours ago, wallum61 said:

Been tweaking about further today but still haven't had any desired outcomes.

in the settings.cfg, may I ask what ID references to? I see that the ID in your stock config has instances where both "Kerbin: <groundstation>" and "<groundstation>"?

 

EDIT(S):

Testing with stock but with Kopernicus is still okay and adds the default custom GS's

Testing with stock, Kopernicus and RealisticAscension (for a lightweight Kopernicus added body) successfully adds a GS onto it's surface

Whenever RSS is added into the mix, none of the GS show up. I'm not sure if there is any workaround.

 

Hi, I would like to take a look at your RSS patch on my side. Which mods do I need to install, beside CNC and RSS?

Thanks.

Share this post


Link to post
Share on other sites
4 hours ago, TaxiService said:

Hi, I would like to take a look at your RSS patch on my side. Which mods do I need to install, beside CNC and RSS?

Thanks.

Mods needed are standard setup for a base RSS installation, the versions I'm using are as follows;

 Kopernicus 1.8.1-1RSS-18.0 and RSS-Textures (res doesn't matter), then bung CNC in as well.

My GameData folder then looks like this:

fkvt9qa.png

Inside of the CNC folder, my config file is used. I have tested it both with and without the "RSS_CommNet_Stations.cfg" in the RealSolarSystem folder.

Cheers for providing assistance

Share this post


Link to post
Share on other sites

@TaxiService latest version 1.5.4 on KSP 1.9.1 is throwing occasional Nullrefs (not spamming)

i am trying to pinpoint the problem but as of now i think it has something to do with scene change? (probably not)

Spoiler

[EXC 22:53:06.451] NullReferenceException: Object reference not set to an instance of an object
    CommNetConstellation.CommNetLayer.CNCCommNetHome.GetDSNRange (System.Int16 level) (at <eb3a42c4b19146209f5a7203c194cc04>:0)
    CommNetConstellation.CommNetLayer.CNCCommNetHome.refresh () (at <eb3a42c4b19146209f5a7203c194cc04>:0)
    CommNetConstellation.CommNetLayer.CNCCommNetHome.Start () (at <eb3a42c4b19146209f5a7203c194cc04>:0)
    UnityEngine.DebugLogHandler:LogException(Exception, Object)
    ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object)
    UnityEngine.Debug:CallOverridenDebugHandler(Exception, Object)

 

Share this post


Link to post
Share on other sites

Can you tell me the outcome of the following:

I've been using 1.5.3 for a while now in a career save and have "Additional Ground Stations" option in my game turned on.

DSN level 3 al around.

If I upgrade to 1.5.4 will the stock additional ground stations get downgraded in DSN level?

Share this post


Link to post
Share on other sites
14 minutes ago, SkiRich said:

Can you tell me the outcome of the following:

I've been using 1.5.3 for a while now in a career save and have "Additional Ground Stations" option in my game turned on.

DSN level 3 al around.

If I upgrade to 1.5.4 will the stock additional ground stations get downgraded in DSN level?

Welp, answered my own question.  Yep, they are all zero.

Share this post


Link to post
Share on other sites
On 6/16/2020 at 1:57 AM, wallum61 said:

Mods needed are standard setup for a base RSS installation, the versions I'm using are as follows;

 Kopernicus 1.8.1-1RSS-18.0 and RSS-Textures (res doesn't matter), then bung CNC in as well.

My GameData folder then looks like this:

Inside of the CNC folder, my config file is used. I have tested it both with and without the "RSS_CommNet_Stations.cfg" in the RealSolarSystem folder.

Cheers for providing assistance

Hi, thanks for the installation information.

RealSolarSystem removed most of stock ground stations, resulting in CNC unable to add new ground stations.

Can you try out the new dev build contained the fix? With it, I can see "Marsya Base" ground station added.

By the way, "RSS_CommNet_Stations.cfg" seems to work in CNC though the names are empty

On 6/17/2020 at 4:56 AM, dtoxic said:

@TaxiService latest version 1.5.4 on KSP 1.9.1 is throwing occasional Nullrefs (not spamming)

i am trying to pinpoint the problem but as of now i think it has something to do with scene change? (probably not)

  Hide contents

[EXC 22:53:06.451] NullReferenceException: Object reference not set to an instance of an object
    CommNetConstellation.CommNetLayer.CNCCommNetHome.GetDSNRange (System.Int16 level) (at <eb3a42c4b19146209f5a7203c194cc04>:0)
    CommNetConstellation.CommNetLayer.CNCCommNetHome.refresh () (at <eb3a42c4b19146209f5a7203c194cc04>:0)
    CommNetConstellation.CommNetLayer.CNCCommNetHome.Start () (at <eb3a42c4b19146209f5a7203c194cc04>:0)
    UnityEngine.DebugLogHandler:LogException(Exception, Object)
    ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object)
    UnityEngine.Debug:CallOverridenDebugHandler(Exception, Object)

 

Can you help to provide the output_log.txt for further investigation? This log is telling either CNC setting not available or missing station information.

Share this post


Link to post
Share on other sites

@TaxiService i am not at my home pc atm, and don't know if i will be in the next 2-3 days, i tried this on a new save and existing one, mods and no mods, note that this happens when i start the game and when i enter the tracking station (but i am not sure, will see what i can do with the logs as soon s i can)

Share this post


Link to post
Share on other sites
Posted (edited)

@TaxiService ok so here is the log and some new information, i noticed that these nullref's start occurring when creating new constellations in tracking station (also in flight scene i assume i did not test that)

in the log the first one starts from line number [69115] in this test i created two constellations named 1 & 2 and their frequencies also 1 & 2

do note that this is on my test install with a lot of mods so ignore other errors, also a thing you might want to look into is that this also happened on my normal install and i already had some constellations created and named,so i assume that is the same error.

https://www.dropbox.com/s/93m19gloq8f0zyq/TaxiService.rar?dl=1

https://www.dropbox.com/s/89wyhnoe203up5z/CNC-PlayerLog.rar?dl=1

if you need anything else let me know

Edited by dtoxic

Share this post


Link to post
Share on other sites

8xbyFjc.png

Is it possible to make it so the two bottom probes by Duna only connect to the probe way above and not all the way to KSC?

I have them on the same frequency so I'm a little confused.

Sorry, new to using this mod...

Share this post


Link to post
Share on other sites
2 hours ago, NateDaBeast said:

8xbyFjc.png

Is it possible to make it so the two bottom probes by Duna only connect to the probe way above and not all the way to KSC?

I have them on the same frequency so I'm a little confused.

Sorry, new to using this mod...

Yes it is, Create a new Constellation named say Duna and frequency 2....set them all (probes/satellites) to frequency 2, and the main satellite that connects to KSC set it to 0 or 1 depending on what you have around kerbin,make sure you have 2 relays on the satellite also,set one to KSC and one for local number 2 frequency the one you created for duna

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.