Jump to content

[1.10] Spectra Visual Compilation 1.4.0 "Jewel" (2nd July 2020, Force 1.8/1.9 compatibility in CKAN)


Recommended Posts

3 hours ago, erickerman said:

G9gcRsc.png

This is what happens when i delete the duna atmo.cfg file

And no, i don't think i've opened the EVE menu, though ill try reinstalling just to be sure.

:/ Yeah I'll definitely need to look into that. Any other visual mods you have installed atm?

Link to post
Share on other sites
  • 3 weeks later...
  • 5 weeks later...
8 hours ago, prototype said:

Hi, just a note that I believe the upload is corrupted (at least on Spacedock). Twice now I've downloaded and the extract fails at '00icemoon.dds'.

 

Still the prettiest mod out there!

Huh, I'll try and reupload it. It won't be until late tonight though sadly :( I get back in about 7 hours.

Edited by Avera9eJoe
Link to post
Share on other sites
  • 1 month later...
  • 3 weeks later...
On 12/13/2019 at 2:30 AM, nwillard said:

Heh miss this mod, I appreciated the optimization and beauty. Any future update aspirations?

Woah, I missed your comment! I forgot to change the header, but this should still work great with the newest update of EnvironmentalVisualEnhancements and Kopernicus. Sorry for the lack of attention.

When you say 'future update aspirations', did you have any features in particular in mind? I could probably tell you if I've thought about them or not :)

Edited by Avera9eJoe
Link to post
Share on other sites
2 hours ago, The Minmus Derp said:

Unfortunately, the oceans are orange, there are no clouds, and there's this horrendous white circle around all atmosphere planets.

Gotcha. Can you remove Scatterer and see if it persists?

Link to post
Share on other sites

I'll try it out and report back!

UPDATE: Kopernicus isn't updated yet so I didn't install that, still got some sweet visuals launching from Kerbin and am glad to try this mod again. Eve didn't have a visible ocean when I got there but that could easily be a different mod conflict I haven't narrowed down yet. Still,

2dDT5rB.jpg

Edited by nwillard
Link to post
Share on other sites
14 hours ago, nwillard said:

I'll try it out and report back!

UPDATE: Kopernicus isn't updated yet so I didn't install that, still got some sweet visuals launching from Kerbin and am glad to try this mod again. Eve didn't have a visible ocean when I got there but that could easily be a different mod conflict I haven't narrowed down yet. Still,

2dDT5rB.jpg

It's beautiful ;~;

Link to post
Share on other sites

Ok, didn't capture a screenshot, but holy moly. I was re entering into the sunset on Kerbin and that sunset looked REAL! Amazing work on this. For the simplicity of installation, this is a gorgeous mod. I LOVE the sunflare as well. Nice work.

Link to post
Share on other sites

I have this issue with spectra that makes the planets look weird.

cyYfyMM.png

KSP log: 

Spoiler

[LOG 20:10:44.174] EVEManager: Issue loading CloudsManager! Error:
UnityEngine.UnityException: Unable to apply node! ---> UnityEngine.UnityException: Unable to parse "settings" in "OBJECT"! ---> UnityEngine.UnityException: Unable to parse "_MainTex" in "settings"!
  at Utils.ConfigHelper.LoadObjectFromConfig (System.Object obj, ConfigNode node) [0x000f1] in <1f2ba18ebdff4c5da1e032603d7743f4>:0 
  at Utils.ConfigHelper.Parse (System.Reflection.FieldInfo field, System.Object& obj, System.String[] value, ConfigNode node) [0x003b7] in <1f2ba18ebdff4c5da1e032603d7743f4>:0 
  at Utils.ConfigHelper.LoadObjectFromConfig (System.Object obj, ConfigNode node) [0x00062] in <1f2ba18ebdff4c5da1e032603d7743f4>:0 
   --- End of inner exception stack trace ---
  at Utils.ConfigHelper.LoadObjectFromConfig (System.Object obj, ConfigNode node) [0x000a8] in <1f2ba18ebdff4c5da1e032603d7743f4>:0 
  at Atmosphere.CloudsObject.LoadConfigNode (ConfigNode node) [0x00000] in <d7bf01ff152a4dd0b67e789f1b135d32>:0 
  at Atmosphere.CloudsManager.ApplyConfigNode (ConfigNode node) [0x00030] in <d7bf01ff152a4dd0b67e789f1b135d32>:0 
  at EVEManager.EVEManagerBase.Apply () [0x00032] in <6e195670478449b995e7bf837ced1c60>:0 
   --- End of inner exception stack trace ---
  at EVEManager.EVEManagerBase.Apply () [0x0005f] in <6e195670478449b995e7bf837ced1c60>:0 
  at EVEManager.EVEManagerBase.LoadConfig () [0x00062] in <6e195670478449b995e7bf837ced1c60>:0 
  at EVEManager.GenericEVEManager`1[T].Setup () [0x00016] in <6e195670478449b995e7bf837ced1c60>:0 
  at EVEManager.GlobalEVEManager.Setup (System.Boolean late) [0x0005c] in <6e195670478449b995e7bf837ced1c60>:0 
[LOG 20:10:44.174] [EVE AtmosphereManager]: Running Setup
[LOG 20:10:44.175] [EVE AtmosphereManager]: Loading...
[LOG 20:10:44.176] [EVE AtmosphereManager]: Cleaning Atmosphere!
[LOG 20:10:44.176] [EVE CityLightsManager]: Running Setup
[LOG 20:10:44.176] [EVE CityLightsManager]: Loading...
[LOG 20:10:44.177] [EVE CityLightsManager]: BoulderCo/CityLights/cityLights/EVE_CITY_LIGHTS
[LOG 20:10:44.180] [EVE] Applying PQS Material Manager!
[LOG 20:10:44.203] [EVE CityLightsManager]: Applied to main Menu
[LOG 20:10:44.203] [EVE TerrainManager]: Running Setup
[LOG 20:10:44.203] [EVE TerrainManager]: Loading...
[LOG 20:10:44.204] [EVE ShadowManager]: Running Setup
[LOG 20:10:44.204] [EVE ShadowManager]: Loading...
[LOG 20:10:44.205] [EVE ShadowManager]: BoulderCo/shadows/EVE_SHADOWS
[LOG 20:10:44.206] [EVE ShadowManager]: Applying to Kerbin
[LOG 20:10:44.206] [EVE] Applying PQS Material Manager!
[LOG 20:10:44.242] [EVE ShadowManager]: Applying to Mun
[LOG 20:10:44.243] [EVE] Applying PQS Material Manager!
[LOG 20:10:44.279] [EVE ShadowManager]: Applying to Minmus
[LOG 20:10:44.279] [EVE] Applying PQS Material Manager!
[LOG 20:10:44.315] [EVE ShadowManager]: Applying to Eve
[LOG 20:10:44.315] [EVE] Applying PQS Material Manager!
[LOG 20:10:44.353] [EVE ShadowManager]: Applying to Gilly
[LOG 20:10:44.353] [EVE] Applying PQS Material Manager!
[LOG 20:10:44.389] [EVE ShadowManager]: Applying to Duna
[LOG 20:10:44.390] [EVE] Applying PQS Material Manager!
[LOG 20:10:44.425] [EVE ShadowManager]: Applying to Ike
[LOG 20:10:44.426] [EVE] Applying PQS Material Manager!
[LOG 20:10:44.461] [EVE ShadowManager]: Applying to Jool
[LOG 20:10:44.462] [EVE] Applying PQS Material Manager!
[LOG 20:10:44.462] [EVE] No PQS!
[LOG 20:10:44.499] [EVE ShadowManager]: Applying to Pol
[LOG 20:10:44.499] [EVE] Applying PQS Material Manager!
[LOG 20:10:44.535] [EVE ShadowManager]: Applying to Bop
[LOG 20:10:44.535] [EVE] Applying PQS Material Manager!
[LOG 20:10:44.572] [EVE ShadowManager]: Applying to Tylo
[LOG 20:10:44.572] [EVE] Applying PQS Material Manager!
[LOG 20:10:44.608] [EVE ShadowManager]: Applying to Laythe
[LOG 20:10:44.608] [EVE] Applying PQS Material Manager!
[LOG 20:10:44.644] [EVE ShadowManager]: Applying to Vall
[LOG 20:10:44.644] [EVE] Applying PQS Material Manager!
[LOG 20:10:44.684] [Scatterer] Celestial Body: Kerbin (CelestialBody)
[LOG 20:10:44.684] [Scatterer] Found: Kerbin / Kerbin
[LOG 20:10:44.684] [Scatterer] Celestial Body: Duna (CelestialBody)
[LOG 20:10:44.684] [Scatterer] Found: Duna / Duna
[LOG 20:10:44.684] [Scatterer] Celestial Body: Laythe (CelestialBody)
[LOG 20:10:44.685] [Scatterer] Found: Laythe / Laythe
[LOG 20:10:44.685] [Scatterer] Celestial Body: Jool (CelestialBody)
[LOG 20:10:44.685] [Scatterer] Found: Jool / Jool
[LOG 20:10:44.685] [Scatterer] Celestial Body: Eve (CelestialBody)
[LOG 20:10:44.685] [Scatterer] Found: Eve / Eve
[LOG 20:10:44.686] [Scatterer] Found main menu light
[LOG 20:10:44.689] [Scatterer] Adding DepthToDistanceCommandBuffer to Landscape Camera
[LOG 20:10:44.690] [Scatterer] Adding DepthToDistanceCommandBuffer to Landscape Camera
[LOG 20:10:44.691] [Scatterer] mapping EVE clouds
[LOG 20:10:44.699] [Scatterer] Eve assembly type found
[LOG 20:10:44.699] [Scatterer] Eve assembly version: Atmosphere, Version=1.8.0.2, Culture=neutral, PublicKeyToken=null
[LOG 20:10:44.699] [Scatterer] Successfully grabbed EVE Instance
[LOG 20:10:44.700] [Scatterer] Detected EVE 2d cloud layer for planet: Kerbin
[LOG 20:10:44.700] [Scatterer] layer2d not found for layer on planet :Laythe
[LOG 20:10:44.700] [Scatterer] layer2d not found for layer on planet :Duna
[LOG 20:10:44.700] [Scatterer] layer2d not found for layer on planet :Eve
[LOG 20:10:44.700] [Scatterer] layer2d not found for layer on planet :Eve
[LOG 20:10:44.700] [Scatterer] layer2d not found for layer on planet :Eve
[LOG 20:10:44.700] [Scatterer] layer2d not found for layer on planet :Eve
[LOG 20:10:44.700] [Scatterer] layer2d not found for layer on planet :Eve
[LOG 20:10:44.700] [Scatterer] layer2d not found for layer on planet :Jool
[LOG 20:10:44.701] [Scatterer] Core setup done
[LOG 20:10:44.702] [Scatterer] disableAmbientLight: Found scaled sunlight
[LOG 20:10:44.702] [Scatterer] disableAmbientLight: Found sunlight
[LOG 20:10:44.774] [Scatterer] Added eclipse caster Mun for Kerbin
[LOG 20:10:44.774] [Scatterer] Added eclipse caster Minmus for Kerbin
[LOG 20:10:44.815] [Scatterer] Atmosphere config found for: Kerbin
[LOG 20:10:44.823] [Scatterer] no inscatter.raw or inscatter.half file found for Kerbin
[LOG 20:10:44.823] [Scatterer] no transmittance.raw or transmittance.half file found for Kerbin
[LOG 20:10:44.824] [Scatterer] no irradiance.raw or irradiance.half file found for Kerbin
[LOG 20:10:44.825] [Scatterer] Camera overlap: 199999.7
[LOG 20:10:44.828] [Scatterer] Effects loaded for Kerbin
[LOG 20:10:45.032] [EVE CloudsManager]: Clouds2D is now MACRO
[LOG 20:10:45.032] [EVE] Applying _MainTex Cubemap
[LOG 20:10:45.032] [EVE] Applying _MainTex Cubemap
[LOG 20:10:45.032] [EVE CloudsManager]: Clouds2D is now SCALED
[LOG 20:10:45.032] [EVE] Applying _MainTex Cubemap
[LOG 20:10:45.032] [EVE] Applying _MainTex Cubemap
[LOG 20:10:45.032] [Scatterer] Camera overlap: 199999.7
[LOG 20:10:45.032] [Scatterer] Skynode initiated for Kerbin
[LOG 20:11:05.978] [Scatterer] No changes to main config, skipping saving.

 

Link to post
Share on other sites

Trying to install this with CKAN forces the installation of Kopernicus. Is this intentional, or is the Spectra listed on CKAN (which does say it's 1.8.1 compatible) the wrong file?

Link to post
Share on other sites
9 hours ago, Yeet_TheDinosaur said:

I have this issue with spectra that makes the planets look weird.

[snip]

KSP log: 

  Reveal hidden contents

[LOG 20:10:44.174] EVEManager: Issue loading CloudsManager! Error:
UnityEngine.UnityException: Unable to apply node! ---> UnityEngine.UnityException: Unable to parse "settings" in "OBJECT"! ---> UnityEngine.UnityException: Unable to parse "_MainTex" in "settings"!
  at Utils.ConfigHelper.LoadObjectFromConfig (System.Object obj, ConfigNode node) [0x000f1] in <1f2ba18ebdff4c5da1e032603d7743f4>:0 
  at Utils.ConfigHelper.Parse (System.Reflection.FieldInfo field, System.Object& obj, System.String[] value, ConfigNode node) [0x003b7] in <1f2ba18ebdff4c5da1e032603d7743f4>:0 
  at Utils.ConfigHelper.LoadObjectFromConfig (System.Object obj, ConfigNode node) [0x00062] in <1f2ba18ebdff4c5da1e032603d7743f4>:0 
   --- End of inner exception stack trace ---
  at Utils.ConfigHelper.LoadObjectFromConfig (System.Object obj, ConfigNode node) [0x000a8] in <1f2ba18ebdff4c5da1e032603d7743f4>:0 
  at Atmosphere.CloudsObject.LoadConfigNode (ConfigNode node) [0x00000] in <d7bf01ff152a4dd0b67e789f1b135d32>:0 
  at Atmosphere.CloudsManager.ApplyConfigNode (ConfigNode node) [0x00030] in <d7bf01ff152a4dd0b67e789f1b135d32>:0 
  at EVEManager.EVEManagerBase.Apply () [0x00032] in <6e195670478449b995e7bf837ced1c60>:0 
   --- End of inner exception stack trace ---
  at EVEManager.EVEManagerBase.Apply () [0x0005f] in <6e195670478449b995e7bf837ced1c60>:0 
  at EVEManager.EVEManagerBase.LoadConfig () [0x00062] in <6e195670478449b995e7bf837ced1c60>:0 
  at EVEManager.GenericEVEManager`1[T].Setup () [0x00016] in <6e195670478449b995e7bf837ced1c60>:0 
  at EVEManager.GlobalEVEManager.Setup (System.Boolean late) [0x0005c] in <6e195670478449b995e7bf837ced1c60>:0 
[LOG 20:10:44.174] [EVE AtmosphereManager]: Running Setup
[LOG 20:10:44.175] [EVE AtmosphereManager]: Loading...
[LOG 20:10:44.176] [EVE AtmosphereManager]: Cleaning Atmosphere!
[LOG 20:10:44.176] [EVE CityLightsManager]: Running Setup
[LOG 20:10:44.176] [EVE CityLightsManager]: Loading...
[LOG 20:10:44.177] [EVE CityLightsManager]: BoulderCo/CityLights/cityLights/EVE_CITY_LIGHTS
[LOG 20:10:44.180] [EVE] Applying PQS Material Manager!
[LOG 20:10:44.203] [EVE CityLightsManager]: Applied to main Menu
[LOG 20:10:44.203] [EVE TerrainManager]: Running Setup
[LOG 20:10:44.203] [EVE TerrainManager]: Loading...
[LOG 20:10:44.204] [EVE ShadowManager]: Running Setup
[LOG 20:10:44.204] [EVE ShadowManager]: Loading...
[LOG 20:10:44.205] [EVE ShadowManager]: BoulderCo/shadows/EVE_SHADOWS
[LOG 20:10:44.206] [EVE ShadowManager]: Applying to Kerbin
[LOG 20:10:44.206] [EVE] Applying PQS Material Manager!
[LOG 20:10:44.242] [EVE ShadowManager]: Applying to Mun
[LOG 20:10:44.243] [EVE] Applying PQS Material Manager!
[LOG 20:10:44.279] [EVE ShadowManager]: Applying to Minmus
[LOG 20:10:44.279] [EVE] Applying PQS Material Manager!
[LOG 20:10:44.315] [EVE ShadowManager]: Applying to Eve
[LOG 20:10:44.315] [EVE] Applying PQS Material Manager!
[LOG 20:10:44.353] [EVE ShadowManager]: Applying to Gilly
[LOG 20:10:44.353] [EVE] Applying PQS Material Manager!
[LOG 20:10:44.389] [EVE ShadowManager]: Applying to Duna
[LOG 20:10:44.390] [EVE] Applying PQS Material Manager!
[LOG 20:10:44.425] [EVE ShadowManager]: Applying to Ike
[LOG 20:10:44.426] [EVE] Applying PQS Material Manager!
[LOG 20:10:44.461] [EVE ShadowManager]: Applying to Jool
[LOG 20:10:44.462] [EVE] Applying PQS Material Manager!
[LOG 20:10:44.462] [EVE] No PQS!
[LOG 20:10:44.499] [EVE ShadowManager]: Applying to Pol
[LOG 20:10:44.499] [EVE] Applying PQS Material Manager!
[LOG 20:10:44.535] [EVE ShadowManager]: Applying to Bop
[LOG 20:10:44.535] [EVE] Applying PQS Material Manager!
[LOG 20:10:44.572] [EVE ShadowManager]: Applying to Tylo
[LOG 20:10:44.572] [EVE] Applying PQS Material Manager!
[LOG 20:10:44.608] [EVE ShadowManager]: Applying to Laythe
[LOG 20:10:44.608] [EVE] Applying PQS Material Manager!
[LOG 20:10:44.644] [EVE ShadowManager]: Applying to Vall
[LOG 20:10:44.644] [EVE] Applying PQS Material Manager!
[LOG 20:10:44.684] [Scatterer] Celestial Body: Kerbin (CelestialBody)
[LOG 20:10:44.684] [Scatterer] Found: Kerbin / Kerbin
[LOG 20:10:44.684] [Scatterer] Celestial Body: Duna (CelestialBody)
[LOG 20:10:44.684] [Scatterer] Found: Duna / Duna
[LOG 20:10:44.684] [Scatterer] Celestial Body: Laythe (CelestialBody)
[LOG 20:10:44.685] [Scatterer] Found: Laythe / Laythe
[LOG 20:10:44.685] [Scatterer] Celestial Body: Jool (CelestialBody)
[LOG 20:10:44.685] [Scatterer] Found: Jool / Jool
[LOG 20:10:44.685] [Scatterer] Celestial Body: Eve (CelestialBody)
[LOG 20:10:44.685] [Scatterer] Found: Eve / Eve
[LOG 20:10:44.686] [Scatterer] Found main menu light
[LOG 20:10:44.689] [Scatterer] Adding DepthToDistanceCommandBuffer to Landscape Camera
[LOG 20:10:44.690] [Scatterer] Adding DepthToDistanceCommandBuffer to Landscape Camera
[LOG 20:10:44.691] [Scatterer] mapping EVE clouds
[LOG 20:10:44.699] [Scatterer] Eve assembly type found
[LOG 20:10:44.699] [Scatterer] Eve assembly version: Atmosphere, Version=1.8.0.2, Culture=neutral, PublicKeyToken=null
[LOG 20:10:44.699] [Scatterer] Successfully grabbed EVE Instance
[LOG 20:10:44.700] [Scatterer] Detected EVE 2d cloud layer for planet: Kerbin
[LOG 20:10:44.700] [Scatterer] layer2d not found for layer on planet :Laythe
[LOG 20:10:44.700] [Scatterer] layer2d not found for layer on planet :Duna
[LOG 20:10:44.700] [Scatterer] layer2d not found for layer on planet :Eve
[LOG 20:10:44.700] [Scatterer] layer2d not found for layer on planet :Eve
[LOG 20:10:44.700] [Scatterer] layer2d not found for layer on planet :Eve
[LOG 20:10:44.700] [Scatterer] layer2d not found for layer on planet :Eve
[LOG 20:10:44.700] [Scatterer] layer2d not found for layer on planet :Eve
[LOG 20:10:44.700] [Scatterer] layer2d not found for layer on planet :Jool
[LOG 20:10:44.701] [Scatterer] Core setup done
[LOG 20:10:44.702] [Scatterer] disableAmbientLight: Found scaled sunlight
[LOG 20:10:44.702] [Scatterer] disableAmbientLight: Found sunlight
[LOG 20:10:44.774] [Scatterer] Added eclipse caster Mun for Kerbin
[LOG 20:10:44.774] [Scatterer] Added eclipse caster Minmus for Kerbin
[LOG 20:10:44.815] [Scatterer] Atmosphere config found for: Kerbin
[LOG 20:10:44.823] [Scatterer] no inscatter.raw or inscatter.half file found for Kerbin
[LOG 20:10:44.823] [Scatterer] no transmittance.raw or transmittance.half file found for Kerbin
[LOG 20:10:44.824] [Scatterer] no irradiance.raw or irradiance.half file found for Kerbin
[LOG 20:10:44.825] [Scatterer] Camera overlap: 199999.7
[LOG 20:10:44.828] [Scatterer] Effects loaded for Kerbin
[LOG 20:10:45.032] [EVE CloudsManager]: Clouds2D is now MACRO
[LOG 20:10:45.032] [EVE] Applying _MainTex Cubemap
[LOG 20:10:45.032] [EVE] Applying _MainTex Cubemap
[LOG 20:10:45.032] [EVE CloudsManager]: Clouds2D is now SCALED
[LOG 20:10:45.032] [EVE] Applying _MainTex Cubemap
[LOG 20:10:45.032] [EVE] Applying _MainTex Cubemap
[LOG 20:10:45.032] [Scatterer] Camera overlap: 199999.7
[LOG 20:10:45.032] [Scatterer] Skynode initiated for Kerbin
[LOG 20:11:05.978] [Scatterer] No changes to main config, skipping saving.

 

This is a Scatterer bug- please first remove Scatterer to confirm that the bug disappears, and than try RE-DOWNLOADING Scatterer and replacing it. I can't stress it enough you have to re-download it. I'm not sure why but the tests I did back in the day indicated that only a re-download of scatterer fixed it.

7 hours ago, aceman67 said:

Trying to install this with CKAN forces the installation of Kopernicus. Is this intentional, or is the Spectra listed on CKAN (which does say it's 1.8.1 compatible) the wrong file?

The CKAN file was created by a different user and it was set up improperly so it thinks all of the parent mods are required (none of them are, except MM). A very kind user messaged me about this last week and I think we might have an update coming soon :)

Link to post
Share on other sites
  • 4 weeks later...

Hello awesome mod! Have been waiting for dependencies to update on CKAN to try it out with 1.8.1 yay

I got a weird dependency issue on CKAN installation when used together with another mod - I believe these two mods should be compatible so I opened a case on the CKAN side https://github.com/KSP-CKAN/NetKAN/issues/7662, just wanted to mention this here, in case you can look into it as well. Thank you!

 

Link to post
Share on other sites
On 1/8/2020 at 1:19 PM, Avera9eJoe said:

The CKAN file was created by a different user and it was set up improperly so it thinks all of the parent mods are required (none of them are, except MM). A very kind user messaged me about this last week and I think we might have an update coming soon :)

We're looking into some fixes for Spectra's CKAN metadata in general at the moment (see previous reply). If you'd like to join us, some expert input would be fantastic to have:

Link to post
Share on other sites
On 2/5/2020 at 6:05 PM, HebaruSan said:

We're looking into some fixes for Spectra's CKAN metadata in general at the moment (see previous reply). If you'd like to join us, some expert input would be fantastic to have:

Greetings! Thank you I totally will. I wasn't the one who made the CKAN file and I've been chatting with another person too about how to fix things. I'll join the pull and try and give some help too. The gist of the story though is that none of the parent mods are required; they are all suggested. That way the mod won't show up as outdated because one of the parent mods is outdated.

Link to post
Share on other sites

Hi. I found a bug while running Spectra on a case sensitive file system (MacOS and Linux). The configs are trying to load some assets from GameData/Spectra/Spectra_Scatterer , but on the zipfile the dir is named GameData/Spectra/Spectra_scatterer .

On Windows machines this doesn't matter, but on Linux and MacOS (with case sensitiveness turned on for the filesystems), you end up with weird images on the screen.

I checked the config files, and every one is using Spectra_Scatterer , so the easiest way out for me was to rename the directory to Spectra_Scatterer.

Cheers

-- post edit --

It's the exactly behaviour described by @Yeet_TheDinosaur . Yeet, do as I said on this post and check if it fixes the issue for you.

Edited by Lisias
Post edit
Link to post
Share on other sites
18 hours ago, Lisias said:

Hi. I found a bug while running Spectra on a case sensitive file system (MacOS and Linux). The configs are trying to load some assets from GameData/Spectra/Spectra_Scatterer , but on the zipfile the dir is named GameData/Spectra/Spectra_scatterer .

On Windows machines this doesn't matter, but on Linux and MacOS (with case sensitiveness turned on for the filesystems), you end up with weird images on the screen.

I checked the config files, and every one is using Spectra_Scatterer , so the easiest way out for me was to rename the directory to Spectra_Scatterer.

Cheers

-- post edit --

It's the exactly behaviour described by @Yeet_TheDinosaur . Yeet, do as I said on this post and check if it fixes the issue for you.

Hey! I see the error (Scatterer's configs for Kerbin/Laythe/Duna were duplicated inside of the Jool config for some reason), and there is a quick change I want to make to the Space Center ground, so I am going to push an update in just a second.

Link to post
Share on other sites

@Avera9eJoe I see from the date, that v1.2.3 was most likely released for and compatable with 1.7.+, then since it also works in 1.8.1 (per the SD listing), I was just wondering if you knew for sure how far back in KSP versions that it may be backward compatable with?

And I'm also assuming that 1.2.4 is only 1.8.1 compatable due to Kopernicus changes in 1.8.1-1? (ie shaders & stuff)?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...