Jump to content

[1.11] Spectra Visual Compilation 1.4.0 "Jewel" (2nd July 2020, Force 1.10/1.11 compatibility in CKAN)


Recommended Posts

Has anyone tested if this works in upscaled Kerbin systems? I have it installed on a 10x scale system and I have some weird artifacts, like some tearing in the atmosphere when the sun sets in orbit and the whole craft turning blue in the upper atmosphere.

 

@Avera9eJoe?

Link to post
Share on other sites
10 hours ago, Emilius73 said:

Has anyone tested if this works in upscaled Kerbin systems? I have it installed on a 10x scale system and I have some weird artifacts, like some tearing in the atmosphere when the sun sets in orbit and the whole craft turning blue in the upper atmosphere.

 

@Avera9eJoe?

Strange things happen when scaling the solar system :/ I haven't tested Spectra with anything other than the default solar system.

Link to post
Share on other sites
  • 4 weeks later...
12 hours ago, StevenH said:

Hey guys, i've been searching in this topic without success : how can i fix this double clouds ? any help would be appreciated

ps : this is starting screen obviously, its the same bug in game

A list of installed add-ons affecting the appearance should be attached.

Link to post
Share on other sites
15 hours ago, StevenH said:

Hey guys, i've been searching in this topic without success : how can i fix this double clouds ? any help would be appreciated

ps : this is starting screen obviously, its the same bug in game

 

mBnwz1C.png

Hey there! Do you see this bug in flight/map view too, or only in the main menu? A list of mods might help too as BezKartuza pointed out.

Link to post
Share on other sites

@Avera9eJoe, I think I've found an issue with Spectra in KSP 1.11.

While a manned craft is in orbital flight around Kerbin - not on the launchpad - the Alt-F12 Console main tab shows a continuously repeating "Error: RenderTexture.Create failed: width & height must be larger than 0".  In the log, there's an associated "(Filename: C:\buildslave\unity\build\Runtime/Graphics/RenderTexture.cpp Line: 386)"

This shows up with KSP 1.11.0 with EVE 1.10.1-3, Scatterer 0.0722, and KopernicusBE R53 (ModularFlightIntegrator included) for 1.11.  It doesn't show up with any smaller combination of mods (at least so far as I've been able to iterate), but I don't think Kopernicus, Scatterer, or EVE is the main culprit as I'm able to run Parallax 1.1.1 with all three without any such error.

So far, it doesn't appear to be immediately debilitating, but I haven't let things run for hours.  I can pastebin the log if requested, but it should be easy to replicate with the listed mods.  I'm running the x64 version of KSP on Win10.

Edited by KSPrynk
clarification
Link to post
Share on other sites
2 hours ago, KSPrynk said:

@Avera9eJoe, I think I've found an issue with Spectra in KSP 1.11.

While a manned craft is in orbital flight around Kerbin - not on the launchpad - the Alt-F12 Console main tab shows a continuously repeating "Error: RenderTexture.Create failed: width & height must be larger than 0".  In the log, there's an associated "(Filename: C:\buildslave\unity\build\Runtime/Graphics/RenderTexture.cpp Line: 386)"

This shows up with KSP 1.11.0 with EVE 1.10.1-3, Scatterer 0.0722, and KopernicusBE R53 (ModularFlightIntegrator included) for 1.11.  It doesn't show up with any smaller combination of mods (at least so far as I've been able to iterate), but I don't think Kopernicus, Scatterer, or EVE is the main culprit as I'm able to run Parallax 1.1.1 with all three without any such error.

So far, it doesn't appear to be immediately debilitating, but I haven't let things run for hours.  I can pastebin the log if requested, but it should be easy to replicate with the listed mods.  I'm running the x64 version of KSP on Win10.

This error happen because of the new update of scatterer 0.0722.

I guess that scatterer configs of mods like spectra or AVP have to be redone, or at least modify to be compatible.

Link to post
Share on other sites

@BezKartuza, this may be related to the errors I've been getting, and the comments on  Scatterer v0.0722.  Over on the Scatterer thread, there seems to be a wide variety of issues.  I've started new saves with the same minimal install noted on 17 Dec and the errors are not consistent in which altitude they happen (I've seen it happen on the launch pad) or which planet they happen on, but it only seems to happen on planets with clouds.  Aside from the RenderTexture.Create failed error, I've also seen repeating Null Ref Exceptions in orbit around other planets (this NRE may be Parallax).  I'm wondering if the errors relate to what type/pattern/altitude of clouds are being generated, by each type of visual mod, in every instance of each save....

Edited by KSPrynk
Link to post
Share on other sites

@Avera9eJoe, @BezKartuza, this seems to be both a Scatterer and KSP 1.11 induced issue (note in the KER thread, discussion on dv calcs gone bad due to how KSP 1.11 now does decimal places) .  I reverted Scatterer to v0.0632 and had similar NRE errors around Jool.  I still think there's something to how clouds are generated over time, as I'm no longer able to get the same error consistently in a given location as I press on with a save over days.

Link to post
Share on other sites
On 12/17/2020 at 8:49 PM, KSPrynk said:

@Avera9eJoe, I think I've found an issue with Spectra in KSP 1.11.

While a manned craft is in orbital flight around Kerbin - not on the launchpad - the Alt-F12 Console main tab shows a continuously repeating "Error: RenderTexture.Create failed: width & height must be larger than 0".  In the log, there's an associated "(Filename: C:\buildslave\unity\build\Runtime/Graphics/RenderTexture.cpp Line: 386)"

This shows up with KSP 1.11.0 with EVE 1.10.1-3, Scatterer 0.0722, and KopernicusBE R53 (ModularFlightIntegrator included) for 1.11.  It doesn't show up with any smaller combination of mods (at least so far as I've been able to iterate), but I don't think Kopernicus, Scatterer, or EVE is the main culprit as I'm able to run Parallax 1.1.1 with all three without any such error.

So far, it doesn't appear to be immediately debilitating, but I haven't let things run for hours.  I can pastebin the log if requested, but it should be easy to replicate with the listed mods.  I'm running the x64 version of KSP on Win10.

 

On 12/17/2020 at 10:56 PM, Carni35 said:

This error happen because of the new update of scatterer 0.0722.

I guess that scatterer configs of mods like spectra or AVP have to be redone, or at least modify to be compatible.

Hm... Could you try deleting/removing my custom Scatterer configs folder from GameData/Spectra/Spectra_Scatterer and see if it persists? I want to confirm that it's an issue with Spectra's configs, and not base Scatterer.

16 hours ago, BezKartuza said:

 

Spectra 1.4.0 / Scatterer v0.0632 - looks ok

  Reveal hidden contents

01-Scatterer-v0-0632-Spectra-1-4-0.png


02-Scatterer-v0-0632-Spectra-1-4-0.png


03-Scatterer-v0-0632-Spectra-1-4-0.png

 

 

Spectra 1.4.0 / Scatterer v0.0722 - looks not ok

  Reveal hidden contents

01-Scatterer-0-0722.png


02-Scatterer-0-0722.png


03-Scatterer-0-0722.png


04-Scatterer-0-0722.png

 

 

 

7 hours ago, KSPrynk said:

@Avera9eJoe, @BezKartuza, this seems to be both a Scatterer and KSP 1.11 induced issue (note in the KER thread, discussion on dv calcs gone bad due to how KSP 1.11 now does decimal places) .  I reverted Scatterer to v0.0632 and had similar NRE errors around Jool.  I still think there's something to how clouds are generated over time, as I'm no longer able to get the same error consistently in a given location as I press on with a save over days.

Darn. The rainbow bug is back... :/ This is an issue with the brightness configs for the main menu being more amplified than in flight, and it's caused by trying to increase the strength of sunset colors. If you load up Andromeda's pack you'll see that he has the same issue too. The only way to fix it is to significantly deaden the color of sunsets.

Link to post
Share on other sites
34 minutes ago, Avera9eJoe said:

Hm... Could you try deleting/removing my custom Scatterer configs folder from GameData/Spectra/Spectra_Scatterer and see if it persists? I want to confirm that it's an issue with Spectra's configs, and not base Scatterer.

I deleted Scatterer_Settings.cfg in the Spectra_scatterer folder and that seems to have eliminated the error message, though I didn't check much to see what kind of substantive impact that had visually (beyond the sky has clouds, water reflects sun).  I recommend checking in on the discussion over in the Scatterer forum (link below).  Blackrack seems to have identified the problem (puts ball back in vismod pack owner's court), and may have some solutions.

Scatterer forum discussion

 My last comment regarding godrays in that forum was out of concern that Parallax's upcoming terrain collision system was also using ray tracing, but Blackrack stated they're unrelated.

Edited by KSPrynk
Link to post
Share on other sites
3 hours ago, KSPrynk said:

I deleted Scatterer_Settings.cfg in the Spectra_scatterer folder and that seems to have eliminated the error message, though I didn't check much to see what kind of substantive impact that had visually (beyond the sky has clouds, water reflects sun).  I recommend checking in on the discussion over in the Scatterer forum (link below).  Blackrack seems to have identified the problem (puts ball back in vismod pack owner's court), and may have some solutions.

Scatterer forum discussion

 My last comment regarding godrays in that forum was out of concern that Parallax's upcoming terrain collision system was also using ray tracing, but Blackrack stated they're unrelated.

Many thanks! I'll have to take a peak when I have more time/interest, I've been tied down by Elder Scrolls Online and Cyberpunk 2077 recently, but if past is any indication I'll be back to playing KSP again sometime in the not so far future.

From what you say with the error code disappearing after deleting Spectra's custom configs, it definitely sounds like there's something wrong in my configs that is causing the error. If you're brave enough you can try to patch in Blackrack's edits? Spectra's Scatterer configs basically just change the atmosphere color on Eve/Duna/Jool, and that's really the only major change. :P 

Link to post
Share on other sites
1 hour ago, Avera9eJoe said:

I've been tied down by Elder Scrolls Online and Cyberpunk 2077

Yikes...good luck on CP2077.  I was looking forward to upgrading HW for that.  Until the bugs.  And graphics hardware  replacing toilet paper on the critical supply shortages list.:unsure:

1 hour ago, Avera9eJoe said:

If you're brave enough you can try to patch in Blackrack's edits?

I'm not sure I'd recognize what he's talking to in MMcode (I think I'm in over my head), but I'll see if Scatterer has some checkboxes I can turn on and off....

EDIT: And there IS a button for Godrays in Scatterer.  That appears to have fixed it for now, though I don't know what I've lost with Godrays turned off....

Edited by KSPrynk
Link to post
Share on other sites

Hello,

I have decided to use Spectra again in my new campaign after a long absence from KSP. I am hoping to find a nice balance between recent stock revamps, Spectra, and a little bit of SVE for city lights and OPM configs. 

In terms of Spectra, I was planning to remove skybox and terrain textures but when I downloaded from Spacedock and installed to my GameData, I could not find any skybox or terrain configs in the spectra folder. 

I also remember being redirected to download a texture pack called KSPRC, which no longer seems to be the case.

And finally, I have noticed that Kopernicus, which ( i think ) would have been required for replacement of terrain textures is no longer listed as a dependency, altho Texture Replacer still is.

 

Any clarification would be most welcome, thanks in advance both for your response and your amazing work!

Link to post
Share on other sites
6 hours ago, canisin said:

Hello,

I have decided to use Spectra again in my new campaign after a long absence from KSP. I am hoping to find a nice balance between recent stock revamps, Spectra, and a little bit of SVE for city lights and OPM configs. 

In terms of Spectra, I was planning to remove skybox and terrain textures but when I downloaded from Spacedock and installed to my GameData, I could not find any skybox or terrain configs in the spectra folder. 

I also remember being redirected to download a texture pack called KSPRC, which no longer seems to be the case.

And finally, I have noticed that Kopernicus, which ( i think ) would have been required for replacement of terrain textures is no longer listed as a dependency, altho Texture Replacer still is.

 

Any clarification would be most welcome, thanks in advance both for your response and your amazing work!

Hey there! The reason you don't see any of these features is because they are no longer included in Spectra; with KSP's official updates to the skybox and surface terrain, I no longer found it enough of an improvement (and in some cases a downgrade) to include my custom terrain and skybox textures. Kopernicus is no longer a required mod. TextureReplacer is still required though to change the planet textures from orbit, though I might end up removing that too if their textures are improved enough in the future.

TL;DR: KSP updated enough that I no longer needed custom terrain and skybox textures, so I removed them. You can still use Kopernicus or TextureReplacer with other mods if you want but Spectra no longer adds anything via them.

Edited by Avera9eJoe
Link to post
Share on other sites
4 hours ago, canisin said:

I am sorry but you both said that TextureReplacer is required and it is not :)
I also could not find any cfg files in the Spectra folder that seems to require it.

Oh shoot, I did? That's definitely a mistake on my end. Wait a sec, TextureReplacer might actually not be required anymore either; I typed that out in the morning when I was still a bit foggy.

Are you installing manually or are you using CKAN? CKAN is the most updated and reliable way of installing Spectra, and it also has a list of recommended mods like custom city lights and 64k clouds.

Link to post
Share on other sites
8 hours ago, Avera9eJoe said:

Oh shoot, I did? That's definitely a mistake on my end. Wait a sec, TextureReplacer might actually not be required anymore either; I typed that out in the morning when I was still a bit foggy.

Are you installing manually or are you using CKAN? CKAN is the most updated and reliable way of installing Spectra, and it also has a list of recommended mods like custom city lights and 64k clouds.

No worries! :D  I am installing manually. And I am running the same or similar like @Xt007 above me and everything is running smooth.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...