Jump to content

[1.11] Spectra Visual Compilation 1.4.0 "Jewel" (2nd July 2020, Force 1.10/1.11 compatibility in CKAN)


Recommended Posts

10 hours ago, HafCoJoe said:

I think this bug is caused by Scatterer having updated and changed a few things without me pushing an update to Spectra; I'm hoping to get an update out when I have the time/energy

Alright, you think downgrading to some specific scatterer version could solve it?

Link to post
Share on other sites
37 minutes ago, Henninggg said:

Alright, you think downgrading to some specific scatterer version could solve it?

I'm unsure sadly; the best solution would be to go into the EVE Atmosphere main and lowering the Eve green glow altitude-

Go to GameData/Spectra/Spectra_Configs/

Open Atmo Main.cfg

Search "body = Eve"

Search "Green"

Lower the height value until it looks better

 

Link to post
Share on other sites
2 hours ago, Rocketry101 said:

So i did not press "Save" ever but this happened to Duna (Maybe a TUFX problem): AtViWpQ.png

:/ that looks exactly like what happens if you hit save several times

Link to post
Share on other sites
22 hours ago, HafCoJoe said:

:/ that looks exactly like what happens if you hit save several times

But i didnt i swear (Wait i do think i have GU installed and GU has visuals (But i removed the ones for stock)

Link to post
Share on other sites
3 hours ago, Rocketry101 said:

But i didnt i swear (Wait i do think i have GU installed and GU has visuals (But i removed the ones for stock)

Are you using multiple mods that add clouds/depend on EVE?

Link to post
Share on other sites
  • 2 weeks later...
4 hours ago, Weimaraner said:

Does anyone know what is causing this?

3nV9SEi.png

Hey there! Yes- this is caused by bugs with installing Scatterer; its usually caused when a file/filepath gets corrupted. If you installed manually- try deleting your download of Scatterer and redownloading it; if you used CKAN, you'll have to clear the local files and redownload/reinstall it through there. I hope this helps? I haven't heard a report of this in a while :confused: 

Link to post
Share on other sites

I reinstalled and re-downloaded it twice, and It is still there. I tried installing using CKAN, and It is still there. I use the Linux version of ksp.

It is just Duna, no other planets have problems.

Edited by Weimaraner
Link to post
Share on other sites
7 hours ago, Weimaraner said:

I reinstalled and re-downloaded it twice, and It is still there. I tried installing using CKAN, and It is still there. I use the Linux version of ksp.

It is just Duna, no other planets have problems.

hm... good to know you're using Linux; there'se an error with the filepath capitalization that only effects linux builds (since they care about capitalization and standard does not). I've been meaning to push an update with a few things but haven't had the time/energy for a while; I'll see if I can get to it soon.

Link to post
Share on other sites

 

4 hours ago, HafCoJoe said:

hm... good to know you're using Linux; there'se an error with the filepath capitalization that only effects linux builds (since they care about capitalization and standard does not). I've been meaning to push an update with a few things but haven't had the time/energy for a while; I'll see if I can get to it soon.

Ok, Thanks. I'll run it without scatterer.

Link to post
Share on other sites
  • 2 weeks later...
On 4/12/2021 at 9:00 AM, Henninggg said:

Eve looks a little weird for me? Other planets looks fine.

kwcjSna.pngkjmNyfu.png

Am getting the same issue as this poster on Eve, as well as a similar issue involving the terminator line on Kerbin. It just looks like a solid red line going around the planet, see here. Also have the most recent versions of EVE and Scatterer installed. Assuming it's the same issue?

20210506063336_1.jpg

20210506051802_1.jpg

Link to post
Share on other sites
On 3/18/2021 at 10:36 PM, Xemrael said:

Greetings, I've been using this mod and have some questions.

First is why doesn't Mun get eclipsed by Kerbin? I mean, it still gets light by the Sun like in Stock:

 

Kerbin doesn't cast a shadow onto the Mun

JpsVCIS.jpg

 

This is a very rough put image but i hope you all get the idea, Kerbin is eclipsing the sun, but there is still light on the Mun ground

tvVMdZ5.jpg

 

Now this part is probably more for the Scatterer forum thread, but still I'll ask here; I have tried to set this options on but they seem to do nothing and reset every time I close and open the game, anything in particular or a bug?

Changing "Fourier grid size" to any of the other 3 values always gets reset, same for "Sky reflections"

CJXOYak.jpg

And same for "Long-Distance terrain shadows"

e0FPZCT.jpg

Hey sorry to repost, just wanted to get an answer for this...

Link to post
Share on other sites
1 hour ago, Xemrael said:

Hey sorry to repost, just wanted to get an answer for this...

Greetings! Thank you for reposting, I must have missed it first time. That's odd because I thought I enabled eclipses; I'll have to look at my settings to see. It might have been because of issues with EVE and Scatterer interacting but I can't remember now :/

I've been meaning to get an update out for Spectra but I haven't had the time to lately; I'll mark this down as something to look into.

Link to post
Share on other sites
14 hours ago, HafCoJoe said:

Greetings! Thank you for reposting, I must have missed it first time. That's odd because I thought I enabled eclipses; I'll have to look at my settings to see. It might have been because of issues with EVE and Scatterer interacting but I can't remember now :/

I've been meaning to get an update out for Spectra but I haven't had the time to lately; I'll mark this down as something to look into.

Thanks for the answer! I did not check all planets, so for example Laythe or others, do cause shadows onto Jool's atmosphere, when passing in front of the Sun, and Laythe gets completely dark when obscured by Jool. The Mun does cause a shadow onto Kerbin, but as I have read sadly only affects the atmosphere, still i was expecting the Mun to get completely dark when blocked by kerbin :huh:

And what about the ingame Scatterer settings? is it something to do with your config files or just a bug?

Link to post
Share on other sites
9 hours ago, dresoccer4 said:

Quick q: is this mod compatible with Parralax?  Wasn't sure if there was overlap

People have reported they work together perfectly :)

11 hours ago, Xemrael said:

Thanks for the answer! I did not check all planets, so for example Laythe or others, do cause shadows onto Jool's atmosphere, when passing in front of the Sun, and Laythe gets completely dark when obscured by Jool. The Mun does cause a shadow onto Kerbin, but as I have read sadly only affects the atmosphere, still i was expecting the Mun to get completely dark when blocked by kerbin :huh:

And what about the ingame Scatterer settings? is it something to do with your config files or just a bug?

It would most likely be something due to my config files, though I can't recall where; the only thing that seems to be changed in my files are terrainShadows = False in GameData\Spectra\Spectra_scatterer\Scatterer_Settings.cfg but I don't think that effects eclipses to my knowledge :/

Link to post
Share on other sites
15 hours ago, HafCoJoe said:

It would most likely be something due to my config files, though I can't recall where; the only thing that seems to be changed in my files are terrainShadows = False in GameData\Spectra\Spectra_scatterer\Scatterer_Settings.cfg but I don't think that effects eclipses to my knowledge :/

Just asking because i got really confused when I tried to change those settings that i highlighted, on the Scatterer in-game menu, and having them do nothing and resetting every time i restarted the game.

As for the eclipses, at least for the Mun i can confirm that the light goes trough Kerbin.

Link to post
Share on other sites
6 hours ago, Xemrael said:

Just asking because i got really confused when I tried to change those settings that i highlighted, on the Scatterer in-game menu, and having them do nothing and resetting every time i restarted the game.

As for the eclipses, at least for the Mun i can confirm that the light goes trough Kerbin.

Ah yeah- the in-game scatterer gui doesn't actually save; you have to test variables in game and then manually change them in the files in GameData/Spectra/Spectra_Scatterer

Link to post
Share on other sites
15 hours ago, geostationary_coffee said:

Is spectra CPU or GPU-intensive? The visual effects are stunning but it really increases lag compared to stock (especially in desert biomes, where even with a 3600x+5600xt I can only get single-digit FPS numbers)

Most visual mods are GPU intensive, while KSP itself is CPU intensive. Spectra is actually quite optimized compared to other visual mods, though it will always have some level of lag. Are you running Scatterer as well? Scatterer is the largest GPU hog of all the parent mods, and thus the largest impact on FPS, so you can try uninstalling it and seeing what it does if you want?

Also, how many parts is the craft that you're using? 

Link to post
Share on other sites
12 hours ago, HafCoJoe said:

Most visual mods are GPU intensive, while KSP itself is CPU intensive. Spectra is actually quite optimized compared to other visual mods, though it will always have some level of lag. Are you running Scatterer as well? Scatterer is the largest GPU hog of all the parent mods, and thus the largest impact on FPS, so you can try uninstalling it and seeing what it does if you want?

Also, how many parts is the craft that you're using? 

I am running scatterer…but I wouldn't want to disable it since the atmospheric effects are BEAUTIFUL, and lagging is nonexistent as long as I'm in space.

The craft only has 46 parts…I've flown this thing all around Kerbin and so far desert biomes have been the only place the game seems  to REALLY slow down. I'm guessing this has nothing to do with part count since I have surface experiments in the desert and switching to those also causes lag. 

(Another interesting observation: I've noticed that the surface of Duna-which I assume implements similar visual effects to Kerbin's deserts-suffers from almost no lag at all.)

Is there a way to solve this issue?

Link to post
Share on other sites
6 hours ago, geostationary_coffee said:

Is there a way to solve this issue?

Sadly no since I can't say I've experienced this myself. Sorry to hear you're getting single digit frames :/ are you starting your missions in the desert, or are you flying there and noticing it? The longer your game is open the worse your fame rate gets over time as it collects garbage.

Link to post
Share on other sites
7 hours ago, geostationary_coffee said:

I am running scatterer…but I wouldn't want to disable it since the atmospheric effects are BEAUTIFUL, and lagging is nonexistent as long as I'm in space.

The craft only has 46 parts…I've flown this thing all around Kerbin and so far desert biomes have been the only place the game seems  to REALLY slow down. I'm guessing this has nothing to do with part count since I have surface experiments in the desert and switching to those also causes lag. 

(Another interesting observation: I've noticed that the surface of Duna-which I assume implements similar visual effects to Kerbin's deserts-suffers from almost no lag at all.)

Is there a way to solve this issue?

Does it also happen with stock?

Check the reflections settings

KtdxhgW.jpg

Believe me, the higher it is the heavier the impact, those settings i just can't max out, being on the Mun with lights makes me see a PowerPoint show.

Link to post
Share on other sites
19 hours ago, Xemrael said:

Does it also happen with stock?

Check the reflections settings

KtdxhgW.jpg

Believe me, the higher it is the heavier the impact, those settings i just can't max out, being on the Mun with lights makes me see a PowerPoint show.

Oh wow that actually worked, I turned those down to Medium and 1024 and I'm getting above 30 now!

thanks!

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...