Jump to content

[1.12.3] Spectra Visual Compilation 1.6.2 "Horizons" (26th July 2022)


HafCoJoe
 Share

Recommended Posts

On 11/11/2021 at 3:28 AM, DPOHbl4 said:

FYI new version of scatterer most likely brakes most parts of this mod. Previous version 0772 works fine for me

Can confirm, especially Eve is looking funky. The rest of the bodies seem unbroken, but they do look somewhat different from previous scatterer versions, eg. a more saturated blue for Kerbin.

Link to comment
Share on other sites

On 11/16/2021 at 10:35 AM, KawaiiLucy said:

Can confirm, especially Eve is looking funky. The rest of the bodies seem unbroken, but they do look somewhat different from previous scatterer versions, eg. a more saturated blue for Kerbin.

Oh, I was already thinking that I did something wrong. Kerbin's atmosphere is looking a bit... thick

Spoiler

zdsSySa.png

Is the atmosphere supposed to look like that at 79 km ASL?

Edited by Just a random person
Seems that it's a scatterer issue
Link to comment
Share on other sites

7 hours ago, Just a random person said:

Oh, I was already thinking that I did something wrong. Kerbin's atmosphere is looking a bit... thick

  Reveal hidden contents

zdsSySa.png

Is the atmosphere supposed to look like that at 79 km ASL?

That might be a base Scatterer thing, there were a couple of posts in the Scatterer thread reporting the same blue glow (which extends up to at least 100km, if my last launch is to be believed).

Link to comment
Share on other sites

On 11/11/2021 at 4:28 AM, DPOHbl4 said:

Previous version 0772 works fine for me

 

13 hours ago, waefre_1 said:

That might be a base Scatterer thing, there were a couple of posts in the Scatterer thread reporting the same blue glow (which extends up to at least 100km, if my last launch is to be believed).

Yep, downgraded scatterer to  0.0772 and it worked fine

Link to comment
Share on other sites

  • 1 month later...
On 12/22/2021 at 5:35 PM, adriangm44 said:

Is the problem with Scatterer already fixed?

Apparently not. Needed to downgrade it. And now I'm getting trouble making sunflares work again... Not sure why. The fix cfg file worked fine for me before but maybe I forgot how to apply it properly.

UPD: got it working. Sunflare component of scatterer wasn't even installed, although CKAN listed it. Downloaded it manually and sunflares appeared, no need for the old fix. Just make sure to downgrade scatterer to 0772

Edited by AbsoluteHuman
update
Link to comment
Share on other sites

Cant even get past the menu the mod makes kopernicus say "kopernicus was unable to load the custom planetary system."

I would love any help!

Link to comment
Share on other sites

2 hours ago, siklidkid said:

Cant even get past the menu the mod makes kopernicus say "kopernicus was unable to load the custom planetary system."

I would love any help!

Don't think Kopernicus is even used in the current version of Spectra. Are you using the latest one? And I guess Spectra isn't compatible with any planetary expansions either way. So maybe just delete Kopernicus?

If the question is how to make them work together than I don't know very much about it. But probably makes sense to look into Kopernicus configs and maybe at least reinstall them.

Link to comment
Share on other sites

5 minutes ago, AbsoluteHuman said:

Don't think Kopernicus is even used in the current version of Spectra. Are you using the latest one? And I guess Spectra isn't compatible with any planetary expansions either way. So maybe just delete Kopernicus?

If the question is how to make them work together than I don't know very much about it. But probably makes sense to look into Kopernicus configs and maybe at least reinstall them.

Hmm, i'll try that.

Link to comment
Share on other sites

Hi. New to Spectra and the sunflare doesn't work at all. I'm not using Scatterer but the Scatterer sunflare is a dependency for Spectra in CKAN. The sun looks smaller and dimmer than stock but no flare no matter where the ship is and same in map view too. KSP 1.12.3. Mod list:

Spoiler

[x] Science! Continued (xScienceContinued 6.0.0.9)
Advanced Fly-By-Wire (Windows) (AdvancedFlyByWire 1.8.3.6)
Better Load Save Game Renewed (BetterLoadSaveGame 2.5.3.4)
Breaking Ground (BreakingGround-DLC 1.7.1)
ClickThrough Blocker (ClickThroughBlocker 1:0.1.10.17)
Community Trait Icons (CommunityTraitIcons v1.1.1)
Contract Parser (ContractParser 9.0)
Contracts Window + (ContractsWindowPlus 9.4)
Craft Manager (CraftManager 1.2.0)
Distant Object Enhancement /L (DistantObject v2.1.1.6)
Distant Object Enhancement /L default config (DistantObject-default v2.1.1.6)
Easy Vessel Switch (EVS) (EasyVesselSwitch 2.3)
EasyBoard (EasyBoard 1.10)
Editor Extensions Redux (EditorExtensionsRedux 3.4.3.5)
Environmental Visual Enhancements Redux (EnvironmentalVisualEnhancements 3:1.11.6.1)
Fill It Up (FillitUp 0.2.0.2)
Hangar Extender (HangerExtenderExtended 3.6.0.2)
Haystack ReContinued (HaystackReContinued 0.5.7.4)
Improved and Updated Chase Camera (ImprovedUpdatedChaseCam 1.6.4.1)
Kerbal Alarm Clock (KerbalAlarmClock v3.13.0.0)
Kerbal Engineer Redux (KerbalEngineerRedux 1.1.9.0)
Kopernicus Planetary System Modifier (Kopernicus 2:release-1.12.1-70)
KSP Recall (KSP-Recall v0.2.1.3)
KXAPI (KXAPI 1.2.0)
Making History (MakingHistory-DLC 1.12.1)
ModularFlightIntegrator (ModularFlightIntegrator 1.2.10.0)
Module Manager (ModuleManager 4.2.1)
Parallax (Parallax 1.3.1)
Parallax - Stock Planet Textures (Parallax-StockTextures 1.3.1)
Planning Node (PlanningNode v0.1.4)
Pood's Milky Way Skybox (PoodsMilkyWaySkybox v.1.3.0)
Portrait Stats (PortraitStats 18.0)
Progress Parser (ProgressParser 11.0)
QuickBrake (QuickBrake 1:1.4.0.8)
QuickGoTo (QuickGoTo 1:1.4.0.9)
Scatterer Sunflare (Scatterer-sunflare 3:v0.0828)
Ship Manifest (ShipManifest 6.0.4.0)
SimpleFuelSwitch (SimpleFuelSwitch 1.4)
Smart Docking Aid (SmartDockingAid v1.1.0)
SpaceTux Library (SpaceTuxLibrary 0.0.8.4)
SpaceY Expanded (SpaceY-Expanded 1.4)
SpaceY Heavy Lifters (SpaceY-Lifters 1.17.2)
Spectra (Spectra v1.5.0)
TAC Fuel Balancer (TacFuelBalancer v2.21.5.2)
TextureReplacer (TextureReplacer v4.5.2)
Toolbar Controller (ToolbarController 1:0.1.9.6)
Trajectories (Trajectories v2.4.3)
TriggerAu Flags (TriggerAu-Flags v2.10.0.0)
TweakScale - Rescale Everything! (TweakScale v2.4.6.8)
Waypoint Manager (WaypointManager 2.8.3.3)
Zero MiniAVC (ZeroMiniAVC 1:1.1.2.4)
 

 

Edited by Krazy1
Link to comment
Share on other sites

Hey all, apologies for my absence from updates; I've been away from KSP for the past months and I'm sadly unsure what's causing the sunflare bug; if anyone knows more, or has a solution, I'm happy to work on getting it into an official release.

Link to comment
Share on other sites

@HafCoJoe Just in case you didn't know, there is a new Scatterer version that has been quite re-worked since the previous version. I don't know if it is this in particular that causes the sunflare bug, but it does cause some other bugs when using the Spectra Scatterer configs.

Link to comment
Share on other sites

  • 2 weeks later...

BTW, is Spectra currently truly incompatible with SSCEP (Stock Scatter Collider Enabler Patch)? I've been using it lately but CKAN stops me from installing them together. I installed it manually and it seems to work...  Maybe some CKAN info needs to be updated? (not sure if it is in SSCEP or Spectra). I get weird texture flickering on the Mun surface (and not other bodies) but looks like it is associated with Kopernicus (SSCEP requirement) and not the mod itself.

Or... Is the real reason of incompatibility with Spectra the Kopernicus mod itself? Then it's sad. At least the sunflares still work fine (with downgraded Scatterer)!

Link to comment
Share on other sites

Hello, I'm experiencing a glitch with Duna.

I've posted the same issue on Reddit, but so far I haven't gotten any satisfactory answers.  Duna looks bluer in that post because I messed around with EVE clouds, which may actually be connected to the issue.

As you can see, Duna has gained blue coloration and EVE seems to be messing up. (Only cloud config available is "DunaAtmoScatterBlue", and the name is invalid(?))

 

- I have already reinstalled both Spectra and EVE several times

- All other planets look as they should

- I am at a loss for what to do

Thank you in advance for any help.

@HafCoJoe

Edited by HenriJayy
Forgot to ping HafCoJoe
Link to comment
Share on other sites

- Troubleshooting did not work

- Using an older version of Scatterer also did not work

I also couldn't've tampered with EVE, as I don't know how even to use the settings.

Help

 

Edited by HenriJayy
Forgot to mention if I tampered with EVE or not
Link to comment
Share on other sites

On 4/19/2017 at 8:26 AM, HafCoJoe said:

Troubleshooting:

  •  
  • Duna is completely blue (more than in the trailer/pictures): You probably clicked `save` in the EVE GUI. Pressing save breaks some of my ModuleManager configs. Don't press save and you'll be fine. If you do press save, reinstalling Spectra will fix this.

That's from the OP. It seems almost impossible to have another cause for that very specific problem... right? My Duna looks good (I'm not using Scatterer). So... I suppose you didn't properly nuke the related mods and redownload them. Did you delete the mod folders in the Gamedata folder? If that really doesn't work then you need to post a KSP log file. I personally can't help further but nobody can help without more details. Are you using CKAN

Link to comment
Share on other sites

2 minutes ago, Krazy1 said:

That's from the OP. It seems almost impossible to have another cause for that very specific problem... right? My Duna looks good (I'm not using Scatterer). So... I suppose you didn't properly nuke the related mods and redownload them. Did you delete the mod folders in the Gamedata folder? If that really doesn't work then you need to post a KSP log file. I personally can't help further but nobody can help without more details. Are you using CKAN

I think I figured out a solution. In the EVE menu in-game, how do you delete DunaAtmoScattererBlue?

- I was using CKAN until I last had to reinstall every mod. It now bugs out, asking to install mods that are already installed, so now I'm not using CKAN. I did delete the mod folders before replacing them, yes. I didn't Cut/Paste.

Link to comment
Share on other sites

More issues.

unknown.png

- Kerbin only has sparse clouds. No real cloud formations appear, it's just these clouds all the time. [Other relevant mods installed: Latest versions of EVE and Scatterer]

Other issues I won't get into:

 - Eve has blue clouds in some places

- Duna is still blue, had to delete the EVE configs

I think I'm gonna try reverting to a previous version of Spectra.

Link to comment
Share on other sites

  • 1 month later...
  • 1 month later...
10 hours ago, Krazy1 said:

Hi @HafCoJoeAt least 3 of the custom Scatterer settings are not being loaded from the scatterer config.cfg file when Spectra is installed. 

Please see diagnosis over on that thread. 

 

No need to bother him, he just provides custom settings. Just delete the .cfg included in spectra or override it if you want.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...