Avera9eJoe

[1.7.3] Spectra v1.2.3 - Visual Compilation (21th March 19)

Recommended Posts

On 3/15/2019 at 7:04 AM, Avera9eJoe said:

 

hm... it sounds as though the update changes a number of things in Spectra's configs. In the meantime I suggest playing either without Spectra or without Scatterer, as Spectra has backup atmospheres that enable when it doesn't find Scatterer.

Or you can delete scatter configs from spectra folder :)

Spoiler

VkYLHSXoFM0.jpg

 

Share this post


Link to post
Share on other sites

Small note about the Kopernicus_terrain config - it contains a mismatched number of opening and closing curly braces. The closing brace on line 4720 closes the @Kopernicus from the beginning of the config, I think... (right before @Body[Eeloo])

Share this post


Link to post
Share on other sites
On 3/18/2019 at 3:41 AM, AccidentalDisassembly said:

Small note about the Kopernicus_terrain config - it contains a mismatched number of opening and closing curly braces. The closing brace on line 4720 closes the @Kopernicus from the beginning of the config, I think... (right before @Body[Eeloo])

Yeah i just run config trough https://nginxbeautifier.com/ and as result:

rFL7x1i.png

Share this post


Link to post
Share on other sites
10 minutes ago, RangeMachine said:

Yeah i just run config trough https://nginxbeautifier.com/ and as result:

rFL7x1i.png

Huh... I'll mark that down to fix, thanks!

I'm in the middle of finals right now (infographic worth half my grade is due tomorrow, doing it on the space shuttle) so there's going to be a delay before I can get my Scatterer configs working. I should have it in a few weeks. Until then I suggest deleting the Scatterer configs and playing with Blackrack's defaults.

Share this post


Link to post
Share on other sites
2 minutes ago, Avera9eJoe said:

Huh... I'll mark that down to fix, thanks!

I'm in the middle of finals right now (infographic worth half my grade is due tomorrow, doing it on the space shuttle) so there's going to be a delay before I can get my Scatterer configs working. I should have it in a few weeks. Until then I suggest deleting the Scatterer configs and playing with Blackrack's defaults.

WIll wait, really liked your Duna colors :)

Share this post


Link to post
Share on other sites
Posted (edited)
5 hours ago, RangeMachine said:

WIll wait, really liked your Duna colors :)

Thank you, that means a lot actually. <3

Most commentary about Duna is dislike for it's blue hue. It's good to hear I'm not the only one who likes it. :)

Edited by Avera9eJoe

Share this post


Link to post
Share on other sites
Posted (edited)
9 hours ago, Avera9eJoe said:

Thank you, that means a lot actually. <3

Most commentary about Duna is dislike for it's blue hue. It's good to hear I'm not the only one who likes it. :)

You removed the yellow tint from the Sun's reflection on Kerbin in the last update. You don't like this now?

I still like the yellow tint, even wrote a small patch to restore it :)

Edited by Marschig

Share this post


Link to post
Share on other sites
Posted (edited)
14 hours ago, RangeMachine said:

WIll wait, really liked your Duna colors :)

Will wait too. Even with the scatterer problem, it is the best visual mod i ever used. 

May kerbal force be with you during your finals

Edited by Phileraene
I m not english spoken...

Share this post


Link to post
Share on other sites
Posted (edited)
15 hours ago, Marschig said:

You removed the yellow tint from the Sun's reflection on Kerbin in the last update. You don't like this now?

I still like the yellow tint, even wrote a small patch to restore it :)

:O I might have on accident, could you send me that patch? Scatterer is the mod I know the least about, and for the last update I skimmed this thread for all the suggestions people made, added them, and then pushed a release as soon as I saw it looked good. I probably changed that without thinking.

On another note, I always wanted to make Kerbin more vibrant blue but I never figured out how to do it. The .half files couldn't make it intense enough.

I might ask for another user to co-author Spectra with who can help me out with my Scatterer configs, if one of you is interested? I got a little burned out when editing the configs last time, so it might be a good idea to pass it to someone who knows more than me. You'd get free reign over the aesthetic of Spectra's Scatterer, and get your name on the OP/config file.

Edited by Avera9eJoe

Share this post


Link to post
Share on other sites
2 hours ago, Avera9eJoe said:

I might have on accident, could you send me that patch?

I just restored some parameters from the previous Spectra:

// Yellow Tint is back :)  (remove this file if you don't like this)
@Scatterer_atmosphere:AFTER[Spectra]
{
	@Atmo[Kerbin]
		{
		@configPoints
		{
			@Item,4
			{
				@skyExtinctionMultiplier = 1
				@skyExtinctionTint = 1.5
			}
			@Item,5
			{
				@skyExtinctionMultiplier = 1
				@skyExtinctionTint = 1.5
			}
			@Item,6
			{
				@postProcessExposure = 0.06
				@skyExtinctionTint = 1.5
			}
		}
	}
}

Without the patch:

B5eeFEv.jpg

With the patch (like in the previous Spectra):

BY3ZI87.jpg

Note: this work with Scatterer 0.0336

Share this post


Link to post
Share on other sites
44 minutes ago, Marschig said:

I just restored some parameters from the previous Spectra:


// Yellow Tint is back :)  (remove this file if you don't like this)
@Scatterer_atmosphere:AFTER[Spectra]
{
	@Atmo[Kerbin]
		{
		@configPoints
		{
			@Item,4
			{
				@skyExtinctionMultiplier = 1
				@skyExtinctionTint = 1.5
			}
			@Item,5
			{
				@skyExtinctionMultiplier = 1
				@skyExtinctionTint = 1.5
			}
			@Item,6
			{
				@postProcessExposure = 0.06
				@skyExtinctionTint = 1.5
			}
		}
	}
}

Without the patch:

B5eeFEv.jpg

With the patch (like in the previous Spectra):

BY3ZI87.jpg

Note: this work with Scatterer 0.0336

Ah yes I remember making that change now, thanks

Share this post


Link to post
Share on other sites
Posted (edited)

Update 1.2.2 is uploading to SpaceDock as I type. I'd love any and all feedback on it, as the Scatterer configs took a bit of guesswork to get running- Still looking for an expert to help me with those if anyone wants to aid with Spectra!

* New Scatterer support

* More links in Extras

Edited by Avera9eJoe

Share this post


Link to post
Share on other sites

Spectra\Spectra_scatterer\Planets\Jool\atmo.cfg has configs for all planets. Is this a bug?

Share this post


Link to post
Share on other sites
9 hours ago, Marschig said:

Spectra\Spectra_scatterer\Planets\Jool\atmo.cfg has configs for all planets. Is this a bug?

Woah... Maybe? I'll look into that

Share this post


Link to post
Share on other sites
Posted (edited)

This is usually an after effect of Scatterer patches not being invoked properly into their own nodes and then using the 'Save' button in the GUI. 

You can tell when this is happening because the texture path URLs will not be pointing to the correct body in the GUI.

Edited by Poodmund

Share this post


Link to post
Share on other sites

How can I get this to work with Stock Visual Terrain?

Share this post


Link to post
Share on other sites
Posted (edited)
2 hours ago, TaintedLion said:

How can I get this to work with Stock Visual Terrain?

After installing Spectra, remove the KSPRC folder from GameData, and remove Spectra_terrain.cfg from GameData/Spectra. After that, you should be able to install SVT.

Edited by Avera9eJoe

Share this post


Link to post
Share on other sites
40 minutes ago, Avera9eJoe said:

After installing Spectra, remove the KSPRC folder from GameData, and remove Spectra_terrain.cfg from GameData/Spectra. After that, you should be able to install SVT.

I couldn't find a file called Spectra_terrain.cfg

Share this post


Link to post
Share on other sites
Posted (edited)
17 hours ago, TaintedLion said:

I couldn't find a file called Spectra_terrain.cfg

It might be labeled with some for of "Kopernicus" in it's title, sorry. Been a bit of time since I touched my terrain configs :P. I'd search GameData/Spectra for ".cfg" and delete the config that deals with terrain. It'll have Kopernicus in the file contents, and probably in the filename too.

Edited by Avera9eJoe

Share this post


Link to post
Share on other sites
2 hours ago, Avera9eJoe said:

It might be labeled with some for of "Kopernicus" in it's title, sorry. Been a bit of time since I touched my terrain configs :P. I'd search GameData/Spectra for ".cfg" and delete the config that deals with terrain. It'll have Kopernicus in the file contents, and probably in the filename too.

Okay thanks mate, it works now.

 

Share this post


Link to post
Share on other sites

I know this is not related to Spectra, but may be someone knows who to fix this thing with sun?
LKEyi4YKszA.jpg

Happens only with d3d11/opengl, with stock and scatterer sunflares

Share this post


Link to post
Share on other sites

Okay, first question, is the ocean supposed to be an inky black at all times?

Second question, how do I make it blue? 

Nota bene, I am not using d3d11 or opengl, because d3d11 makes the game lag and become extremely pixelated, and opengl makes it show the loading screen for two seconds then instantly crash with no message.

Share this post


Link to post
Share on other sites
Posted (edited)
32 minutes ago, RocketSquid said:

Okay, first question, is the ocean supposed to be an inky black at all times?

Second question, how do I make it blue? 

Nota bene, I am not using d3d11 or opengl, because d3d11 makes the game lag and become extremely pixelated, and opengl makes it show the loading screen for two seconds then instantly crash with no message.

Okay, first question, no. :P Second question, it depends. Are you using the most recent version of Scatterer? Spectra doesn't have any custom ocean configs, so its most likely something wrong with Scatterer.

All custom load commands like d311 or opengl are basically pointless now that the game is 64bit/ Unity 5. All messages suggesting them will most likely be from 3-4 years ago.

Edited by Avera9eJoe

Share this post


Link to post
Share on other sites
Just now, Avera9eJoe said:

Okay, first question, no. :P Second question, I don't know. Spectra doesn't have any custom ocean configs, so its most likely something wrong with Scatterer. Are you using the most recent version of Scatterer?

Are you using any custom commands at all on your game? All of those are basically moot now that the game is 64bit/ Unity 5. All messages suggesting them will most likely be from 3-4 years ago.

I tried, they made the game not work so great, so I stopped. I'll see if I've got a defective Scatterer, and possibly delete it if it's correct and still doing this.

Share this post


Link to post
Share on other sites
7 minutes ago, RocketSquid said:

I tried, they made the game not work so great, so I stopped. I'll see if I've got a defective Scatterer, and possibly delete it if it's correct and still doing this.

Yeah, my guess is its something w/ scatterer. On another note though I usually play without scatterer in my games since I cherish my framerate :P Its a gorgeous mod but when building with 600+ parts it can get slow

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.