Avera9eJoe

[1.7.3] Spectra v1.2.3 - Visual Compilation (21th March 19)

Recommended Posts

@Avera9eJoe do surface features such as dust storms on Duna appear without me installing scatterer or does this mod not have such without it?

Share this post


Link to post
Share on other sites
5 hours ago, The-Doctor said:

@Avera9eJoe do surface features such as dust storms on Duna appear without me installing scatterer or does this mod not have such without it?

Yes they do! Scatterer only adds the haze in atmospheric planets and the improved water visuals. EVE is what handles all particles and clouds.

Share this post


Link to post
Share on other sites
Posted (edited)

I'm also seeing those grids and Moiré patterns on Kerbin. The screenshots are from a heavily modded fresh save, but it persists on a clean install with only Spectra and its dependencies. 1080p on 2x AA and max settings.

It miraculously fixed itself after a restart, then returned after restarting again to see if that was a fluke. Two more restarts and some messing about in different scenes, but no change. Another restart and once more it didn't show. Curious. I checked if I had any start-up parameters and removed the -force-d3d11 flag, but kept -popupwindow. No issue on both tries and I'm getting a bit weary booting it up, so small sample size it is. I guess it's the DX11 API, then?

https://i.imgur.com/S2R7f2T.jpg

https://i.imgur.com/3q2cRDf.jpg

 

That aside, I think I'm in love with the mod. Crazy how pretty KSP can be.

Edited by SkullCollector

Share this post


Link to post
Share on other sites
54 minutes ago, SkullCollector said:

I'm also seeing those grids and Moiré patterns on Kerbin. The screenshots are from a heavily modded fresh save, but it persists on a clean install with only Spectra and its dependencies. 1080p on 2x AA and max settings.

It miraculously fixed itself after a restart, then returned after restarting again to see if that was a fluke. Two more restarts and some messing about in different scenes, but no change. Another restart and once more it didn't show. Curious. I checked if I had any start-up parameters and removed the -force-d3d11 flag, but kept -popupwindow. No issue on both tries and I'm getting a bit weary booting it up, so small sample size it is. I guess it's the DX11 API, then?

https://i.imgur.com/S2R7f2T.jpg

https://i.imgur.com/3q2cRDf.jpg

 

That aside, I think I'm in love with the mod. Crazy how pretty KSP can be.

I run -popupwindow on my save but other parameters can be pretty strange on visuals. I'm out of the loop on real cause, but that's sounding more and more likely. KSPRC had the same issue back before 64bit.

Share this post


Link to post
Share on other sites

I can confirm Dx11 also caused slight 'graininess' to textures on my install. I went back to Dx9 and I'll just live with my pagefile getting thrashed :P

Share this post


Link to post
Share on other sites

@Avera9eJoe so I attempted an install without ksprc or scatterer, It's fine and lovely but no dust storms, but I found a work around to make them appear that makes me very happy

Share this post


Link to post
Share on other sites
On 6/17/2019 at 8:00 PM, The-Doctor said:

@Avera9eJoe so I attempted an install without ksprc or scatterer, It's fine and lovely but no dust storms, but I found a work around to make them appear that makes me very happy

What is your workaround?

Share this post


Link to post
Share on other sites
18 hours ago, jpinard said:

What is your workaround?

I installed scifi visuals and deleted all of its folders besides the one for dust storms alongside spectra, I only installed the clouds for spectra nothing else

Share this post


Link to post
Share on other sites
On 6/21/2019 at 4:42 PM, The-Doctor said:

I installed scifi visuals and deleted all of its folders besides the one for dust storms alongside spectra, I only installed the clouds for spectra nothing else

Cool thank you!

Share this post


Link to post
Share on other sites
On 6/17/2019 at 7:41 AM, SkullCollector said:

I'm also seeing those grids and Moiré patterns on Kerbin. The screenshots are from a heavily modded fresh save, but it persists on a clean install with only Spectra and its dependencies. 1080p on 2x AA and max settings.

It miraculously fixed itself after a restart, then returned after restarting again to see if that was a fluke. Two more restarts and some messing about in different scenes, but no change. Another restart and once more it didn't show. Curious. I checked if I had any start-up parameters and removed the -force-d3d11 flag, but kept -popupwindow. No issue on both tries and I'm getting a bit weary booting it up, so small sample size it is. I guess it's the DX11 API, then?

https://i.imgur.com/S2R7f2T.jpg

https://i.imgur.com/3q2cRDf.jpg

 

That aside, I think I'm in love with the mod. Crazy how pretty KSP can be.

So the game normally runs in DX9 mode?  Where do you find the Kerbal start-up parameters and if you didn't put DX11 in there who/what did?

Share this post


Link to post
Share on other sites
1 hour ago, jpinard said:

So the game normally runs in DX9 mode?  Where do you find the Kerbal start-up parameters and if you didn't put DX11 in there who/what did?

You make a shortcut and add the parameters behind the path, or if you run via steam you put them in "SET LAUNCH OPTIONS" from the games properties.

Share this post


Link to post
Share on other sites
Posted (edited)

Several years without playing the game (and all my ships and saves are now lost of course because I was using mods that have not been updated), I have to say that your work significantly participated in my renewed excitement! I'm really glad to find a pack like that to dive in KSP again. The complicated installation of mods, especially the conflicts and sometimes difficulty in knowing which mod does what (can mods be combined or do they replace each others, etc.), have always been what kept me from getting back to KSP in the past. After having been used to the improved graphics, it is hard to find motivation for Vanilla KSP. Therefore, I'm very grateful that people maintain such great packs and do some curating to ease the whole process.

I see that Scatterer is recommended for the pack, but unfortunately it seems to cause glitches in my case: Kerbin is very dark with a yellowish tint from space, and totally black from the ground:

z_T7.png

z_TC.png

Removing Scatterer solves the black Kerbin ground, weird tint from space, as well as the thick opaque white glow. EVE clouds now seem to work correctly too:

z_Ai.png

However, I would prefer having Scatterer working correctly and get the benefits of it.

Finally, I'm also having a glitch with helmets, I am guessing it is related to reflection but I am not sure what mod causes that:

z_T5.png

z_TR.png

Any ideas? I'm running KSP 1.7.1 since Kopernicus is not ready for 1.7.2 yet.
 

 

 

Edited by Korb Biakustra

Share this post


Link to post
Share on other sites
Posted (edited)
2 hours ago, Korb Biakustra said:

Several years without playing the game (and all my ships and saves are now lost of course because I was using mods that have not been updated), I have to say that your work significantly participated in my renewed excitement! I'm really glad to find a pack like that to dive in KSP again. The complicated installation of mods, especially the conflicts and sometimes difficulty in knowing which mods does what (can mods be combined or do they replace each others, etc.), have always been what kept me from getting back to KSP in the past. After having been used to the improved graphics, it is hard to find motivation for Vanilla KSP). Therefore, I'm very grateful that people like maintain such great packs and do some curating to ease the whole process.

I see that Scatterer is recommended for the pack, but unfortunately it seems to cause glitches in my case: Kerbin is very dark with a yellowish tint from space, and totally black from the ground:

Removing Scatterer solves the black Kerbin ground, weird tint from space, as well as the think opaque white glow. EVE clouds now seem to work correctly too:

However, I would prefer having Scatterer working correctly and get the benefits of it.

Finally, I'm also having a glitch with helmets, I am guessing it is related to reflection but I am not sure what mod causes that:

Any ideas? I'm running KSP 1.7.1 since Kopernicus is not ready for 1.7.2 yet.
 

 

 

Are you running dx9 or something custom?

 

Edited by Jognt

Share this post


Link to post
Share on other sites

Not that I know of. No custom launch options in Steam. However, I'm playing on Linux, so maybe there are specific issues?

Share this post


Link to post
Share on other sites
2 hours ago, Korb Biakustra said:

Not that I know of. No custom launch options in Steam. However, I'm playing on Linux, so maybe there are specific issues?

At the very least it means you're not running DirectX. :D
I have no experience with Linux though so I can't help you with that sorry :/

Share this post


Link to post
Share on other sites

Hey there @Korb Biakustra and thanks @Jognt for replying for me :)

Thanks for the compliments! This pack is truly a supercut of my favorite elements of every major visual pack before it, so a lot of credit also goes to the original creators @Proot @Astronomer, @Galileo , and the rest :) it's good to know you're not using any launch options. You are correct in pretty much every you said, too. We'll have to wait for Scatter and Kopernicus to catch up for a lot of features, and those visors are definitely caused by a bug with the reflection shaders. Did you use TextureReplacer, or TextureReplacerReplaced?

Share this post


Link to post
Share on other sites

Thanks for the fast reply! 

So, do I understand it right that my issues with Scatterer are to be expected in 1.7.1? Then if no one else can use Scatterer, I'm not jealous. :>

I am using TextureReplacer, since it is the one mentioned in the Spectra zip file. Should I try with TextureReplacerReplaced? The thread didn't seem quite active, I thought we were in need of a Texture Replacer Replaced Replacement. :<

 

Share this post


Link to post
Share on other sites
3 hours ago, Korb Biakustra said:

Thanks for the fast reply! 

So, do I understand it right that my issues with Scatterer are to be expected in 1.7.1? Then if no one else can use Scatterer, I'm not jealous. :>

I am using TextureReplacer, since it is the one mentioned in the Spectra zip file. Should I try with TextureReplacerReplaced? The thread didn't seem quite active, I thought we were in need of a Texture Replacer Replaced Replacement. :<

 

You are correct to use TextureReplacer. It looks like the shader plugin isn't updated, though I'm not certain. You might want to ask in the thread. Are you using Windowshine? Reflections won't work if the reflection shader is out of date.

Share this post


Link to post
Share on other sites

I am not using Windowshine. I am curious, do you guys have working visor reflections at the moment? If yes, I could surely use your shader plugin! I will ask in the TextureReplacer eventually, but right now my priority is to solve other issues with other mods (some SSTU parts don't assemble as they should). Then fixing Scatterer would be good too, but apparently I'm not the only one having these issues at the moment, until an update is released.  The visor issue is minor, lowest priority at the moment.

Share this post


Link to post
Share on other sites
7 minutes ago, Korb Biakustra said:

I am not using Windowshine. I am curious, do you guys have working visor reflections at the moment? If yes, I could surely use your shader plugin! I will ask in the TextureReplacer eventually, but right now my priority is to solve other issues with other mods (some SSTU parts don't assemble as they should). Then fixing Scatterer would be good too, but apparently I'm not the only one having these issues at the moment, until an update is released.  The visor issue is minor, lowest priority at the moment.

Could you send a picture of your GameData folder just in case so I can see the other mods you have installed too? It might give me some more info too.

Share this post


Link to post
Share on other sites

There is one in my post above with the pictures. But wait, turns out I might be using a wrong version of TextureReplacer, I was misled by a mention saying "this version has working reflections" in the thread, but it is probably outdated. I'll try another one. Is there any chance it can solve Scatterer, or is Scatterer definitely not working for 1.7.1 yet?

Share this post


Link to post
Share on other sites
Posted (edited)

@Avera9eJoe

Kudos on your work in this, I discovered the mod via FB just today, and uninstalled Astronomers to give it a go.
I'm doing it all through CKAN and can report that all went well (after reverting to 1.7.1 cos Kopernicus). All dependencies seemed to work out OK!
I really like the shading/colours, they are much more subtle.
There is one thing I can't seem to find, maybe I'm just needing to tweak something, and that's cloud shadows on Kerbin. Or is it just a case on a one liner change in a config file?
Anyway, good work and I came on here to say so, I don't post very often as you can see! :)

Edited by gigglebok
made a mess of bold chars!

Share this post


Link to post
Share on other sites
Posted (edited)
2 hours ago, gigglebok said:

@Avera9eJoe

Kudos on your work in this, I discovered the mod via FB just today, and uninstalled Astronomers to give it a go.
I'm doing it all through CKAN and can report that all went well (after reverting to 1.7.1 cos Kopernicus). All dependencies seemed to work out OK!
I really like the shading/colours, they are much more subtle.
There is one thing I can't seem to find, maybe I'm just needing to tweak something, and that's cloud shadows on Kerbin. Or is it just a case on a one liner change in a config file?
Anyway, good work and I came on here to say so, I don't post very often as you can see! :)

Thank you! *Changing shadows would take some manual editing of config files since if you save through the EVE gui it tends to break Dunas configs. I disabled them since they use a few extra frames and I was worried about system impact.

Edited by Avera9eJoe

Share this post


Link to post
Share on other sites
11 hours ago, Avera9eJoe said:

Thank you! *Changing shadows would take some manual editing of config files since if you save through the EVE gui it tends to break Dunas configs. I disabled them since they use a few extra frames and I was worried about system impact.

Could you give me some pointers on where to look to change/add cloud shadow settings? I am a complete n00b compared to you but I can handle a text editor - it's just something I am really missing compared to the other
"eye candy" mods. I did a quick google but all the references I can see are either to do with making your own Unity model or showing off features in other mods. If it has the shadows it would be perfect :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.