Jump to content

Umnanned crewable command pods not launchable


Recommended Posts

Hi there,

i am writing a cfg that should provide upgradeable (via stock upgrade mechanism) SAS and remote controll support. cfg follows:

Spoiler

// Upgradeable SAS and removed minimumCrew
@PART[*]:HAS[@MODULE[ModuleCommand]:HAS[~minimumCrew[0]]]:FOR[RealCommandModules]
{

    @MODULE[ModuleCommand]
    {
        //showUpgradesInModuleInfo = true    
        
        UPGRADES
        {
            UPGRADE
            {
                name__ = unmanned_crew_pods
                description__ = Now with internal probe core.
                minimumCrew = 0
                
                RESOURCE
                {
                    name = ElectricCharge
                    rate = 0.025
                }
                hasHibernation = true
                hibernateOnWarp = true
            }
        }
    }

    MODULE
    {
        name = ModuleSAS
        //showUpgradesInModuleInfo = true    
        moduleIsEnabled = false
        
        UPGRADES
        {
            UPGRADE
            {
                name__ = SAS_support_lvl0
                description__ = Now with basic SAS support.
                SASServiceLevel = 0
                moduleIsEnabled = true
            }
            
            UPGRADE
            {
                name__ = SAS_support_lvl1
                description__ = Now with level 1 SAS.
                SASServiceLevel = 1
                moduleIsEnabled = true
            }
            
            UPGRADE
            {
                name__ = SAS_support_lvl2
                description__ = Now with level 2 SAS.
                SASServiceLevel = 2
                moduleIsEnabled = true
            }
            
            UPGRADE
            {
                name__ = SAS_support_lvl3
                description__ = Now with level 3 SAS.
                SASServiceLevel = 3
                moduleIsEnabled = true
            }
        }
    }
}

PARTUPGRADE
{
    name = SAS_support_lvl0
    partIcon = RelayAntenna100
    techRequired = electrics    
    entryCost = 5000
    cost = 0
    title = Basic SAS Support
    description = Adds basic SAS capabilities for manned command modules.
}

PARTUPGRADE
{
    name = SAS_support_lvl1
    partIcon = RelayAntenna100
    techRequired = precisionEngineering    
    entryCost = 5000
    cost = 0
    title = Level 1 SAS Support
    description = Adds level 1 SAS capabilities for manned command modules.
}

PARTUPGRADE
{
    name = SAS_support_lvl2
    partIcon = RelayAntenna100
    techRequired = unmannedTech    
    entryCost = 5000
    cost = 0
    title = Level 2 SAS Support
    description = Adds level 2 SAS capabilities for manned command modules.
}

PARTUPGRADE
{
    name = SAS_support_lvl3
    partIcon = RelayAntenna100
    techRequired = advUnmanned    
    entryCost = 5000
    cost = 0
    title = Level 3 SAS Support
    description = Adds level 3 SAS capabilities for manned command modules.
}

PARTUPGRADE
{
    name = unmanned_crew_pods
    partIcon = RelayAntenna100
    techRequired = basicScience    
    entryCost = 5000
    cost = 0
    title = Probe Cores for Manned Pods
    description = Adds basic remote control capabilities for manned command modules.
}


 

It also works (almost, since i cant add modules with upgrades, SAS is shown from the beginning, but cant be used since i use moduleIsEnabled = false), as shown here:

rxGKj1r.png

See the Unmanned under Command. So no Crew needed anymore, BUT i get following message if i try to launch without crew:

z6XZ1RR.png

Log says: [LOG 18:53:15.552] [Pre-Flight Check]: Checking for NoControlSources: FAIL!

Is this a bug related to the upgrade mechanism not being checked by the Pre-Flight Checks? Just to be clear, the pod works fine without crew:

MFVNttz.png

Edited by Blackline
Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...