VITAS

SpaceDock.info (Mod Hosting Site)

Recommended Posts

Vorg    65

Getting emails also now, but unless you still have servers to move, I don't see anyway to check the current email on file or change it if you get a different email, for those that rely on ISP's for email and chase after current best deals. 

Share this post


Link to post
Share on other sites
VITAS    495
Posted (edited)

Yes youre right. You cant change your email address atm. Unless i find a bunch of python devs im unable to change that. sorry.

Im simply to busy to add features to the site.

Moving Servers is a permanent thing.
Theres always change in the infrastructure.

E.g. The G20 summit is where one rack is located and i cant get to it until thats over (see todays images below), so i had to move stuff off there untill i can gurantee that i can fix stuff it it breaks.

Then theres stuff that breaks and adjustments in resources dependiong on that months donations.

SpaceDock is a busy site so i need to work on it all the time.

Life would be great if i wasnt the only one maintaining it. (apart from Thomas coding on future versions)

 

Update:

i hope they dont burn down the servers :/

there are thick smoke clouds i can see from here over the area.

gipfel1014_v-contentgross.jpg

3e5dad5f5521061d89c42f17398ade23ea20e8cd

71-108730421.jpg&sp=c4887ae9d3b209b74f83

Update

My Servers still exist But there was some massive destruction on the streets arround the Building (burning cars, destroyed shops and the like).

Its all cleaned up now and i will check on the systems tomorrow.

https://www.reuters.com/news/picture/protesting-the-g-idUSRTX3ABM0

https://uk.reuters.com/article/uk-g20-germany-protests-idUKKBN19S1BB?il=0

 

 

Edited by VITAS

Share this post


Link to post
Share on other sites
VITAS    495

We had some downtime today. I found a Bug in the sites code.

Its now running again.

Share this post


Link to post
Share on other sites
shdwlrd    10

I keep getting a HTTP 500 error when I try to go to the KSP section. I can get into the other sections, I can even download mods, if they are being followed. I just can't get to the KSP front page.

Share this post


Link to post
Share on other sites
Posted (edited)

Good Day! I was attempting to download a mod in spacedock (SM Marine and some similar mods) but when i click download, it tells me that it took too long to respond then an error saying ERR_CONNECTION_TIMED_OUT   This has been happening since the server downtime yesterday (and also the day before yesterday). (July 8, 2017-July 10, 2017)

 

Edit (This was saved as a draft): Now i go into it and it says it broke with this thing that says "500 Internal Error"... ;.;

Edited by Jansel80Gaming
Fixed some typos and made it easier to understand

Share this post


Link to post
Share on other sites
VITAS    495

Yes theres a bug that took down the site twice. :/

Share this post


Link to post
Share on other sites
DStaal    1196

The SSL certificate just expired.

Share this post


Link to post
Share on other sites
VITAS    495

Yes somehow the Lets Encrypt Bot didnt run because of one domain having problems.

:/

 

Share this post


Link to post
Share on other sites
Stone Blue    894
Posted (edited)

Sorry if this has already been answered somewhere in the thread, but, does anyone know what the optimal image size is to fit the image header on top of your mod page?

@VITAS ??

EDIT: Ok, after over an hour of messing around, I think i got a good ratio.... ~3.75:1 (WxH)... I got a 1500x400 image to "fit"...
???... vOv

 

Edited by Stone Blue

Share this post


Link to post
Share on other sites
VITAS    495

i dont know if there is an optimal image size :/

 

Share this post


Link to post
Share on other sites
Thomas P.    1555

The header that contains the image has a maximal height of 400px, so an optimal image would be 400px high. The width is a bit trickier. There is no fixed value, it is stretched based on your screen size (or not). For example, if the image isn't wide enough, this happens: dgdznQ6.png

Most people have a screen width between 1300 and 1900, so my guess would be that something in the middle of that (1500px - 1600px) would be the best choice.

But because SpaceDocks CSS is junk, there is no real *best* choice.

And while writing this I saw the edit and that @Stone Blue already figured out what I just said. So I dont know why I am sending this.

Share this post


Link to post
Share on other sites
VITAS    495

one day.... i hope :)

Share this post


Link to post
Share on other sites
Stone Blue    894
2 minutes ago, VITAS said:

one day.... i hope :)

LOL... yeah...I've been playing around trying to make a dark theme for SD... Cant get some elements to change the way I want... :P
 

 

Share this post


Link to post
Share on other sites
VITAS    495

the css is kerbalstuffs modification of bootstrap, that i in turn modified to look like it does. SO dont expect it to look like you want by overwriting it another time :D

Share this post


Link to post
Share on other sites
Stone Blue    894

Other than some text and minor elements, I got it mostly where I want it: ZERO percent white, except a few buttons and text... :thumbs_up:

Share this post


Link to post
Share on other sites
Thomas P.    1555
3 minutes ago, Stone Blue said:

LOL... yeah...I've been playing around trying to make a dark theme for SD... Cant get some elements to change the way I want... :P

In case you are interested in helping with SpaceDock's development (especially on the frontend side of things), you could take a look at theese two repositories:

Any help would be highly appreciated. :)

Share this post


Link to post
Share on other sites
VITAS    495

Hi,

somehow Apache was stuck. i just restarted it. Sorry about that.
Im also debating to move servers soon. It comes down to: do i want to have the hussel to migrate everything i set up since 2011 and think that 2011 is old enough for server hardware to get something newer. :/

(And it also depends on my predictions regarding donations in the future)

Share this post


Link to post
Share on other sites
TheKurgan    198

Thank you.

The site seems to be working fine, it doesn't seem slow by comparison to other sites with a similar ammount of content.

Is the hardware causing any issues? 

Share this post


Link to post
Share on other sites
VITAS    495
Posted (edited)

Me trying to be on Holliday and the apache server beeing unresponsive/crashing (dont ask my why) was the problem.

Fixed and Sorry :)

 

Regading my thought on switching Servers:

the Database is slow and spacedock is very sensetive to any other service running on the same system (e.g. antispam gateway).

i also think, that the site could be way more responsive. Especialy for unbuffered loads (first time visits)

Edited by VITAS

Share this post


Link to post
Share on other sites
Poodmund    791
1 hour ago, VITAS said:

Me trying to be on Holliday and the apache server beeing unresponsive/crashing (dont ask my why) was the problem.

Fixed and Sorry :)

No need to be sorry, enjoy your holidays. KSP will still be here when you get back. :D 

Share this post


Link to post
Share on other sites
VITAS    495

Update:

I decided to rent a new server for SpaceDock (and eventualy get rid of the existing main server)

The current main server has the following specifications:

i7 2600 (Sandy Bridge)
32GB RAM
2x2TB Magnetic HD
1Gbit/s

The new one has:

AMD Ryzen 7 1700x
64GB RAM
2x 500GB SSD
1Gbit/s

Its a bit more Expensive (than the current one as well as similar newer intel ones with ssd) but the added cores and memory hopefully speed up the database an thus the site.

You can also see that the current server is in use by me since 2011 so even exchanging it for some similar intel system from today would bring me some performance gain.

 

Migration will take quite a while, because im busy at work and my motivation to do even more sysadmin stuff after work isnt that great.

Theres also a bunch of services (like email) that arent as easy to move.

 

 

Share this post


Link to post
Share on other sites
TheKurgan    198

From your perspective I guess the server seemed less then ideal, from my perspective, it seemed fine... I know there is a little down time once in a while, but nothing intolerable. 

I don't think you needed to go through the trouble and extra expense.

Your site and the service it provides to the modding community is invaluable!! Thanks!!

Edited by TheKurgan

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now