Jump to content

What is the strangest bug you have found?


MiffedStarfish
 Share

Recommended Posts

22 hours ago, ModerndayLink64 said:

That happens to me a lot, I thknow no it is caused by switching from windowed to full screen via alt+enter while in the main menu

I get it when the game isn't in the computer's focus at the end of loading. I sometimes alt+tab out of KSP while it's loading, and sometimes this occurs.

Link to comment
Share on other sites

one time I used the orbit editer to get my craft so far from the sun that the altimeter looped back to meters, then I returned to the space center and the ground was completely messed up. it was shaped like the surface of a washing board, and the buildings were at way different heights as well. even the water was warped!

I think this was a problem with the game generating terrain after going EXEREMLY far away.

Link to comment
Share on other sites

Well... I once decided to do a Duna mission like they did in The Martian. So, I had to build a Duna Ascent Vehicle! The spacecraft passed initial flight tests, I just had to mount it on a Duna-capable rocket. This went fine and I left the game for the night. Twenty-four hours later, I come back, start up KSP, open up the DAV, and hit launch. The thing lags out immediately, and I have several seconds to watch physics load and glitch out. The navball says 00000000.0000000m/s, all of the nav indicators are on top of each other, the clock says Year 999, day 99, and the rocket is moving at many, many, many times faster than light. The altimeter was also strange. Uh... revert, I guess. I get back to VAB, and I can't do anything. Clicking on a part duplicates it, and I can't add on to the rocket or takes parts away. I tried adding a part... and it made this the root part and made it float like the rocket didin't exist. I had to redesign the entire thing. And the DAV had at least 200 parts.

On 6/29/2017 at 9:47 PM, NordicToast said:

made everything half transparent by hyperediting my ship a quintillionish meters from the sun, even reverting didnt fix it.

I think Danny got something like that once, but that was after getting a kerbal stuck in a solar panel in LKO.

"I'm not sure why I went EVA but I'm glad I did." -Danny

Link to comment
Share on other sites

I've had a few, like the first time I landed at the Old Airfield. Jeb went up to the control tower, hopped on a window, I took a screenshot, and then he hopped down again. Only, when he landed back on the floor, it did the 'Kerbal falling, landing on ground, staggering and then getting up again' animation, like if you fall from over 3m or something. Then, the screen went black, the altimeter went 100,000, 200,000, and so on, and then went white, like blank. I pressed F3 for the flight log, and it was 'Jebediah Kerman: On escape trajectory out of the Sun'. I went back to the KSC, and it was just empty space, like the space skybox.

'

 

Link to comment
Share on other sites

  • 2 months later...
On 9/26/2017 at 8:07 AM, Virdin said:

Using the power of the monoprop engine to hit my kerbal into the ocean at 0.2× the speed of light. Then my camera buggered off towards Dres.

Basically what Danny did. Except mine were much less vigorous. But alot more...whacky...

Link to comment
Share on other sites

Mine was a contract bug to explore Duna. Some how, according to the game, I flew a probe to Duna, entered the SOI, landed on the surface (using parachutes and a small engine to soft land), transmitted data from the surface but I did not enter the atmosphere even though I was floating down and gathered data on the way.

It only registered the atmospheric entry after I went into orbit and then into sub orbital. Originally I flew straight into the atmosphere and aerobraked. Not as elaborate as some of the others but a strange one.

Link to comment
Share on other sites

i was messing around and used  no crash damage and bounced off a mountain and was thrown  out of the solar system.

ive fallen through the ground a  few times on random bodies.

ive had my vessel explode mid flight and the game claimed i smashed into a planet 

kerbal is full of shenanigans 

Link to comment
Share on other sites

Still working on this one.  I apparently got upgraded during a hiatus, and upon loading I got a warning about Kopernicus.  I had installed OPM, Kopernicus and a couple others.  So I downloaded an update to Kopernicus, and installed it, and I get this

https://imgur.com/a/Mdrxz

 

And now, I have two suns.  One of them, seems to be unreachable via the tab key, but I've reloaded the game, my OPM loads just fine AND I have an extra sun.

https://imgur.com/A44h02k

I am playing through a fresh game on the science tree to 'explore' this unusual bug.  I am not sure how I caused this or what the heck.

 

I installed the mod same as I always have . . .   I actually hope whatever I've managed to do stays. I'm delighted, not annoyed.

 

https://imgur.com/ssAGQl7

Link to comment
Share on other sites

@eloquentJane

I am not sure.  I want to see if both cast shadows when Kerbin gets round between them.    I'll know by then lol.  Still playing science mode, gotta unlock solar panels.

 

PS I am quite positive I have merely done something I don't understand with the mod install.  It was just that it kept telling me there was a problem, with the mod it then cheerfully loaded up for me.

 

 

Edited by Angie
clarification
Link to comment
Share on other sites

6 hours ago, Angie said:

@eloquentJane

I am not sure.  I want to see if both cast shadows when Kerbin gets round between them.    I'll know by then lol.  Still playing science mode, gotta unlock solar panels.

 

PS I am quite positive I have merely done something I don't understand with the mod install.  It was just that it kept telling me there was a problem, with the mod it then cheerfully loaded up for me.

So I even figured out why.  I pasted gamedata into gamedata after downloading the .zip file.  What it did was create a fixed sun at infinity that orbited the entire solar system as quickly as Kerbin rotated.  It was fixed by deleting the errant gamedata folder and re-pasting it at the correct level.  Mac user, sheesh.

 

I thought to put it in time accelerate because the new sun was moving around so quickly, and its behavior became obvious after two seconds.  I laughed my ass off.  Probably a default setting that fell through when I mucked up the filesystem.

 

Freaking hilarious!

6 hours ago, Angie said:

 

 

 

Link to comment
Share on other sites

  • 3 weeks later...

I wanted to do a test to see the efficiency of the atomic engine. So i made a craft with the atomic engine (obviously), and i planned to put the ship into a orbit between Kerbin and Eve. But i was too lazy, and i wanted to open the cheat menu and put me into a sun orbit between those planets. But i did not know the SMA of a orbit like i wanted. So i opened the cheat menu and i put a aleatory SMA in a orbit arround the Sun. But the number was too big. And i ended in a trajectory of escape of the Sun, at a extremally high altitude. So i wanted to know how far i could go, and i put a even bigger SMA. And at this point, the bug started. The altimeter marked 0 meters, and i can't could see the Sun. So i reverted. But the launchpad was dark, and i lanched the ship at day. So i warped, and the Sun never rises. So i noticied that i make the Sun DISSAPEAR. And i noticied that the Sun also dissapeared in my other 2 saves. But i restarted the game, and the problem was solved.

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...