Virindi

[1.2.2] Probe Control Room Continued (1.2.2.6, 2017/05/01)

Recommended Posts

pQC1UJI.png

 

Since the most recent maintainers seem to have decided not to continue this mod, I have gone ahead and updated it.

This mod adds a "Mission Control" IVA to unkerballed vessels.

-Supports either standard RasterPropMonitor MFDs or the ASET versions.

-Configuration option to force control room only for probe vessels (no external view).

 

Requirements:

-Module Manager

-RasterPropMonitor

-[Optional] ASET Props

-***NOTE*** If you are using ScanSat, you currently need the dev version of ScanSat to avoid a problem with RPM displays going unresponsive. ***NOTE***

 

Download/Source:

https://github.com/Virindi-AC/KSP-ProbeControlRoom/releases

 

Changelog:

1.2.2.6

-Fix broken sun effects in normal IVAs after going into PCRIVA
-Disable vessel labels while in PCRIVA
-Disable part highlighters while in PCRIVA
-Change enter room hotkey to be like a normal keybinding
-Make the room lights brighter
-Improve preservation of camera when restarting PCRIVA in a new room
-Fix a bunch of exceptions caused by interactions with the DeepFreeze mod

1.2.2.5

-Fix a large number of cases where you can end up stuck inside a probe core looking out at the world rather than in the control room.

-Fix problems on decoupling parts from the ship, and persist the camera when this happens.

-Fix interaction with stock IVA. Previously, sometimes an invisible control room would exist while you were inside a stock IVA. This would block some button clicks in the IVA.

 

License: CC-BY-NC-SA-3.0

This mod is a continuation of the work of: @Tabakhase, @icedown, @Albert VDS, @MeCripp, @Nils277, @JPLRepo, @Dexter9313, @Z-Key Aerospace, @jlcarneiro.

Edited by Virindi
  • Like 22

Share this post


Link to post
Share on other sites

Thanks for keeping this ticking! I've always wanted to try it but it never seemed updated. How do controls and maneuvering work, from map screen? Or is that disabled too?

Share this post


Link to post
Share on other sites
2 minutes ago, Nightside said:

Thanks for keeping this ticking! I've always wanted to try it but it never seemed updated. How do controls and maneuvering work, from map screen? Or is that disabled too?

The map screen works as normal. If you want to disable it, the Through the Eyes mod has an option for that :)

Share this post


Link to post
Share on other sites

Note that as mentioned at the end of the previous thread, the mod deepfreeze for me was not compatible with this -- sorry I don't have error logs but by process of elimination of mod, double checked, that was the one for me causing the control room to lose camera focus every staging event and to sometimes show a camera view from inside the probe instead of mission control.

Maybe you fixed that (both problems mentioned in OP), but just letting you know in case you didnt check that specific mod (vs only for scansat o something).

Also, could we please fix the lighting? It gets dark in the control room whenever the probe is not lit in space. Even if that can't be fixed directly, just adding some nice strong ceiling lights (the model even already has some) would probably drown out the effect at least.

 

Thanks for updating!

If I find time, I plan on modeling the IVA of this with much fancier ASET props layout, not just the MFD, but it might be awhile. Definitely more motivated now with fixes made!

Edited by Crimeo

Share this post


Link to post
Share on other sites
54 minutes ago, Crimeo said:

that was the one for me causing the control room to lose camera focus every staging event and to sometimes show a camera view from inside the probe instead of mission control.

This happened to me while testing with no other mods enabled. I was able to cause the outside view by doing nothing but going to map view and going back.

The mod should be much more robust against that now, but the best way to know is to check :) I have not yet tried it with DeepFreeze.

 

54 minutes ago, Crimeo said:

Also, could we please fix the lighting? It gets dark in the control room whenever the probe is not lit in space. Even if that can't be fixed directly, just adding some nice strong ceiling lights (the model even already has some) would probably drown out the effect at least.

I am looking at this kind of thing right now. I discovered that it is currently causing glitchy IVA sun behavior...it disables MOVEMENT of the sun in IVA but never reenables it at all. I am also working right now on force disabling vessel labels while in the control room.

 

Oh and by the way, I submitted a patch to RasterPropMonitor so we can have cameras and other displays cease updating when the vessel goes out of control range. That is "coming soon" :)

Edited by Virindi
  • Like 1

Share this post


Link to post
Share on other sites

Bug found: when a KOS window or mechjeb or whatever else has focus, keyboard commands are not supposed to affect the game (do not in stock). But when I hit "c" even when one of these windows has focus, the camera still switches to probe control room. Should only do so when nothing local has focus. Same for arrow keys, etc.

Also, as you mouse around the control room, stuff in the camera feeds gets highlighted green, because it thinks my mouse is right over that part, due to us lying to it about my "kerbal" being in the probe core.

Edited by Crimeo

Share this post


Link to post
Share on other sites
23 minutes ago, Crimeo said:

Also, as you mouse around the control room, stuff in the camera feeds gets highlighted green, because it thinks my mouse is right over that part, due to us lying to it about my "kerbal" being in the probe core.

Do you mean that stuff gets highlighted through a RPM camera? Or just stuff that is invisible getting highlighted? I haven't seen this, how can I reproduce?

 

The keypress thing I see the issue, easy fix...unless I am missing something nonobvious.

Edited by Virindi

Share this post


Link to post
Share on other sites
Quote

Do you mean that stuff gets highlighted through a RPM camera? Or just stuff that is invisible getting highlighted? I haven't seen this, how can I reproduce?

Through the RPM camera only. Whatever part my mouse would be mousing over if I was actually looking from that perspective inside the probe core, turns green if it is visible in the exterior CCTV. (I am using HullCameraVDS). Just install an external camera that would include the probe core in its shot, switch to it in RPM, move mouse all around.

Share this post


Link to post
Share on other sites
7 minutes ago, Crimeo said:

Through the RPM camera only. Whatever part my mouse would be mousing over if I was actually looking from that perspective inside the probe core, turns green if it is visible in the exterior CCTV. (I am using HullCameraVDS). Just install an external camera that would include the probe core in its shot, switch to it in RPM, move mouse all around.

I see it now. Will look at it.

Share this post


Link to post
Share on other sites

1.2.2.6 released. All the above mentioned issues should be fixed.

 

As for DeepFreeze causing you to get stuck "inside the pod", that can still happen...in fact, it can happen with no mod installed but DeepFreeze. This happens when you go IVA then freeze the kerbal who you are viewing; you stay in that IVA but the room disappears. If PCR is enabled and you just froze your last kerbal, you can then start PCR normally...or it would be properly started for you if you have force PCRIVA enabled in the config.

  • Like 1

Share this post


Link to post
Share on other sites

Thanks! I've been waiting for this!

Share this post


Link to post
Share on other sites

It's very good to see this back on track!

I have a somewhat embarrassing question, though: I can't remember how to show the map view on a screen... :blush:

If memory serves me, it should be one of the leftmost buttons on the top or bottom rows...

ETA: I vaguelly remember something about those maps being Scansat's... Is that correct? I would be a shame... I gave it up to ease the load on may notebook. Can't Kerbnet be integrated?

ETA2: Apparently it won't do... :(

 

Edited by jlcarneiro

Share this post


Link to post
Share on other sites
2 hours ago, jlcarneiro said:

It's very good to see this back on track!

I have a somewhat embarrassing question, though: I can't remember how to show the map view on a screen... :blush:

If memory serves me, it should be one of the leftmost buttons on the top or bottom rows...

Bottom left button if using the RPM (non-ASET) screens. You currently need to build ScanSat from the dev branch as noted above (https://github.com/S-C-A-N/SCANsat/tree/dev). I will be looking into this issue shortly. You also need to scan the planet, of course.

  • Like 1

Share this post


Link to post
Share on other sites

I was just told if the probe runs out of power, all screens go blank. Does this happen with no signal as well?

Share this post


Link to post
Share on other sites
1 hour ago, Virindi said:

Bottom left button if using the RPM (non-ASET) screens. You currently need to build ScanSat from the dev branch as noted above (https://github.com/S-C-A-N/SCANsat/tree/dev). I will be looking into this issue shortly. You also need to scan the planet, of course.

Oh, my memory still serves for something! :)

About the requirements (SCANsat and scan the planet) I did scan the planet, problem was SCANsat. Hope you can solve this shortly! If I can help with something... :wink:

And thank you very much! For your hard work and for your attention!

Share this post


Link to post
Share on other sites
48 minutes ago, Brent Kerman said:

I was just told if the probe runs out of power, all screens go blank. Does this happen with no signal as well?

No. The best way to accomplish this is currently being investigated.

Share this post


Link to post
Share on other sites

So I've been working on an improved IVA for this, but it's got all kinds of bizarre bugs. Like... staging and stage lock for no apparent reason don't work in probe control room -- exact same prop works in a manned control pod on same vessel, keyboard spacebar works (as if simply unlocked to begin with), but not probe control staging or stage unlock. Just stays locked. Plenty of EC, radio connection (spacebar wouldn't work without these anyway).

SAS randomly sometimes doesn't let me push anything but stabilize, even in orbit mode, other times it does. Other times it just switches my mode without asking. Works just fine in manned IVA, smooth as silk.

Several props don't seem to load again no idea why, but ONLY in that one IVA, everywhere else they work fine. I would have guessed this was just a mistake in placing the prop in a wall or something by accident, but it happened on several prop types (aborts, certain kinds of rotaries), consistently to the type, and like half a dozen of them. Having trouble remembering which exactly, I replaced several with other versions of themselves, like rotary switch with tumbler, etc. Stage lock was one, too, actually. Covered didn't work, tumbler did. Covered works just fine in all other manned IVAs.

The probe IVA is also still not giving up keyboard focus -- you didn't write that in the changelog, but you said "above issues fixed" earlier, so dunno if you got to it or not yet. But yeah the KOS terminal or mechjeb or whatever should block ALL keystrokes from doing anything, it does in normal camera, and in manned iVA, but not probe IVA. Result = typing in "100" for mechjeb ascent for example will activate action groups 1 and 10, etc.

IVA config so far if helpful: https://pastebin.com/D4NrCLe1
(requires ASET, ASET avionics, and flightsystems redux)

also photo for fun!

(And yes I know flight directors aren't pilots... I don't know how to edit the textures where the nametags are. Also I'm pretty sure "probe mission control rooms" like this don't even exist...?)

Edited by Crimeo
  • Like 1

Share this post


Link to post
Share on other sites
2 hours ago, Crimeo said:

Also I'm pretty sure "probe mission control rooms" like this don't even exist...?

Sure they do. Here's the Hubble Control Room at NASA Goddard I visited a few years ago

tOHZRTm.jpg

JPL has a more centralized control room as does the ESA at ESOC if you want to look them up, but the Hubble above is the closest to what PCR has for KSP as sort of a single-use thing. I'd love if someone modeled a more expansive internals with more desks like the JPL/ESOC room but, this'll do.

@Virindi or anyone - the textures are still MBM and should be upgraded to DDS?

Edited by Drew Kerman
  • Like 1

Share this post


Link to post
Share on other sites
9 hours ago, Crimeo said:

The probe IVA is also still not giving up keyboard focus -- you didn't write that in the changelog, but you said "above issues fixed" earlier, so dunno if you got to it or not yet. But yeah the KOS terminal or mechjeb or whatever should block ALL keystrokes from doing anything, it does in normal camera, and in manned iVA, but not probe IVA. Result = typing in "100" for mechjeb ascent for example will activate action groups 1 and 10, etc.

I listed this as fixed because your report made it sound like the problem was just with the 'c' key. I changed the behavior of the 'c' key. It used to be that typing "c" into a textbox caused the room to activate, now it works like any other hotkey.

Additionally, I tested mechjeb. When I open maneuver planner and type in a number when in PCR, no action groups are activated. Your bug report needs more information. I cannot reproduce it.

Perhaps the problem is related to the props issue? Like maybe some prop you added which caused things to break also caused keys to not be captured?

Edited by Virindi

Share this post


Link to post
Share on other sites

Okay so yes I did not explain well enough. "C" is (Still) more weird than other keys, but not the only problem:

Outside the probe control room: Keyboard acts like normal, all keys disabled when entering any window that captures the keyboard (mechjeb, or kos, for example, not specific to one mod). EXCEPT for "c" which even outside of the probe room, still brings me into the probe room when hitting it, even in a capturing window. I just now confirmed that that is still happening in version 1.2.2.6.

Inside the probe control room: Gets much worse. The entire keyboard never gets captured by any window similar to mechjeb. All keys do their normal things at all times. space will stage, numbers will fire AGs, arrow keys will move the view around in the background IVA, "T" will toggle SAS, etc. etc. even while trying to type in commands to another mod in its own window.

Replication: No idea what to tell you, it just happens whenever I open any window that would normally capture the keyboard. Nothing triggers it, it's always the case from the start. Everything to do with probe control room doesn't get captured (anything inside it, and the activation for it while outside of it), everything else does (all other keys besides C outside the room)

I can try to start stripping down to vanilla and building up different sets of windowed mods to debug, when I get time.


Edit: also, no, not props, because problem is identical to what was happening with the probe control room back before I started working on my own IVA at all. So it's either not prop related, or it's specifically the ASET 40x20 or ASET 60x30 multifunction display props, common to both IVA before and after. Possible, but still unlikely because I also use those same 2 props in various manned IVAs without any issues.

Edited by Crimeo

Share this post


Link to post
Share on other sites

RPM is unresponsive only cauae i can find is SCANSat, where is dev version for it.

Share this post


Link to post
Share on other sites
2 hours ago, PrathamK said:

RPM is unresponsive only cauae i can find is SCANSat, where is dev version for it.

You looking for this ?

 

Share this post


Link to post
Share on other sites

Thanks.

The Coffee is Cool, don't touch its very hot but

Edited by PrathamK

Share this post


Link to post
Share on other sites

Thank you for your great work. I am using the most curent version, i am also using scatter and eve high res and experiencing strange sun effects on camera screens with in the PCR. Which do not exist in other IVA.

Has anyone else experienced this problem?

 

Share this post


Link to post
Share on other sites
29 minutes ago, WhitestWizard said:

Thank you for your great work. I am using the most curent version, i am also using scatter and eve high res and experiencing strange sun effects on camera screens with in the PCR. Which do not exist in other IVA.

 

I have also encountered this in normal IVAs. It depends on where your camera part is facing compared to where you are actually facing, Scatterer seems to draw things from the perspective of the main camera and not take into account RPM cameras.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now