Ger_space

[1.2.2 & 1.3 & 1.4 & 1.5] Kerbin-Side continued 1.4.5 [05.11.2018]

Recommended Posts

Just now, Sigma88 said:

SD already takes care of repositioning / resizing KK statics

Wow, I guess I'll try this night and report the results. Thanks!

Share this post


Link to post
Share on other sites
47 minutes ago, Ger_space said:

I will not say I will never do this, but it will not before winter, when I start working on SigmaDimension support, as this will be easier to implement with some changes I planned for that time.

the only thing that you could add is telling SD which the groups are, I have already made a plugin that can do that (loads KK groups and feeds them to SD)

but it's a pretty dumb plugin and I didn't spend much time on it.

if you ever start working on this feel free to contact me so I can show you how SD accepts input from external plugins :)

 

 

EDIT: actually there's another thing you could do which is load all statics from the same "group" into one single PQSCity Mod, but I think that would be pretty hard to do

 

 

37 minutes ago, evileye.x said:

Wow, I guess I'll try this night and report the results. Thanks!

as @Ger_space mentioned there are different types of issues when scaling a planet.

the best way to assure that everything loads properly would be to scale the size of the buildings by the same scale factor you used for the planet's radius.

the problem with this is that on a 10x install buildings can look enormous

the alternative would be leaving the building 1x, but then they would spread out since their position is encoded in "LAT-LON" rather than relative position

the solution I found for SD is to allow users to define "Groups" of buildings that have to be considered part of the same group

you can do this by hand, writing a cfg targetting all the statics by name

or you can use KKtoSD which is a plugin that will automatically load all KK statics into SD, that plugin is still experimental so it might have some issues

Edited by Sigma88

Share this post


Link to post
Share on other sites

Hey,

thanks for your work.

I have a little issue.

When I just add the Kerbin-Side Campus part, my tracking station is downgraded.

I upgraded it to stage 2 and it should be able to track and communicate with my spaceships and probes in orbit of Kerbin and the Mun.

With Kerbin-Side Campus, my ships loss connection as soon as they are on the other side of Kerbin.

 

How can I fix this without installing Kerbin-Side Ground Stations?

 

Thanks again.

Share this post


Link to post
Share on other sites
On 23.6.2017 at 1:32 PM, gladi said:

Hey,

thanks for your work.

I have a little issue.

When I just add the Kerbin-Side Campus part, my tracking station is downgraded.

I upgraded it to stage 2 and it should be able to track and communicate with my spaceships and probes in orbit of Kerbin and the Mun.

With Kerbin-Side Campus, my ships loss connection as soon as they are on the other side of Kerbin.

 

How can I fix this without installing Kerbin-Side Ground Stations?

 

Thanks again.

Tracking stations cannot communicate through planets.

You probably have activated CommNet support in kerbal konstructs. Deactivate this, save your game and then restart KSP.

This should bring back the stock extra Groundstations (Which you use but they get deleted by KK).

Share this post


Link to post
Share on other sites
On 25.6.2017 at 8:47 AM, Ger_space said:

Tracking stations cannot communicate through planets.

You probably have activated CommNet support in kerbal konstructs. Deactivate this, save your game and then restart KSP.

This should bring back the stock extra Groundstations (Which you use but they get deleted by KK).

Hey, thanks for your reply.

I disabled CommNet Support and now my Mun probe is connecting to the tracking station on Kerbin, but without KK its connected  to all tracking stations.

Is there another option I need to set?

Would really love to keep the campus at KSC.

Share this post


Link to post
Share on other sites

Hi,

Thanks for keeping that great mod alive, just to let you know :

I've installed the complete version with CKAN and it works, then I've added Kerbin Air Race with CKAN and all the CoreAssets content for air race is missing, it's just adding the airrace folder with the cfg files for each race.

Intalling it from spacedock solves the problem.

Share this post


Link to post
Share on other sites
15 hours ago, varsass said:

Hi,

Thanks for keeping that great mod alive, just to let you know :

I've installed the complete version with CKAN and it works, then I've added Kerbin Air Race with CKAN and all the CoreAssets content for air race is missing, it's just adding the airrace folder with the cfg files for each race.

Intalling it from spacedock solves the problem.

It's a problem of ckan, there is not much I can to about, except remove the air race from it and put a note at the front page.

Share this post


Link to post
Share on other sites

I have a problem with ground stations (I using the complete pack).

Sometimes, they don't work.
The previous game session worked correctly. Then I reopen the game and only the KSC communicates whith my probes.
Is there anything I can check to understand the reason?

Thanks
Edited by Simog

Share this post


Link to post
Share on other sites
2 hours ago, Simog said:

I have a problem with ground stations (I using the complete pack).

Sometimes, they don't work.
The previous game session worked correctly. Then I reopen the game and only the KSC communicates whith my probes.
Is there anything I can check to understand the reason?

Thanks

Please upload the game log file from a session when this happens.

What kind of game are you playing? Career or sandbox? Have you opened the stations from the tracking station?

Share this post


Link to post
Share on other sites
I'm in Career mode.
While I waiting for the answer, I did some other tests. I noticed that in the options of Kerbal konstrukt, I found checked both, Commnet and Remotetech options (that I don't have it). Removed the latter, it has resumed to work and the option has become gray and not clickable.

The log file: Here  I hope it's the right file 

Thanks
 
Edited by Simog

Share this post


Link to post
Share on other sites
On 26. 6. 2017 at 10:23 PM, gladi said:

Hey, thanks for your reply.

I disabled CommNet Support and now my Mun probe is connecting to the tracking station on Kerbin, but without KK its connected  to all tracking stations.

Is there another option I need to set?

Would really love to keep the campus at KSC.

 

On 25. 6. 2017 at 8:47 AM, Ger_space said:

Tracking stations cannot communicate through planets.

You probably have activated CommNet support in kerbal konstructs. Deactivate this, save your game and then restart KSP.

This should bring back the stock extra Groundstations (Which you use but they get deleted by KK).

Hello. How can I disable CommNet Support? Also does anyone know how to cheat-open some base? Valentinas Base in my game closed itself for no reason...

Share this post


Link to post
Share on other sites

Hello @Ger_space!

Do your ground stations have the all the same comm net range? If it possible to have range specified to each station, or comm net does not work like that?

Share this post


Link to post
Share on other sites
1 hour ago, evileye.x said:

Hello @Ger_space!

Do your ground stations have the all the same comm net range? If it possible to have range specified to each station, or comm net does not work like that?

They should now have diverse ranges, but I'm not sure if this really works. I never had the time to test this feature, after I changed the ranges.

I really hope that the remoteTech guys port tier mod to use CommNet, so I can have a look how this is done properly.

I made the range depend on the groundstation model used, but I the diversity is limited.

Share this post


Link to post
Share on other sites

Hello, I have an issue with the mod in career mode. One day I invest lots of money to open the runways, groundstations, everything and the next time I play some of them are randomly closed. Any idea why or how I might be able to fix it?

Share this post


Link to post
Share on other sites

hey @Ger_space when you get back, how much work would it be to get all the models centered properly? I just placed a tracking dish (ksiderooftopdish1) and would like to rotate it occasionally whenever it happens to be in view but the center of the model is way off to the side so I have to rotate it and re-position it

Share this post


Link to post
Share on other sites
On 16.7.2017 at 5:09 AM, Drew Kerman said:

hey @Ger_space when you get back, how much work would it be to get all the models centered properly? I just placed a tracking dish (ksiderooftopdish1) and would like to rotate it occasionally whenever it happens to be in view but the center of the model is way off to the side so I have to rotate it and re-position it

As much I would like to do this, I would need to reposition all existing instances to refflect thier fixed center. Maybe I will do this but I don't know if this is really worth it. 

 

On 14.7.2017 at 5:13 PM, nervv said:

Hello, I have an issue with the mod in career mode. One day I invest lots of money to open the runways, groundstations, everything and the next time I play some of them are randomly closed. Any idea why or how I might be able to fix it?

alt+f12 and give you the credits back. I don't know why this is happening, as I cannot reproduce this. I never got a logfile when this is happening, so I could perhaps see an error message, why KK thinks the bases need to be closed. 

Share this post


Link to post
Share on other sites
1 hour ago, Ger_space said:

As much I would like to do this, I would need to reposition all existing instances to refflect thier fixed center. Maybe I will do this but I don't know if this is really worth it.

could this be something I can do myself in blender just for this one model or others on an as-needed basis?

Share this post


Link to post
Share on other sites

Yep - same problem - All my opened bases have re-set to closed and I've lost a lot of credits :(

Only thing comes to mind is It happened after a re-load but I'm not familiar enough with the mechanism to find what's different in the two save files.

Let me know if I can help with the debug process - oh..to show my newness to the mod - what's the base log button about - I've found no reason for it?

Edited by Keefe

Share this post


Link to post
Share on other sites
11 hours ago, Keefe said:

Yep - same problem - All my opened bases have re-set to closed and I've lost a lot of credits :(

Only thing comes to mind is It happened after a re-load but I'm not familiar enough with the mechanism to find what's different in the two save files.

Let me know if I can help with the debug process - oh..to show my newness to the mod - what's the base log button about - I've found no reason for it?

same here, open bases and after a while i find them closed...

Share this post


Link to post
Share on other sites
5 hours ago, Drew Kerman said:

Also @Ger_space when you made available the Squad objects were you able to find the dishes used for the tracking stations placed around Kerbin?

yes this should be accessable. But I don't know.

 

1 hour ago, Acvila said:

same here, open bases and after a while i find them closed...

which version of KSP and KK? 

So: If you want this bug fixed please be a bit more verbose about the installed mods, which versions used etc. I cannot see any pattern and on my system the bases stay open. 

Share this post


Link to post
Share on other sites

ksp 1.3 it was one month - 2weeks ago with the last version that was then. now i don't have it installed so can't provide log.

Share this post


Link to post
Share on other sites
3 hours ago, Acvila said:

ksp 1.3 it was one month - 2weeks ago with the last version that was then. now i don't have it installed so can't provide log.

thanks,

I still have no idea how this can happen. It looks like some problems from KSP, so KK doesn't get the savegame state on a scene switch, so KK thinks it is a new game and closes everything. I wish there is a releable way for a mod to detect a new game and a load from a save, which internally failed.

Share this post


Link to post
Share on other sites

Hi @Ger_space,

sorry - wasn't trying to be shy of giving info - I can send on a log if you like.

I did play around with the config and save files (manually entering true values to open bases)- but to no avail.

You've hit the nail on the head I think - scene switching would immediately overwrite the text files as closed

I believe it first happened while doing a Kerbinside jobs mission for me - "recovering" a passenger then going back to my craft via tracking station.

Prior to that had 4-5 stations opened without issue through 4 saves.

Have been using the latest versions of KK, Kerbinside complete etc..but also top heavy with Kerbalism, Vesselviewer, scanSAT etc.

new to these forums...so im looking for a place i can upload a log file to post to you. I've since uninstalled the mod but think I still have the save & log file on my system.

Share this post


Link to post
Share on other sites
On 7/18/2017 at 5:57 AM, Ger_space said:

yes this should be accessable. But I don't know.

forgot to follow up on this response. If you can check the next time you get a chance, having the ability to place a separate dish around the Tier 1 tracking station without having to upgrade to Tier 2 and then doing some image chopping to make it look like the Tier 1 has an extra dish would be great

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.