Ger_space

[1.2.2 & 1.3 & 1.4 & 1.5] Kerbin-Side continued 1.4.5 [05.11.2018]

Recommended Posts

13 hours ago, Drew Kerman said:

forgot to follow up on this response. If you can check the next time you get a chance, having the ability to place a separate dish around the Tier 1 tracking station without having to upgrade to Tier 2 and then doing some image chopping to make it look like the Tier 1 has an extra dish would be great

The CommNet antenna is placeable by KK. 

Share this post


Link to post
Share on other sites
3 hours ago, Ger_space said:

The CommNet antenna is placeable by KK. 

My apologies - it turns out I did not have the latest version like I thought I did :huh: found it! OMG and it rotates and everything. Why in the hell did Squad not replace the dishes at the KSC tracking station with these?? *sigh*

Share this post


Link to post
Share on other sites

I'm also having the issue of instance switching resetting the bases I have opened. I'm on KSP 1.3 64bit and I have tried starting a new save and the issue still resides. Other than that this is a really sick mod and I enjoy it a lot. Thanks for all the hard work on it.

Share this post


Link to post
Share on other sites
On 8/7/2017 at 6:27 PM, Simog said:

I have a problem with ground stations (I using the complete pack).

Sometimes, they don't work.
The previous game session worked correctly. Then I reopen the game and only the KSC communicates whith my probes.
Is there anything I can check to understand the reason?

Thanks

Hi
I started a new game but the problem persists. By doing various tests, I noticed that a quicksave and quickload solve the problem but sooner or later reappears.
Before Quicksave:
oeTMUw0W.png

After Quickload:
2bYWBfqW.png

Career Mode and the Tracking Station is on Level 2

Since I have so many mods, there is some known incompatibility?

Thanks

Log File

Edited by Simog

Share this post


Link to post
Share on other sites
1 hour ago, JeffersonFlight said:

I'm also having the issue of instance switching resetting the bases I have opened. I'm on KSP 1.3 64bit and I have tried starting a new save and the issue still resides. Other than that this is a really sick mod and I enjoy it a lot. Thanks for all the hard work on it.

can you please test the latest beta of kerbal-konstructs? https://github.com/GER-Space/Kerbal-Konstructs/releases/tag/1.1.9.4

I tested a new persistence model and I hope it should fix it. The only "problem" is, that the the current state of all bases gets resetten again, because I did't found a way to make both variants work with each other. you can use alt+f12 to give you the lost money back. 

This should really be the last time the savegame format changes and I now use a different strategy to save the state (and I don't reset the state on a scene switch anymore, only on loading a savegame) 

47 minutes ago, Simog said:

Hi
I started a new game but the problem persists. By doing various tests, I noticed that a quicksave and quickload solve the problem but sooner or later reappears.
 

Since I have so many mods, there is some known incompatibility?

Thanks

Log File

I'll have a look at it, when I'm back at my notebook. The CommNet implementation could be a bit funky. Adding an removing groundstations sometimes killed CommNet for me, but I never could saw a pattern. I hope, that with the next release of KK the problems are less prominent. But I'm pretty much stuck, until there is a new version of RemoteTech, which uses the CommNet infratructure as a base. (so I can have a look how implement this)

Share this post


Link to post
Share on other sites

I sure can, I'm going to install it now and run a test and will let you know the result after testing. Thank you again for all your work and I appreciate the reply!


*EDIT*
I have tested the latest beta for kerbal-konstructs and the state switching issue that resets open/closed bases has been resolved. Thank you for the awesome mod and fixing the issue so quickly. All issues seem resolved for me and again I'm on KSP 1.3 64bit

Edited by JeffersonFlight

Share this post


Link to post
Share on other sites
On 5/3/2017 at 10:25 AM, Beetlecat said:

Hot dang! :) Thank you for keeping the dream alive!

Now to see if the side-jobs contracts still work...

Did it?

Does anyone know if this works with Kerbal Construction Time?

Share this post


Link to post
Share on other sites

Issue to report:

The helipad spawn point at Jeb's Island Resort is mostly underground. I tried to spawn in a fuel truck to refuel a tilt rotor I'd launched from KSC, and it came in mostly underground and promptly exploded.

Is there a way for me to fix this myself via editing a particular file, or via the KK menu? Or would it require some serious work to fix?

Share this post


Link to post
Share on other sites

I've encountered an issue. I unlocked a few sites in career mode, when I loaded up the game again, the sites were locked again. I then turned off that particular function to unlock all my sites, and although I saved the setting, when I again reloaded the game, the sites were locked away again. Basically it seems the career mode thing is resetting every time I load up the game.

Share this post


Link to post
Share on other sites

Guys, what can be wrong with my install, if I can't launch from any site except KSC? I've tried the following:

1 - Click on site on map, text says "Selected site is [site name]" - when I switch to Space center view nothing changes and launched craft appears in KSC

2 - Changed "Default VAB launch site" to other side through mod settings - when I try to launch anything from VAB it appears in KSC :(

I'm using KerbinSide  Kerbin-Side Skyways pack with with latest KerbalKonstructs. Probably I simple don't understand how mod should work? Buth there are no readme or wiki or any documentations around :( At least google can't find it.

Share this post


Link to post
Share on other sites
1 hour ago, 1greywind said:

Guys, what can be wrong with my install, if I can't launch from any site except KSC? I've tried the following:

1 - Click on site on map, text says "Selected site is [site name]" - when I switch to Space center view nothing changes and launched craft appears in KSC

2 - Changed "Default VAB launch site" to other side through mod settings - when I try to launch anything from VAB it appears in KSC :(

I'm using KerbinSide  Kerbin-Side Skyways pack with with latest KerbalKonstructs. Probably I simple don't understand how mod should work? Buth there are no readme or wiki or any documentations around :( At least google can't find it.

Are you playing career mode?

Share this post


Link to post
Share on other sites
21 minutes ago, NomenNescio said:

Are you playing career mode?

I've tried both career and sandbox. In career (new game in 1.3 created for test purpose) I can open/close sites for funds, but still don't understand how to launch from them. In sandbox mode "open/close" buttons are inactive.

Do I understand correctly that launch site switch occurs when I click on the icon on the map view? Or I should first reach site with one of my crafts?

Share this post


Link to post
Share on other sites
2 hours ago, 1greywind said:

I've tried both career and sandbox. In career (new game in 1.3 created for test purpose) I can open/close sites for funds, but still don't understand how to launch from them. In sandbox mode "open/close" buttons are inactive.

Do I understand correctly that launch site switch occurs when I click on the icon on the map view? Or I should first reach site with one of my crafts?

You press the KK button in the VAB or SPH. Then select the base you want to Launch from and then press Launch.

On ‎19‎.‎08‎.‎2017 at 9:03 PM, NomenNescio said:

I've encountered an issue. I unlocked a few sites in career mode, when I loaded up the game again, the sites were locked again. I then turned off that particular function to unlock all my sites, and although I saved the setting, when I again reloaded the game, the sites were locked away again. Basically it seems the career mode thing is resetting every time I load up the game.

Try the latest beta of Kerbal Konstructs and report back if the problem persiists. This Version should contain some fixes for that. https://github.com/GER-Space/Kerbal-Konstructs/releases/tag/1.1.9.4

Share this post


Link to post
Share on other sites

Got a question on how the offices are supposed to function in KSC's campus.

So 'hiring kerbals' and assigning them to the offices is supposed to generate funds. It states '[x] per 12 hours' or something, maximum of 24000. Two assigned kerbals is 0.2 per 12 hours according to what it says.

However, it then goes and generates that 24000 funds within one minute... which is really imbalanced. I mean, I'm happy how it got me out of bankruptcy extremely quickly, but still. Isn't fair.

Is this fund generation rate an issue with the mod/something in its configs, or is it not playing nice with something else in my tons of other mods? (Like Kerbal Construction Time maybe.) This happens in both KSP 1.2.2 and 1.3.

Edited by Box of Stardust

Share this post


Link to post
Share on other sites
13 hours ago, Box of Stardust said:

Got a question on how the offices are supposed to function in KSC's campus.

So 'hiring kerbals' and assigning them to the offices is supposed to generate funds. It states '[x] per 12 hours' or something, maximum of 24000. Two assigned kerbals is 0.2 per 12 hours according to what it says.

However, it then goes and generates that 24000 funds within one minute... which is really imbalanced. I mean, I'm happy how it got me out of bankruptcy extremely quickly, but still. Isn't fair.

Is this fund generation rate an issue with the mod/something in its configs, or is it not playing nice with something else in my tons of other mods? (Like Kerbal Construction Time maybe.) This happens in both KSP 1.2.2 and 1.3.

Hmm I need to check that. This should not have happened.

Share this post


Link to post
Share on other sites
1 hour ago, Ger_space said:

Hmm I need to check that. This should not have happened.

 

Also, it only happens when the office building is actually selected. When deselected, I think it works properly. 

Share this post


Link to post
Share on other sites
On 8/17/2017 at 11:45 AM, MaverickSawyer said:

Issue to report:

The helipad spawn point at Jeb's Island Resort is mostly underground. I tried to spawn in a fuel truck to refuel a tilt rotor I'd launched from KSC, and it came in mostly underground and promptly exploded.

Is there a way for me to fix this myself via editing a particular file, or via the KK menu? Or would it require some serious work to fix?

you should be able to use the KK editor to scoot it up a bit.

Share this post


Link to post
Share on other sites
1 hour ago, Nightside said:

you should be able to use the KK editor to scoot it up a bit.

I... did not know that. Will take a look into that next time I boot up.

Would the changes be persistent across saves, or are they save specific?

Share this post


Link to post
Share on other sites
On 26.08.2017 at 5:10 AM, MaverickSawyer said:

Would the changes be persistent across saves, or are they save specific?

Changes will be saved in mod's files, regardless of the game save files.

Share this post


Link to post
Share on other sites
17 hours ago, LordOfMinecraft99 said:

does this work with Sigma Dimensions?

depends on what you mean by "work"

 

usual rescaling issues will apply, but KKtoSD should be able to solve the majority of those

Share this post


Link to post
Share on other sites

Trying to figure out how to have just the upgraded KSC, the campus and that radar dish looking thing near KSC... . I don't want all the other launch sites and comm stations. What do I need, or what do I need to delete?

Edited by TheKurgan

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.