Jump to content

[1.4.5] Smart Actuators v1.1.1 (8/1/18)


Recommended Posts

16 minutes ago, dlrk said:

The latest version causes an access violation 1.2.2 upon loading a craft in the VAB.

Are you saying you are using KSP 1.2.2? If so, any SA version after 1.0.1.1 simply won't work with KSP 1.2.2 as it is built on 1.3 references. If you want to use SA 1.1.0.1 on KSP 1.2.2 you'll have to go here and download the dll and replace the one currently installed (I compiled SA 1.1.0.1 on KSP 1.2.2 for a twitch streamer who asked me to).

If you are on KSP 1.3 it should be working so could you please post a link to your output_log.txt.

Link to post
Share on other sites
  • 2 weeks later...

Heya, just letting you know that the most recent version of your mod causes a metric tonne of log spam and slows the game right down while bloating the hell out of output_log. It appears to only occur when certain stock engines are on the craft or are dropped into the SPH/VAB, even if they're not attached to anything.

 

Hope this helps, thanks for all your work!

Link to post
Share on other sites

@LemonSkin @Gordon Dry Hmm looks like I might have bundled my test version instead of the release version (the "false" was an easy way of checking to see if it was working). This one should be all good https://github.com/theRagingIrishman/SmartActuation/releases/tag/1.1.0.2

Edited by TheRagingIrishman
Link to post
Share on other sites
9 minutes ago, Gordon Dry said:

Ouh! now the log is spammed with this in VAB (dunno if it's SmartActuators):

Exiting EditorPartEvent
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

And again a full log:
https://www.dropbox.com/s/4g72xful2epn1u3/2017-06-15-3 KSP.log.zip?dl=1

Ya that's not SA (just tested to confirm). The only time SA writes to the log (now that I cleared the testing statements) is when you first start KSP (in the main menu) and if there's an exception thrown in the vab/sph (but those messages will all start with "PROBLEM.").

Link to post
Share on other sites
5 hours ago, TheRagingIrishman said:

@LemonSkin @Gordon Dry Hmm looks like I might have bundled my test version instead of the release version (the "false" was an easy way of checking to see if it was working). This one should be all good https://github.com/theRagingIrishman/SmartActuation/releases/tag/1.1.0.2

Cheers, I'll test it now!

4 hours ago, Gordon Dry said:

Perhaps it's TweakScale, I also posted there because it's throwing a lot of exceptions on start.

TweakScale is pretty notorious for being incompatible with mods across updates. Good luck fixing it!

Link to post
Share on other sites
  • 2 weeks later...

I don't use TweakScale so I can't exclude it, but I did have a log that was spammed with False, and the spamming was related to SmartActuation (no spamming with all my mods but SmartActuation; spamming with only SmartActuation).

 

The update, tagged 1.1.0.2 above does not spam the log.

Thank you!

Link to post
Share on other sites
49 minutes ago, Kerbart said:

I don't use TweakScale so I can't exclude it, but I did have a log that was spammed with False, and the spamming was related to SmartActuation (no spamming with all my mods but SmartActuation; spamming with only SmartActuation).

 

The update, tagged 1.1.0.2 above does not spam the log.

Thank you!

Yup I accidentally left a debugging statement in. I actually realised right after I released 1.1 and "fixed" it in 1.1.0.1 but I messed up my release system and uploaded the unfixed version of the mod

Link to post
Share on other sites
  • 7 months later...
  • 5 months later...
On 7/27/2018 at 6:55 PM, linuxgurugamer said:

@TheRagingIrishman If you aren't going to continue this, would you mind if I adopt it?

Thanks for the offer, but I actually just updated it.

Release v1.1.1 for KSP 1.4.5 is now available at https://github.com/theRagingIrishman/SmartActuation/releases/tag/1.1.1

And to all you forum peeps, sorry I disappeared. I got into a rough situation and had to move away from KSP completely to be able to deal with it. I'm back now and will update my mods to keep up with the latest versions of KSP,  but I won't be as active as I was before. If anyone finds a bug or has a suggestion for an upgrade, please put it on Github so that I'll get a notification about it. Thanks, and keep flying!

Edited by TheRagingIrishman
Link to post
Share on other sites
1 minute ago, TheRagingIrishman said:

Thanks for the offer, but I actually just updated it.

And to all you forum peeps, sorry I disappeared. I got into a rough situation and had to move away from KSP completely to be able to deal with it. I'm back now and will update my mods to keep up with the latest versions of KSP,  but I won't be as active as I was before. If anyone finds a bug or has a suggestion for an upgrade, please put it on Github so that I'll get a notification about it. Thanks, and keep flying!

Welcome back.

Please update the OP and the thread title to reflect the update.

Feel free to call on me if you need help with an6 updates

Link to post
Share on other sites
ADDON BINDER: Cannot resolve assembly: UnityEngine.CoreModule, Culture=neutral, PublicKeyToken=null
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

ADDON BINDER: Cannot resolve assembly: UnityEngine.CoreModule, Culture=neutral, PublicKeyToken=null
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

AssemblyLoader: Exception loading 'SmartActuation': System.Reflection.ReflectionTypeLoadException: The classes in the module cannot be loaded.
  at (wrapper managed-to-native) System.Reflection.Assembly:GetTypes (bool)
  at System.Reflection.Assembly.GetTypes () [0x00000] in <filename unknown>:0 
  at AssemblyLoader.LoadAssemblies () [0x00000] in <filename unknown>:0 

Additional information about this exception:

 System.IO.FileNotFoundException: Could not load file or assembly 'UnityEngine.CoreModule, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
File name: 'UnityEngine.CoreModule, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null'

 System.IO.FileNotFoundException: Could not load file or assembly 'UnityEngine.CoreModule, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
File name: 'UnityEngine.CoreModule, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null'

 System.IO.FileNotFoundException: Could not load file or assembly 'UnityEngine.CoreModule, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
File name: 'UnityEngine.CoreModule, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null'

Broken for me. Using 1.4.5 windows x64

Link to post
Share on other sites
20 hours ago, PyjackMeat said:

Broken for me. Using 1.4.5 windows x64

Can you please:

  1. Create a GitHub issue  https://github.com/theRagingIrishman/SmartActuation/issues/new
  2. Go through https://forum.kerbalspaceprogram.com/index.php?/topic/83212-how-to-get-support-read-first/ and put the information described there into the GitHub issue

Can't promise I'll get it done immediately, bit busy now,  but I'll try and take a look. 

Edited by TheRagingIrishman
Link to post
Share on other sites
  • 1 month later...

This does not appear to be working for me in 1.4.5.   I'm using B9 Procedural parts, but they should be supported because they appear to use the stock modules that are described in the OP.   

EDIT : I created a github issue for it. 

Edited by eberkain
Link to post
Share on other sites
  • 2 weeks later...
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...