Jump to content

Recommended Posts

The PartTools package is a set of utilities used by modders to import 3D models into KSP. PartTools also includes the coloranimation tool and the KSPAssetCompiler tool (for compiling asset bundles).


PartTools have been updated and re-compiled for Unity 2019.2.2f1 for KSP 1.10+ to include all of these tools in one unity asset bundle.
 

Current latest version can be downloaded here.

To install:


For information about how to build and use fonts for Localization please refer to this link.

Previous Version 

For the old Unity 2017 PartTools you can use this link: Unity 2017 Part Tools

Link to post
Share on other sites
  • 2 months later...
  • 8 months later...
  • 6 months later...

PartTools for KSP 1.5.0 has been updated. Link in the opening post above.
This includes the new part shaders.
Also fixed a bug with localspace offset on IVA models (when exported) then being spawned for prop placement being placed in the wrong position in world space when spawned from parttools.
NB: PartTools still requires Unity 2017.1.3p1.

Link to post
Share on other sites
  • 5 months later...

PartTools has been updated to align with KSP 1.7.0.

Link in the opening post above.
This includes the new part shader.

NB: PartTools still requires Unity 2017.1.3p1.

Link to post
Share on other sites
  • 6 months later...
  • 3 months later...

Part Tools has been updated for KSP 1.9.0
This was required to cater for changes make to KSPedia loading.
Also removed the second/legacy copy of the part shaders from the bundle.

Link in the opening post above.

NB: Part Tools now requires Unity 2019.2.2f1

Link to post
Share on other sites
  • 5 months later...

Part tools has been updated for KSP 1.10.x.

Includes

- removed old shaders that were causing confusion.
- fixed exported internal spaces not working if you had your OS set to non-English.
- uses newer Free TMPro that corresponds to the one we use in KSP. So make sure you update that in your project.
- fixed issue where mod created fonts were not working/being loaded into KSP main game.
- added some of the newer part shaders we now use.

NB: Part Tools now requires Unity 2019.2.2f1

There is a link above to the older Unity 2017 version if you still want to use that.

 

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
×
×
  • Create New...