MOARdV

[WIP] [1.8.x] MOARdV's Avionics Systems - MAS Interactive IVA! (v1.1.0, 4 November 2019)

Recommended Posts

ok, after further testing I confirmed that the MAS diagnosis was a false positive.  It turned out that the vessel I first noticed the issue on had it's docking port attached to a hidden interstage node, so it wasn't an issue with any mod.  I had built a test rig to find the cause of the issue, but I neglected to properly account for the effect of gravity, which skewed my results.  Score one for the scientific method.  I'm sorry to have caused any trouble.

Share this post


Link to post
Share on other sites

I think i may have either an installation issue or a bug, but every vessel I launch has a [Avionics System] Initialization Error, Read Message Log, and this only appeared after i installed MAS and i can't figure out what the hell is happening 

Share this post


Link to post
Share on other sites
On 5/21/2018 at 2:11 AM, ChickenBot448 said:

I think i may have either an installation issue or a bug, but every vessel I launch has a [Avionics System] Initialization Error, Read Message Log, and this only appeared after i installed MAS and i can't figure out what the hell is happening 

Without seeing the log, I can't really tell you what's happening.  If you can post the entire log on DropBox or another file sharing site, I can figure it out.

Share this post


Link to post
Share on other sites
10 hours ago, MOARdV said:

Without seeing the log, I can't really tell you what's happening.  If you can post the entire log on DropBox or another file sharing site, I can figure it out.

The thing is, there is no output_log to get as i haven't had a crash, and the "Message Log" doesn't seem to exist. I never understood how to get these mods to work properly anyway because i just play these for fun, but i can't give you the log if i can't find it. I'll need to figure out a way to get it so you can have a look at it. 

Share this post


Link to post
Share on other sites
4 hours ago, ChickenBot448 said:

The thing is, there is no output_log to get as i haven't had a crash

doesn't matter. A separate log is made for crashes but a regular log is always created as soon as you start the game. See the bottom-most link in MOARdV's sig for locations of the log file

Share this post


Link to post
Share on other sites

@MOARdV Thank you for creating MAS! I can see that it has great potential and has better flexibility than RPM. I'm looking forward to making my SpaceX style touchscreen too. I've started working on the cockpit for my flying saucer:

Q35unu0.png

It isn't much but it's a start. Those buttons are MAS_SAS_xxxx types, are there ways to change the look? I'm not familiar with the new ASET buttons, I'm guessing that I have to make new buttons with different design patterns if I'm understanding the documentation correctly...

I mentioned earlier that I'm going for something like this:

49b1b6bd38283c6b39e33edc995bb5b3.jpg

I've no problems making a touchscreen prop. That reminds me, what kinds of resource displays does the MAS MFD have? Can it show alarms as well? Instead of individual alarms like you have in ASET, I'd love to make an MFD screen that shows them. Is that possible?

Edited by Angel-125

Share this post


Link to post
Share on other sites

Anybody see this error when you add the MAS_ALCOR_MFD1?

[ERR 13:00:55.000] [MASFlightComputer] MASFlightComputer.FixedUpdate exception: System.ArgumentException: Unexpected variable type Unknown for variable (fc.Remap)((fc.HottestEngineTemperature)(false), 0, (fc.HottestEngineTemperatureMax)(false), (-1), 252) in mutableVariablesList
  at AvionicsSystems.MASFlightComputer.FixedUpdate () [0x00000] in <filename unknown>:0

Share this post


Link to post
Share on other sites

@Angel-125 - for the push buttons, yes, you'll need to configure your own to change the style.  I've attempted to simplify that by creating a Prop Config tool that can automate a lot of the process once you've selected the look-and-feel for the props.  Hopefully it's not too difficult to figure out (I tried to document it, and the example XML is the file I am using for creating props).

Right now, the MAS MFD has one general-purpose resource page that shows monoprop, propellant (whatever the current active engines), and electrical charge as half-circle digital gauges with numeric details.  That page also has three user-configurable gauges (meaning, the player can select whatever resource he/she wants to display on each of those slots).  For alarms - you mean Kerbal Alarm Clock alarms, or general system alarm things (low fuel, engine fault)?  If it's the former, the current MAS-KAC interface only shows you the next alarm for the current craft.  I can change that to let you list all KAC alarms, but there hasn't been a request for it.  If it's the latter, I've got a page on my "touch screen" data display that has a lot of status lamp type displays (low fuel, atmospheric entry, impact, that sort of thing).

3 minutes ago, Angel-125 said:

Anybody see this error when you add the MAS_ALCOR_MFD1?

[ERR 13:00:55.000] [MASFlightComputer] MASFlightComputer.FixedUpdate exception: System.ArgumentException: Unexpected variable type Unknown for variable (fc.Remap)((fc.HottestEngineTemperature)(false), 0, (fc.HottestEngineTemperatureMax)(false), (-1), 252) in mutableVariablesList
  at AvionicsSystems.MASFlightComputer.FixedUpdate () [0x00000] in <filename unknown>:0

Probably because I forgot to update that MFD when I made some changes a while back.  The MFD1 is the first one I worked on, and it was supposed to be similar to a Soyuz TMA display.  However, I stopped using it a while ago, so it's kind of fallen by the wayside.

Share this post


Link to post
Share on other sites
4 minutes ago, MOARdV said:

@Angel-125 - for the push buttons, yes, you'll need to configure your own to change the style.  I've attempted to simplify that by creating a Prop Config tool that can automate a lot of the process once you've selected the look-and-feel for the props.  Hopefully it's not too difficult to figure out (I tried to document it, and the example XML is the file I am using for creating props).

Right now, the MAS MFD has one general-purpose resource page that shows monoprop, propellant (whatever the current active engines), and electrical charge as half-circle digital gauges with numeric details.  That page also has three user-configurable gauges (meaning, the player can select whatever resource he/she wants to display on each of those slots).  For alarms - you mean Kerbal Alarm Clock alarms, or general system alarm things (low fuel, engine fault)?  If it's the former, the current MAS-KAC interface only shows you the next alarm for the current craft.  I can change that to let you list all KAC alarms, but there hasn't been a request for it.  If it's the latter, I've got a page on my "touch screen" data display that has a lot of status lamp type displays (low fuel, atmospheric entry, impact, that sort of thing).

Oh, that's a useful tool, thanks for pointing that out. :) As for the MFD, yes, I'm looking for system alarms. The resource display sounds exactly like what I need. Also, which of the MFDs is the touchscreen?

I'm also getting this error:

[ERR 13:00:55.000] [MASFlightComputer] MASFlightComputer.FixedUpdate exception: System.ArgumentException: Unexpected variable type Unknown for variable (fc.Remap)((fc.HottestEngineTemperature)(false), 0, (fc.HottestEngineTemperatureMax)(false), (-1), 252) in mutableVariablesList
  at AvionicsSystems.MASFlightComputer.FixedUpdate () [0x00000] in <filename unknown>:0

when using MAS_ALCOR_MFD1. Perhaps that'll go away if I'm using the correct mfd..?

Last question: Does MAS have a Heads Up Display like RPM?

Thanks again for your help!

Share this post


Link to post
Share on other sites
20 minutes ago, Angel-125 said:

when using MAS_ALCOR_MFD1. Perhaps that'll go away if I'm using the correct mfd..?

I guess the forum auto-merge didn't show you my reply - I think it's because I haven't kept MFD1 current, since I'm not using it.  MFD2 is what's in my current IVA.  I'll go double check the old MFD to see if it needs updated.

21 minutes ago, Angel-125 said:

Last question: Does MAS have a Heads Up Display like RPM?

Not yet.  The IVA I currently have doesn't have any good locations for a HUD, and last I saw, alexustas was working on a flight management system.  So, no HUDs at the moment that I know of.

Share this post


Link to post
Share on other sites

How do you get pages to display in the MFD? I am using the MAS_ASET_MFD2, but it doesn't appear to show anything. Here's a copy of my logs:

Spoiler

[LOG 19:30:01.814] [MASComponent] Configuration complete in prop #3 (MAS_toggle_Stage): 6 nodes created
[LOG 19:30:01.820] [MASComponent] Configuration complete in prop #6 (MAS_pb_SAS_Prograde): 6 nodes created
[LOG 19:30:01.824] [MASComponent] Configuration complete in prop #7 (MAS_pb_SAS_Retrograde): 6 nodes created
[LOG 19:30:01.828] [MASComponent] Configuration complete in prop #8 (MAS_pb_SAS_RadialIn): 6 nodes created
[LOG 19:30:01.833] [MASComponent] Configuration complete in prop #9 (MAS_pb_SAS_RadialOut): 6 nodes created
[LOG 19:30:01.837] [MASComponent] Configuration complete in prop #10 (MAS_pb_SAS_Normal): 5 nodes created
[LOG 19:30:01.841] [MASComponent] Configuration complete in prop #11 (MAS_pb_SAS_AntiNormal): 6 nodes created
[LOG 19:30:01.845] [MASComponent] Configuration complete in prop #12 (MAS_pb_SAS_Target): 5 nodes created
[LOG 19:30:01.850] [MASComponent] Configuration complete in prop #13 (MAS_pb_SAS_AntiTarget): 6 nodes created
[LOG 19:30:01.854] [MASComponent] Configuration complete in prop #14 (MAS_pb_SAS_StabilityAssist): 6 nodes created
[LOG 19:30:01.859] [MASComponent] Configuration complete in prop #15 (MAS_pb_SAS_ManeuverNode): 6 nodes created
[LOG 19:30:01.861] [MASComponent] Configuration complete in prop #16 (MAS_SmallPlate_SAS): 3 nodes created
[LOG 19:30:01.867] [MASComponent] Configuration complete in prop #17 (MAS_pb_Gear): 8 nodes created
[LOG 19:30:01.873] [MASComponent] Configuration complete in prop #18 (MAS_pb_RCS): 8 nodes created
[LOG 19:30:01.878] [MASComponent] Configuration complete in prop #19 (MAS_FI_Gear): 6 nodes created
[LOG 19:30:01.882] [MASComponent] Configuration complete in prop #20 (MAS_FI_Brakes): 6 nodes created
[LOG 19:30:01.888] [MASComponent] Configuration complete in prop #21 (MAS_pb_Lights): 8 nodes created
[LOG 19:30:01.894] [MASComponent] Configuration complete in prop #22 (MAS_pb_Brakes): 8 nodes created
[LOG 19:30:01.897] [MASComponent] Configuration complete in prop #23 (MAS_FI_Lights): 6 nodes created
[LOG 19:30:01.901] [MASComponent] Configuration complete in prop #24 (MAS_FI_RCS): 6 nodes created
[LOG 19:30:01.904] [MASComponent] Configuration complete in prop #25 (MAS_PanelDivider): 1 nodes created
[LOG 19:30:01.908] [MASComponent] Configuration complete in prop #26 (MAS_FI_SAS): 6 nodes created
[LOG 19:30:01.910] [MASComponent] Configuration complete in prop #27 (MAS_SmallPlate_MechJeb): 3 nodes created
[LOG 19:30:01.914] [MASComponent] Configuration complete in prop #28 (MAS_RWL_MasterAlarm): 4 nodes created
[LOG 19:30:01.922] [MASComponent] Configuration complete in prop #29 (MAS_RWL_MasterCaution): 4 nodes created
[LOG 19:30:01.927] [MASComponent] Configuration complete in prop #30 (MAS_RWL_EngineFlameOut): 4 nodes created
[LOG 19:30:01.934] [MASComponent] Configuration complete in prop #31 (MAS_toggle_Abort): 7 nodes created
[LOG 19:30:02.375] [MASMonitor] Configuration complete in prop #33 (MAS_ALCOR_MFD2) with 18 pages
[LOG 19:30:02.393] [MASComponent] Configuration complete in prop #33 (MAS_ALCOR_MFD2): 22 nodes created
[LOG 19:30:02.953] [MASMonitor] Configuration complete in prop #34 (MAS_ALCOR_MFD2) with 18 pages
[LOG 19:30:02.970] [MASComponent] Configuration complete in prop #34 (MAS_ALCOR_MFD2): 22 nodes created
[LOG 19:30:03.281] [MASMonitor] Configuration complete in prop #35 (MAS_ALCOR_MFD2) with 18 pages
[LOG 19:30:03.297] [MASComponent] Configuration complete in prop #35 (MAS_ALCOR_MFD2): 22 nodes created
[LOG 19:30:03.593] [MASMonitor] Configuration complete in prop #36 (MAS_ALCOR_MFD2) with 18 pages
[LOG 19:30:03.613] [MASComponent] Configuration complete in prop #36 (MAS_ALCOR_MFD2): 22 nodes created
[LOG 19:30:04.217] [MASMonitor] Configuration complete in prop #37 (MAS_ALCOR_MFD2) with 18 pages
[LOG 19:30:04.240] [MASComponent] Configuration complete in prop #37 (MAS_ALCOR_MFD2): 22 nodes created
[LOG 19:30:04.574] [MASMonitor] Configuration complete in prop #38 (MAS_ALCOR_MFD2) with 18 pages
[LOG 19:30:04.592] [MASComponent] Configuration complete in prop #38 (MAS_ALCOR_MFD2): 22 nodes created
[LOG 19:30:05.209] [MASMonitor] Configuration complete in prop #39 (MAS_ALCOR_MFD2) with 18 pages
[LOG 19:30:05.226] [MASComponent] Configuration complete in prop #39 (MAS_ALCOR_MFD2): 22 nodes created
[LOG 19:30:05.232] [MASComponent] Configuration complete in prop #40 (MAS_toggle_Engine): 6 nodes created
[LOG 19:30:05.238] [MASComponent] Configuration complete in prop #41 (MAS_toggle_Stage): 6 nodes created
[LOG 19:30:05.245] [MASComponent] Configuration complete in prop #42 (MAS_toggle_Engine): 6 nodes created
[LOG 19:30:05.575] [MASMonitor] Configuration complete in prop #43 (MAS_ALCOR_MFD2) with 18 pages
[LOG 19:30:05.592] [MASComponent] Configuration complete in prop #43 (MAS_ALCOR_MFD2): 22 nodes created
[ERR 19:30:05.627] [RasterPropMonitorComputer]: Tried to look for method with propToUse still null?

[ERR 19:30:05.627] [RasterPropMonitorComputer]: Tried to look for method with propToUse still null?

[ERR 19:30:05.631] [JSIVariableAnimator]: INITIALIZATION ERROR, CHECK CONFIGURATION.

[EXC 19:30:05.633] NullReferenceException: Object reference not set to an instance of an object
    JSI.RasterPropMonitorComputer.TerminalVelocity (JSI.RPMVesselComputer comp)
    JSI.RasterPropMonitorComputer.<GetEvaluator>b__21 (System.String variable, JSI.RPMVesselComputer comp)
    JSI.RasterPropMonitorComputer.AddVariable (System.String variableName)
    JSI.RasterPropMonitorComputer.InstantiateVariableOrNumber (System.String variableName)
    JSI.VariableOrNumberRange..ctor (JSI.RasterPropMonitorComputer rpmComp, System.String sourceVariable, System.String range1, System.String range2, System.String moduloVariable)
    JSI.CustomVariable.ProcessSourceNode (.ConfigNode node, JSI.RasterPropMonitorComputer rpmComp, System.Boolean& reverse)
    JSI.CustomVariable..ctor (.ConfigNode node, JSI.RasterPropMonitorComputer rpmComp)
    JSI.JUtil.InstantiateComplexVariable (.ConfigNode node, JSI.RasterPropMonitorComputer rpmComp)
    JSI.RasterPropMonitorComputer.GetEvaluator (System.String input, System.Boolean& cacheable)
    JSI.RasterPropMonitorComputer.AddVariable (System.String variableName)
    JSI.RasterPropMonitorComputer.InstantiateVariableOrNumber (System.String variableName)
    JSI.VariableOrNumberRange..ctor (JSI.RasterPropMonitorComputer rpmComp, System.String sourceVariable, System.String range1, System.String range2, System.String moduloVariable)
    JSI.CustomVariable.ProcessSourceNode (.ConfigNode node, JSI.RasterPropMonitorComputer rpmComp, System.Boolean& reverse)
    JSI.CustomVariable..ctor (.ConfigNode node, JSI.RasterPropMonitorComputer rpmComp)
    JSI.JUtil.InstantiateComplexVariable (.ConfigNode node, JSI.RasterPropMonitorComputer rpmComp)
    JSI.RasterPropMonitorComputer.GetEvaluator (System.String input, System.Boolean& cacheable)
    JSI.RasterPropMonitorComputer.AddVariable (System.String variableName)
    JSI.RasterPropMonitorComputer.InstantiateVariableOrNumber (System.String variableName)
    JSI.VariableOrNumberRange..ctor (JSI.RasterPropMonitorComputer rpmComp, System.String sourceVariable, System.String range1, System.String range2, System.String moduloVariable)
    JSI.VariableAnimationSet..ctor (.ConfigNode node, .InternalProp thisProp, JSI.RasterPropMonitorComputer rpmComp)
    JSI.JSIVariableAnimator.Start ()
[ERR 19:30:05.637] [JSIVariableLabel]: Start failed with exception System.NullReferenceException: Object reference not set to an instance of an object
  at JSI.RasterPropMonitorComputer.TerminalVelocity (JSI.RPMVesselComputer comp) [0x00000] in <filename unknown>:0
  at JSI.RasterPropMonitorComputer.<GetEvaluator>b__21 (System.String variable, JSI.RPMVesselComputer comp) [0x00000] in <filename unknown>:0
  at JSI.RasterPropMonitorComputer.AddVariable (System.String variableName) [0x00000] in <filename unknown>:0
  at JSI.RasterPropMonitorComputer.InstantiateVariableOrNumber (System.String variableName) [0x00000] in <filename unknown>:0
  at JSI.StringProcessorFormatter..ctor (System.String input, JSI.RasterPropMonitorComputer rpmComp) [0x00000] in <filename unknown>:0
  at JSI.JSIVariableLabel.Start () [0x00000] in <filename unknown>:0

[ERR 19:30:05.642] [RasterPropMonitorComputer]: Tried to look for method with propToUse still null?

[ERR 19:30:05.643] [JSIVariableLabel]: Start failed with exception System.NullReferenceException: Object reference not set to an instance of an object
  at JSI.RasterPropMonitorComputer.TerminalVelocity (JSI.RPMVesselComputer comp) [0x00000] in <filename unknown>:0
  at JSI.RasterPropMonitorComputer.<GetEvaluator>b__21 (System.String variable, JSI.RPMVesselComputer comp) [0x00000] in <filename unknown>:0
  at JSI.RasterPropMonitorComputer.AddVariable (System.String variableName) [0x00000] in <filename unknown>:0
  at JSI.RasterPropMonitorComputer.InstantiateVariableOrNumber (System.String variableName) [0x00000] in <filename unknown>:0
  at JSI.VariableOrNumberRange..ctor (JSI.RasterPropMonitorComputer rpmComp, System.String sourceVariable, System.String range1, System.String range2, System.String moduloVariable) [0x00000] in <filename unknown>:0
  at JSI.CustomVariable.ProcessSourceNode (.ConfigNode node, JSI.RasterPropMonitorComputer rpmComp, System.Boolean& reverse) [0x00000] in <filename unknown>:0
  at JSI.CustomVariable..ctor (.ConfigNode node, JSI.RasterPropMonitorComputer rpmComp) [0x00000] in <filename unknown>:0
  at JSI.JUtil.InstantiateComplexVariable (.ConfigNode node, JSI.RasterPropMonitorComputer rpmComp) [0x00000] in <filename unknown>:0
  at JSI.RasterPropMonitorComputer.GetEvaluator (System.String input, System.Boolean& cacheable) [0x00000] in <filename unknown>:0
  at JSI.RasterPropMonitorComputer.AddVariable (System.String variableName) [0x00000] in <filename unknown>:0
  at JSI.RasterPropMonitorComputer.InstantiateVariableOrNumber (System.String variableName) [0x00000] in <filename unknown>:0
  at JSI.StringProcessorFormatter..ctor (System.String input, JSI.RasterPropMonitorComputer rpmComp) [0x00000] in <filename unknown>:0
  at JSI.JSIVariableLabel.Start () [0x00000] in <filename unknown>:0

[LOG 19:30:05.644] [RasterPropMonitorComputer]: Unrecognized variable FARPM_STALL_FRACTION
[ERR 19:30:05.652] [JSIVariableAnimator]: INITIALIZATION ERROR, CHECK CONFIGURATION.

[EXC 19:30:05.653] NullReferenceException: Object reference not set to an instance of an object
    JSI.RasterPropMonitorComputer.TerminalVelocity (JSI.RPMVesselComputer comp)
    JSI.RasterPropMonitorComputer.<GetEvaluator>b__21 (System.String variable, JSI.RPMVesselComputer comp)
    JSI.RasterPropMonitorComputer.AddVariable (System.String variableName)
    JSI.RasterPropMonitorComputer.InstantiateVariableOrNumber (System.String variableName)
    JSI.VariableOrNumberRange..ctor (JSI.RasterPropMonitorComputer rpmComp, System.String sourceVariable, System.String range1, System.String range2, System.String moduloVariable)
    JSI.CustomVariable.ProcessSourceNode (.ConfigNode node, JSI.RasterPropMonitorComputer rpmComp, System.Boolean& reverse)
    JSI.CustomVariable..ctor (.ConfigNode node, JSI.RasterPropMonitorComputer rpmComp)
    JSI.JUtil.InstantiateComplexVariable (.ConfigNode node, JSI.RasterPropMonitorComputer rpmComp)
    JSI.RasterPropMonitorComputer.GetEvaluator (System.String input, System.Boolean& cacheable)
    JSI.RasterPropMonitorComputer.AddVariable (System.String variableName)
    JSI.RasterPropMonitorComputer.InstantiateVariableOrNumber (System.String variableName)
    JSI.VariableOrNumberRange..ctor (JSI.RasterPropMonitorComputer rpmComp, System.String sourceVariable, System.String range1, System.String range2, System.String moduloVariable)
    JSI.CustomVariable.ProcessSourceNode (.ConfigNode node, JSI.RasterPropMonitorComputer rpmComp, System.Boolean& reverse)
    JSI.CustomVariable..ctor (.ConfigNode node, JSI.RasterPropMonitorComputer rpmComp)
    JSI.JUtil.InstantiateComplexVariable (.ConfigNode node, JSI.RasterPropMonitorComputer rpmComp)
    JSI.RasterPropMonitorComputer.GetEvaluator (System.String input, System.Boolean& cacheable)
    JSI.RasterPropMonitorComputer.AddVariable (System.String variableName)
    JSI.RasterPropMonitorComputer.InstantiateVariableOrNumber (System.String variableName)
    JSI.VariableOrNumberRange..ctor (JSI.RasterPropMonitorComputer rpmComp, System.String sourceVariable, System.String range1, System.String range2, System.String moduloVariable)
    JSI.VariableAnimationSet..ctor (.ConfigNode node, .InternalProp thisProp, JSI.RasterPropMonitorComputer rpmComp)
    JSI.JSIVariableAnimator.Start ()
[ERR 19:30:05.655] [JSIVariableLabel]: Start failed with exception System.NullReferenceException: Object reference not set to an instance of an object
  at JSI.RasterPropMonitorComputer.TerminalVelocity (JSI.RPMVesselComputer comp) [0x00000] in <filename unknown>:0
  at JSI.RasterPropMonitorComputer.<GetEvaluator>b__21 (System.String variable, JSI.RPMVesselComputer comp) [0x00000] in <filename unknown>:0
  at JSI.RasterPropMonitorComputer.AddVariable (System.String variableName) [0x00000] in <filename unknown>:0
  at JSI.RasterPropMonitorComputer.InstantiateVariableOrNumber (System.String variableName) [0x00000] in <filename unknown>:0
  at JSI.StringProcessorFormatter..ctor (System.String input, JSI.RasterPropMonitorComputer rpmComp) [0x00000] in <filename unknown>:0
  at JSI.JSIVariableLabel.Start () [0x00000] in <filename unknown>:0

[ERR 19:30:05.657] [JSIVariableLabel]: Start failed with exception System.NullReferenceException: Object reference not set to an instance of an object
  at JSI.RasterPropMonitorComputer.TerminalVelocity (JSI.RPMVesselComputer comp) [0x00000] in <filename unknown>:0
  at JSI.RasterPropMonitorComputer.<GetEvaluator>b__21 (System.String variable, JSI.RPMVesselComputer comp) [0x00000] in <filename unknown>:0
  at JSI.RasterPropMonitorComputer.AddVariable (System.String variableName) [0x00000] in <filename unknown>:0
  at JSI.RasterPropMonitorComputer.InstantiateVariableOrNumber (System.String variableName) [0x00000] in <filename unknown>:0
  at JSI.VariableOrNumberRange..ctor (JSI.RasterPropMonitorComputer rpmComp, System.String sourceVariable, System.String range1, System.String range2, System.String moduloVariable) [0x00000] in <filename unknown>:0
  at JSI.CustomVariable.ProcessSourceNode (.ConfigNode node, JSI.RasterPropMonitorComputer rpmComp, System.Boolean& reverse) [0x00000] in <filename unknown>:0
  at JSI.CustomVariable..ctor (.ConfigNode node, JSI.RasterPropMonitorComputer rpmComp) [0x00000] in <filename unknown>:0
  at JSI.JUtil.InstantiateComplexVariable (.ConfigNode node, JSI.RasterPropMonitorComputer rpmComp) [0x00000] in <filename unknown>:0
  at JSI.RasterPropMonitorComputer.GetEvaluator (System.String input, System.Boolean& cacheable) [0x00000] in <filename unknown>:0
  at JSI.RasterPropMonitorComputer.AddVariable (System.String variableName) [0x00000] in <filename unknown>:0
  at JSI.RasterPropMonitorComputer.InstantiateVariableOrNumber (System.String variableName) [0x00000] in <filename unknown>:0
  at JSI.StringProcessorFormatter..ctor (System.String input, JSI.RasterPropMonitorComputer rpmComp) [0x00000] in <filename unknown>:0
  at JSI.JSIVariableLabel.Start () [0x00000] in <filename unknown>:0

And the config I'm using for my cockpit:

Spoiler

    MODULE
    {
        name = MASFlightComputer

        gLimit = 9000
        baseDisruptionChance = 0.0
        requiresPower = false
        powerOnVariable = ""

//        PERSISTENT_VARIABLES
//        {
//            MAS_IMP_Mode_Select = 1
//        }

        RPM_COLOROVERRIDE
        {
            COLORDEFINITION
            {
                // 'white' label unlit color
                name = ASET_SWITCHER_NAME_ZEROCOLOR
                color =  213, 213, 213, 255
            }
        }
    }

Clearly I'm missing something but I'm not sure what. I'm using MAS 0.14.0. Any ideas?

Thanks! :)

Share this post


Link to post
Share on other sites

Ok, I fixed the RPM errors thanks to @G'th:

gTo55gL.png

Unfortunately the MAS_ASET_MFD2 monitors are still dead. Full logs here. I'm sure I'm missing something, I'm just not sure what.

Share this post


Link to post
Share on other sites
1 hour ago, Angel-125 said:

Ok, I fixed the RPM errors thanks to @G'th:

gTo55gL.png

Unfortunately the MAS_ASET_MFD2 monitors are still dead. Full logs here. I'm sure I'm missing something, I'm just not sure what.

In case you don't see the msg I sent you try this:

MODULE
    {
        name = MASFlightComputer
        requiresPower = true
        gLimit = 9000
        baseDisruptionChance = 0

        PERSISTENT_VARIABLES{}
        RPM_COLOROVERRIDE
        {
            COLORDEFINITION
            {
                // 'white' label unlit color
                name = ASET_SWITCHER_NAME_ZEROCOLOR
                color =  213, 213, 213, 255
            }
        }
    }

 

Edited by G'th

Share this post


Link to post
Share on other sites
8 hours ago, Angel-125 said:

Unfortunately the MAS_ASET_MFD2 monitors are still dead. Full logs here. I'm sure I'm missing something, I'm just not sure what.

I suspect it's the empty string for the powerOnVariable - that likely evaluates to 0, which tells MAS that there's no power.  Remove powerOnVariable entirely, or set it to 1 if you want to add a custom master power switch later.

One other thing you will want to add is either MAS_swRotary_InstrumentLight (to allow the player to adjust the instrument backlight brightness), or add 

Backlight = 1

to the PERSISTENT_VARIABLES in MASFlightComputer (this will force the backlights to full brightness, but it takes away the player's ability to adjust it if you don't include a dimmer switch).

Share this post


Link to post
Share on other sites
43 minutes ago, MOARdV said:

I suspect it's the empty string for the powerOnVariable - that likely evaluates to 0, which tells MAS that there's no power.  Remove powerOnVariable entirely, or set it to 1 if you want to add a custom master power switch later.

One other thing you will want to add is either MAS_swRotary_InstrumentLight (to allow the player to adjust the instrument backlight brightness), or add 


Backlight = 1

to the PERSISTENT_VARIABLES in MASFlightComputer (this will force the backlights to full brightness, but it takes away the player's ability to adjust it if you don't include a dimmer switch).

Thank you much, I will give these a try. :)

Share this post


Link to post
Share on other sites

I've released MAS v0.15.0.  This update adds some features and fixes a few things.  The full release notes and the update will be on GitHub in a few minutes (since it looks like I forgot to upload it first :blush: ).  Possibly the top feature for most people is that MAS won't automatically install all of the radio navigation beacons in the stock waypoints manager.  They can still be re-added (or removed) later through the MAS Settings dialog (accessed through the AppLauncher from the space center).

Share this post


Link to post
Share on other sites
1 hour ago, MOARdV said:

I've released MAS v0.15.0.  This update adds some features and fixes a few things.  The full release notes and the update will be on GitHub in a few minutes (since it looks like I forgot to upload it first :blush: ).  Possibly the top feature for most people is that MAS won't automatically install all of the radio navigation beacons in the stock waypoints manager.  They can still be re-added (or removed) later through the MAS Settings dialog (accessed through the AppLauncher from the space center).

Awesome, looking forward to using that. Also, do you have any examples of a MASCamera configuration? How should a camera transform be oriented? Which axis does the lens use?

Thanks again, the cockpit is nearly done. :)

Share this post


Link to post
Share on other sites
47 minutes ago, Angel-125 said:

Awesome, looking forward to using that. Also, do you have any examples of a MASCamera configuration? How should a camera transform be oriented? Which axis does the lens use?

Thanks again, the cockpit is nearly done. :)

MASCamera follows the transform standards of ASET parts, which follows the standards of RPM:

Quote

Cameras will be pointing in the Z+ direction of the transform, with X+ towards the right of the field of view, and will move if the transform itself moves.

I'll update the MAS Camera documentation to include that info (which is from the RPM wiki on GitHub), since that is kind-of important. :)

I've been following the saucer development (my son is very excited about the pending release).  I think the cockpit windshield needs a "Groom Lake Parking Pass" sticker in the corner to keep with the other nods to A-51. :)  Although that'd probably be too difficult to read to make it worthwhile.

Share this post


Link to post
Share on other sites

Hotfix MAS v0.15.1 is up - I fixed the problem with spamming the waypoint manager with nav beacons, but didn't validate the changes with a MAS IVA.  This update fixes the NRE introduced in v0.15.0.

Share this post


Link to post
Share on other sites
4 hours ago, MOARdV said:

MASCamera follows the transform standards of ASET parts, which follows the standards of RPM:

I'll update the MAS Camera documentation to include that info (which is from the RPM wiki on GitHub), since that is kind-of important. :)

I've been following the saucer development (my son is very excited about the pending release).  I think the cockpit windshield needs a "Groom Lake Parking Pass" sticker in the corner to keep with the other nods to A-51. :)  Although that'd probably be too difficult to read to make it worthwhile.

Groom Lake Parking pass... love it! :) Thanks for the info on the camera.

Share this post


Link to post
Share on other sites

Woot!

jvCmHaK.png

I'll have to figure out the shaders later.. I'd like to have night vision cameras for when it gets dark..

Share this post


Link to post
Share on other sites
3 hours ago, Angel-125 said:

I'll have to figure out the shaders later.. I'd like to have night vision cameras for when it gets dark..

Those are (hopefully) easy to do.  Just add a mode to the MASCamera that uses MOARdV/Monochrome or MOARdV/MonochromeNoise (depending on whether you want some noise on the image) and tweak the channel colors and gain values.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.