themaster401

[KSP 1.7] Astronomer's Visual Pack [v3.74 "Warpspeed"]

Recommended Posts

hey om @themaster401 could you please fix the ckan download links because when i click 2k 4k and even 8k it does not work and it says it depends on astronomers visual pack which is not updated for ksp 1.4.5....... I have absoluty no idea what is going on here:/

Share this post


Link to post
Share on other sites

Is it possible to remove the white clouds/streaks from jool. I find it very ugly tbh and not really fitting for it being a gas giant

Edited by Pointblank66

Share this post


Link to post
Share on other sites
On 9/5/2018 at 10:57 AM, The_8_Bit_Zombie said:

Hello! Does anyone know if a laptop with a NVIDIA Quadro K2100M graphics card and 32GB of RAM would be able to run AVP well? Thanks!

Hi, I'm running the game in full HD with high graphics settings and AVP on a laptop with the Quadro M2000M, and 48GB RAM. I've never experienced smooth gameplay after the first couple of flights in career mode, but it's definitely playable! 

Share this post


Link to post
Share on other sites
13 hours ago, Midline said:

Hi, I'm running the game in full HD with high graphics settings and AVP on a laptop with the Quadro M2000M, and 48GB RAM. I've never experienced smooth gameplay after the first couple of flights in career mode, but it's definitely playable! 

Despite the insane specs workstation laptops boast (which do, to their credit, crush productive workloads with relative ease), they aren't all that optimized for gaming :( . Glad you're still enjoying the experience!

Share this post


Link to post
Share on other sites
On 9/17/2018 at 1:07 PM, Galileo said:

48gb of ram in a laptop? :/

Do I really need to confess that I use my work laptop for some stimulating space simulations on my spare time? I thought that obvious, doesn't everyone? ;) 

Share this post


Link to post
Share on other sites

Hi all,

Im trying to install this mod from CKAN, it seems to be 1.4.5 compatible (Im running 1.4.5 ksp version) but it is under the "incompatible" section. If i go to the "relationships" tab scatterer is marked as only compatible with 1.4.2, could that be the problem?

Thx!

Share this post


Link to post
Share on other sites
1 hour ago, swoosh said:

Im trying to install this mod from CKAN, it seems to be 1.4.5 compatible (Im running 1.4.5 ksp version) but it is under the "incompatible" section. If i go to the "relationships" tab scatterer is marked as only compatible with 1.4.2, could that be the problem?

Hi @swoosh.  I just want to confirm you're trying to install "Astronomer's Visual Pack" by @themaster401 (shows in CKAN as "themaster402" for some reason), version 3.7.4.0.

There's also the original "Astronomer's Visual Pack (depreciated)" by @Astronomer, but that's for max KSP 1.0.4.  Don't try to install that.  You shouldn't even see that except if viewing "Filter (All)".

Next question, have you modified your KSP install in any way besides using CKAN?  Have you manually installed any mods or changed files within mods except by running CKAN and KSP?

Also, I'd suggest you check your CKAN client program's compatible KSP versions.  Click on the top "Settings" then "Compatible KSP versions".  The window "Compatible KSP versions" should pop up.  By default, it should have KSP 1.4 checked and only it.  Can you tell me what it has checked?

Edited by Jacke

Share this post


Link to post
Share on other sites
4 hours ago, swoosh said:

Hi all,

Im trying to install this mod from CKAN, it seems to be 1.4.5 compatible (Im running 1.4.5 ksp version) but it is under the "incompatible" section. If i go to the "relationships" tab scatterer is marked as only compatible with 1.4.2, could that be the problem?

Thx!

Yes, it is currently Incompatible through CKAN because one of its dependencies (Scatterer) is only listed as compatible with 1.4.2.

BUT, Scatterer does appear to work fine in 1.4.5.

SO if you tell go to CKAN Settings tab and temporarily set CKAN to allow 1.4.2 mods to be compatible, CKAN will allow AVP to be installed.

After its installed, uncheck 1.4.2 from the compatible versions.

 

 

Edited by BlackHat

Share this post


Link to post
Share on other sites
21 minutes ago, BlackHat said:

Yes, it is currently Incompatible through CKAN because one of its dependencies (Scatterer) is only listed as compatible with 1.4.2.

BUT, Scatterer does appear to work fine in 1.4.5.

SO if you tell go to CKAN Settings tab and temporarily set CKAN to allow 1.4.2 mods to be compatible, CKAN will allow AVP to be installed.

After its installed, uncheck 1.4.2 from the compatible versions.

No, don't do that.

Compatibility should be for the default KSP 1.4.  That will match all of the 1.4.x versions.  Other versions are not necessary.  It shouldn't be splitting beyond that.  Astronomer's Visual Pack and scatterer install in my CKAN, so there's something wrong in yours.

What does your CKAN say are the compatible KSP versions checkmarked ?

This is what happens on my CKAN when I install Astronomer's Visual Pack.

Spoiler

When I select Astronomer's Visual Pack, I get asked 2 questions:

1.  To select one of the three available Astronomer's Visual Pack texture packs:
I pick only one, 2K.  Click "Continue"

2.  To select one of two sources for sunflare:
I pick only one, scatterer - sunflare.  Click "Continue"

Then I'm back at the mod selection screen.  Click "Apply changes".  I see that there will be installed up to 9 packages (unless I already have them installed):

Astronomer's Visual Pack
Kopernicus
ModuleFlightIntegrator
scatterer
LoadingScreenManager
Environment Visual Enhancements (the mod that AVP is just the config for)
Astronomer's Visual Pack - 2K Textures
scatterer - sunflare
scatterer - default config

Click "Apply".

Then I see a screen saying TextureReplacer is a recommended mod and asking if I want to install it.  I agree and leave it checked.  Then click "Continue".

Then I see the mods downloaded and installed.

And these should finish successfully.

Exactly what happens when you try to install AVP on your CKAN ?

Edited by Jacke

Share this post


Link to post
Share on other sites

My CKAN is set to only install 1.4.5 mods. (NOTHING checked in the Compatible KSP versions settings. Thus it defaults to the installed Game version) This will only install mods that are marked as 1.4.5 compatible or set up as compatible max version of 1.4.9. or any. (Currently 568 mods)

Selecting 1.4 in Settings to allow All 1.4 mods, enables 846 mods.

This allows all mods that are only 1.4.0 or 1.4.1 or 1.4.2 or 1.4.3 or 1.4.4 compatible to be installed.

But some authors have not updated their mods and some of these are NOT compatible with 1.4.5 yet. (although quite a few are).

But me personally I don't want to allow CKAN to install them until I have Confirmed on the forums that they are compatible.

 

So when I want to install a mod and I see in CKAN that it (or one of its dependencies) is only 1.4.2 compatible (like Scatterer) and I want to install it because it is a dependency for another mod (Like SVE which I use) I go on the forum and Confirm that the 1.4.2 mod, Does work in 1.4.5. Then I set CKAN to temporarily allow 1.4.2 mods to be installed. Install the mod I wanted (Like SVE) and it will install Scatterer also, since it is a dependency. Then I return Compatible versions back to its default setting of only installing mods that are marked as compatible with the installed KSP version.

Edited by BlackHat

Share this post


Link to post
Share on other sites
17 minutes ago, BlackHat said:

My CKAN is set to only install 1.4.5 mods. (NOTHING checked in the Compatible KSP versions settings. Thus it defaults to the installed Game version) This will only install mods that are marked as 1.4.5 compatible or set up as compatible max version of 1.4.9. or any. (Currently 568 mods)

Selecting 1.4 in Settings to allow All 1.4 mods, enables 846 mods.

Most mods that are compiled on any KSP 1.4.x patch release can be used on any later KSP 1.4.y release.   Patch releases that are radical breaks that require recompiles get known as such quite quickly.  Even the changes in KSP 1.4.1 that came out with the the release of Making History as far as I know didn't break compatibility with KSP 1.4.0.  And you can check out what happened in each patch release via the KSP wiki.

https://wiki.kerbalspaceprogram.com/wiki/Version_history

This is why the default config for CKAN is enable compatibility with all of KSP 1.4.

Even mod authors with automatic mod compile and release systems don't recompile for every KSP patch release.  And many of those "1.4.5" compatible mods aren't recompiles for 1.4.5.  They are the mods for which the mod author has updated a .version file online to explicitly change the range of KSP versions supported by a given mod release.  Not all mod authors know they can do that and many don't.

By sticking to only mods for the single current patch release of KSP and ones you've received absolute proof of compatibility, you're increasing your administrative burden, excluding the use of many mods, and not necessarily improving the security of your game.  Savegame and craft file backups and keeping an eye to the forums are a better method to protect yourself against game and savegame breaking bugs of all sorts.

Share this post


Link to post
Share on other sites
1 hour ago, BlackHat said:

My CKAN is set to only install 1.4.5 mods. (NOTHING checked in the Compatible KSP versions settings. Thus it defaults to the installed Game version) This will only install mods that are marked as 1.4.5 compatible or set up as compatible max version of 1.4.9. or any. (Currently 568 mods)

Selecting 1.4 in Settings to allow All 1.4 mods, enables 846 mods.

This allows all mods that are only 1.4.0 or 1.4.1 or 1.4.2 or 1.4.3 or 1.4.4 compatible to be installed.

But some authors have not updated their mods and some of these are NOT compatible with 1.4.5 yet. (although quite a few are).

But me personally I don't want to allow CKAN to install them until I have Confirmed on the forums that they are compatible.

 

So when I want to install a mod and I see in CKAN that it (or one of its dependencies) is only 1.4.2 compatible (like Scatterer) and I want to install it because it is a dependency for another mod (Like SVE which I use) I go on the forum and Confirm that the 1.4.2 mod, Does work in 1.4.5. Then I set CKAN to temporarily allow 1.4.2 mods to be installed. Install the mod I wanted (Like SVE) and it will install Scatterer also, since it is a dependency. Then I return Compatible versions back to its default setting of only installing mods that are marked as compatible with the installed KSP version.

 

 

 

 

I did this, and when it let me check the box to install the mod it all works as Jacke said (options for texture, etc). All seems to be working right, thx all guys! :)

Share this post


Link to post
Share on other sites
4 hours ago, Trekkie148 said:

Hey um @themaster401 it's optional to install Scatterer right because unfortunately my computer hates it but i love it "side note thanks @blackrack

But yeah, I'm just wondering if that's optional. 

AVP will run without scatterer and only EVE, per-se, but you will definitely have a much worse experience as everything is optimized for scatterer enhancement.

Share this post


Link to post
Share on other sites
8 hours ago, themaster401 said:

AVP will run without scatterer and only EVE, per-se, but you will definitely have a much worse experience as everything is optimized for scatterer enhancement.

I'm just wondering if there is a setting in Scatterer for less memory computers or the best settings for that. @themaster401 @blackrack

Share this post


Link to post
Share on other sites

Hello, does anyone have an idea why my KSC has submerged under water? When game loads, it's either OK or flying above ground, but after time warp the Great Flood starts and almost everything goes below sea level. I have KSP 1.4.5, latest available EVE, AVP, Scatterer, Kopernicus, Module manager, texture replacer and 2k res textures. Plus some other non-environmental mods

Spoiler

FD8E479D44F738BC07D7F9A9704A9498D179AD2B

UPDATED:

False alarm, it appears the texture replacer wasn't in fact installed :D I was fooled by presence of the TextureReplacer directory, that was inside the AVP package. Solved by installing the missing mod. Funny side effect it was

Edited by Fogged
Solved

Share this post


Link to post
Share on other sites
On 10/5/2018 at 9:59 AM, The_8_Bit_Zombie said:

Hello, I have one more question regarding GPUs and AVP if anyone here happens to know; Would a GTX 1050-ti be able to run this mod smoothly? Thanks!

I just started a new career using this card (4gb) and the 8k texture pack and so far runs perfectly smooth, if bigger ships and more parts cause a problem in future I will drop down to the 4k pack. My pc ram is 8gb plus 16gb optane pretend ram. 

Share this post


Link to post
Share on other sites

I attempted to find this on CKAN and I've found the 2k, 4K and 8K versions but it says i dont have the right version for the actual pack I'm on KSP 1.4.5 with the making history DLC any help?

Share this post


Link to post
Share on other sites
9 hours ago, Weavetoucher said:

I just started a new career using this card (4gb) and the 8k texture pack and so far runs perfectly smooth, if bigger ships and more parts cause a problem in future I will drop down to the 4k pack. My pc ram is 8gb plus 16gb optane pretend ram. 

I did test out the 8k packs once, but I was using the "-force-glcore" command line option at the time and that lead to often screwed up textures.  Apparently the 8k textures have to be used with DX9, so no "-force-glcore" or "-force-d3d11".  I think KSP on both Linux and Mac uses OpenGL, so no 8k textures for them.  This could change though.

 

3 hours ago, GoldenKraken said:

I attempted to find this on CKAN and I've found the 2k, 4K and 8K versions but it says i dont have the right version for the actual pack I'm on KSP 1.4.5 with the making history DLC any help?

First, check your KSP compatibility in the CKAN client: Settings > Compatible KSP versions.  "1.4" should be checked.

Next, ignore all the the non-compatible mods.  Click on "Filter" and click "Compatible".  That excludes all the KSP 1.0.4 Astronomer's packs from over 2 years ago.

Those "2k", "4k", "8k".  Those are just the texture packs.  You must have one of them but only one of them.

AVP itself is called "Astronomer's Visual Pack" and its author is listed as "themaster402" (which is strange, assume it's @themaster401 on GitHub).

To install AVP, follow my guide in this post up above.  (Always skim the last page or two of a topic for help.)

https://forum.kerbalspaceprogram.com/index.php?/topic/160878-ksp-145-astronomers-visual-pack-v374-warpspeed/&do=findComment&comment=3458958

 

Share this post


Link to post
Share on other sites
1 hour ago, Jacke said:

I did test out the 8k packs once, but I was using the "-force-glcore" command line option at the time and that lead to often screwed up textures.  Apparently the 8k textures have to be used with DX9, so no "-force-glcore" or "-force-d3d11".  I think KSP on both Linux and Mac uses OpenGL, so no 8k textures for them.  This could change though.

 

First, check your KSP compatibility in the CKAN client: Settings > Compatible KSP versions.  "1.4" should be checked.

Next, ignore all the the non-compatible mods.  Click on "Filter" and click "Compatible".  That excludes all the KSP 1.0.4 Astronomer's packs from over 2 years ago.

Those "2k", "4k", "8k".  Those are just the texture packs.  You must have one of them but only one of them.

AVP itself is called "Astronomer's Visual Pack" and its author is listed as "themaster402" (which is strange, assume it's @themaster401 on GitHub).

To install AVP, follow my guide in this post up above.  (Always skim the last page or two of a topic for help.)

https://forum.kerbalspaceprogram.com/index.php?/topic/160878-ksp-145-astronomers-visual-pack-v374-warpspeed/&do=findComment&comment=3458958

 

Thank You!!! My KSP looks beautiful now!!! Respect +100

Share this post


Link to post
Share on other sites

Hello !

First of all, thanks for this GREAT mod pack, it's really a pleasure for the eyes. It's well explained, easy to install, and beautiful.

I have a question regarding the very recent update (KSP 1.5) ; It looks like the mod pack isn't compatible with the update (10 fps, 12+ GB of RAM usage).

Do you guys at least know which mod could the cause, so that I can find out a fix by myself ? I know that keeping this huge work up to date must be really exhausting, so I'm not waiting for a fix or an update of the mod pack anytime soon, just ideas about how to temporarily fix the framerates without having to uninstall the entire pack :)

Thanks!

 

**EDIT** : Okay I did some testing by myself, removing some mods, adding others, etc ... And I've narrowed it down to TextureReplacer. When all other mods are installer and NOT this one, everything runs fine, no problem. However, if I put TextureReplacer (among the other mods, or even all alone), framerate drops down to 20-25 and RAM and CPU usages both increase like hell. Which is weird, because when I check the content of the mod, there are just some textures for the skybox ...

Oh well. Hope it helps!

Edited by Wastel
Edit post testing

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now