themaster401

[KSP 1.8.0] Astronomer's Visual Pack [v3.83 "Endgame"]

Recommended Posts

 

On 5/20/2019 at 12:54 PM, Spyro said:

I'm new to this. Is there any video that I can see to know how to install this mod? I'm totally ignorant about it 

If you go here https://github.com/themaster402/AstronomersVisualPack/releases and download all the dependencies, and the zip at the bottom (AVP 3.8.zip)

Out of the optional mods I'd just take distant object enhancement, because it's nice to see flares when a station passes overhead.

If you need more help on how to actually install mods, I've made a crap guide for you here:

Spoiler

So you want to open you gamedata folder that is in your KSP directory. And have your downloaded mods open as well: 

0MIjsRV.png

Then open your mod zips and transfer what is in the gamedata folder inside of them to your ksp gamedata folder ,like so:

 

bjqqO2C.png

If it's done your gamedata should look like this:

bkZ6Eor.png

 

 

Share this post


Link to post
Share on other sites

Also anyone else getting the bug where the kerbals' mouth flickers and when he falls over the entire worlds spazzes out? I got this in 1.6 as well

Share this post


Link to post
Share on other sites
Posted (edited)
On 4/14/2019 at 1:30 AM, Jarmo said:

Yep. That's my problem as well, I have stars on opening screen (where kerbin is always covered in white clouds or mist).
No stars, very, very dark space. No milky way, or whatever it's called down here.

And that as well, not a problems as such, as it's all nice and pretty.

Also, let me say thanks a million to everybody who's involved in this kerbal beautification effort, everything is so beautiful I could burst.

It actually took me many attempts to get Astronomers installed and I've probably fumbled up something in the process.

Especially getting the PlanetShine working, took many attempts and I have no idea what finally clicked to enable it, seems like I did nothing different, just  kept uninstalling/reinstalling until stuff suddenly worked.

 

So I'm not super happy to start poking around randomly, I'll rather live without stars than without planetshine.

But if it's a known or obvious easy fix issue, I'd rather have it all.

 

 

That's my installed stuff. There are a few conflicts:

  • AVP 2K textures: ! AVP-Textures
  • Distant Object Enhancement default config: ! DistantObject config
  • Environmental Visual Enhacements: EnvironmentalVisualEnhancements-LR (not indexed)
  • Kopernicust PSM: Kitopia tech release 1.3.0-2
  • Scatterer: ! Scatterer
  • Scatterer default: Scatterer config
  • Scatterer - sunflare: Scatterer - sunflare
  • Spectra: Spaceplane Corrections v0.19 and ! Planet shine config

 

  •  

Any help getting the stars back much appreciated!
If no luck, the whole mod still much appreciated! Beautiful stuff.

___

Edit. 

Ok, I have no Idea what I did, poked around with planetshine and Distant Objects settings, and the stars came back.

It's still very dark, no milky way, but there are a handful of stars in the sky, the brightest ones I guess.

 

I cant help but notice you have both AVP and Spectra installed. Isnt Spectra a visual overhaul too? If so, thats going to conflict. 

Edited by Jognt

Share this post


Link to post
Share on other sites
4 hours ago, Boamere said:

 

If you go here https://github.com/themaster402/AstronomersVisualPack/releases and download all the dependencies, and the zip at the bottom (AVP 3.8.zip)

Out of the optional mods I'd just take distant object enhancement, because it's nice to see flares when a station passes overhead.

If you need more help on how to actually install mods, I've made a crap guide for you here:

  Reveal hidden contents

So you want to open you gamedata folder that is in your KSP directory. And have your downloaded mods open as well: 

0MIjsRV.png

Then open your mod zips and transfer what is in the gamedata folder inside of them to your ksp gamedata folder ,like so:

 

bjqqO2C.png

If it's done your gamedata should look like this:

bkZ6Eor.png

 

 

Oh wow, it's that easy ? thanks dude I really appreciate it.

Share this post


Link to post
Share on other sites
7 hours ago, Spyro said:

Oh wow, it's that easy ? thanks dude I really appreciate it.

Yeah it's a lot nicer than modding skyrim lmao, Np dude.

 

Also there's a modding launcher thingy called "CKAN" that installs mods for you.

But it only lets you install mods if they are confirmed compatible for the most recent version (unless you edit the settings), so I just look on the forums and see if the mod I want works with the current version and install manually most of the time.

Share this post


Link to post
Share on other sites
11 hours ago, Jognt said:

I cant help but notice you have both AVP and Spectra installed. Isnt Spectra a visual overhaul too? If so, thats going to conflict. 

That wasn't the cause of the "no stars" issue, however. "No stars" is a feature of Distant Object Enhancement.

VYMvQjd.png

Share this post


Link to post
Share on other sites
Posted (edited)
2 hours ago, panarchist said:

That wasn't the cause of the "no stars" issue, however. "No stars" is a feature of Distant Object Enhancement.

Yes, the person I quoted also said this though:

Quote

Especially getting the PlanetShine working, took many attempts and I have no idea what finally clicked to enable it, seems like I did nothing different, just  kept uninstalling/reinstalling until stuff suddenly worked.

Since he mentioned having more problems than just DOE’s sky dimming I figured I’d mention it. (Especially since he sounded quite frustrated later on, and no one else pointed out the Spectra thing)

Edited by Jognt

Share this post


Link to post
Share on other sites
5 minutes ago, Jognt said:

Yes, the person I quoted also said this though:

Since he mentioned having more problems than just DOE’s sky dimming I figured I’d mention it. (Especially since he sounded quite frustrated later on, and no one else pointed out the Spectra thing)

Yeah, good call.

Share this post


Link to post
Share on other sites

Is there another 43k cloud texture that looks more like the 8k one available somewhere?

Share this post


Link to post
Share on other sites
On 5/13/2019 at 2:24 PM, space_powder said:

I'm assuming AVP 3.8 will work with the latest Scatterer? Or do I still need to use 0.0336?

I was also hoping for that, but there's still a huge warning on the first page to keep using Scatterer v0.0336. I guess that it will be published here when this restriction is gone.

/Marconi

Share this post


Link to post
Share on other sites

Hi there, I am an happy and grateful AVP's user; for me, the last release of it was superlative! Unfortunately the release of Breaking Grounds and the recent changes to the game, made this mod uncompatible with KSP 1.7.1 (even without the new DLC  installed) so my simple question is: is there going to be an AVP update anytime soon? :)

Share this post


Link to post
Share on other sites
Posted (edited)
18 minutes ago, gap said:

Hi there, I am an happy and grateful AVP's user; for me, the last release of it was superlative! Unfortunately the release of Breaking Grounds and the recent changes to the game, made this mod uncompatible with KSP 1.7.1 (even without the new DLC  installed) so my simple question is: is there going to be an AVP update anytime soon? :)

What about it broke, because EVE Andy scatterer work fine for me? If you mean the Kopernicus stuff, then yeah, you’ll need to wait. Kopernicus isn’t updated yet and won’t be for a little while. 

Edited by Galileo

Share this post


Link to post
Share on other sites
Posted (edited)
9 minutes ago, Galileo said:

What about it broke, because EVE Andy scatterer work fine for me? If you mean the Kopernicus stuff, then yeah, you’ll need to wait. Kopernicus isn’t updated yet and won’t be for a little while. 

Yes, I use Kopernicus as well as AVP,  but when I launch the game, together with the Kopernicus warning, I get notified about AVP too not being compatible with the current KSP version...

Edited by gap

Share this post


Link to post
Share on other sites
2 minutes ago, gap said:

Yes, I use Kopernicus as well as AVP,  but when I launch the game, together with the Kopernicus warning, I get notified about AVP too not being compatible with the current KSP version...

That’s probably just a warning because of the version file. It’s max version probably says 1.7. That’s not the case as the key dependencies work fine on 1.7.1. They only thing you’ll be missing is terrain textures. Just remove kopernicus and ignore the version warning.

Share this post


Link to post
Share on other sites
1 minute ago, Galileo said:

That’s probably just a warning because of the version file. It’s max version probably says 1.7. That’s not the case as the key dependencies work fine on 1.7.1. They only thing you’ll be missing is terrain textures. Just remove kopernicus and ignore the version warning.

Okay, I will try and I will report back in case I notice anything wrong with the game. Thanks!

Share this post


Link to post
Share on other sites
Posted (edited)
4 hours ago, gap said:

Okay, I will try and I will report back in case I notice anything wrong with the game. Thanks!

So, I uninstalled Kopernicus and I ran KSP 1.7.1 in DX11 mode with the following mods installed:

  • Spoiler

     

    • ModuleManager v4.0.2
    • EVE v1.4.2-2
    • scatterer v0.0336
    • TextureReplacer v3.7
    • AVP v3.8.0.0  + AVP 8k textures v1.8
    • DistantObjectEnhancement v1.9.1.1 + default config
    • PlanetShine v0.2.6.1 + default config
    • KS3P recompiled for  KSP 1.6 and DX11 + DX11 shaders by jrodriguez
    • TexturesUnlimited v1.4.7.21 + unoffcial default stock configs

     

When I enter the Start Game menu for the first time, menu's text is hidden behind Kerbin, and Kerbin's atmosphere doesn't look right:

Spoiler

MZRpN3V.png

The same atmosphere glitch is also visible in game (here one of the training missions), and the game is a bit laggy:

Spoiler

gZejzlD.png

When I enter again the menu, it looks like this:

Spoiler

ZOSjj86.png

Before the KSP 1.7.1 update, everything was fine. If need be, I can provide log files. 


 

 

 

 

 

Edited by gap

Share this post


Link to post
Share on other sites
3 minutes ago, gap said:

So, I uninstalled Kopernicus and I ran KSP 1.7.1 in DX11 mode with the following mods installed:

  •   Reveal hidden contents

     

    • ModuleManager v4.0.2
    • EVE v1.4.2-2
    • scatterer v0.0336
    • TextureReplacer v3.7
    • AVP v3.8.0.0  + AVP 8k textures v1.8
    • DistantObjectEnhancement v1.9.1.1 + default config
    • PlanetShine v0.2.6.1 + default config
    • KS3P recompiled for  KSP 1.6 and DX11 + DX11 shaders by jrodriguez
    • TexturesUnlimited v1.4.7.21 + unoffcial default stock configs

     

When I enter the Start Game menu for the first time, menu's text is hidden behind Kerbin, and Kerbin's atmosphere doesn't look right:

  Reveal hidden contents

MZRpN3V.png

The same atmosphere glitch is also visible in game (here one of the training missions), and the game is a bit laggy:

  Hide contents

gZejzlD.png

When I enter again the menu, it looks like this:

  Hide contents

ZOSjj86.png

Before the KSP 1.7.1 update, everything was fine. If need be, I can provide log files. 


 

 

 

 

 

I have no idea. Looks like this is a AVP exclusive issue as I have never seen that with any other visual pack on 1.7.1. SVE is fine and SciFi was fine as well. Also, the visuals for my other planet packs seem fine too.  ¯\_(ツ)_/¯ I have no clue.

Share this post


Link to post
Share on other sites
1 minute ago, Galileo said:

I have no idea. Looks like this is a AVP exclusive issue as I have never seen that with any other visual pack on 1.7.1. SVE is fine and SciFi was fine as well. Also, the visuals for my other planet packs seem fine too.  ¯\_(ツ)_/¯ I have no clue.

Next, I will try uninstalling AVP, and see if that fixes the issues. If it does, then it is an incompatibility between KSP 1.7.1 and AVP. I have never tried SVE, though from videos it looks nice too. I might give it a go while themaster402 irons out the problems (supposed that my diagnosis is correct). Reports by other AVP users might be useful too...

Share this post


Link to post
Share on other sites
19 hours ago, Galileo said:

I have no idea. Looks like this is a AVP exclusive issue as I have never seen that with any other visual pack on 1.7.1. SVE is fine and SciFi was fine as well. Also, the visuals for my other planet packs seem fine too.  ¯\_(ツ)_/¯ I have no clue.

Quick update: removing all the mods, and re-adding them after having run a file integrity check, seems to have fixed the problem. It turned out that one of the game files was corrupted. Thank you for the feed back Galileo!

Share this post


Link to post
Share on other sites
17 minutes ago, gap said:

Quick update: removing all the mods, and re-adding them after having run a file integrity check, seems to have fixed the problem. It turned out that one of the game files was corrupted. Thank you for the feed back Galileo!

Glad it was something simple!

Share this post


Link to post
Share on other sites
Posted (edited)
Spoiler

‍‌‍‍‍‍‌‍‌‍‌‍‌‌‍‍‌‌‍‌‌)‌‍‍‌‍‍‌‌‌‍‍‌‌‌‍‍‍‌‌‌‍‍‌‍‍‍‍‌‍‍‌‌‌‌‌‍‌‍

 ‍‍‍‌‌ ‍‍‍‍‌‍ ‌‍‌‍‌ ‌‍‍‌‌ ‍‌‌‍‍(%C2%B4%EF%BD%A1%E2%80%A2%CF%89%E2%80%A2(%C2%B4%EF%BD%A1%E2%80%A2%CF%89%E2%80%A2(%C2%B4%EF%BD%A1%E2%80%A2%CF%89%E2%80%A2(%C2%B4%EF%BD%A1%E2%80%A2%CF%89%E2%80%A2

Edited by IxC999
adding more img

Share this post


Link to post
Share on other sites

6je8EKX.png

v3.81 "Endgame"

  • Updated to scatterer version 0.0540
  • Fixed lightning, snow and other effects
  • Marked as compatible with 1.7.1

unknown.png

 

Share this post


Link to post
Share on other sites
16 hours ago, themaster401 said:

v3.81 "Endgame"

  • Updated to scatterer version 0.0540
  • Fixed lightning, snow and other effects
  • Marked as compatible with 1.7.1

 

Thank you very much! :wub:

Share this post


Link to post
Share on other sites

How long until it's marked as "Compatible" for the latest KSP version on ckan?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.