Jump to content

Kerbal Space Program update 1.3 Grand Discussion thread.


UomoCapra
 Share

Recommended Posts

19 minutes ago, RocketBlam said:

Any mod I tried to run with it caused a crash, but without mods it seems to run fine.

The current release of Module Manager is not working and causing crashes.  Any mod that uses it will not work either.  We just have to wait for an update.  Mods that don't use it should work provided they don't need updating.

Edited by Alshain
Link to comment
Share on other sites

4 hours ago, mritchey said:

I logged in to my current favorite game, Kerbal Space Program, to find that, not only was there an update, I had no choice in whether I download it. After the game gets through the loading screen, it crashes and tell me it would be nice if I could send the log file to the developers. No ... it would be nice if I wasn't forced to update my game with no way to go back to 1.2.

Same story here.  While I love the idea of fixes for on going problems to any software.  All this update did for me was destroy a game that used to work,  

Now i have a broken and hungry Kerbal who can't get to his space station for snacks.    

Link to comment
Share on other sites

Well this all sounds pretty cool!

I haven't played any Kerbal for the past several months, due to frustration with terrain seams and also just general burnout. But it's been long enough that I was just starting to miss KSP again, and thought up a couple new ideas for a career. Nice timing, Squad. :D

Think I'll wait a week or three for the modding scene to stabilize a little, then build up a new insanely modded install and hit the SPH again.

Link to comment
Share on other sites

5 hours ago, mritchey said:

I logged in to my current favorite game, Kerbal Space Program, to find that, not only was there an update, I had no choice in whether I download it. After the game gets through the loading screen, it crashes and tell me it would be nice if I could send the log file to the developers. No ... it would be nice if I wasn't forced to update my game with no way to go back to 1.2.

1 hour ago, JustAToy said:

Same story here.  While I love the idea of fixes for on going problems to any software.  All this update did for me was destroy a game that used to work,  

Now i have a broken and hungry Kerbal who can't get to his space station for snacks.    

Steam users should know better than to mod the Steam install.

You should copy the "\Steam\steamapps\common\Kerbal Space Program" folder to another location on your computer, and mod the copy instead.

That way, you'll always have a vanilla copy for identifying problems with, too.

 

Link to comment
Share on other sites

I have no use for this update, but I'm glad they made the game accessable for all the potential players who, for whatever reason, are unable to pick up a second language. I can still play on my 1.2 install, so the hassle this update causes for me is insignificant compared to the service it provides for many, many others.

Besides, I've been meaning to re-balance and update my own mods for a while, as well as make some new ones. This seems like the perfect time to download a clean copy of 1.3 and use it for testing. But I doubt I'll update my "for playing"-install until all mods I use require me to.

Link to comment
Share on other sites

7 minutes ago, JAFO said:

Steam users should know better than to mod the Steam install.

Sort of. It is indeed good advice at this point, but there's no reason for someone who bought since the last update, installed a few mods, and doesn't read the forum to expect that it'll randomly stop working one day. Usually the expectation is that once you buy a finished game and install it, it will continue to work. (Hint, backwards compatibility. :))

Link to comment
Share on other sites

2 hours ago, JustAToy said:

Same story here.  While I love the idea of fixes for on going problems to any software.  All this update did for me was destroy a game that used to work,  

Now i have a broken and hungry Kerbal who can't get to his space station for snacks.    

 

Downgrading back to 1.2.2 is just 3 clicks away, and then it should work again. But as said above, after you do it -- copy it out someplace else on your disk, so steam doesn't overwrite it.

Edited by bewing
Link to comment
Share on other sites

What a nice surprise to wake up to! Congratulations on the new release, bringing native language support to nearly 2 billion Spanish, Russian, Chinese and Japanese speakers is pretty massive! KSP can be enjoyed by nearly the whole globe with this update.

Time to make a still image backup of my 1.2.2 install, although I'll probably be playing it for a while, a vanilla 1.3 install is already downloading here, and I'm gonna enjoy and go 'hurray' on every mod that updates.

I take my hat of in gratitude to all the modders who keep updating their mods, sharing there love for the game for everybody to enjoy.

Link to comment
Share on other sites

2 hours ago, JustAToy said:

Same story here.  While I love the idea of fixes for on going problems to any software.  All this update did for me was destroy a game that used to work,  

Now i have a broken and hungry Kerbal who can't get to his space station for snacks.    

You should just simply not play the version that steam writes on your HD. Copy your version of KSP elsewhere and play whatever version you want. Let steam update your original version and grab a copy of this and start to mod it to your liking when your mods are ready. In the meantime just stay on 1.2.2

Link to comment
Share on other sites

Wow... that's got to be the least interesting update I've ever seen.
About the only reason I can see to download this one is fixing the terrain seam regression. (which should have been fixed in 1.2.x, where it was introduced).
Honestly, I don't think it's remotely worth breaking all the mods.
No performance improvements? GC stutter reduction? Physics jank fixes? Any reason to upgrade at all?

Zzzzzz.... Wake me up when we get that Unity 5.6 upgrade. For now, I''m sticking with 1.2.2.

Link to comment
Share on other sites

7 hours ago, Manwith Noname said:

Ah well. Can't wait for 1.4 :D

I WANT PARTS!!!!! (SOB)

 

8 hours ago, Gameslinx said:

As the game loads: yay new update!

Once in game for 15 minutes: not much changed, all my mods broke, switching back to 1.2.2

There isn't much content in this update for native speakers so I imagine most if us who use/develop mods will stick to 1.2.2 for now.

I WANT MODS! (SOB)

Link to comment
Share on other sites

5 hours ago, bewing said:

The more the better, of course. If possible. German is a little tricky, because the UI has some limits and some german words are really long. You know how to spell scientist in german? :)

To be fair, you can probably get away with substituting "Forscher" there instead of "Wissenschaftler". It may be sorta colloquial and strictly speaking translates to "researcher", but Germans will know what you want to say and it's actually one letter shorter than "scientist"! :P 

Our affinity for compound words is, admittedly, more of a problem...

Edited by Streetwind
Link to comment
Share on other sites

Some are upset the update doesn't add enough new stuff. Some are upset that not enough bugs were fixed. Whiners.

Me, I'm ecstatic that the freaking runway and terrain seams are fixed! Don't even care about any of the other stuff. Since many of my missions tend to start on the runway, land on some terrain somewhere, take off from terrain, and then land again either on the runway or on yet more terrain... breaking the freaking runway and terrain seams broke most of the game for me. Kudos to Squad on the localization and fixing other stuff and all that whatever yadda yadda good for you I'm sure yo momma's proud and all... I can take off and land a spaceplane without exploding now!! All I care about. You make me a happy spaceplane geek again. You complete me. I may even shed a manly tear of happiness if nobody's looking.

Link to comment
Share on other sites

5 hours ago, bewing said:

The more the better, of course. If possible. German is a little tricky, because the UI has some limits and some german words are really long. You know how to spell scientist in german? :)

Hey, as long as we don't threaten a Grund­stücks­ver­kehrs­ge­neh­mi­gungs­zu­stän­dig­keits­über­tra­gungs­ver­ord­nung...

Link to comment
Share on other sites

48 minutes ago, Jay The Amazing Toaster said:

1.3: Doesn't support Sumerian 

DISAPPOINTED
(obviously kidding)

I'm so glad that Squad isn't considering translating it to Dutch, all translated games which get or are translated into it instantly transforms into a game with an ELI5 feeling.

Edited by LoSBoL
Link to comment
Share on other sites

6 minutes ago, FreeThinker said:

How to switch back?

I assume you are on steam, and didn't save a copy? Probably best to save a copy of your current 1.3.0. Then in the client, right click on KSP, select Properites/Betas -- and select "Previous_1.2.2".

Link to comment
Share on other sites

4 hours ago, HebaruSan said:

Since folks tend to post their wish lists on these announcement threads, I have a very simple one: Backwards compatibility. It would be a big boost in quality of life for modders and players if no further breaking changes were made to the APIs. Just think how nice it would be if the next release's announcement thread didn't have several people complaining that it was crashing because they still had out of date mods installed. Or think how KSP's mod portfolio would no longer be at risk of shrinking over time once old mod versions (many impossible to update due to license restrictions) continue working without modification.

I say it's simple (and I speak from experience on that) because all you have to do is avoid removing functions or changing their type signatures, which is comparatively easy as dev tasks go because you always know when you're doing it (your IDE may even have a flag to check for it). New functionality can always be added via new functions, and in C# that includes overloads. It's fine to change behavior if an old function can no longer be supported as-is, for example CelestialBody.theName could have been updated to return CelestialBody.name in 1.3 instead of being removed completely.

I realize that no response can be given due to "NDA" and plans-can-change, but I do think this is at least worth considering.

 
 
 

I agree, I just fixed KSPI for KSP 1.3, all I has to do is modify a few properties names  (title in displayname) and duplicate some parameter. This should not have been necessary if you maintained the  properies and method calls.  I guess most mods have similar issues. This could all have been prevented. what a pity.

1 minute ago, bewing said:

I assume you are on steam, and didn't save a copy? Probably best to save a copy of your current 1.3.0. Then in the client, right click on KSP, select Properites/Betas -- and select "Previous_1.2.2".

 
 

I Tried, I requires some kind of beta Key. Where to get it again?

Edited by FreeThinker
Link to comment
Share on other sites

As native Russian speaker playing KSP for years already I find this localisation great and, on the other hand, will not use it and stick with English. Cause it is worse than original anyway. You speak "Кербин", not "Kёрбин" in it, like we used to hear. You call Probodobodyne "Горизонд". It sounds funny, but now I can't understand many things and need to relearn something just to have "native language". While missing ability to easily communicate with much larger and rich (ideas, mods, content) community speaking English, cause too much differences exist. Apart from that, there no other major changes in game, new bugs (caused by localisation), remaining old bugs (with physics). 1.3 is coming too soon to be really good update for me, honestly.

Link to comment
Share on other sites

2 hours ago, HebaruSan said:

Usually the expectation is that once you buy a finished game and install it, it will continue to work. (Hint, backwards compatibility. :))

The worst kept secret in KSP is that the game's not actually finished even though they said it was.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...