Jump to content

Looking for weapons mods!


WhiteWeasel
 Share

Recommended Posts

It's been a very long time since I have played KSP, and I had a bit off a macey dean phase. Coming back, that sorta has not left, though I'm dropping the pretenses and wish to use actual mods! But what would you recommend? I know about BD armory, but are there any others that are 1.3 compatible?

Link to comment
Share on other sites

1.3 hasnt been out very long. Things like BD Armory and any other mod with a plugin will need some time to update, especially complex things. I suggest checking back through maybe twenty pages on the addon releases, i think i remember seeing one other weapons mod that looks pretty interesting.

Link to comment
Share on other sites

ANY of the weapon mods that do not use a plugin will be fine in 1.3 if they were previously updated for 1.22  and there are a good few of those  Those mods  that do have a plugin.    deleting the plugin (dll usually located in a plugins folder within the mod) , while removing some functionality, it will also prevent the incompatible DLL from messing with your game

Ps no real space combat is possible with BDA as it primarily focuses on atmospheric and terrestrial combat

Edited by SpannerMonkey(smce)
Link to comment
Share on other sites

4 hours ago, Benjamin Kerman said:

1.3 hasnt been out very long. Things like BD Armory and any other mod with a plugin will need some time to update, especially complex things. I suggest checking back through maybe twenty pages on the addon releases, i think i remember seeing one other weapons mod that looks pretty interesting.

Darn it, seems like every time I try to play this game, mods are constantly broken by updates. 

Link to comment
Share on other sites

7 minutes ago, WhiteWeasel said:

Darn it, seems like every time I try to play this game, mods are constantly broken by updates. 

I did check, and it looks like BDArmory is up to date for 1.3. Have at it!

 

Edited by Benjamin Kerman
Link to comment
Share on other sites

19 minutes ago, Benjamin Kerman said:

I did check, and it looks like BDArmory is up to date for 1.3. Have at it!

 

Thanks, though the issue is that there are some companion mods I'd like to use like B9 aerospace which I know does not work. So I suppose I have to wait for a bit. 

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...