• 0
bartekkru99

My craft keeps spinning...

Question

I've taken a contract to transfer crew between two vehicles in orbit of Minmus, but then when I did the rendezvous and one of my kerbals got out of the capsule its reaction wheels started applying torque on their own and since there's no crew inside I can't stop it by turning SAS or pressing ALT+x.woiYiil.png

Share this post


Link to post
Share on other sites

12 answers to this question

Recommended Posts

  • 0

Before you do anything else, press Alt+X (or your OS equivalent modifier key) to zero out any trim you might have accidentally applied.

Share this post


Link to post
Share on other sites
  • 0

Also, make sure your joystick is calibrated and zeroed. (I can't tell you how many times this turned out to be the cause of phantom rotation forces for me.) 

Share this post


Link to post
Share on other sites
  • 0

Both good suggestions! Sadly, I've also been having the same trouble with fully-stock KSP v1.3, on a keyboard with alt+x liberally applied. I'm planning on doing a work-around hunt pretty soon, so I'll let you know if I find anything.

Edit:

@bartekkru99 Hm... It seems to be caused directly by the Kerbal exiting the craft.

So the first finding is alt+x doesn't clear trim while SAS is on anymore, which I believe is new since 1.0.5. You need to first turn off SAS to alt+x clear trim. Even if you do this for both the craft and the Kerbal, the problem persists. Also, the problem isn't affected by recent user changes to trim. I can't find any permutation of changing/clearing trims while hopping the Kerbal in and out or quicksaving/loading that effected the magnitude or direction of rotation. In my case, the effect also doesn't seem to occur when exiting a command chair, just the pod I'd been piloting from. I wonder if different kerbals would spin the craft differently, or if it's tied to the pod.... I'm not so sure this is entirely trim based for me...Turning off all wheels and batteries doesn't even effect it! Well then.

Does turning off the batteries and reaction wheels make a difference for you, @bartekkru99?

Anyways, bottom line, I found a work around! Turn off SAS and clear trim, then exit the craft, let go of the ladder and rails-time-warp. At this point the craft behaves normally (not spinning like a wacky perpetual motion gyro.) It will only fix the problem until you exit the craft again, but it atleast works temporarily. I hope that works for now!

Edited by Cunjo Carl

Share this post


Link to post
Share on other sites
  • 0

Is there anything placed very close to the capsule hatch?

Sometimes when your Kerbal exits it can cause collisions with items surface attached nearby and create uncontrolled spinning.

Share this post


Link to post
Share on other sites
  • 0

@HvP Nice! Well sussed, you got it for me. It was ladder drive! Between this and the "turn off SAS before holding alt+x" advice hopefully this will get it for our OP as well.

Share this post


Link to post
Share on other sites
  • 0

Has any of you read the entire post and/or looked at the picture? I have clearly said that Alt+x does nothing since I have no control over the craft and on the screenshot below pitch indicator (that I have circled with a thick red line) in the left-bottom corner is shifted down which means that reaction wheels are working.

Share this post


Link to post
Share on other sites
  • 0
40 minutes ago, bartekkru99 said:

Has any of you read the entire post and/or looked at the picture? I have clearly said that Alt+x does nothing since I have no control over the craft and on the screenshot below pitch indicator (that I have circled with a thick red line) in the left-bottom corner is shifted down which means that reaction wheels are working.

It's almost certainly a mod problem. Turn off all your mods temporarily and see if it still happens.

 

Share this post


Link to post
Share on other sites
  • 0
58 minutes ago, bartekkru99 said:

Has any of you read the entire post and/or looked at the picture? I have clearly said that Alt+x does nothing since I have no control over the craft and on the screenshot below pitch indicator (that I have circled with a thick red line) in the left-bottom corner is shifted down which means that reaction wheels are working.

I didn't notice that pitch indicator the first time, but now I've tried to simulate your circumstances and I can replicate the behavior WITH the stuck pitch indicator, under no control, with SAS off, after EVAing the pilot.

The situation only presented itself if I had trim applied (ALT+S for example) with SAS off before sending the pilot on EVA. And since the craft was out of commnet range all control at that point was lost, but the gauge still showed pitch being applied even though control was lost.

I can confirm that even a slight amount of trim input will continue to be applied even when the craft should be receiving no control input and is unsolvable in its current state. I see no way to realistically regain control of the craft once this happens. I'm not sure if it would be considered a bug or not however because I can imagine a similar scenario occurring if I were to jump out of a craft with the engine firing -- it would just fly away from me. It takes control to turn the engine off again just as I suppose it would require control to turn the trim control back to zero. Either way, we would be leaving the craft in a runaway state.

If you feel this behavior is unrealistic or unintended then I'd recommend you add it to the bug tracker: http://bugs.kerbalspaceprogram.com/projects/ksp/issues?set_filter=1&tracker_id=1

38 minutes ago, bewing said:

It's almost certainly a mod problem. Turn off all your mods temporarily and see if it still happens.

See my last post. I have been able to replicate one possible set of circumstances leading to this problem in stock 1.3.

Share this post


Link to post
Share on other sites
  • 0
9 minutes ago, HvP said:

See my last post. I have been able to replicate one possible set of circumstances leading to this problem in stock 1.3

Your suggestion is good, but it shouldn't cause the pitch input indicator to be non-zero. In any case, nobody should be coasting around in a rocket with SAS off and trim applied. So I still think this has to be a mod problem.

 

Edited by bewing

Share this post


Link to post
Share on other sites
  • 0
38 minutes ago, bewing said:

Your suggestion is good, but it won't cause the pitch input indicator to be non-zero.

 

It does though. Fully stock test. You can also see that the ship is rotating so fast in this still frame that it is coming apart. I applied positive pitch with ALT-S, EVAd the pilot and switched back to the test craft to take this screencap. Notice the pitch indicator.

9keEeQB.png

Edit to add: I went ahead and added the issue to the bug tracker just in case it is not intended behavior.

http://bugs.kerbalspaceprogram.com/issues/15432

Edited by HvP
added bug tracking link

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, HvP said:

If you feel this behavior is unrealistic or unintended then I'd recommend you add it to the bug tracker: http://bugs.kerbalspaceprogram.com/projects/ksp/issues?set_filter=1&tracker_id=1

I'm pretty sure it's intended. Alteast, I've been using this for ages to keep my craft upright when landing a rocket on sloped ground. Often you'll land on a slope, then you want to hop out to say plant a flag, but SAS will turn off if you do and your craft will tip off balance due to gravity, and the whole thing goes pear shaped. So, you turn off SAS and set trim to hold your craft upright. Then your Kerbal can safely hop out and do their mission while the manuevering jets / reaction wheels keep the craft standing tall. You just need to be careful to not mix this with active SAS, or you'll get a funny thing I call the simon says glitch, where the craft mimics your motions, but that's another story.

3 hours ago, bartekkru99 said:

Has any of you read the entire post and/or looked at the picture? I have clearly said that Alt+x does nothing since I have no control over the craft and on the screenshot below pitch indicator (that I have circled with a thick red line) in the left-bottom corner is shifted down which means that reaction wheels are working.

Yep! One thing you may not have tried yet was the content from my answer (atleast it's not clear from your posts). Did you try turning off SAS before holding alt+x to clear trim while the kerbal is still in the craft? In the present version, you can set trim with SAS on, but you can't clear it. I believe this is a new bug since v1.0.5, but it's easy enough to work around for now. If this doesn't happen to work for you, feel free to send one of your save files, and I'll give it a try on my pure-vanilla ksp and see if it reproduces on this end! I haven't been able to reproduce trouble otherwise, save the one HvP cured for me. Hopefully we'll get you going too by hook or by crook.

EDIT: Trim will tend to build up on your craft if you're maneuvering while phys-time-warping. The phys-timewarp involves alt+> , and maneuvering is WASD. Together, they make alt+WASD, which sets trim. This can also happen to me a lot if I'm using rails time warp to halt rotation while doing similar silly things *cough* I mean, purely dignified things! You then need to go and clear that trim before hopping out of the craft. It's not ideal, but it's a funny result of the way the controls got laid out. Perhaps this happened for you?

Edited by Cunjo Carl

Share this post


Link to post
Share on other sites
  • 0
40 minutes ago, bewing said:

In any case, nobody should be coasting around in a rocket with SAS off and trim applied. So I still think this has to be a mod problem.

Certainly a possibility. I agree that whatever is leading to this circumstance in the OP's case isn't likely to be intentional use of the trim. The situation makes that unlikely and I was just surprised that it could be replicated in stock. I had never considered this before and it can bite hard if unprepared for it.

@Cunjo Carl You're a braver man than I am!

 

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.