FreeThinker

[1.3.1/1.4.5] KSP Interstellar Extended 1.19.4 Continued Development Thread

Recommended Posts

Posted (edited)

@FreeThinker and everyone else, Squad's update broke the texture link on my VASIMR thruster. To fix it you have to go into Warpplugin/Parts/Engines/VASIMR2 and update the texture line in VASIMR.cfg to:
texture = model001, Squad/Parts/Engine/liquidEnginePoodle/engine_dif

Also, Freethinker, my cyclotron cover is still not removable. the part name is 'cover' to toggle it off. It just needs to be added in the CFG.

Edited by SpaceMouse
  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, SpaceMouse said:

@FreeThinker and everyone else, Squad's update broke the texture link on my VASIMR thruster. To fix it you have to go into Warpplugin/Parts/Engines/VASIMR2 and update the texture line in VASIMR.cfg to:
texture = model001, Squad/Parts/Engine/liquidEnginePoodle/engine_dif

Also, Freethinker, my cyclotron cover is still not removable. the part name is 'cover' to toggle it off. It just needs to be added in the CFG.

Could you provide me the updated files or even better make a pull request in github with the correction?

Share this post


Link to post
Share on other sites
Posted (edited)
21 hours ago, FreeThinker said:

Could you provide me the updated files or even better make a pull request in github with the correction?

I could provide files sure. I'm unsure what method your using right now to display and hide subparts.

As far as the texture on VASIMR, It's just the end on the texture line that needs to be changed. Squad changed the name.

Edited by SpaceMouse

Share this post


Link to post
Share on other sites
Posted (edited)

I seem to be running in to a bug with the Candle engine now.  It used to generate electricity on its own, and now no longer does.  I have tried quick save/quick load with no result, as well as closing the game and re-opening it.  Am I missing something?  Sorry if I missed something in the notes; I did look, but did not see anything about the Candle.

 

Edit:  It seems that the engine has stopped producing megajoules.  It has lots of thermal power, I don't know what would cause this.  It most likely happened after docking the probe with a station.

 

Edit 2:  Second probe, all worked perfectly until I docked, then MJ production stopped again.  

Edited by protochicken
  • Like 1

Share this post


Link to post
Share on other sites

Next release will add integration with Nearea Far Future Mod

5i93vOc.png

Visible engine here is the beam core antimatter reactor

  • Like 4

Share this post


Link to post
Share on other sites

I was using mechjebs differential thrust functionality for VTOL'in with 4 thermal nozzles and experienced some non-proportional behavior with the limit thrust lever: a 10% lever gave about 1% engine thrust, 50% about 20% and 70% around 70%

This way it's hard to balance engine thrust for using them as VTOL engines. I guess it's the same behavior with the main thrust lever as well.

Share this post


Link to post
Share on other sites
7 hours ago, Blackline said:

I was using mechjebs differential thrust functionality for VTOL'in with 4 thermal nozzles and experienced some non-proportional behavior with the limit thrust lever: a 10% lever gave about 1% engine thrust, 50% about 20% and 70% around 70%

This way it's hard to balance engine thrust for using them as VTOL engines. I guess it's the same behavior with the main thrust lever as well.

What reactor was used?

Share this post


Link to post
Share on other sites
On 4/21/2018 at 1:36 AM, protochicken said:

I seem to be running in to a bug with the Candle engine now.  It used to generate electricity on its own, and now no longer does.  I have tried quick save/quick load with no result, as well as closing the game and re-opening it.  Am I missing something?  Sorry if I missed something in the notes; I did look, but did not see anything about the Candle.

 

Edit:  It seems that the engine has stopped producing megajoules.  It has lots of thermal power, I don't know what would cause this.  It most likely happened after docking the probe with a station.

 

Edit 2:  Second probe, all worked perfectly until I docked, then MJ production stopped again.  

Ive been having a similar issue with the Timberwind Engine, I THINK(havnt done that much bug testing) ive traced at least part of this issue to a "supercapacitor" part, I also had a regular MJ only capacitor.  I think the supercapacitors stored charge (conversion of ec I think) throws off the mods ability to regulate the ec/mj ratio.  I may have the names of the parts wrong but I think its whatever part that adds a ""stored charge" resource".  Im running a lot of mods and some custom MM patches so your issue may be different, but do you have one of those supercap parts on the ship that seems to break reactors?

Share this post


Link to post
Share on other sites
Posted (edited)

For integration with Far Future Mod, I will try to have at least same performance as the original

But in order to achieve this, the reactors  need to generate amazing amounts of power.

Just notice how much power output is required to make the Mirror Cell Fusion have the same performance!

1lxFseA.png

The main difference is that it adds upgrading,  multiple fusion and propellant modes and acceleration during timewarp

 

Edited by FreeThinker
  • Like 1

Share this post


Link to post
Share on other sites
20 hours ago, Temeriki said:

Ive been having a similar issue with the Timberwind Engine, I THINK(havnt done that much bug testing) ive traced at least part of this issue to a "supercapacitor" part, I also had a regular MJ only capacitor.  I think the supercapacitors stored charge (conversion of ec I think) throws off the mods ability to regulate the ec/mj ratio.  I may have the names of the parts wrong but I think its whatever part that adds a ""stored charge" resource".  Im running a lot of mods and some custom MM patches so your issue may be different, but do you have one of those supercap parts on the ship that seems to break reactors?

I do not.  It's a simple craft, just the engine, fuel, battery, RCS,. probe core, and docking clamp.  It was build to fly out and dock with a space station that needed additional power generation.  I will fiddle with it more when I get home from work and see if I can find more details.

Share this post


Link to post
Share on other sites
Posted (edited)
2 hours ago, protochicken said:

I do not.  It's a simple craft, just the engine, fuel, battery, RCS,. probe core, and docking clamp.  It was build to fly out and dock with a space station that needed additional power generation.  I will fiddle with it more when I get home from work and see if I can find more details.

Its a known problem that after docking you might lose all power. A known work around is to quick save and reload after docking

Edited by FreeThinker
  • Like 1

Share this post


Link to post
Share on other sites

When you say in

23 hours ago, FreeThinker said:

For integration with Far Future Mod, I will try to have at least same performance as the original

But in order to achieve this, the reactors  need to generate amazing amounts of power.

Just notice how much power output is required to make the Mirror Cell Fusion have the same performance!

1lxFseA.png

The main difference is that it adds upgrading,  multiple fusion and propellant modes and acceleration during timewarp

 

When you say integration with far future are you talking about making a MM compat or making stock KSPI-e integrate with far future out of the box?  Either way im excited!

Share this post


Link to post
Share on other sites
Posted (edited)
28 minutes ago, Temeriki said:

When you say in

When you say integration with far future are you talking about making a MM compat or making stock KSPI-e integrate with far future out of the box?  Either way im excited!

It a single MM script that modifies exiting Far Future Parts with KSPIE controls. I also put them in a more balanced location in the tech tree and make their performance dependent on unlocked techs

Edited by FreeThinker
  • Like 1

Share this post


Link to post
Share on other sites
2 hours ago, FreeThinker said:

Its a known problem that after docking you might lose all power. A known work around is to quick save and reload after docking

Fair enough.  Quickloading didn't seem to fix it for me, but if it's a known issue I will not worry about it.  I noticed in my testing this evening that the Candle no longer generates any thermal power at all unless it is under thrust.  Is this a bug?  Or did I miss something in the release notes.

 

  • Like 1

Share this post


Link to post
Share on other sites

Just to let the mod creator know I think 1.4.3 has introduced an issue with solar generation in this mod as all my spacecraft old and newly launched no longer generate power in full sunlight. Exposure shows zero in part popups. Solar panels work fine with stock install. I have reverted to 1.4.2 so i can use this great mod, I am in rush to update to 1.4.3 I just wanted to make those who make these mods job easier. Thanks for making KSP even better than the base game. Keep up the good work.

  • Like 1

Share this post


Link to post
Share on other sites
3 hours ago, Freeman Dyson said:

Just to let the mod creator know I think 1.4.3 has introduced an issue with solar generation in this mod as all my spacecraft old and newly launched no longer generate power in full sunlight. Exposure shows zero in part popups. Solar panels work fine with stock install. I have reverted to 1.4.2 so i can use this great mod, I am in rush to update to 1.4.3 I just wanted to make those who make these mods job easier. Thanks for making KSP even better than the base game. Keep up the good work.

Exactly what solar receiver are you using and do you have any radiators on that vessel?

Share this post


Link to post
Share on other sites
Posted (edited)

Spend quite some time to get the Beam Core Antimatter reactor right, which needed a serious upgrade

tVFWebl.png

It allows you to create one of the fastest non FTL ships possible. Above example vessel has a deltaV  of 2/3c with a speedup time of 4 years. One of the key strategies involved to achieve this is to increase the Mass ratio of it fuel/propellant, which is a mix of AntiHydrogen and Hydrogen. The KSPI beam core antimatter reactor is throttleble between 20200000s and 5050000s. By taking along more Hydrogen than antimatter, we increase our mass ratio at the expanse of average Isp, which might sound bad but it reduces cost and improves deltaV capability. Overall this effectively allows you to colonize distant stars at about 1/3c speed which is  3 times the speed than achievable with Fusion Engine which travel about 1/10c

Edited by FreeThinker

Share this post


Link to post
Share on other sites
Posted (edited)

A Beta KSPIE 1.19 can be downloaded from here

Changelog

* Added Timewarp acceleration to Vista, Z-Pinch Airospike, GasCore Engine, Magneto Inertial Fusion Engine and Plasma Nozzle

* Added Kspi Patch for Far Future Beam Core Antimatter engine and Mirror Cell Fusion Engine

* Balance: Increased Power Beam Core Antimatter reactor to 5 TW

* Balance: Improve mass ratio and gee-force simulation on Anti Hydrogen Containment device

* Fixed magnetic nozzle mass propellant deficiency

* Fixed issue with Solar Receiver not able to function when wasteheat storage is missing

Edited by FreeThinker
  • Like 2

Share this post


Link to post
Share on other sites
On 4/30/2018 at 4:20 AM, FreeThinker said:

* Added Kspi Patch for Far Future Beam Core Antimatter engine and Mirror Cell Fusion Engine

I searched for the mod "FarFutureTechnologies" , it came out nothing.

Where can I find this mod???

Share this post


Link to post
Share on other sites
1 hour ago, Iso-Polaris said:

I searched for the mod "FarFutureTechnologies" , it came out nothing.

Where can I find this mod???

FAR future mod can be downloaded from his dropbox link or better directly from github.

Share this post


Link to post
Share on other sites
Posted (edited)
22 hours ago, FreeThinker said:

FAR future mod can be downloaded from his dropbox link or better directly from github.

Gracias

However it seems the mod is severely outdated,is it gonna work on  1.4?

 

Edited by Iso-Polaris

Share this post


Link to post
Share on other sites

KSP_x64_2018_05_03_23_13_42_06.png

The Solid Fuel Electric Fission Reactor does not work at all:

Status:Active 0%

All requirements are met,however it does not produce any power whatsoever.

  • Like 2

Share this post


Link to post
Share on other sites
3 hours ago, Iso-Polaris said:

Gracias

However it seems the mod is severely outdated,is it gonna work on  1.4?

 

Perhaps not all of it, but at least in combination with KSPIE at least the Beam core and Mirror Cell Fusion will. Its mainly the graphics and model switching that is used

Share this post


Link to post
Share on other sites

This pic should be on the first page showcasing the mod. I made it with the engines you suggested, I actually did overkill and recently dumped some fuel, it has a delta v of 2.8 MILLION at full tank capacity. I don't think ANYONE has built such a fully functional and lovely looking starship in KSP, EVER.

Image may contain: night

  • Like 3

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now