FreeThinker

[1.8.1, 1.7.3/1.6.1/1.5.1/1.4.5] KSP Interstellar Extended 1.25 Continued Development Thread

Recommended Posts

On 5/28/2017 at 5:43 PM, FreeThinker said:

Bata Version 1.14.1 for Kerbal Space Program 1.3.0 which can be downloaded from here

Released on 2017-05-29

  • Updated Tweakscale to official 1.3 release (1.3.6)
  • Improved GUI Kerbstein drive to show required power in vAB and in flght
  • Balance improved mass scaling Kerbstein (to expoment 2.5)
  • Fixed premature exploding antimatter tank due to initial geeforce spike at launch

When I install this, It tells me that Community tech tree requires Kerbal 1.2.2 then crashes to the desk top

Share this post


Link to post
Share on other sites
50 minutes ago, Infleto said:

When I install this, It tells me that Community tech tree requires Kerbal 1.2.2 then crashes to the desk top

Install by CKAN? I'm waiting for @Nertea to update CTT to 1.3. For now I recommend installing manually

Share this post


Link to post
Share on other sites
35 minutes ago, FreeThinker said:

Install by CKAN? I'm waiting for @Nertea to update CTT to 1.3. For now I recommend installing manually

I installed by downloading and plopping the files into the game data folder.

Share this post


Link to post
Share on other sites
50 minutes ago, FreeThinker said:

Install by CKAN? I'm waiting for @Nertea to update CTT to 1.3. For now I recommend installing manually

Good timing, it has just been updated. 

Share this post


Link to post
Share on other sites

Here is the updated tech tree mod for v1.3 (it's a separate mod bundled in).

 

Edited by nsbrown93

Share this post


Link to post
Share on other sites

strange bug detected (and no log entries) - all solar power is drained away without reason (i.e. drainage exactly the same as solar power input(with small delay for several frames), battery power still lasts according to real usage, but no solar input (i.e. all solar input according to megajoules management display drained for unspecified reason), 1.3. no kspie parts used.

 

 

Share this post


Link to post
Share on other sites
15 hours ago, okder said:

strange bug detected (and no log entries) - all solar power is drained away without reason (i.e. drainage exactly the same as solar power input(with small delay for several frames), battery power still lasts according to real usage, but no solar input (i.e. all solar input according to megajoules management display drained for unspecified reason), 1.3. no kspie parts used.

 

 

EDIT ***  workaround found -- DISABLE KOPERNICUS for now ***   

The problem seems to require both KSP Interstellar extended  - AND - Kopernicus.      At the moment, i don't think any of the planet mods are updated for 1.3, so it would seem easiest to disable kopernicus.  at least thats how it seems to me.

 

Testing details:

Test - in each game, created a rover, drove to use up some EC.  opened solar panels. (stock 1x6 retractable ones)  if charged normally, is ok.   if charge flickered at 0.00 and 0.01 for a few frames before staying 0.00, then is bugged.

test1 - my game with lots of mods - bugged

test2 - my game with lots of mods, minus KSP Interstellar Extended  - ok

test3 - stock game - new sandbox - ok

test4 - new sandbox with only interstellar + dependancys that CKAN required.  - ok

test5 - new sandbox with only interstellar + dependancys + reccommended from CKAN - ok

test6 - new sandbox with only interstellar + required dependancies  (not reccommended mods), plus kopernicus - bugged.

 

EDIT - pps -- I did not test with only Kopernicus, because my game had been using kopernicus for several days + was ok.  it wasn't until i added interstellar last night that the problem started happening. so I kind of knew that kopernicus by itself didnt cause the trouble.

 

 

FYI - i had googled and found this OLD (2015) thread, which talked about a problem with Kopernicus + the sun?    

 

------------- original message text below ....         --------------------------

 

I get the same problem.    have several mods installed (Kopernicus, USI stuff, some part mods) but new mods installed today are

- Interstellar extended, plus the mods that CKAN said it needed/wanted (interstellar fuel switch, couple others?)

- firespitter plane/heli parts (already had firespitter core)

- CTT

Google had some 2 year old thread where Kopericus was causing some issue with the sun.   kind of assuming these new issues are different.    its not crashing, so no log file.  I can get a complete list of mods if needed.

 

ps.  issue was occuring with a ship that had 4x the stock 1x6 retractable solar panels, the small thin ones that track the sun.  they tracked the sun normally, and tooltip showed percent of sun exposure and showed energy flow, but the battery power was very gradually going down, from the hibernating probe core, despite 2 of the panels being 90% in the sun

Edited by CFTeague2
add mod test notes

Share this post


Link to post
Share on other sites
7 hours ago, CFTeague2 said:

EDIT ***  workaround found -- DISABLE KOPERNICUS for now ***  

that's probably their fix for multi star universes, some solar panel gives NAN % value, but 0 charge(others panels gives normal charge and normal sun coverage in same time), and that's in turn makes kspie crazy, stock ksp power works normally without kspie.

 

Share this post


Link to post
Share on other sites

I have the same problem with the vanila sky solar panels. They don´t give charge although they show that they do.

Share this post


Link to post
Share on other sites
7 hours ago, riglper said:

I have the same problem with the vanila sky solar panels. They don´t give charge although they show that they do.

The problem is fixed in the latest release of KSPI-E 1.14.2 which can be downloaded from here

Share this post


Link to post
Share on other sites

Quick question; Doesn't Interstellar Extended engines play nice with Mechjeb these days? I seem to recall those guys didn't play well together back in Wave-Functions version.

Share this post


Link to post
Share on other sites

Should KSPI-E's nuclear engines/reactors be used instead of NFT's? Is there a patch to make the two use the same nuclear model?

Share this post


Link to post
Share on other sites

@dlrk Interstellar adds reactors that are a lot more powerful and futuristic than NFT's, whereas NFT's are more simple and more stockalike. It all depends on what you are looking for. As to a patch? I have no idea. I don't know any off of the top of my head.

Share this post


Link to post
Share on other sites
On 6-6-2017 at 3:12 AM, AWESOMEPIEMAN said:

Did KSP-I remove the solar sail part or am I losing my mind?

It got broken, I get it back as soon as it works again in conjunction with beamed power which act as an artificial sun.

Edited by FreeThinker

Share this post


Link to post
Share on other sites

@Dirk I feel the same as well, I like the NFT parts (and they're a lot easier to use) but when use with KSPI-E they don't balance very well.

Share this post


Link to post
Share on other sites
20 hours ago, samwisee said:

@Dirk I feel the same as well, I like the NFT parts (and they're a lot easier to use) but when use with KSPI-E they don't balance very well.

Could you elaborate exactly why they don't balance very well? . Notice that in the near future I plan to improve integration with  Near Future Technologies. Therefore any ideas and constructive criticism are welcome at this point

Edited by FreeThinker

Share this post


Link to post
Share on other sites

@FreeThinker, should it be possible to add a UI Font size setting/slider for the in-flight GUI? like others did on MecJeb and/or KER.

 

Thaat's just because the KSPI-E four windows are too big in dimensions for low res screens (like my Half HD laptop display) and the gui is cluttering the screen. Just 0.8x actual size should be enought for me, that is the same setting i use in Mechjeb, this way they'll also be unisied in format.

That could be useful also for the very high res screens to magnify fonts and see better.

 

Bye, Ciro.

Edited by Ciro1983811

Share this post


Link to post
Share on other sites
On 16-6-2017 at 9:14 AM, Aghanim said:

Warning: CKAN currently does not work for KSPI because somewhere in the indexer pipeline, the correct KSPI version that is 1.14.3 got changed into 1.4.3, breaking CKAN downloader as it tries to download KSPI version that is nonexistent in Spacedock: https://github.com/KSP-CKAN/NetKAN/issues/5635

Is the problem fixed now after a new version of KSPIE 1.14.4 is released?

Edited by FreeThinker

Share this post


Link to post
Share on other sites
19 minutes ago, FreeThinker said:

Is the problem fixed now?

Unfortunately not, https://github.com/KSP-CKAN/CKAN-meta/blob/master/KSPInterstellarExtended/KSPInterstellarExtended-1.4.3.ckan shows that the version indexed in CKAN for KSP 1.3 is still 1.4.3 instead of 1.14.3, lets try to tell the CKAN devs in the thread now

EDIT: I have tried to create a pull request for CKAN meta to revert bad KSPI 1.4.3 KSP version from 1.3 to 1.0.4, hopefully making all CKAN clients to be able to download KSPI again, even if it is the old version: https://github.com/KSP-CKAN/CKAN-meta/pull/1278

Edited by Aghanim

Share this post


Link to post
Share on other sites
9 hours ago, Aghanim said:

Unfortunately not, https://github.com/KSP-CKAN/CKAN-meta/blob/master/KSPInterstellarExtended/KSPInterstellarExtended-1.4.3.ckan shows that the version indexed in CKAN for KSP 1.3 is still 1.4.3 instead of 1.14.3, lets try to tell the CKAN devs in the thread now

EDIT: I have tried to create a pull request for CKAN meta to revert bad KSPI 1.4.3 KSP version from 1.3 to 1.0.4, hopefully making all CKAN clients to be able to download KSPI again, even if it is the old version: https://github.com/KSP-CKAN/CKAN-meta/pull/1278

@FreeThinkerI never had this trouble.

 

Regularily upgraded via CKAN to 14.3 and now 14.4 (not 14.5).

Edited by Ciro1983811

Share this post


Link to post
Share on other sites

@FreeThinker, also, in MKSReactors patch we miss the Nuke Reactor 1,25 "Short".

 

I wrote mine, just check the values and add it please..!!

 

@PART[USI_Nuke_125_S]:NEEDS[KolonyTools&!NearFutureElectrical]:FOR[WarpPlugin]
{
	-MODULE[FissionReactor] { }
	-MODULE[ModuleResourceConverter] { }
	-MODULE[ModuleCoreHeat] { }
        -MODULE[FissionGenerator] { }
        -MODULE[RadioactiveStorageContainer] { }

	-RESOURCE[EnrichedUranium] { }
	-RESOURCE[DepletedFuel] { }

	!MODULE[FissionReactor]{}
	!MODULE[RadioactiveStorageContainer]{}
	!MODULE[FissionGenerator]{}

	MODULE
	{
		name = InterstellarFissionMSRGC
		upgradeTechReqMk2 = largeNuclearPower
		upgradeTechReqMk3 = nuclearFuelSystems 
		upgradeTechReqMk4 = advNuclearPower
		coreTemperatureMk1 = 1000
		coreTemperatureMk2 = 1260
		coreTemperatureMk3 = 1587
		coreTemperatureMk4 = 2000
		basePowerOutputMk1 = 7
		basePowerOutputMk2 = 9
		basePowerOutputMk3 = 30
		basePowerOutputMk4 = 60
		PowerOutputExponent = 3.2
		upgradedPowerOutputExponent = 3.644
		originalName = Nuclear Reactor Mk1 (1.25m Short)
		upgradedName = Nuclear Reactor Mk2 (1.25m Short)
		upgradeCost = 60
		radius = 1.25
		partMass = 0.4
		minimumThrottle = 0.1
		consumeGlobal = false
		reactorType = 2
		upgradedReactorType = 2
		fuelEfficiency = 0.1376
		upgradedFuelEfficiency = 0.1376
		heatTransportationEfficiency = 0.95
		bonusBufferFactor = 1
		canBeCombinedWithLab = true
		canBreedTritium = true
		neutronEmbrittlementLifepointsMax = 1000
	}

	
	MODULE
	{
		name = FNGenerator
		pCarnotEff = 0.31
		maxThermalPower = 800
		upgradedpCarnotEff = 0.6
		upgradedName = KTEC Solid State Generator
		originalName = Brayton Cycle Gas Turbine
		upgradeTechReq = experimentalElectrics
		upgradeCost = 200
		animName = e7
		radius = 0.625
		partMass = 0.15
		calculatedMass = false
	}

	

	RESOURCE
	{
		name = ThermalPower
		amount = 0
		maxAmount = 80
	}

	RESOURCE
	{
		name = Megajoules
		amount = 0
		maxAmount = 80
	}

	RESOURCE
	{
		name = WasteHeat
		amount = 0
		maxAmount = 40000
	}

	RESOURCE
	{
		name = UF4
		amount = 24
		maxAmount = 24
	}

	RESOURCE
	{
		name = ThF4
		amount = 0
		maxAmount = 24
	}

	RESOURCE
	{
		name = Actinides
		amount = 0
		maxAmount = 24
	}
}

 

Share this post


Link to post
Share on other sites
39 minutes ago, Ciro1983811 said:

@FreeThinkerI never had this trouble.

 

Regularily upgraded via CKAN to 14.3 and now 14.4 (not 14.5).

On second thought the bad version number only affects pyKAN not the official CKAN client, as for some reason pyKAN thinks that 1.4.3 > 1.14.1. Still, bad metadata is still bad, and it needs to be fixed

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.