Jump to content

KSP Interstellar Extended Continued Development Thread


FreeThinker
 Share

Recommended Posts

What about making atmospheric mode being more realistic?

It should act differently depending on atmosphere composition - thrust and isp should depend where you are flying.

It should work differently if you are flying on Earth, Venus or Uranus.

Edited by raxo2222
Link to comment
Share on other sites

14 minutes ago, raxo2222 said:

What about making atmospheric mode being more realistic?

It should act differently depending on atmosphere composition - thrust and isp should depend where you are flying.

It should work differently if you are flying on Earth, Venus or Uranus.

True, instead of defining a fixed Isp modifier we should have a different Isp for every planet or moon with an atmosphere. Actually, this number could be calculated from the existing atmospheric definition, by simply taking the sum of all fraction multiplied by its density,  and compare them to an all Hydrogen atmosphere. (which has a Isp modifier of 1). Or more precisely

Isp modifier = sqrt(2) / sqrt(sum ( resource fraction * resource density )). As a result, you should get lower Isp factor on duna, resulting in higher thrust near the surface but more difficulty in higher atmosphere.

Edited by FreeThinker
Link to comment
Share on other sites

1 hour ago, FreeThinker said:

True, instead of defining a fixed Isp modifier we should have a different Isp for every planet or moon with an atmosphere. Actually, this number could be calculated from the existing atmospheric definition, by simply taking the sum of all fraction multiplied by its density,  and compare them to an all Hydrogen atmosphere. (which has a Isp modifier of 1). Or more precisely

Isp modifier = sqrt(2) / sqrt(sum ( resource fraction * resource density )). As a result, you should get lower Isp factor on duna, resulting in higher thrust near the surface but more difficulty in higher atmosphere.

Well it would be better than now, but VASMIR, MPD or Thermal Turbojet/Ramjet should react differently in atmospheric mode. Also engines with highest ISP should even work in trace atmosphere, when in atmospheric mode (air intakes would work like scoops we have now, just they would collect everything and feed engines with it)

BTW what about decreasing air scoop density limit? Even 0.0001% of trace atmosphere is something for high ISP such as magnetic nozzle or VISTA engines/reactors, especially if exosphere is hydrogen rich, and you are going very fast and you have bigS scoop.

Edited by raxo2222
Link to comment
Share on other sites

On 23-5-2016 at 1:23 AM, maranble14 said:

Not sure if this has been addressed already or not, but I can't seem to get microwave transceivers to function properly in relay mode. I set up a network of 4 GKO satellites trying to beam power around the planet, but for some reason they do not function when I set them to relay. But if I switch them over to receiving mode, they automatically detect the presence of my power stations. Is this user error, or a known bug? I've tried posting this question in several places and have yet to receive a response. Thanks!

eK7PXM0.png

You cannot receive the power you are sending on the same vessel and direction only matters when receiving.

Link to comment
Share on other sites

A few questions:

  • Is anyone else getting negative mass parts when scaling parts to be larger/not getting updates when parts are scaled up? Occurs with Mechjeb, stock readout and Engineer Redux.
  • What ever happened to mode/model switching? Has that been ditched in favor of completely different parts (e.g. Molten Salt/Gas-core reactors, graphene/MoLi radiators)

    and
     
  • Will bundled parts be removed/modulemanager-ed to require original part packs? It's nice having other modders' work integrated into the KSPI framework, but was definitely very mindboggling hopping back on after a rather long break from the game.
Link to comment
Share on other sites

11 hours ago, dakhr said:

I don't get negative mass but reactors not scale up the power ,only mass increase ,I did not have this problem 2 recent releases ago

Actually they do but it won't be applied until after launch. You can usually force an update by reconnecting the part

11 hours ago, fried_rice said:
  • Will bundled parts be removed/modulemanager-ed to require original part packs? It's nice having other modders' work integrated into the KSPI framework, but was definitely very mindboggling hopping back on after a rather long break from the game.

Well I'm trying to create a complete experience of gradually getting more advanced technologies. Starting with the Solid Core Nuclear Reactor  en end with faster than light engine. To do this I need models which unfortunately only a fraction can be made by KSPI affiliated artist, the rest I need to find else where in other mods. I make a distinction to core parts which define the main technologies and external part, which are external mods modified by MM scripts. An example would be USI Kolonisation mod.

Edited by FreeThinker
Link to comment
Share on other sites

Thanks ,a ton for mod and reply I will test it :) BTW probably I'm doing something wrong but I can't force ISRU to process nuclear fuels ,I'm playing science at the moment ,do I need some technology to unlock this feature ??

Edited by dakhr
misspelling
Link to comment
Share on other sites

On ‎5‎/‎24‎/‎2016 at 8:13 PM, dunclaw said:

I'm also seeing a problem with mass and tweak scale.

Repro case is pretty simple

Start a new craft with any capsule

Attach a thermoelectric generator and rescale to 1.25m

Mass I normal at this point.

Attach a particle bed reactor

Mass explodes to 1400 tons.

Detaching the reactor doesn't change the mass.

I think I found the issue with the 1333 Mass factor several people have been posting about. The .18 release changed USI_NF_Mode.cfg (I'm running with near future stuff installed)

from:

@PART[*]:HAS[@MODULE[FNModuleCryostat]]:NEEDS[NearFutureElectrical]:FOR[WarpPlugin]

To:

@PART[*]:HAS[@MODULE[FNGenerator]]:NEEDS[NearFutureElectrical]:FOR[WarpPlugin]

{

@MODULE[FNGenerator]

{

@rawPowerToMassDivider *= 0.002

}

}

This makes the mass divider really tiny and the resulting generator mass huge.

Link to comment
Share on other sites

2 hours ago, dunclaw said:

I think I found the issue with the 1333 Mass factor several people have been posting about. The .18 release changed USI_NF_Mode.cfg (I'm running with near future stuff installed)

from:

@PART[*]:HAS[@MODULE[FNModuleCryostat]]:NEEDS[NearFutureElectrical]:FOR[WarpPlugin]

To:

@PART[*]:HAS[@MODULE[FNGenerator]]:NEEDS[NearFutureElectrical]:FOR[WarpPlugin]

{

@MODULE[FNGenerator]

{

@rawPowerToMassDivider *= 0.002

}

}

This makes the mass divider really tiny and the resulting generator mass huge.

Good find, it appears the modifiers are applied too often. Going to fix it in next release

Link to comment
Share on other sites

20 hours ago, Mine_Turtle said:

Size does not matter as long as I can get it into orbit. The ISP on Tokamak is insane, I get around 3k ISP with Hydrogen. As long as I find water and dirt(for supplies) I should be able to get to any inner planet and refuel there.

True, in space, dimentions do not matter that much, unless you a close to the sun, or when areo breaking but you can pretty much forget about building an effective multiple SSTO vessel with it. THe Tokamak engine is best suited for building your first  manned interplanetary vessel. Note it also has a high thrust mode when you switch to Lithium propellant combined in in D-T fuel mode, which allows you to convert all fusion power directly into thrust. This will be usefull for capture retro burns or when used while getting into orbit.

Edited by FreeThinker
Link to comment
Share on other sites

Jumping back on after a few months away, the Hybrid Thermal Rocket no longer accepts anything but atmosphere as propellant. Is this an intentional change? I have the old files still, but I wanted to be sure before I "fixed" it.

Link to comment
Share on other sites

1 hour ago, Liquid5n0w said:

@FreeThinker I've been trying to size up the NTR engine with tweakscale, but it seems to loose it's upgrades when I change it's size? Whats going on, will detach then reattach work?

 

I think this is just a VAB problem, check if the problem persist when lauching

4 hours ago, nezumi said:

Jumping back on after a few months away, the Hybrid Thermal Rocket no longer accepts anything but atmosphere as propellant. Is this an intentional change? I have the old files still, but I wanted to be sure before I "fixed" it.

You need to have the required tech to be able to use it in differnent modes than just Atmosphere

Link to comment
Share on other sites

1 hour ago, FreeThinker said:

You need to have the required tech to be able to use it in differnent modes than just Atmosphere

I already have Advanced Nuclear Propulsion (hence having Hybrid Thermal Turbojets, not just Thermal Turbojets. I also have magnetic nozzles unlocked, which is from the same tech.) It sounds like this is just a bug from loading a game across versions. I'll see about locking and unlocking it via debug and see if that fixes it.

Link to comment
Share on other sites

I have a couple of questions about IR telescopes.  Rather than generating 0.17 science/day when in survey mode (in Kerbin orbit) hey seem to be treating their observation data as a limited resource and producing diminishing returns over time.  Also they do not seem to be consuming liquid Helium, though they do need an occasional EVA for maintenance.  Is this by design?  Also I cannot seem to transfer more than one piece of data to the Science Lab or Mobile Processing Lab; it either won't transfer, or the data just disappears without producing data.  I have verified this with a clean install of KSP 1.1.2 and the latest KSPIe, so I know it's not conflicting mods doing this.  Also the nuclear reactors (both molten salt and pebble bed) don't upgrade in performance with increased tech... they always sit at the Mk1, even in the VAB.  Halp...!?  :/

 

Link to comment
Share on other sites

16 hours ago, FreeThinker said:

True, in space, dimentions do not matter that much, unless you a close to the sun, or when areo breaking but you can pretty much forget about building an effective multiple SSTO vessel with it. THe Tokamak engine is best suited for building your first  manned interplanetary vessel. Note it also has a high thrust mode when you switch to Lithium propellant combined in in D-T fuel mode, which allows you to convert all fusion power directly into thrust. This will be usefull for capture retro burns or when used while getting into orbit.

>no effective SSTO

CHALLENGE ACCEPTED!

Link to comment
Share on other sites

Been working on that SSTO. It barely fits in the hangar.
It's taken me a while just to get an aerodynamic hullform, but i got it, and the engines installed nicely. still have to install reactors, secondary engines, ATM processors, and correct fuels... AND RADIATORS.
still undecided about FTL tech.
jJofwe6.pnglndg3if.pngJ6BTT4H.pngnYxtq3r.pngWcTGFnr.png

Edited by Rushligh
Link to comment
Share on other sites

I went back through just to see where the Hybrid Thermal Rocket is supposed to kick on, and here's what I found.

All of this is with version 1.8.20, fuel switch 2.0.7, installed via CKAN. I removed Interstellar, deleted the cache, and reinstalled (not fuel switch though). I don't see a 'community tech tree' mod, so I didn't touch that.

The front page says the Thermal Turbojets become Hybrid Thermal Rockets with Advanced Nuclear Propulsion. Digging through the ModuleManagerTechTree, Advanced Nuclear Propulsion is the ID name, but the displayed name is High Efficiency Nuclear Propulsion. I recommend changing this on the front page.

Regardless, when I go to Advanced Nuclear Propulsion, aka High Efficiency Propulsion, it shows the engine accepts only atmosphere as a fuel mode.

http://imgur.com/R8RJtih

Based on the fact that I have that tech (see the image) and it's a "Hybrid" Thermal Turbojet, I think this is a bug.

I did find a workaround; by replacing UpgradedThermalTurbojet with ThermalTurbojet, the functionality returns to normal. For some reason this already works fine in my sandbox game (also restored from months ago). Hopefully this is a result of dusting off ancient games and nothing more epidemic?

Edited by nezumi
Link to comment
Share on other sites

9 hours ago, nezumi said:

I went back through just to see where the Hybrid Thermal Rocket is supposed to kick on, and here's what I found.

All of this is with version 1.8.20, fuel switch 2.0.7, installed via CKAN. I removed Interstellar, deleted the cache, and reinstalled (not fuel switch though). I don't see a 'community tech tree' mod, so I didn't touch that.

The front page says the Thermal Turbojets become Hybrid Thermal Rockets with Advanced Nuclear Propulsion. Digging through the ModuleManagerTechTree, Advanced Nuclear Propulsion is the ID name, but the displayed name is High Efficiency Nuclear Propulsion. I recommend changing this on the front page.

Regardless, when I go to Advanced Nuclear Propulsion, aka High Efficiency Propulsion, it shows the engine accepts only atmosphere as a fuel mode.

http://imgur.com/R8RJtih

Based on the fact that I have that tech (see the image) and it's a "Hybrid" Thermal Turbojet, I think this is a bug.

I did find a workaround; by replacing UpgradedThermalTurbojet with ThermalTurbojet, the functionality returns to normal. For some reason this already works fine in my sandbox game (also restored from months ago). Hopefully this is a result of dusting off ancient games and nothing more epidemic?

You need unified field theory and... the other 10k science one that unlocks the warp drives, to get all the modes for everything unlocked, in my experience.

Link to comment
Share on other sites

After playing around with KSPI reactors and looking at the code I have found several issues:

1) Engines can force reactor to activate, even when it should not. For example here you can see small fusion reactor with thermal turbojet attached to it: http://imgur.com/QiCxpbS Reactor is offline and there are no sources of power to start the fusion reaction. However, once I activate the engine the reactor startups and produces power: http://imgur.com/PlaVh80 Same behaviour is observed for fusion reactors, AM and AIM reactors. However, if I use fission reactor then reactor will not activate.

2) In case of a large fusion reactor situation is even worse as the engine will explode from overheating when working in atmo mode. Having looked at the code I found the source in ThermalNozzleController.cs:1322 which causes this overheating. Because the reactor is technically offline, the calculated fuel flow rate is almost 0 and being in divider for baseHeatProduction it causes engine to generate insane amount of heat quickly.

3) QSR causes my game to crash when pulling part from part list or reverting flight to VAB. I still need to look at potential cause of this problem.

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...