Jump to content

KSP Interstellar Extended Continued Development Thread


FreeThinker
 Share

Recommended Posts

Err just btw I can't seem to find the Fusion reactors, antimatter reactors or warp drives do they become visible down the tech tree as you advance, because I can see everything else.

Link to comment
Share on other sites

Nope, everything is in the patch except Tweakscale

Nope, not at the moment

- - - Updated - - -

Most likely it is. All Sophisticated KSPI engines are messed up due to they way KSP 1.0 changed the the control of EnginesFX. In my next patch I plan to fix it. Now that I have properly fixed Thermal Nozzle, I should be able to repeat the same for all engines.

Sounds good. Thanks again. I'll keep an eye out for the next patch.

Link to comment
Share on other sites

same here. is it possible to use this on career yet?

tbh I couldn't even get the reactors to work, I followed the instructions so *hands up is surrender*

So... Yeah this seems completely broken for me.

Edited by etheoma
Link to comment
Share on other sites

Okay, I am having the same problem as the first time i pointed this out. So I downloaded the latest kerbal Space program, I downloaded both the interstellar and the the latest extended version, as i have seen updates for, and that is it(i don't really use tweakscale). The same problems are there for me.

Parts need to be orientated a certain way to join, or join incorrectly in order to build stuff but locking other parts out due to orientation.

Thermal thrusters and some of the other thrusters don't attach or work.

ships explode randomly if i do get them together.

I am not sure if tweakscale is important to make this work, i'd like to think not, but after the updates to this mod i hoped things would work. Its a shame because i do like this mod. and this is with totally fresh starts. no other mods and just interstellar and the extended installed. Is there anything else that I am missing or do i need tweakscale or what?

Link to comment
Share on other sites

tbh I couldn't even get the reactors to work, I followed the instructions so *hands up is surrender*

So... Yeah this seems completely broken for me.

do you have the new CTT installed?

Also:

Freethinker, in the current CTT patch, the patch for my magnetic nozzle patch for simian engines is as follows:

@PART[Simian_MagneticNozzle,Leo-Simian_MagneticNozzle]:NEEDS[StarLionIndustries]:FOR[WarpPlugin]
{
@TechRequired = advNuclearPropulsion
@MODULE[ModuleEnginesFX]
{
!PROPELLANT[LiquidNitrogen]{}
!PROPELLANT[Nitrogen]{}
!PROPELLANT[LqdHydrogen]{} //this is the current 'default' fuel
PROPELLANT
{
name = LiquidFuel
ratio = 1.0
DrawGauge = True
}
}
}

To match the current magnetic nozzle, could you remove the LiquidFuel patch from that? The new release I am about to upload has the Magnetic Nozzle properly using LqdHydrogen.

Link to comment
Share on other sites

I installed the latest version of this mod and now KSP just stops loading when it tries to load the aluminum hybrid rocket. I tried removing that part file but then the same thing happened with the methane rocket engine. Does anyone know how to fix this?

Link to comment
Share on other sites

I installed the latest version of this mod and now KSP just stops loading when it tries to load the aluminum hybrid rocket. I tried removing that part file but then the same thing happened with the methane rocket engine. Does anyone know how to fix this?

double check that you have the model and texture files for those parts?

Link to comment
Share on other sites

Just tried installing this on a fresh copy of ksp 1.0.2.

Starting up would hang when it got to AntimatterReactors. I tried removing those parts and then it'd hang on another part. over a series of trials, I ended up removing the following parts before ksp would finish starting:

GameData\WarpPlugin\Parts\

electrical

AntimatterReactors

FissfussReactor

LargeFusionReactor

NuclearReactor1Sphere

NuclearReactor3Sphere

PFissionReactor

SmallFusionReactor

engines

AluminumHybrid

MagneticNozzle

MethaneEngine

MPD

ThermalRocketNozzle

Vista

Each attempt would result in an entry like this at the end of output.log:


PartLoader: Compiling Part 'WarpPlugin/Parts/Electrical/AntimatterReactors/AntimatterReactor/TweakableAntimatterReactor'

(Filename: C:/buildslave/unity/build/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 56)

NullReferenceException: Object reference not set to an instance of an object
at FNPlugin.ReactorFuel..ctor (.ConfigNode node) [0x00000] in <filename unknown>:0

at FNPlugin.ReactorFuelMode.<.ctor>b__0 (.ConfigNode nd) [0x00000] in <filename unknown>:0

at System.Linq.Enumerable+<CreateSelectIterator>c__Iterator10`2[ConfigNode,FNPlugin.ReactorFuel].MoveNext () [0x00000] in <filename unknown>:0

at System.Collections.Generic.List`1[FNPlugin.ReactorFuel].AddEnumerable (IEnumerable`1 enumerable) [0x00000] in <filename unknown>:0

at System.Collections.Generic.List`1[FNPlugin.ReactorFuel]..ctor (IEnumerable`1 collection) [0x00000] in <filename unknown>:0

at System.Linq.Enumerable.ToList[ReactorFuel] (IEnumerable`1 source) [0x00000] in <filename unknown>:0

at FNPlugin.ReactorFuelMode..ctor (.ConfigNode node) [0x00000] in <filename unknown>:0

at FNPlugin.InterstellarReactor.<GetInfo>b__13 (.ConfigNode node) [0x00000] in <filename unknown>:0

at System.Linq.Enumerable+<CreateSelectIterator>c__Iterator10`2[ConfigNode,FNPlugin.ReactorFuelMode].MoveNext () [0x00000] in <filename unknown>:0

at System.Linq.Enumerable+<CreateWhereIterator>c__Iterator1D`1[FNPlugin.ReactorFuelMode].MoveNext () [0x00000] in <filename unknown>:0

at System.Collections.Generic.List`1[FNPlugin.ReactorFuelMode].AddEnumerable (IEnumerable`1 enumerable) [0x00000] in <filename unknown>:0

at System.Collections.Generic.List`1[FNPlugin.ReactorFuelMode]..ctor (IEnumerable`1 collection) [0x00000] in <filename unknown>:0

at System.Linq.Enumerable.ToList[ReactorFuelMode] (IEnumerable`1 source) [0x00000] in <filename unknown>:0

at FNPlugin.InterstellarReactor.GetInfo () [0x00000] in <filename unknown>:0

at PartLoader.CompilePartInfo (.AvailablePart newPartInfo, .Part part) [0x00000] in <filename unknown>:0

at PartLoader+.MoveNext () [0x00000] in <filename unknown>:0

(Filename: Line: -1)

[TechManager]: OnDestroy

(Filename: C:/buildslave/unity/build/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 56)

Hope this is useful

Link to comment
Share on other sites

This is most likely a missing resource issue. Please verify you have a folder CommunityResourcePack in your GameData Folder, open CommonResources.cfg and check if LqdOxygen is in the list. If not you have an old version

- - - Updated - - -

tbh I couldn't even get the reactors to work, I followed the instructions so *hands up is surrender*

So... Yeah this seems completely broken for me.

Most likely you forgot to add Fusion Fuel. IN future patch I will add a small amount to the reactor, that should help it a bit

Edited by FreeThinker
Link to comment
Share on other sites

Which Fusion Fuel is most recommended?

@edit

Bro, i cant understand, why your "updated" mod files is OUTDATED? when im trying to replace all files included in .rar, the system tells me that difference is in file size and modification date, my files are newer and bigger than your "new" files... can you explain this?

Edited by Refax
Link to comment
Share on other sites

Thank for the heads up. Still I would have like these things not suddenly to change. I guess you have your reasons. But people like me don't expect them to change suddenly. THis is forcing me to to use my own scales.

Mass scaling was about the last thing that has always been broken with TweakScale (constant mass fraction clearly is by design in stock KSP). So I fixed it for KSP1.0, which I consider the best possible time for introducing breaking changes. This also balanced the weight of a rew other things (like solar panels properly preserve power/mass now).

Link to comment
Share on other sites

I haven't been able to test antimatter reactors but all fusion engines and all fission reactors of any size act like this.

98G9XcA.jpg

Also without any reactors or any energy or thermal power The plasma engines Attila engines Megnetic Nozzle will generate thrust the worst culprit of this is the magnetic Nozzle

T6ZWdwN.jpg

Also they generate greater IPS numbers than they are supposed to but that's the least of our problems, Also the tech tree wont work even with the Community Tech Tree integration, again not the main problem, but pleas when I say something is completely broken I mean its competently broken I don't over exaggerate, often I under exaggerate unless for comedic effect.

- - - Updated - - -

Eh w.e. seems to be fixed in the most recent update, as long as it works I don't care about how it works.

Thank you for your continued upkeep of KSPI the best propulsion etc mod ever, only reason why its not the best mod ever is because of FAR.

Further edit however the fusion engine seems to be buggy as it keeps overheating... Instantly as soon as I turn it on it explodes. other than that everything is fine, I don't know maybe I was getting an old version but I did re-install 3 - 4 times making sure I had the latest version of everything so :S I think there might have just been something wrong with 1.0.3 and I did 1.0.4 first go.

Edited by etheoma
Link to comment
Share on other sites

Mass scaling was about the last thing that has always been broken with TweakScale (constant mass fraction clearly is by design in stock KSP). So I fixed it for KSP1.0, which I consider the best possible time for introducing breaking changes. This also balanced the weight of a rew other things (like solar panels properly preserve power/mass now).

if By mass fraction you mean tank Dry Mass / Wet Mass , that might be true but it should not have been forced on non tank parts which grow with scalar 2.5

- - - Updated - - -

i just noticed that the Kerbalstuff page has the ckan-enabled label - I don't see it there though?

Once I have a stand alone version, I will get it properly listed on CKAN, but before that, 99% should first work. I can only do that if people actually report any bugs with the most recent version of the mod

- - - Updated - - -

Also they generate greater IPS numbers than they are supposed to but that's the least of our problems,

This looks kind of hilarious. It is caused by the fact that is has a default Fuel Flow which is not set, but it is combined with a very high Isp. THe result is that you are Shot to space at incredible speed

- - - Updated - - -

Also the tech tree wont work even with the Community Tech Tree integration, again not the main problem,

Did you put the ModuleManager.2.6.2.dll into you GameData folder? Community Tech Tree only works with the latest Module Manager

Link to comment
Share on other sites

if By mass fraction you mean tank Dry Mass / Wet Mass , that might be true but it should not have been forced on non tank parts which grow with scalar 2.5

I had to rethink what is a good default and what are the exceptions. So cubic mass is the most obvious behavior one would expect from an enlarged model. Also there are a lot more tanks than engines. I also put this up to discussion but got no replies. If there are open questions with the KSPI configs I can have a look if you want.

Link to comment
Share on other sites

I had to rethink what is a good default and what are the exceptions. So cubic mass is the most obvious behavior one would expect from an enlarged model. Also there are a lot more tanks than engines. I also put this up to discussion but got no replies. If there are open questions with the KSPI configs I can have a look if you want.

Well, I have been working with Tweakscale for quite some time now, so I know how to fix it for myself, but I think not everyone is so proficient. Right now, Tweakscale seem to offer a very limited choice in default scales. One stack ( which now scales with cubic), stack_square, stack_square (which as the name implies scales with square) but there is nothing in between. Could you please offer a default scale which lies in between cubic and square (=2.5) . For myself I have defined the stack_interstellar and surface_interstellar which both use 2.5 which in my opinion is the best scale factor for mass as it makes bigger thing more mass efficient except when performance scales with surface (like with solar panels and radiators)

Edited by FreeThinker
Link to comment
Share on other sites

Once I have a stand alone version, I will get it properly listed on CKAN, but before that, 99% should first work. I can only do that if people actually report any bugs with the most recent version of the mod

Ah, OK. I was asking because the MM patch I made isn't allowed to be added on CKAN until its dependency is also on.

Link to comment
Share on other sites

FreeThinker, if you right click on a radial radiator, you can see that it has two temperatures, that have nothing in common. After launch, one of them tends to go down, and the other goes up.

What temerpatures? Do you mean the one hat looks something like "Temerature: 478.7K / 1600K"

Link to comment
Share on other sites

What temerpatures? Do you mean the one hat looks something like "Temerature: 478.7K / 1600K"

Yes, that one, and the stock temperature as well.

In space, the stock temperature goes down, while the waste heat / KSPI temperature goes up until thermal equilibrium.

Edit: while the KSPI temperature can be the one of the cooling system and the stock temperature that of the part itself, that won't work for radiators. They should only have a single temperature.

Edited by SymbolicFrank
Link to comment
Share on other sites

Is step 2 in the installation instructions still required?

Yep, still required

- - - Updated - - -

Yes, that one, and the stock temperature as well.

In space, the stock temperature goes down, while the waste heat / KSPI temperature goes up until thermal equilibrium.

Edit: while the KSPI temperature can be the one of the cooling system and the stock temperature that of the part itself, that won't work for radiators. They should only have a single temperature.

Well, I don't see it. You must be using some Plugin which makes the Temperature visible because in stock it is not. I guess deadly reentry. You can ignore the inconsistencies for now. In the futue I want to integrate them, meaning they which affect each other, transporting heat from hot sports to the radiators.

Edited by FreeThinker
Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...