Jump to content

KSP Interstellar Extended Continued Development Thread


FreeThinker
 Share

Recommended Posts

Well, I don't see it. You must be using some part which makes the Temperature visible because in stock it is not.

You have to be launched to see it. There was a mod for that, but that was depreciated because it's now default.

Actually, there's even more context-sensitive temperature data in the right-click part menu depending on what is happening, which is interesting when you're on re-entry for example, but that is irrelevant. Like the external temperature, the temperature of the connected parts and such.

Link to comment
Share on other sites

Mind if I ask why? Seems you've got everything needed on this mod.

THe short answer is that its still a WIP, there are still a lot of issues which needs to be solved before I make a full download. Also note, even if I would make a full download now, it wouldn't change anything about the procedure because I would still have to make a lot of fixes, which would require generate a lot of unnecessary traffic

Link to comment
Share on other sites

Well, I don't see it. You must be using some Plugin which makes the Temperature visible because in stock it is not. I guess deadly reentry. You can ignore the inconsistencies for now. In the futue I want to integrate them, meaning they which affect each other, transporting heat from hot sports to the radiators.

You were right, it was a plugin. Sorry I bothered you.

Link to comment
Share on other sites

testing 1.0.4:

Reactors do not deplete any fuels. Example: depleated uranium doesn't increase & uranium doesn't decrease, Antimatter won't decrease.

Alcubierre Drive is currently showing up as a fuel tank

Sethlon reactors & phased array microwave transmitters still have bad connection nodes (easy enough to edit for further testing)

Edited by WolfWaya
correction on one thing in my note
Link to comment
Share on other sites

I noticed that in sandbox mode, you were able to give antimatter reactors or antimatter initiated reactors their fuel without having to go through the painful process of collecting it, but in the newest version this is removed. Is this intentional? I can see removing it for career/science mode, but I always thought of sandbox as a "play without constraints and test craft" type of thing.

Link to comment
Share on other sites

@ Freethinker: Thanks for maintaining and improving this mod. played with it in 23.5, it's good to see it's still going.

hit a few bugs (i think). reactors won't always properly connect to attachment nodes. and in a test flight the Vista engine does explode upon ignition.

stock install save the mods in the installation instructions. sandbox mode.

hope this helps and thanks again for the great work!

Link to comment
Share on other sites

Could someone create me some Icons for KSPI Filter Extensions? I need a Icon for Reactors, Radiators and Microwave Equipment

- - - Updated - - -

Version 1.0.5 for Kerbal Space Program 1.0.2

Released on 2015-05-04

  • Magnetic Nozzle now scales from (original low) ISP to 100 times its Minimum ISP
  • Improved Megawatt buffering for Gas Core Reactor and Molten Salt Reactor
  • Improved stability Power in relation with Fusion Reactors
  • fixed Tweakscale Magnetic Nozzle
  • Improved integration with Filter Extension

- - - Updated - - -

The Magnetic Nozzle now finally has an edge over other propulsion engines, namely very High Isp. This could theoretically send you to another solar system on a Realistic scale!

The control is similar to the Vista Engines, you start with High Isp at very low thrust and gradually get Higher Isp

- - - Updated - - -

@ Freethinker: Thanks for maintaining and improving this mod. played with it in 23.5, it's good to see it's still going.

hit a few bugs (i think). reactors won't always properly connect to attachment nodes. and in a test flight the Vista engine does explode upon ignition.

stock install save the mods in the installation instructions. sandbox mode.

hope this helps and thanks again for the great work!

Next Patch will adres the Vista Engine

- - - Updated - - -

testing 1.0.4:

Reactors do not deplete any fuels. Example: depleated uranium doesn't increase & uranium doesn't decrease, Antimatter won't decrease.

Alcubierre Drive is currently showing up as a fuel tank

Sethlon reactors & phased array microwave transmitters still have bad connection nodes (easy enough to edit for further testing)

Thanks for the report

- - - Updated - - -

I noticed that in sandbox mode, you were able to give antimatter reactors or antimatter initiated reactors their fuel without having to go through the painful process of collecting it, but in the newest version this is removed. Is this intentional? I can see removing it for career/science mode, but I always thought of sandbox as a "play without constraints and test craft" type of thing.

I think I have a solution for this. The resource will be non tweakable but in Sandbox mode it will start filled.

Edited by FreeThinker
Link to comment
Share on other sites

I noticed this mod caused a lot of empty research nodes because they are handled by tweakscale now instead of actually being unlocked.

You might want to look around how mechjeb handles this,

so you don't have to make a modified version of the community tech tree mod and update it regularly.

Also people view it as odd and start searching for bugs and other issues.


@PART[microwaveThermalEnergyReceiver*]:NEEDS[CommunityTechTree]:FOR[WarpPlugin]
{
@TechRequired = [COLOR=green]microwave[/COLOR]PowerTransmission
}
@PART[phasedArray1]:NEEDS[CommunityTechTree]:FOR[WarpPlugin]
{
@TechRequired =[COLOR=green]microwave[/COLOR]PowerTransmission

Edited by Neouni
Link to comment
Share on other sites

I noticed this mod caused a lot of empty research nodes because they are handled by tweakscale now instead of actually being unlocked.

You might want to look around how mechjeb handles this,

so you don't have to make a modified version of the community tech tree mod and update it regularly.

Also people view it as odd and start searching for bugs and other issues.

Yes, I have seen it too. I have already fixed it. I will upload in a few minutes

Edited by FreeThinker
Link to comment
Share on other sites

Maybe I'm doing something wrong, but three things occured with the plasma thruster when i just tested it

1. Liquidfuel won't work as a fuel

2. It wouldnt go above ~12 GW, even with an antimatter reactor attached

3. "Quantumvacuum" propellant doesnt work for me, vacuumplasma was always 0 even in space

Link to comment
Share on other sites

Liquidfuel is a low performance chemical which is the equivalent of Kerosine, and it won't work in any KSPI Engine. Beside realism issues, the propellant is impossible to balance with other propellants. Use any of propellants I have added support of.

Edited by FreeThinker
Link to comment
Share on other sites

Allthough not impossible, it would become a whole lot easier if you have tweakscale installed. If you have problem that too many (stock) part become Tweakable, you can simple disable it by removing/renaming the Squad_Tweakscale.cfg from GameData/TweaksScale/patches.

Link to comment
Share on other sites

Just wanted to expand on issues with the plasma thruster already mentioned.....

Maybe I'm doing something wrong, but three things occured with the plasma thruster when i just tested it

1. Liquidfuel won't work as a fuel

2. It wouldnt go above ~12 GW, even with an antimatter reactor attached

3. "Quantumvacuum" propellant doesnt work for me, vacuumplasma was always 0 even in space

There is no scaling of power output from plasma thruster, a 1.25m and a 5m thruster both have the same thrust, isp and max. power handling ie 12500MW.

And there is no option to switch to Quantumvacuum as a propellent in atmosphere or in space.

Oh and Freethinker I love you and want to have your kerbals. Seriously though big thanks for all your work

Link to comment
Share on other sites

I thought I'd just update the textures to the .dds format myself, and upload them here. There is an issue with some engines though, the game got stuck when loading a cfg that belonged to them. It most likely has something to do with the textures, problem is, I don't always know which textures. There might also be another way to fix it besides not converting the textures, and it just seemed like the best idea to hand it 'as is' to you so you could hopefully fix it yourself.

Memory usage is low: with only this mod installed just over 2 GB in the VAB with full settings, and with the half-res setting enabled at about 1,6 GB, so yeah... best change ever :wink:

Oh, almost forgot the link to the dropbox file: https://www.dropbox.com/s/08ps5n4axoyvh1f/KSPI%20Extended%20in%20DDS.zip?dl=0

Edit: Ok, so the loading problems can be fixed by not converting the textures that belong to those parts. So I managed to fix all but the aluminum hypbrid engine, since that one is just a .cfg file and I have no clue what textures it uses.

Edited by FunnyBunny14
Link to comment
Share on other sites

I thought I'd just update the textures to the .dds format myself, and upload them here. There is an issue with some engines though, the game got stuck when loading a cfg that belonged to them. It most likely has something to do with the textures, problem is, I don't always know which textures. There might also be another way to fix it besides not converting the textures, and it just seemed like the best idea to hand it 'as is' to you so you could hopefully fix it yourself.

Memory usage is low: with only this mod installed just over 2 GB in the VAB with full settings, and with the half-res setting enabled at about 1,6 GB, so yeah... best change ever :wink:

Oh, almost forgot the link to the dropbox file: https://www.dropbox.com/s/08ps5n4axoyvh1f/KSPI%20Extended%20in%20DDS.zip?dl=0

Edit: Ok, so the loading problems can be fixed by not converting the textures that belong to those parts. So I managed to fix all but the aluminum hypbrid engine, since that one is just a .cfg file and I have no clue what textures it uses.

That aluminium pulls the stock SRB texture (I think the RT-10)

Link to comment
Share on other sites

Well, I tried converting everything again, and for some reason it worked this time. Strange.

Anyway, everything is now converted, and loading doesn't get stuck. I used the dds converter from @Lilleman by the way (http://forum.kerbalspaceprogram.com/threads/98672-WIN-KSP-to-DDS-texture-converter)

It is simple to use, and works really well.

The link to the working conversion: https://www.dropbox.com/s/vdzu8o7rfa4oqb3/KSPI-E%20dds%20conversion.zip?dl=0

I think I may have somehow messed up the compressed and the non-compressed files. I was playing around with the different options the first time, but I am now using non-compressed, for all, with 100% certainty.

Edited by FunnyBunny14
Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...