Jump to content

Change The Sun dynamics back!


Recommended Posts

Change The sun dynamics back please, or at least make it an option! I don't like the fact that the shadows and sun just Jerk around (Look like they move at 2 fps) In time warp! I Like it the old way, when it was smooth!   ;.; 

Link to comment
Share on other sites

Suppose I should drop my support in here since my latest post history :) 

Nice to know I'm not the only one a bit disappointed by this change and the developmental philosophies behind it

On 6/8/2017 at 5:33 AM, stibbons said:

The devblog discussing this change just went up today, and is pretty interesting reading.

Seeing as the jerkiness in time warp was an intended tradeoff to ensure better shadows, and there's an implied better fix coming with a Unity engine update, it seems unlikely there'll be any change until that update.

I agree with this however, I doubt it would be reverted or changed before the unity update

Link to comment
Share on other sites

So what Im hearing is yet another "update" caused a degradation in quality, with an vague implication that it would be "fixed" or "improved" at a later update.

Gawd these blinking updates...

If the updates keep coming at this pace and pevel of impact, I am never going to play KSP again.

That not a "Im boycotting KSP!!" comment, its a practical one. I've played unfinished KSP, 100s of hours of it. Then it was released at v.1.0 and I played it some more. Until wheels we're completely screwed up by a big "update". And since then it has remained in a perpetual state of "just wait until the next update fixes things". Yes, I know 1.2.2 (or whichever) has been the most stable and feature-complete version, but Im still waiting for fixes and updates and yet more fixes for the updates. And now a new unity version? Call me pessimistic but if that doesnt break some more stuff, I'll eat my hat. Figuratively.

I just cant bring myself to really get back into KSP for another few hundred hours whilst it is still being fixed. And it IS still being fixed. Im understanding of the complexity of defeating all known bugs, but why introduce more?!

/rant

Link to comment
Share on other sites

This issue was mentioned in the latest KSP Weekly, quote provided below for convenience.

Quote

Furthermore, we did some bug fixing for 1.3.1 including, but not limited to: a change to the camera clipping pane, so we don’t have to see what Kerbal’s have been eating for breakfast when you zoom right in on them, and the addition of a KSC building shadow shader fix to the SPH/VAB scenes. We also fixed the alignment of settings in some UI elements, as well as a problem in 1.3 with vessels that have fuel lines or struts inside fairings exploding on launch. Similarly, we applied a better fix for sun shadows so the shadow flickering remains reduced (as it is in 1.3), but restored the sun motion across the sky to be as smooth as it was before 1.3. On top of that, we added a long requested “Control from Here” action groups to Wheel motors, steering and Docking Ports, as well as to External command seats (and action group).

The KSP Weekly post in question:

 

Link to comment
Share on other sites

What bugs me is the fact I still run into the famous "Cannot deploy while stowed" issue with stuff like solar panels and landing gear that is affixed to the OUTSIDE of cargobays...atleast I did in 1.2.2, no clue if its in 1.3 as ive not had a whack at it, waiting for mods to catch up lol. Shadows ive not noticed

time 20:14:30

Edited by AlamoVampire
Link to comment
Share on other sites

On 6/18/2017 at 8:48 AM, rob593 said:

This issue was mentioned in the latest KSP Weekly, quote provided below for convenience.

The KSP Weekly post in question:

 

Correct. It is fixed for the upcoming patch release whilst still retaining the shadow fix.

Link to comment
Share on other sites

On 13/06/2017 at 2:42 PM, The Aziz said:

This is the curse of development. It's even told in rhymes.

HTisMpC.jpg

/out

In my own personal development world I have just eliminated a massive memory leak without making any new bugs so I am REALLY happy. Of course then I tried to improve the options that can be sent over the serial and speed up the main loop and it failed to run and produced no error code so I may have to either roll that one back or put in debug code to see where it either stops or loops.

But the memory leak is gone! That has been bugging (Ba-Dum-Tish!) me for about two months.

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...