severedsolo

[1.7.1+] Earn Your Stripes 2.2 (16/06/2019) - Allowing Kerbals to earn an Orange Suit since 2017

Recommended Posts

Good day,

what version for RO/RP-0 KSP 1.2.2 should I be using for this awesome mod? Sorry if its already been said... its late and I'm tired... 

Reason I ask is that I know some mods work just fine when they're upgraded to KSP 1.3.0 and may even have further fixes than their KSP 1.2.2 counterparts.

Thanks,
CM

Edited by Calvin_Maclure

Share this post


Link to post
Share on other sites
On 15/12/2017 at 2:14 AM, Calvin_Maclure said:

Good day,

what version for RO/RP-0 KSP 1.2.2 should I be using for this awesome mod? Sorry if its already been said... its late and I'm tired... 

Reason I ask is that I know some mods work just fine when they're upgraded to KSP 1.3.0 and may even have further fixes than their KSP 1.2.2 counterparts.

Thanks,
CM

My apologies, for some reason I have stopped receiving email notifications for this thread, or I missed them.

Anyway: The first version of this mod was compiled against 1.3.0, there has never been a 1.2.2 version I am afraid. You are of course welcome to try one of the 1.3.0 builds (EarnYourStripes 1.1.1 was the last one of those) but this is entirely at your own risk and will void your warranty.

On 23/12/2017 at 10:28 PM, BADATKSP said:

Hey can you add more colours plz or more

More colours to what? The suits? Try this mod

Share this post


Link to post
Share on other sites

The remove existing honours option does not seem to be working for me anymore...

Share this post


Link to post
Share on other sites
On 12/28/2017 at 11:47 PM, severedsolo said:

More colours to what? The suits? Try this mod

I appreciate the plug, my good man.  Thanks!

Share this post


Link to post
Share on other sites
5 hours ago, Errol said:

The remove existing honours option does not seem to be working for me anymore...

Odd. It's working ok for me, and I've not made any changes. Log and save please.

5 hours ago, Cetera said:

I appreciate the plug, my good man.  Thanks!

You deserve it. Your suits are amazing!

Share this post


Link to post
Share on other sites

https://www.dropbox.com/sh/67e9s55pqpxu68g/AACQaDu1CeSCo-D19kZaqRGIa?dl=0

@severedsoloI noticed that the option actually works in a new sandbox save, but new career saves it does not work...

EDIT: The problem now seems intermittent. I am creating lots of new saves as I continue to install mods and test for stability, and I just created a career save where the option worked. 

Edited by Errol

Share this post


Link to post
Share on other sites
3 hours ago, Errol said:

I noticed that the option actually works in a new sandbox save, but new career saves it does not work...

Well thats frustrating. I can see it's skipping the removal, but the log doesn't tell me why.

Please download this build and replace the existing dll. I've turned on some extra logging so please reproduce and file the log again.

Please also make sure you are restarting KSP before starting a new save (EYS will start the first time you go to the Space Centre and continue to run in the background, it may be a first load problem)

Share this post


Link to post
Share on other sites

Honestly, it has only happened twice as far as I can remember, the second time being when I posted. Now I am about to actually start playing and do less new save creation. I will use that .dll, and if I do create any new saves and see the problem again, I will grab the log and post it for you. 

(This also means I will finally be play testing the orbital decal feature you made for kessler syndrome...)

EDIT: Well, it happened again on the very next try in sandbox. Updated the log files and save in that dropbox, here's the link again anyway:

https://www.dropbox.com/sh/67e9s55pqpxu68g/AACQaDu1CeSCo-D19kZaqRGIa?dl=0

EDIT2: Wait a minute......I may have forgotten to change the option in that last one.....ooops......

Edited by Errol

Share this post


Link to post
Share on other sites
9 hours ago, Errol said:

EDIT2: Wait a minute......I may have forgotten to change the option in that last one.....ooops......

Yeah, the log says they pass every test except StripHonours On - so I'm gonna guess that was the issue :P if you do get it to happen again just re-provide and give me a poke please.

Share this post


Link to post
Share on other sites

PSA:

14 hours ago, UomoCapra said:

We are excited for the 1.4 release and look forward to the launch of the Making History Expansion next week. For our mod creators, please note an additional update 1.4.1 will come alongside that release and will need to be integrated as well.

None of my mods will be updated for 1.4, I will wait for the 1.4.1 release next week. At this point of time I don't know if any of them work and no support will be offered to users running 1.4.

Share this post


Link to post
Share on other sites

Earn Your Stripes 1.4.0 Released

  • Updated for KSP 1.4.1
  • Added debug mode (will turn on extra logging if you have a problem)
  • Added option to use the Vintage Suits by default (requires Making History)

Share this post


Link to post
Share on other sites

This mod is probably on of the tinyiest I've seen so far, but the effect is HUGE.

It's like chatterer. Makes you identify with your small green friends :D

Thanks.

Share this post


Link to post
Share on other sites

Does this mod work with KSP v1.4.1, and is it still maintained, so that it will be updated to be compatible with KSP v1.4.2?

Share this post


Link to post
Share on other sites
7 hours ago, GJNelson said:

Does this mod work with KSP v1.4.1, and is it still maintained, so that it will be updated to be compatible with KSP v1.4.2?

It works perfectly fine

 

Share this post


Link to post
Share on other sites
8 hours ago, GJNelson said:

Does this mod work with KSP v1.4.1

Yes

8 hours ago, GJNelson said:

is it still maintained

The last update was only a month ago, what makes you think it isn't maintained?

8 hours ago, GJNelson said:

so that it will be updated to be compatible with KSP v1.4.2?

It's already compatible with 1.4.2 (and probably will work fine in 1.4.3 too), it just happens that I built it against 1.4.1 at the time, so that's what the OP and AVC files say.

Edited by severedsolo

Share this post


Link to post
Share on other sites
1 hour ago, severedsolo said:

Yes

The last update was only a month ago, what makes you think it isn't maintained?

It's already compatible with 1.4.2 (and probably will work fine in 1.4.3 too), it just happens that I built it against 1.4.1 at the time, so that's what the OP and AVC files say.

Goofed in my post, the first version was supposed to be 1.4.2 also, and thanks for the answer. CKAN hasn't updated yet that it works for KSP v1.4.2, so I wanted to be sure before I force CKAN to download the mod.

I love the idea of this mod. Thank you for creating and sharing!

Share this post


Link to post
Share on other sites

Heads up - updates and support are going to be slow for the forseeable future:

A moment of silence please. My venerable old desktop has finally died. The indications are that it's a critical hardware failure (I'm suspecting motherboard, but it might be the CPU too - it's definitely something critical anyway). Sadly this machine is a second generation i5 so the chances of getting a replacement component are next to zero. Which means I need to build a new PC, but don't have the money right now (and likely won't until September). RIP old friend, you've been a very faithful companion.

For users of my mods: this means that updates are going to be a bit sparse going forward until I can scrape the money together to replace it.

I have a machine I can use as a backup, but it's my wifes main computer, which means I probably won't be able to get on it that much (she's a writer). My other alternative is a very slow netbook that definitely won't play KSP.

Share this post


Link to post
Share on other sites
On 4/19/2018 at 12:30 AM, severedsolo said:

Heads up - updates and support are going to be slow for the forseeable future:

A moment of silence please. My venerable old desktop has finally died. The indications are that it's a critical hardware failure (I'm suspecting motherboard, but it might be the CPU too - it's definitely something critical anyway). Sadly this machine is a second generation i5 so the chances of getting a replacement component are next to zero. Which means I need to build a new PC, but don't have the money right now (and likely won't until September). RIP old friend, you've been a very faithful companion.

For users of my mods: this means that updates are going to be a bit sparse going forward until I can scrape the money together to replace it.

I have a machine I can use as a backup, but it's my wifes main computer, which means I probably won't be able to get on it that much (she's a writer). My other alternative is a very slow netbook that definitely won't play KSP.

Just dealt with that same situation there...Gigabyte was gracious enough to allow me to RMA my motherboard and then they provided me with a "nothing wrong in multiple configurations" statement. I haven't hooked it up again but instead went ahead and bought a new board and CPU. Make sure you do the paper clip test to verify that the power supply isn't the culprit also. If it isn't booting or powering on at all it could just be the motherboard and thankfully many motherboards are capable of supporting older chips IF you need it.

 

Paper clip test video:

Spoiler

 

 

Edited by reschke

Share this post


Link to post
Share on other sites

Are World Firsts only tracked if they're selected as a promotion criteria? Only my first orbital Kerbal (both low and high orbits achieved) doesn't have that flag set in the save file. I'm going to be switching my options so that becomes a criteria, presumably it's as simple as deleting the word "false" and substituting the word "true" to correct the log?

May your computer get repaired/replaced with the minimum of fuss and expense.

Share this post


Link to post
Share on other sites
5 hours ago, JH4C said:

Are World Firsts only tracked if they're selected as a promotion criteria? Only my first orbital Kerbal (both low and high orbits achieved) doesn't have that flag set in the save file. I'm going to be switching my options so that becomes a criteria, presumably it's as simple as deleting the word "false" and substituting the word "true" to correct the log?

Yes it only tracks it if the option is turned on in the settings, and it is as simple as switching the "false" to "true" to correct it.

HOWEVER - even with that option turned on, the first orbit is a slightly special case. See, to stop the minor world firsts from being recorded, I have set it so that flag will only go true if the kerbal has achieved orbit at least once. KSP doesn't record the orbit in the Kerbals flight log until after the world first has fired, so kerbals don't actually get credit for the first orbit.

The workaround is to make sure the first kerbal to achieve orbit is also the first kerbal to return from orbit.

Edited by severedsolo

Share this post


Link to post
Share on other sites

Thanks for the info; I've not done anything since their orbital mission, so I may see if I still have a quicksave of them in space. If not, then they'll just have to go back!

ETA: I did still have a quicksave of the mission in progress, just after I made my de-orbit burn. Still gained World First credits for launch, orbit, splashdown, landing, and recovery! I even managed to pick up a couple of extra science points I must have missed the first time through, which was nice.

Edited by JH4C

Share this post


Link to post
Share on other sites
6 hours ago, severedsolo said:

The workaround is to make sure the first kerbal to achieve orbit is also the first kerbal to return from orbit.

There are ways to retroactively ensure this. Just ask the russians..

Share this post


Link to post
Share on other sites

EarnYourStripes 1.5 Released

  • Added ability to edit all aspects of starting kerbals (Name, Gender, Stupidity/Courage, Class, BadS)
  • Added ability to randomly generate starting kerbals
  • Recompiled against 1.4.3

Note these features are off by default and need to be turned on in the difficulty settings. If using on an existing save, all kerbals currently available in your roster will be assumed to be your "starting kerbals".

Also, AVC will not inform you about this update. I re-arranged my Git environment, because it was ridiculous that I needed to create a new solution everytime I reinstall Windows. By doing this I had to break the existing paths to the online version file. Normal service will be resumed from the next update.

Edited by severedsolo

Share this post


Link to post
Share on other sites

has anyone tried this on 1.5.x yet? 

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.