Jump to content

[1.9.x] Toolbar Continued - Common API for draggable/resizable buttons toolbar


Recommended Posts

1 hour ago, merlinux said:

Newly switched to ckan (yes it took me that long) and after upgrading toolbar was missing. 

Came here reading the changelog then I installed unblur and everything is ok.

So not sure if its a feature missing from ckan or some dependency missing in the updated pkg, but if you upgrade toolbar through ckan dont forget to install unblur!

Refresh your CKANCKAN was updated this morning, but for some reason it didn't take.  I just forced a rebuild, and it's now there, so you should be good moving forward

 

Link to post
Share on other sites
1 hour ago, merlinux said:

Newly switched to ckan (yes it took me that long) and after upgrading toolbar was missing. 

Came here reading the changelog then I installed unblur and everything is ok.

So not sure if its a feature missing from ckan or some dependency missing in the updated pkg, but if you upgrade toolbar through ckan dont forget to install unblur!

For some reason the changes to dependency info in the Toolbar.netkan are not reflected in the Toolbar-1.7.19.ckan?
So the dependency didn't get automatically installed by CKAN as it normally should.

As already noted, the workaround is to explicitly ask CKAN to install unBlur, which will fix the problem.

Sniped!

 

Edited by cakepie
sniped
Link to post
Share on other sites
4 hours ago, Gordon Dry said:

Version file of latest release still says

  "KSP_VERSION": {
    "MAJOR": 1,
    "MINOR": 5,
    "PATCH": 1
  },
  "KSP_VERSION_MIN": {
    "MAJOR": 1,
    "MINOR": 5,
    "PATCH": 1
  } 

So is it only KSP 1.7.1 or backwards compatible as well?

I suppose it will be backwards compatible, as long as unBlur is also available.

Link to post
Share on other sites
1 hour ago, linuxgurugamer said:

Refresh your CKANCKAN was updated this morning, but for some reason it didn't take.  I just forced a rebuild, and it's now there, so you should be good moving forward

 

no worries ;) was just letting people know in case they were wondering where their toolbar had gone. All that in the improbable scenario that they'd missed the big red letters in the changelog heh heh

Edited by merlinux
Link to post
Share on other sites
34 minutes ago, merlinux said:

no worries ;) was just letting people know in case they were wondering where their toolbar had gone. All that in the improbable scenario that they'd missed the big red letters in the changelog heh heh

and on the front page :D

 

Link to post
Share on other sites
  • 2 weeks later...
5 hours ago, Tonka Crash said:

@linuxgurugamer Now that you have unBlur as a dependency, would you consider configuring this toolbar to scale with the master game UI scale setting.

Probably not.  The main issue is that the icons are 24x24, and won't look better if scaled up too much.  Besides, I'm rather busy with some bug fixes and enhancements to other mods

Link to post
Share on other sites
1 hour ago, Meta Jonez said:

So ToolbarController is not a req of this mod?  Damned odd, because I couldn't see the Toolbar until I installed the Controller.  

No, but the unBlur is a requirement.

Link to post
Share on other sites
  • 2 weeks later...
  • 3 weeks later...

BETA RELEASE 

  • Re-enabled the InstallChecker
  • Added button scaling (currently on a per-screen basis)
  • Added BigTexturePath for larger icons (better resolution)
  • Added window to control scaling
  • Added scaling to go along with the stock UI and stock UI APP scaling
  • Removed the hard dependency on the unBlur mod.  It will use the unBlur if it's installed, otherwise will read the file

There is a simultaneous release of the ToolbarController to support this

https://github.com/linuxgurugamer/ksp_toolbar/releases/tag/1.7.20

 

Edited by linuxgurugamer
Link to post
Share on other sites

Am having an issue where whenever I assign icons to folders on the toolbar, they immediately get reset whenever the scene changes. Seems to still happen even if I try setting the toolbar settings file to read only. Any idea what the issue is? The mod's working beautifully otherwise.

Link to post
Share on other sites
7 hours ago, baldamundo said:

Am having an issue where whenever I assign icons to folders on the toolbar, they immediately get reset whenever the scene changes. Seems to still happen even if I try setting the toolbar settings file to read only. Any idea what the issue is? The mod's working beautifully otherwise.

Never having used folders with the mod, can you be a bit more specific? 

Are you using the new beta?

Link to post
Share on other sites
2 hours ago, linuxgurugamer said:

Never having used folders with the mod, can you be a bit more specific? 

Are you using the new beta?

When you create a folder, you have the option to choose an icon for it instead of the default folder icon (and it automatically provides a selection of different icons to choose from from your GameData folder).

It seems like it's supposed to get saved in the settings file at the bit where it says e.g.:

folder_58587545
				{
					texturePath = 000_Toolbar/folder

but it always seems to get immediately reset upon scene change

 

And I'm using version 1.7.17.15 downloaded from CKAN - although I'm pretty sure this is a longstanding problem. I remember similar issues when I last played KSP probably years ago.

Link to post
Share on other sites

New release, 1.7.20

  • Re-enabled the InstallChecker
  • Added button scaling (currently on a per-screen basis)
  • Added BigTexturePath for larger icons (better resolution)
  • Added window to control scaling
  • Added scaling to go along with the stock UI and stock UI APP scaling
  • Removed the hard dependency on the unBlur mod.  It will use the unBlur if it's here, otherwise will read the file

Be sure to install the updated ToolbarController 

Link to post
Share on other sites

@linuxgurugamer

for some reason, when i update to the newest toolbarcontroller, 0.1.8.1, my fps is nosediving from the 80's, down to 15 to 12.

I have run test builds, with various mods and all have same results, when using toolbarcontroller 0.1.7.0 my fps is 'normal' and when updated to 0.1.8.1 it drops to 25% or norm, or roughly 15 to 12 fps...

I have pulled the new version from my builds and am back running on 0.1.7.0 and all is fine again.

Any ideas???

I can send logs if they will help.

cheers.

Link to post
Share on other sites

Just started a new KSP install with 1.7.3 and Toolbar doesn't seem to be able to show .dds icons anymore.

Any Mods that use a .dds file for their icons shows only a purple square on the toolbar.

I can fix this by simply converting the .dds files to png but I'm worried I've screwed something up that will cause me problems later.

The ingame Log reports  "[icon filename] '(Clone)' is not readable, the texture memory can not be accessed from scripts. You can make the texture readable in the Texture Import Settings."

Debug log shows

UnityException: Texture '(Clone)' is not readable, the texture memory can not be accessed from scripts. You can make the texture readable in the Texture Import Settings.
    UnityEngine.Texture2D.GetPixels (Int32 miplevel)
    UnityEngine.Texture2D.GetPixels ()
    Toolbar.LocalTextureScale.ThreadedScale (UnityEngine.Texture2D tex, Int32 newWidth, Int32 newHeight, Boolean useBilinear)
    Toolbar.LocalTextureScale.Bilinear (UnityEngine.Texture2D tex, Int32 newWidth, Int32 newHeight)
    Toolbar.Button.get_Texture ()
    UnityEngine.Debug:LogException(Exception)
    Toolbar.Log:log(LogLevel, Exception, String, Object[])
    Toolbar.Log:error(Exception, String, Object[])
    Toolbar.Button:get_Texture()
    Toolbar.Button:get_Content()
    Toolbar.Button:drawInToolbar(Rect, Boolean)
    Toolbar.Toolbar:drawButtons()
    Toolbar.Toolbar:draw()
    Toolbar.ToolbarManager:OnGUI()

Have I modified something I shouldn't have? (Texture Import Settings) and how do I undo it?

 

 

Link to post
Share on other sites
48 minutes ago, Coyote21 said:

Have I modified something I shouldn't have? (Texture Import Settings) and how do I undo it?

Well, a log file would have helped.

Please make sure you are running the latest version, and then post a log if it happens, also would be helpful to know which mods' icons are giving you the problem

8 hours ago, drtedastro said:

@linuxgurugamer

for some reason, when i update to the newest toolbarcontroller, 0.1.8.1, my fps is nosediving from the 80's, down to 15 to 12.

I have run test builds, with various mods and all have same results, when using toolbarcontroller 0.1.7.0 my fps is 'normal' and when updated to 0.1.8.1 it drops to 25% or norm, or roughly 15 to 12 fps...

I have pulled the new version from my builds and am back running on 0.1.7.0 and all is fine again.

Any ideas???

I can send logs if they will help.

cheers.

Do you have the unBlur mod installed? It's optional now, but when present is supposed to avoid some slowdowns associated with reading files

and yes, logs would help.

Link to post
Share on other sites

OK, sorry thought I was saving some time by only posting, what I thought was the relevant section of my log.

Using version 1.7.20 installed with CKAN, with UnBlur

The mods with icon issues are all the ones using .dds files for icons, but specifically in my case, they are:

  • Action Group Manager
  • Chatterer
  • Quick Exit
  • kOS

I have fixed all but Action Group Manager by simply converting the .dds files to .png files. This is not working for Action Group Manager however.

I have undone my fixes (returned all to original) for this output_log.

output_log.txt avail at https://www.dropbox.com/s/fjyh32dokij2jpv/output_log.txt?dl=0

Let me know if you need anything else.

 

Edited by Coyote21
Needed to recreate output_log file
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...