HaArLiNsH

[1.3.1]TextureReplacerReplaced v0.5.4

Recommended Posts

3 hours ago, Aelfhe1m said:

The heavy duty seat is another model reskin around the KerbalSeat part module.

@HaArLiNsH Programmatically it should be enough to check if the part hosting a Kerbal has the KerbalSeat module.  


if (part.FindModuleImplementing<KerbalSeat>()) {...}

That code snippet needs optimising of course. Better to cache the result after the first check rather than call the search function every time.

Probably less hassle than trying to maintain a list of all the seat parts separately since this will need to be updated whenever a new part mod adds another seat.

Edit: Actually thinking about it there may be an exception needed for KerbalSeat modules that are modelled as enclosed spaces like in the Omicron Space Car mod.

I'll look into this after I found the Lost Tongue  :)

Share this post


Link to post
Share on other sites

Well... I tried several times ejecting my kerbals and the scatterer MM config and I looked on every angle I could....

THE TONGUES ARE GONE !   :o

Share this post


Link to post
Share on other sites
1 hour ago, HaArLiNsH said:

Well... I tried several times ejecting my kerbals and the scatterer MM config and I looked on every angle I could....

THE TONGUES ARE GONE !   :o

Are they critical though?

Share this post


Link to post
Share on other sites
2 hours ago, HaArLiNsH said:

THE TONGUES ARE GONE !   :o

I'm speechless! :P

Although to be honest I've never noticed tongues on Kerbals ever! Guess I've not been paying enough attention.

Share this post


Link to post
Share on other sites

maybe could get an answer from Squad if they had them or not or should and don't..

Share this post


Link to post
Share on other sites

Using the newest TRR+WindowShine combo:

Does the "%colour = 0.5 0.5 0.5" value actually affect the reflective-ness anymore? I'm trying to dial down the glare so it's somewhat less than high-gloss liquid-metal but it's not making any changes.

The front two cockpits have values set to [.05 .05 .05] and the one in the back is [.5 .5 .5].

2VbwJHW.jpg

Edited by Beetlecat

Share this post


Link to post
Share on other sites

I'm guessing this mod isn't ready yet? I'm not sure if the old texture replacer still works for 1.3

Share this post


Link to post
Share on other sites
32 minutes ago, sardia said:

I'm guessing this mod isn't ready yet? I'm not sure if the old texture replacer still works for 1.3

This is with the new TRR(eplaced) and the latest windowshine.

Share this post


Link to post
Share on other sites
3 hours ago, sardia said:

I'm guessing this mod isn't ready yet? I'm not sure if the old texture replacer still works for 1.3

It works quite well for me.

Share this post


Link to post
Share on other sites
6 hours ago, sardia said:

I'm guessing this mod isn't ready yet? I'm not sure if the old texture replacer still works for 1.3

This mod works "like a charm" now (normally) :)

It's still in a prerelease state because there will be more features soon.

 

7 hours ago, Beetlecat said:

Using the newest TRR+WindowShine combo:

Does the "%colour = 0.5 0.5 0.5" value actually affect the reflective-ness anymore? I'm trying to dial down the glare so it's somewhat less than high-gloss liquid-metal but it's not making any changes.

The front two cockpits have values set to [.05 .05 .05] and the one in the back is [.5 .5 .5].

 

Do you mean the line the @default.cfg? 

I'm not sure if it is still in use now. If not, it will come back soon, when I make the config window gui where you will be able to configure your texture and reflection color ingame :)

Otherwise, I'm sure @Ger_space , aka Reflection and Shader Master will be able to tell us more on this.

 

 

As for the tongue, I'm nearly sure there were there before the female body, the old head textures had the a place for the tongue, and they removed it because they couldn't find a proper solution to map from the texture file. The female head texture don't have the place for the teeth neither the tongue.

Well ok, I won't loose time on this :)

 

Edited by HaArLiNsH

Share this post


Link to post
Share on other sites
10 hours ago, Beetlecat said:

Using the newest TRR+WindowShine combo:

Does the "%colour = 0.5 0.5 0.5" value actually affect the reflective-ness anymore? I'm trying to dial down the glare so it's somewhat less than high-gloss liquid-metal but it's not making any changes.

The front two cockpits have values set to [.05 .05 .05] and the one in the back is [.5 .5 .5].

Is it possible to set the alpha channel of the _Color value? Something like [1 1 1 0.05], because this should affect the reflectiness more than the rgb values, which only affect the tint of the reflections in a small way.

In fact I'm more than suprised that the part did't turn out near black. 

 

Edited by Ger_space

Share this post


Link to post
Share on other sites
1 hour ago, smotheredrun said:

Weren't tongues and teeth visible in 1.2.2? Or have I been hallucinating them?

Ah ! It seems I'm not the only who freak out :)

Share this post


Link to post
Share on other sites

 

4 hours ago, Ger_space said:

Is it possible to set the alpha channel of the _Color value? Something like [1 1 1 0.05], because this should affect the reflectiness more than the rgb values, which only affect the tint of the reflections in a small way.

In fact I'm more than suprised that the part did't turn out near black. 

 

6 hours ago, HaArLiNsH said:

Do you mean the line the @default.cfg? 

I'm not sure if it is still in use now. If not, it will come back soon, when I make the config window gui where you will be able to configure your texture and reflection color ingame :)

Otherwise, I'm sure @Ger_space , aka Reflection and Shader Master will be able to tell us more on this.

The values are in the WindowShineTR-v13.2.cfg that's been dropped in the TRR folder. Here's the one for the Mark 1 cockpit:

@PART[Mark1Cockpit]:HAS[!MODULE[TRReflection]]:NEEDS[TextureReplacerReplaced]
{
    %MODULE[TRReflection]
    {
%name = TRReflection
%shader = ShaderNG/TR_Reflective_Emissive_Alpha
%colour = 0.02 0.02 0.02
%interval = 4
%meshes = Cockpit
    }
}

There's no fourth (alpha) value showing here, and setting these values (assuming RGB) to anything did nothing. Commenting the block out switched off the reflection entirely. I'll try adding a fourth value for alpha and see what happens!

Oh, heck! I've posted this in the TRR thread -- sorry!!! :I  I'll still report back though, since shineyness and texture replacing go hand-in-hand. :wink:

Edited by Beetlecat
Gah! Wrong thread.

Share this post


Link to post
Share on other sites
14 hours ago, Beetlecat said:

 

 

The values are in the WindowShineTR-v13.2.cfg that's been dropped in the TRR folder. Here's the one for the Mark 1 cockpit:


@PART[Mark1Cockpit]:HAS[!MODULE[TRReflection]]:NEEDS[TextureReplacerReplaced]
{
    %MODULE[TRReflection]
    {
%name = TRReflection
%shader = ShaderNG/TR_Reflective_Emissive_Alpha
%colour = 0.02 0.02 0.02
%interval = 4
%meshes = Cockpit
    }
}

There's no fourth (alpha) value showing here, and setting these values (assuming RGB) to anything did nothing. Commenting the block out switched off the reflection entirely. I'll try adding a fourth value for alpha and see what happens!

Oh, heck! I've posted this in the TRR thread -- sorry!!! :I  I'll still report back though, since shineyness and texture replacing go hand-in-hand. :wink:

This is the right  thread for this, because TRR must pass the colour value correctly to the shader. I havn't checked the TRR sources yet. I can do this when I'm back home.

 

Share this post


Link to post
Share on other sites
9 hours ago, Ger_space said:

This is the right  thread for this, because TRR must pass the colour value correctly to the shader. I havn't checked the TRR sources yet. I can do this when I'm back home.

Adding the alpha value had no effect. I didn't try removing the %colour line altogether  (also, just wanted to double-check that color/colour might not be an issue?).

There are a couple other funny things, such as seeing the reflection of the back hatch on the inline of the mk1, even though there's a node attached (and the angle would be wrong, besides) and the outline of the cockpit glass through the shadow of the entire craft.

Share this post


Link to post
Share on other sites
12 hours ago, Ger_space said:

This is the right  thread for this, because TRR must pass the colour value correctly to the shader. I havn't checked the TRR sources yet. I can do this when I'm back home.

 

2 hours ago, Beetlecat said:

Adding the alpha value had no effect. I didn't try removing the %colour line altogether  (also, just wanted to double-check that color/colour might not be an issue?).

There are a couple other funny things, such as seeing the reflection of the back hatch on the inline of the mk1, even though there's a node attached (and the angle would be wrong, besides) and the outline of the cockpit glass through the shadow of the entire craft.

I did some testing on this and it appears as though the colour line doesn't seem do anything anymore... beforehand if I wanted to make the reflection weaker I would lower all three numbers (I.E. change all three from 0.8 to 0.2), but now changing them doesn't seem to do anything. I checked very quickly though so I might be off on this conclusion.

 

 

Share this post


Link to post
Share on other sites
8 hours ago, Vorg said:

I thought that setting was for the visors

There's a separate colour config line inside each individual part module. It used to effect the color and intensity of the reflections but it seems to have broken in the most recent release. @Ger_space in all honestly though I don't mind that it doesn't work though lol - I only used it to change intensity without having to edit the part textures again. It's not all too necessary to have imo. @Beetlecat what are your thoughts though?

 

Share this post


Link to post
Share on other sites
1 minute ago, Avera9eJoe said:

There's a separate colour config line inside each individual part module. It used to effect the color and intensity of the reflections but it seems to have broken in the most recent release. @Ger_space in all honestly though I don't mind that it doesn't work though lol - I only used it to change intensity without having to edit the part textures again. It's not all too necessary to have imo. @Beetlecat what are your thoughts though?

My only thought was to be able to give subtle tweaks to different cockpits either by "shade" of the material, or how actually glossy it appeared. :)

Share this post


Link to post
Share on other sites
3 hours ago, HaArLiNsH said:

Hey guys, I was busy as hell this week so  did no followed the last topic, @Avera9eJoe & @Beetlecat does it work now or do you need something different in TRR ?

I think what was discovered is that the "%colour = 0.4 0.4 0.4"  line  does absolutely nothing in the config where parts are assigned their shininess. It's not possible to alter the degree of reflection, nor any sort of hue (as it would imply).

Share this post


Link to post
Share on other sites

Sorry for the newb report. I am using TRR 0.3 as WindowShine does not currently work with 0.4, and I noticed I could not toggle the EVA suit (helmet was off, while on runway), just wondering if it's a 0.3 problem or something else?

Edited by selfish_meme

Share this post


Link to post
Share on other sites
18 hours ago, selfish_meme said:

Sorry for the newb report. I am using TRR 0.3 as WindowShine does not currently work with 0.4, and I noticed I could not toggle the EVA suit (helmet was off, while on runway), just wondering if it's a 0.3 problem or something else?

@Ger_space and @HaArLiNsH I confirm this as well :/ I'm not sure what the cause is though. Since WindowShine is set up properly now though I'm betting you can use it as a test bench to get it working again?

Share this post


Link to post
Share on other sites

@HaArLiNsH 

OK, I finally had some time to look at the issue. The Shader doesn't have a "_ReflectColor" parameter anymore. I need to update the reflection shader, so it is similar to the visor. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.