Starwaster

[1.3.0] Procedural Parts - Starwaster Branch

Recommended Posts

 

5 hours ago, SVS said:

Just wondering is there a stockalike texture available somewhere?

In switchable menu for the parts

Share this post


Link to post
Share on other sites
7 hours ago, SVS said:

Just wondering is there a stockalike texture available somewhere?

Look up "FreedomTex" it has a spaceplane texture. It's what I use for all my remakes and it looks pretty decent.

Share this post


Link to post
Share on other sites

I don't know how much this has to do with PP mod itself, but this message for some reason can't be removed after the game loads, I've tried changing the .version file but that didn't help. Otherwise it works fine in 1.3.1.

mcmRKT9.png

Share this post


Link to post
Share on other sites
5 hours ago, notJebKerman said:

I don't know how much this has to do with PP mod itself, but this message for some reason can't be removed after the game loads, I've tried changing the .version file but that didn't help. Otherwise it works fine in 1.3.1.

mcmRKT9.png

The assembly version itself is what is being checked there. The message cannot be removed without changing the version in the AssemblyInfo file and recompiling the plugin.

Share this post


Link to post
Share on other sites

CKAN does not list this mod for quite some time. Any chances, that this mod will reoccur?

Share this post


Link to post
Share on other sites
6 hours ago, Carraux said:

CKAN does not list this mod for quite some time. Any chances, that this mod will reoccur?

Try:

 

Share this post


Link to post
Share on other sites

When i'm in the SPH or VAB, I set my desired texture for the procedural tank, but when I launch, the tank just turns white. It also happens in custom textures.

Share this post


Link to post
Share on other sites
43 minutes ago, Capt.gelo said:

When i'm in the SPH or VAB, I set my desired texture for the procedural tank, but when I launch, the tank just turns white. It also happens in custom textures.

Not enough information to go by, where's the logs? where's the ModuleManager.ConfigCache file? What KSP version? Did you try just stock KSP + ModuleManager + Procedural Parts? 

Can't do anything without information.

Share this post


Link to post
Share on other sites

I'm working on a new PP Texture pack - basic colors/textures intended to mesh well with stock parts + popular part mods. There are several Normal Maps from old texture packs I want to keep alive , but it looks like MainSailor and Blackheart are completely MIA.

Does anyone know if there's an issue with me repackaging some of their art as long as I give them credit? I can't even look up their licenses anymore.

4Do33Zx.png

Edited by Tyko

Share this post


Link to post
Share on other sites

My texture pack is officially launched  :D      @Starwaster - if you support this mod I'd appreciate you adding it as a compatible mod on your list on page 1

 

 

 

Share this post


Link to post
Share on other sites

Hey just wanted to say been a long time fan of procedural parts and 99% of the time just wait for updates to come out before I bother asking if a certain bug is known. Though for this mod I haven't seen much activity.  Just wanted to know for all that the procedural SRB's are inoperable on the current version of KSP due to the error in placement of the engine bell upon loading of the craft before launching.  Done all my own testing as well as bounced feedback off of friends.  This is the only mod I had downloaded at the time.

Share this post


Link to post
Share on other sites

I'm using Procedural parts in Realism Overhaul and my Procedural SRBs have gimbal locked for pitch, I can only make adjust the yaw and roll. Which is wierd and I'm guessing not a feature. I saw some other people were having this issue as well, is this a known issue and if so does anyone know a fix/workaround for this? 

Share this post


Link to post
Share on other sites
On 8/12/2018 at 5:45 AM, Alistral said:

I'm using Procedural parts in Realism Overhaul and my Procedural SRBs have gimbal locked for pitch, I can only make adjust the yaw and roll. Which is wierd and I'm guessing not a feature. I saw some other people were having this issue as well, is this a known issue and if so does anyone know a fix/workaround for this? 

No it's a definite known bug linked to the model gimbal transform and it started happening when certain changes were made to the stock gimbal code. As far as I can tell, gimbal transforms were not originally axis sensitive. It just served as a point from which part of the model could be rotated. But when gimbal functionality was changed to limit gimbal rotation to certain axes some older engine models broke.

This is something I have fixed locally but the fix has certain graphical glitches in the editor inventory screen where the SRB thumbnail has two visible bells. And that's something that I have suddenly lost the ability to change when I updated the unity editor and it doesn't want to open the mesh scene file anymore. I never got that issue sorted out and didn't want to release it looking crappy like that.

Share this post


Link to post
Share on other sites

Is anyone else experiencing this problem where no other stack decouplers appear in the VAB or SPH when the procedural decoupler is loaded? They appear in the R&D center when I research the nodes, but they are missing from the parts list in the VAB or SPH. After I deleted the cfg for the procedural decoupler, they appear correctly.

Share this post


Link to post
Share on other sites
3 hours ago, lodestar said:

Is anyone else experiencing this problem where no other stack decouplers appear in the VAB or SPH when the procedural decoupler is loaded? They appear in the R&D center when I research the nodes, but they are missing from the parts list in the VAB or SPH. After I deleted the cfg for the procedural decoupler, they appear correctly.

No, that does not sound normal and there's nothing in the mod that does that. At least not in this branch of the mod.

Share this post


Link to post
Share on other sites

any plans to update this to 1.5.1? Also I have many texture who don't work since the 1.2.2. update. (freedom textures). Someone can do something or how can i update this?

Share this post


Link to post
Share on other sites

Stupid question.....possibly....  

Why does the procedural heat shield cost like $14k at 1.25m when the stock one is only $300?  

Sorry if this is addressed somewhere in here but I couldn't find anything.  

Share this post


Link to post
Share on other sites
15 hours ago, Eugene Moreau said:

Stupid question.....possibly....  

Why does the procedural heat shield cost like $14k at 1.25m when the stock one is only $300?  

Sorry if this is addressed somewhere in here but I couldn't find anything.  

I don't know, certainly not due to any decision on my part. Doesn't sound right, does it?

Share this post


Link to post
Share on other sites
On 11/10/2018 at 8:58 AM, Vince_K said:

any plans to update this to 1.5.1? Also I have many texture who don't work since the 1.2.2. update. (freedom textures). Someone can do something or how can i update this?

Look for procedural parts tidal stream branch, link about 10 to 20 post before your question

Share this post


Link to post
Share on other sites
1 hour ago, Dnarbnellih2 said:

Are Mk2 procedural parts possible (like fuel tanks and adapters) from 1.25m to Mk2, or 2.5m to Mk2.

No. You can only build cylindrical or tapered parts.

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.