rsparkyc

[1.2.2] Realistic Progression Zero (RP-0) - Lightweight RealismOverhaul career v0.54 June 15

Recommended Posts

20 minutes ago, Kevin Kyle said:

https://www.dropbox.com/s/pri3dmr6y3qaziw/KKMoonImpactsaves.zip?dl=0

 

There ya go Mat. There is a save in there called Moon Impact Mission if you want to reload it from its current position. Ship Name is "Explorer Impactor" Over in the missions list you can see that the first two requirements are currently met. 

I don't understand Why, but this is what I found:

  1. Fly in to moon at 1x time warp
    • Impact the moon becomes ticked
    • Launch a new vessel becomes un-ticked
  2. Time warp while in KSC
    • Probe flies through moon and in sling shot out of Earth's SOI
  3. Time warp while in Tracking Station
    • Same as 1.
  4. Fly in to moon at 1000x time warp
    • Game reverts to 10x just before impact
    • Big badda boom
    • Contract successful

Share this post


Link to post
Share on other sites
2 minutes ago, MatBailie said:

I don't understand Why, but this is what I found:

  1. Fly in to moon at 1x time warp
    • Impact the moon becomes ticked
    • Launch a new vessel becomes un-ticked
  2. Time warp while in KSC
    • Probe flies through moon and in sling shot out of Earth's SOI
  3. Time warp while in Tracking Station
    • Same as 1.
  4. Fly in to moon at 1000x time warp
    • Game reverts to 10x just before impact
    • Big badda boom
    • Contract successful

OK, fly into the Moon at 1000x it is. I can see I need to boost up the ole testing skills here in Kerbal land. Ive been slacking. lol Thanks for looking at that. If you figure out why it does that, that would be great and feel free to report that to the proper person, whoever that is. :)

Share this post


Link to post
Share on other sites
Just now, Kevin Kyle said:

OK, fly into the Moon at 1000x it is. I can see I need to boost up the ole testing skills here in Kerbal land. Ive been slacking. lol Thanks for looking at that. If you figure out why it does that, that would be great and feel free to report that to the proper person, whoever that is. :)

It's because it is broked...

Share this post


Link to post
Share on other sites

New release?

I was wondering whether there could be a new release of the main branch soon. - It is >200 committs ahead of the current release, and I am sure there are some great bugfixes in there.

I could imagine quite a few reasons why it shouldn't be release, but I am just wondering whether there actually is a problem or whether you are just waiting for the perfect.

Thanks!

Gustav

 

Share this post


Link to post
Share on other sites

Btw, if anyone of you experiences massive performance issues with RP-0, try to disable the build time and launch your craft directly from the VAB.

My game speed was basically halved because of a KSP bug where performance gets worse when you launch a ship from the KSC (not sure about tracking station and swithcing).

Share this post


Link to post
Share on other sites

SO how do you all deal with electric power consumption? Do you use the old calculator and do the math to figure out if you have enough electric or do you use one of the 2 addons for that? Same thing for communication distances, how do you deal with that as well? Currently Im just doing what the tutorials say and not worrying about such things but I can see I will have too sooner or later.

Share this post


Link to post
Share on other sites

Hey, alot of Raidernicks probes , his Vostok and Voskhod pods, and all the FASA pods are not showing due to a bug in this mod. Once I removed RP all parts showed in VAB as required. I think there is a config in the RP blocking command pods. I havn'nt figured out which file was screwing around with the pods. It seems to be some conflict in the tech tree as I had to actually hand-type the pods name in the persistient save file where the tech tree is saved. RP was failing to include the pods to begin with. Placing the pods in the save file still yields no parts in VAB, but Ill leave that part up to you as I dont have time to fiddle around much. Cheers

Share this post


Link to post
Share on other sites
8 hours ago, lextacy said:

Hey, alot of Raidernicks probes , his Vostok and Voskhod pods, and all the FASA pods are not showing due to a bug in this mod. Once I removed RP all parts showed in VAB as required. I think there is a config in the RP blocking command pods. I havn'nt figured out which file was screwing around with the pods. It seems to be some conflict in the tech tree as I had to actually hand-type the pods name in the persistient save file where the tech tree is saved. RP was failing to include the pods to begin with. Placing the pods in the save file still yields no parts in VAB, but Ill leave that part up to you as I dont have time to fiddle around much. Cheers

There is a conflict with AmpYear that breaks the loading of theses objects
Remove it and all pods and avionics should be available in the VAB.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now