Jump to content

[WIP][1.8.1, 1.9.1, 1.10.1, 1.11.0–2, 1.12.2–4] Principia—version Ἱπποκράτης, released 2022-11-23—n-Body and Extended Body Gravitation


eggrobin
 Share

Recommended Posts

Hm... but i still have problem. With config game starts, but when i switch to some ship and press "M" to go to map view, game crash.

I thought,, that problem is somewhere in old trajectories stored in old save, so i created new profile and start completely new carier, but result is the same.

This is in principia log:

Log file created at: 2021/12/19 11:27:10
Running on machine: MSI
Log line format: [IWEF]mmdd hh:mm:ss.uuuuuu threadid file:line] msg
E1219 11:27:10.705547 17960 interface.cpp:702] Initialized Google logging for Principia
E1219 11:27:10.707542 17960 interface.cpp:703] Principia version 2021120408-Hamilton-0-gd0f59ca12318ef52bff4ee83615a2e1851f719a1 built on 2021-12-05T18:18:20Z by Microsoft Visual C++ version 192930037 for Windows x86-64
E1219 11:27:10.707542 17960 interface.cpp:716] Base address is 00007FFC75DB0000
E1219 11:27:10.714525 17960 ksp_plugin_adapter.cs:322] Unexpected KSP version 1.12.3; this build targets 1.8.1, 1.9.1, 1.10.1, 1.11.x, and 1.12.2.
E1219 11:27:34.330938 17960 ksp_plugin_adapter.cs:322] Unexpected KSP version 1.12.3; this build targets 1.8.1, 1.9.1, 1.10.1, 1.11.x, and 1.12.2.
E1219 11:27:45.593734 17960 ksp_plugin_adapter.cs:322] Unexpected KSP version 1.12.3; this build targets 1.8.1, 1.9.1, 1.10.1, 1.11.x, and 1.12.2.
    @   00007FFCDA2F443F      google::LogMessageFatal::~LogMessageFatal [0x00007FFCDA2F443E+46]
    @   00007FFC75E5EE93      principia__LogFatal [0x00007FFC75E5EE92+322]
    @   00000241E9CBCEA9      (No symbol) [0x00000241E9CBCEA8]
F1219 11:27:52.760295 17960 gl_lines.cs:25] Exception while drawing lines: System.TypeInitializationException: The type initializer for 'principia.ksp_plugin_adapter.Style' threw an exception. ---> System.ArgumentException: You can only call GUI functions from inside OnGUI.

  at UnityEngine.GUIUtility.CheckOnGUI () [0x00010] in <58f888e0d56a4620958c8e58a768c70d>:0

  at UnityEngine.GUI.get_skin () [0x00001] in <58f888e0d56a4620958c8e58a768c70d>:0

  at principia.ksp_plugin_adapter.Style..cctor () [0x00037] in <1fb8e31093424753b8844b2e63416cf2>:0

   --- End of inner exception stack trace ---

  at principia.ksp_plugin_adapter.PrincipiaPluginAdapter+<>c__DisplayClass139_0.<RenderTrajectories>b__2 () [0x00387] in <1fb8e31093424753b8844b2e63416cf2>:0

  at principia.ksp_plugin_adapter.GLLines.Draw (System.Action line_vertices) [0x0001c] in <1fb8e31093424753b8844b2e63416cf2>:0

 

Link to comment
Share on other sites

BTW: As i did a few test, it looks, that game crash only, when i jump to map view on the ship which has previously cerated some prinkipia trajectory. When trajectory doesn't exist, i can go to map view, create flight plan, execute node. And it works well. But not sure when problems start, looks to me, that problems start when i save and restart game.

Link to comment
Share on other sites

9 hours ago, JeromeHeretic said:

Hm... but i still have problem. With config game starts, but […], game crash.
[…]

From https://github.com/mockingbirdnest/Principia/wiki/Principia-configuration-files#the-principia_override_version_check-configuration:

Quote

Note however that there will be no support whatsoever if the version check is overridden.

 

Link to comment
Share on other sites

Yes, i make in principia directory config file "principia.cfg" with this:

principia_override_version_check {
  version = 1.12.2
  version = 1.12.3
}

Without this config game don't start. This map view crashes happens with this config. So... am i missing something?

EDIT: About "no support when version override" - so simply i must wait for next release of principia, which will be compiled with 1.12.3 libs and that will solve this problem? No problem with that, i can live with 1.12.2...

Edited by JeromeHeretic
Link to comment
Share on other sites

I'm using 1.12.2 and it seems like I have a problem with the skybox. I think what's happening is related to the game never really "getting into space" as it originally does, so the graphical mods (not sure which and where) doesn't kick in to show the skybox background properly when reaching space. Does anyone know how to manually make the skybox visible again? Or if there's any setting I might have to tweak? (is it even a mod thing or is it present in vanilla as well?)

Edited by lodiped
Link to comment
Share on other sites

Hi. I’m currently looking at trying to assemble a custom solar system out of a combination of a few different planet packs’ planets, and am looking to make it principia compatible. Is the only real way to check for that through trial and error in game, or does anyone have any recommendations for other ways to test it. I’m thinking maybe universe sandbox 2 could work?

Link to comment
Share on other sites

  • 2 weeks later...

For the new moon (lunation number 272), the new release (Hardy) is out.

  • Russian localization has been added; thanks to @von Kerman for contributing the translation and answering an endless stream of questions on the grammar of Russian.
  •  An issue has been fixed which led to slow camera rotation in the plotting frame if the active vessel was at a low altitude.
  • A crash has been fixed which would occur when drawing trajectories without the UI having ever been shown since KSP was started.

See the change log for more details.

For the convenience of our Chinese users, the binaries can be downloaded either from Google Drive or from 腾讯微云.

Link to comment
Share on other sites

Just wondering - how would one go about adding axial tilt to a kopernicus body when principia is installed? I’ve been looking around the documentation and GitHub code but can’t seem to find either information or templates to try and base my patch off of. 

Link to comment
Share on other sites

7 hours ago, CessnaSkyhawk said:

Just wondering - how would one go about adding axial tilt to a kopernicus body when principia is installed? I’ve been looking around the documentation and GitHub code but can’t seem to find either information or templates to try and base my patch off of. 

Believe it or not, it's documented.

Link to comment
Share on other sites

24 minutes ago, pleroy said:

Believe it or not, it's documented.

I believe it as I’ve seen that page already - I’m just having some difficulty understanding exactly which values I would need to modify. From what I could glean from it and from the confit file for RSS it looks like it’s something involving the two axis values (axis RA and axis Dec) but I’m not 100% sure how they work. I tried to figure it out best I could before I asked for help, but I’m sorry if asking for some guidance is a problem

EDIT: I think I might be starting to see it. Is it sort of like calculus spherical coordinates with RA being like theta and Declination being like iota?

Edited by CessnaSkyhawk
Calc III ftw
Link to comment
Share on other sites

50 minutes ago, Nicodo123 said:

will it ever be available on CKAN, or are there just too many issues that would come with adding it to it?

CKAN can't do these installation steps for you, or check for them, or notify you about them:

C++ dependencies

If Principia was added to CKAN, users would end up with broken installs due to that.

Link to comment
Share on other sites

I have a problem where in the flight planner my node disappears before the burn is over, also it seems that (and I know this is primarily a Mechjeb question so I'm already going to ask it over in that thread) the MechJeb "execute Principia node" function isn't really working. The burn time indicator is acting weird as well, counting down normally at first but then jumping around to all sorts of values. I'll add my logs after I test removing a few mods.

Edited by Radical2638
Link to comment
Share on other sites

48 minutes ago, Radical2638 said:

I have a problem where in the flight planner my node disappears before the burn is over, also it seems that (and I know this is primarily a Mechjeb question so I'm already going to ask it over in that thread) the MechJeb "execute Principia node" function isn't really working. The burn time indicator is acting weird as well, counting down normally at first but then jumping around to all sorts of values. I'll add my logs after I test removing a few mods.

i see the same, the suggestion i got was either setup a kos script or do burns manually. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...