Jump to content

[WIP][1.8.1, 1.9.1, 1.10.1, 1.11.0–2, 1.12.2] Principia—version Hamilton, released 2021-12-04—n-Body and Extended Body Gravitation


eggrobin
 Share

Recommended Posts

18 minutes ago, R-T-B said:

Also not questioning the concept, but how do your zips work?  They don't seem to be a "platform dependent installer" at all.

They are not, which is why the installation process requires installing the right system dependencies metioned (and, for Windows, linked to) in the FAQ.

Link to comment
Share on other sites

Just now, eggrobin said:

They are not, which is why the installation process requires installing the right system dependencies metioned (and, for Windows, linked to) in the FAQ.

I forgot I even did that when I first setup Principia...  I guess you just proved why it's important to link to your page!  heh, thanks.

Link to comment
Share on other sites

1 hour ago, Bej Kerman said:

Is there any specific reason this isn't on CKAN?

This has been asked before, this will be asked again...

Pretty much the same reasons that were given recently in reply to a question by @R-T-B.  Note that system-specific dependencies are particularly bad: since CKAN doesn't know about them (not even to the point of informing the user), 90% of the installs through CKAN would be broken and users wouldn't have a way to find help.  See also CKAN issue #1739.

Link to comment
Share on other sites

If anyone is curious and hasn't yet found out why at a certain point burning retrograde doesn't push you any further back and seems stuck, it's because the retrograde direction moves to the opposite of where it was before, causing it to get stuck. If you want to be able to push farther, you'll have to make a new node right after that goes prograde or just handle the burn yourself without mission planning. Please correct me if I'm wrong or missing anything.

Link to comment
Share on other sites

18 minutes ago, AccidentalColonies said:

If you want to be able to push farther, you'll have to make a new node right after that goes prograde

or use an inertially fixed manœuvre, which will use the initial Frenet frame throughout the burn.

Link to comment
Share on other sites

8 hours ago, Mirror World said:

1.11.1 has lived.

Add a cfg file containing: principia_override_version_check {}.  Don't forget to remove it once the next version is out: we won't support you if you override the version check (we'll know from the logs).

Link to comment
Share on other sites

8 hours ago, Mirror World said:

Noooooooooooooooooo.1.11.1 has lived.I neglecteed not to stop steam from updating my game.

Modded installs should be copied out of Steam to be independent from it. There are no problems with that, everything will still function fine.

But in the meantime, Steam allows you to back to earlier versions of the game, under the "Betas" (I think that's what it was) option in the launch settings. Simply select the earlier version and redownload it.

Link to comment
Share on other sites

5 hours ago, pleroy said:

Add a cfg file containing: principia_override_version_check {}.  Don't forget to remove it once the next version is out: we won't support you if you override the version check (we'll know from the logs).

Thanks! That works perfectly. I was willing to wait until Gödel but I can't play KSP without Principia now, downgrading to stock physics is like going back to your normal car after driving a Lambo! Will remove once Gödel is out though.

5 hours ago, Delay said:

Modded installs should be copied out of Steam to be independent from it. There are no problems with that, everything will still function fine.

But in the meantime, Steam allows you to back to earlier versions of the game, under the "Betas" (I think that's what it was) option in the launch settings. Simply select the earlier version and redownload it.

The funny thing is that I was doing this and the one time I run KSP from Steam I forgot to rename the game folder and it auto-updates :(. Also, you can't downgrade to 1.11.0, only to the latest patches of each version.

Edit: Of course, Principia Germain works with 1.10.1, but I'm using Parallax  1.2.0 which only works for 1.11.x.

Edited by Aksijaha
Link to comment
Share on other sites

On 2021/1/31 at PM8点26分, Delay said:

修改后的安装应从Steam中复制出来,以与之独立。没问题,一切仍然可以正常运行。

但是与此同时,Steam允许您在启动设置的“ Betas”(我想就是这样)选项下返回游戏的早期版本。只需选择早期版本并重新下载即可。

But steam only allowed me to go back to 1.10 instead of before the patch was updated

On 2021/1/31 at PM8点25分, pleroy said:

添加一个cfg文件,其中包含:  principia_override_version_check {}不要忘记在下一个版本发布后将其删除:如果您覆盖版本检查(我们将从日志中知道),我们将不支持您。

Thank you! I can continue to Launch Kerbals:D

Link to comment
Share on other sites

3 hours ago, zaphearo said:

I downloaded your zip file from Google drive, but before installing it, I decided to check it for viruses and the result was bad.How so?

Interesting.  That happens from time to time.  When I give VirusTotal the bit.ly link I get Comodo Valkyrie Verdict: Malware and when I give it the .zip file I get, as you do, Jiangmin: RiskTool.CoinMiner.j.  The latter seems to be triggered by the glog.dll library that we are using.

Antiviruses are full of this kind of false positives.  There is not much I can say or do to prove that we are in good faith, other than tell you that the source is on github and you can inspect it and build from it.

Link to comment
Share on other sites

7 minutes ago, pleroy said:

Interesting.  That happens from time to time.  When I give VirusTotal the bit.ly link I get Comodo Valkyrie Verdict: Malware and when I give it the .zip file I get, as you do, Jiangmin: RiskTool.CoinMiner.j.  The latter seems to be triggered by the glog.dll library that we are using.

Antiviruses are full of this kind of false positives.  There is not much I can say or do to prove that we are in good faith, other than tell you that the source is on github and you can inspect it and build from it.

Understood. Do I understand correctly that even though the archive name indicates version 1.11, I can use it for my RSS/RO/RP 1.8.1 build? I did not find a separate link to 1.8.1. I apologize for my English,it is not my native language and I know it at a mediocre level.

Link to comment
Share on other sites

22 minutes ago, zaphearo said:

Understood. Do I understand correctly that even though the archive name indicates version 1.11, I can use it for my RSS/RO/RP 1.8.1 build? I did not find a separate link to 1.8.1.

Right, as mentioned in the README there is a single binary for 1.8.1 to 1.11.0.   Note that 1.11.1 is not supported yet (but see above in this thread if you got hit by a Steam update).

22 minutes ago, zaphearo said:

I apologize for my English,it is not my native language and I know it at a mediocre level.

No worries, English is not my native language either.  :)

Link to comment
Share on other sites

Hi, I have a question/suggestion about your mod. Why don't you add auto-planning of maneuvers and auto-running of these maneuvers as in mehjeb? I think this will significantly expand the audience and popularity of your modification. Few people want to manually create maneuvers for 30 minutes, but I think many people want to see the cool physics of n bodies. Those people who want to manually create and perform maneuvers can simply not use these functions, and those people whose knowledge and skills are not high-level can use them.Or you can create 2 versions of principia, standart principia and principia Lite with these features. People will have a choice, but now there is no choice, either a person must know physics at a good level and enjoy the physics of n bodies, or he must play with a  poor stock physics of KSP.

Link to comment
Share on other sites

11 minutes ago, ZYKerman said:

Why is it not on CKAN :(

 

On 1/22/2021 at 9:43 AM, Bej Kerman said:

Is there any specific reason this isn't on CKAN?

On 1/22/2021 at 10:57 AM, pleroy said:

This has been asked before, this will be asked again...

Pretty much the same reasons that were given recently in reply to a question by @R-T-B.  Note that system-specific dependencies are particularly bad: since CKAN doesn't know about them (not even to the point of informing the user), 90% of the installs through CKAN would be broken and users wouldn't have a way to find help.  See also CKAN issue #1739.

 

Link to comment
Share on other sites

For the new moon (lunation number 261), the new release (Gödel) is out.

  • Support for KSP 1.11.1 has been added.
  • Principia is localized in simplified Chinese. Thanks to @CindyRIng for this significant contribution, and to @Zaikarion for helping with linguistic questions.
  • Some crash-inducing bugs have been fixed.

 See the change log for more details.

For the convenience of our Chinese users, the binaries can be downloaded either from Google Drive or from 腾讯微云.

Link to comment
Share on other sites

thanks for the new release, Principia team! 

I just checked the change log and noticed this: "We welcome feedback on the localization or contributions regarding other languages."

I can produce translations to Spanish if needed, let me know.

Link to comment
Share on other sites

42 minutes ago, hypervelocity said:

I can produce translations to Spanish if needed, let me know.

Sure.  Make a copy of the en-us.cfg file, name it es-es.cfg, translate all the strings and send us a pull request.  Try to use the correct technical terms, e.g., obtained from Wikipedia, not the KSP jargon.  (I seem to remember that you're in South America, so es-419.cfg might be more appropriate, but I am not sure that KSP knows about language subtleties.)

Link to comment
Share on other sites

2 minutes ago, pleroy said:

Sure.  Make a copy of the en-us.cfg file, name it es-es.cfg, translate all the strings and send us a pull request.  Try to use the correct technical terms, e.g., obtained from Wikipedia, not the KSP jargon.  (I seem to remember that you're in South America, so es-419.cfg might be more appropriate, but I am not sure that KSP knows about language subtleties.)

Will do!

Link to comment
Share on other sites

First of all. A huge thanks for this mod devs. It is awesome. It always bothered me that KSP did not proper orbits simulation.

Now, I have a help request. I decided to try gaming on Linux. I use Arch Linux, which I realize it is not supported by the precompiled binaries since it does not have libc++ 8 and libcx++abi 8. I could use "debootstrap", as someone suggested previous on this thread, but as far as I understand, this would take several additional GB and I am kinda of short in disk space. However, Arch does have  the version 11 of such libraries. So I thought it should be possible to compile against them. After some digging, I found the compilation instructions inside the "documentation" folder.

I installed the necessary tools (packages base-devel, libc++, clang and libc++abi). From the root folder of Principia's repo, I ran the "install_deps.sh" without problems. I created a symbolic link at "../KSP Assemblies/1.11.1" to "Kerbal Space Program/KSP_Data/Managed" and then finally ran "make". Then, I got the following error
 

In file included from tools/generate_configuration.cpp:16:
In file included from ./physics/solar_system.hpp:15:
In file included from ./physics/ephemeris.hpp:22:
./physics/geopotential.hpp:104:45: error: reference to enumeration must use 'enum' not 'enum class' [-Welaborated-enum-class]
  using SurfaceFrame = geometry::Frame<enum class SurfaceFrameTag>;
                                            ^~~~~~


Other errors follow, but they are similar to this one. I tryed replacing "enum class" with "enum", but I get "error: ISO C++ forbids forward references to 'enum' types" instead. Am I doing something wrong or is just a matter that Principia is inherently incompatible with newer versions of clang?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...