Jump to content

[WIP][1.8.1, 1.9.1, 1.10.1, and 1.11.0–2] Principia—version Green, released 2021-05-11—n-Body and Extended Body Gravitation


Recommended Posts

stderr is giving me this now

exception_ptr not yet implemented

Native stacktrace:

	/home/user/.steam/steam/steamapps/common/Kerbal Space Program/KSP_Data/Mono/x86_64/libmono.so(+0x92406) [0x7f71efe91406]
	/lib/x86_64-linux-gnu/libpthread.so.0(+0x110bf) [0x7f71fc8f90bf]
	/lib/x86_64-linux-gnu/libc.so.6(gsignal+0xcf) [0x7f71fbad6fff]
	/lib/x86_64-linux-gnu/libc.so.6(abort+0x169) [0x7f71fbad8429]
	/usr/local/lib/libc++.so.1(_ZNSt13exception_ptrD1Ev+0x33) [0x7f7140d79347]
	GameData/Principia/Linux64/principia.so(_ZNSt3__17promiseIN9principia4base6StatusEED2Ev+0x35) [0x7f71419b15e5]
	GameData/Principia/Linux64/principia.so(_ZN9principia4base10ThreadPoolINS0_6StatusEE21DequeueCallAndExecuteEv+0x173) [0x7f71419b1043]
	GameData/Principia/Linux64/principia.so(_ZNSt3__114__thread_proxyINS_5tupleIJNS_10unique_ptrINS_15__thread_structENS_14default_deleteIS3_EEEENS_6__bindIMN9principia4base10ThreadPoolINS9_6StatusEEEFvvEJPSC_EEEEEEEEPvSI_+0x3c) [0x7f71419b138c]
	/lib/x86_64-linux-gnu/libpthread.so.0(+0x7493) [0x7f71fc8ef493]
	/lib/x86_64-linux-gnu/libc.so.6(clone+0x3e) [0x7f71fbb8cace]
I refuse to debug myself!
No threads.

Debug info from gdb:


=================================================================
Got a SIGABRT while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries 
used by your application.
=================================================================

 

Link to post
Share on other sites
  • 2 weeks later...

2018-10-09

For the new moon (lunation number 232), the new release (Διόφαντος) is out.

Nothing new this time; we have been working on improved gravity models, but they are not ready yet.

See the change log for more details.

 We support two versions of KSP: downloads are available for 1.4.5 and 1.3.1. Make sure you download the right one (if you don't, the game will crash on load).

Link to post
Share on other sites
7 hours ago, Geligord said:

The mod says that I have the wrong version of Windows installed (32 instead of 64), although I have the correct version of the windows installed(x64). What to do?

You need to have (1) a 64-bit processor (2) a 64-bit installation of Windows (3) a 64-bit installation of KSP.  At least one of these prerequisites is missing (I suspect that you have a 32-bit installation of KSP).

Link to post
Share on other sites
15 minutes ago, Geligord said:

When no mod is installed, Principia works as it should. When I use my build, Principia reports that I am using the 32-bit version of the game.

What do you mean by "when I use my build"?  Build of what?  Built how?

Edited by pleroy
Link to post
Share on other sites
12 minutes ago, Geligord said:

My mod set. Sorry for a google translator

I suspect that you have a mod that simulates a 32-bit architecture by claiming that the pointers are 32 bits.  Something like that was in use when KSP didn't really work on 64-bit machines.

Link to post
Share on other sites

I seem to have a problem getting to Ike's L5 Point for some reason. It seems much more unstable than mun's L5 Point(I already have a stable relay sat there). I know minmus Lagrange Points are a bit weird due to the proximity to the mun and (maybe) the edge of kerbins soi, but ike has no stable Points as far as i can see. the reason is that a contract wants me to be in a stationary duna orbit, so i thought it would be nice to have it in ikes L5 Point as it is in the correct orbit.

Why?

xsmZ4qA.png

Link to post
Share on other sites
3 minutes ago, Eriksonn said:

I seem to have a problem getting to Ike's L5 Point for some reason.

It's explained in the Principia FAQ as to why it's not possible to have a stable Ike/Duna L5 or L4 orbit. Off the top of my head, I think it has something to do with Ike being too massive (or too close) to allow for a stable Lagrange point.

Link to post
Share on other sites

Ah, well then. I guess i will have to do a boring regular orbit closer to duna then.:(

The problem with this contract in particular is that it says: maintain orbit over this Point. but that Point is directly under ike, so i cant really do anything...

Edited by Eriksonn
Link to post
Share on other sites

I've been running into an odd bug in my current 1.3.1 RSS/RO/RP-1 save. Any vessels farther from Earth than LEO (an absolute boundary is yet to be established) have certain parts offset from where they should be. The problem disappears when I begin timewarping. The bug only occurs if Principia is installed. The problem gets more severe the longer a vessel is in flight, as well as the further it travels from Earth, and occasionally causes phantom torque. As an example, I loaded up the game and proceeded to switch between 4 craft files, 3 of which demonstrate the problem.

Screenshots and an explanation can be found in this album: https://imgur.com/a/fKZ8N51

Copies of those screenshots as well as my glog folder, ksp.log, and an exhaustive mod list can be found here: https://www.dropbox.com/sh/33okku23f6jrtvc/AAAgNGalGlHUg2-ij4QJWbPza?dl=0

Any other necessary files/documentation will be provided upon request. The same goes for a GitHub issue, if this problem is an actual issue and not some idiocy on my end.

Link to post
Share on other sites
On 10/15/2018 at 3:26 AM, IncongruousGoat said:

I've been running into an odd bug in my current 1.3.1 RSS/RO/RP-1 save. Any vessels farther from Earth than LEO (an absolute boundary is yet to be established) have certain parts offset from where they should be...

@IncongruousGoat: This is a very bizarre bug, and not one that has been reported before.  My gut feeling is that this is a nasty interaction with some other mod, but these problems are exceedingly difficult to debug.  The thing that is especially strange is that Principia only translates parts, and never rotates them.  So we could be guilty for the engine being off-centre, for instance, but it's harder to see how we would cause the antenna to rotate.

If you can put your save on dropbox we'll take a look, but don't hold your breath, more likely than not we won't be able to pinpoint the cause.

Link to post
Share on other sites

@pleroy I went and added the save folder to the Dropbox link from earlier. As for the rotation thing, I only saw it on that one vessel, of all the ones I loaded across various saves, so I'm not sure about that.

I'm going to try uninstalling mods one by one and see if I can pin down which one is causing the problem. I'll let you know if I figure out which one is being problematic.

Link to post
Share on other sites
4 hours ago, IncongruousGoat said:

Update: It looks like Kerbal Joint Reinforcement was the mod causing the problem. Eh, I can work around not having it by auto-strutting everything to everything else. If it works well enough in stock...

Thanks for taking the time to find the mod causing the problem.  From reading its description it's clear that it alters the physics, apparently in ways that are incompatible with Principia.  We'll get in touch with @ferram4 to understand more.

Link to post
Share on other sites
6 hours ago, Someone2018 said:

Anyone know how to compile this beast?

It seems to have dependencies on google compatibility files that cannot find online anywhere.

As well as unity engine dlls not included in the managed folder of KSP.

documentation/Setup.md had the needed hints

Link to post
Share on other sites
  • 2 weeks later...
4 hours ago, oguz said:

Is it possible to disable everything except axial tilt of planets? :P

If you want only axial tilt, check the starmods post in Daily Kerbal forum. The Tilt'em mod is supposed to do exactly that. 

It is a very new mod, so read through its thread for known bugs and stuff. 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...