Pamynx

[1.7.X] Civilian Population [RELEASED : 07/04/2018]

Recommended Posts

I am trying to find TACLS for KSP v 1.4.5  Can't seem to find it anywhere.  Please help!

Share this post


Link to post
Share on other sites
On 11/22/2018 at 10:53 PM, jinnantonix said:

I am trying to find TACLS for KSP v 1.4.5  Can't seem to find it anywhere.  Please help!

I don't believe they made TACLS for KSP v 1.4.5. If you are looking for the thread its

The Latest version for 1.4 they have is 1.4.1 which was working with 1.4.5 when I was playing with it

https://github.com/KSP-RO/TacLifeSupport/releases/tag/v0.13.9.0

 

Share this post


Link to post
Share on other sites

I have a question, how do you use the civilian contractor dock? In the YouTube video I watched, there was a button in its menu that said recruit kerbal, which sent up a new kerbal. Now that button is not there. Also, it allows me to hire civilian kerbals. Am I supposed to get them to my station and bring them in by docking a contractor dock to a contractor dock? Can I use a normal dock to bring in civilians? I am confused. Life support wise, my station and the 2 kerbals, a pilot and a scientist, works.

Can you please tell me how the civilian system works?

Edited by SlamduncAZ

Share this post


Link to post
Share on other sites

I am not sure how DeepFreeze work, but as Civilian Population keeps tracks of the age of the kerbal on it own, DeepFreeze won't prevent them to get old and finally die.

What I am almost sure is that as civilian kerbals are just regular ones, they should stop consuming resources when frozen.

By the way I am a little bit late and should thing about upgraing this mod to latest version. I hope I will find some time soon !

Share this post


Link to post
Share on other sites
On 2/6/2019 at 7:52 PM, Pamynx said:

I am not sure how DeepFreeze work, but as Civilian Population keeps tracks of the age of the kerbal on it own, DeepFreeze won't prevent them to get old and finally die.

What I am almost sure is that as civilian kerbals are just regular ones, they should stop consuming resources when frozen.

By the way I am a little bit late and should thing about upgraing this mod to latest version. I hope I will find some time soon !

If you do decide to pick this up, I know many people who would be most grateful!

Regarding DeepFreeze compatibility, this is something that would be very useful indeed, especially for those of us who have planet packs installed that require centuries of travel.

Regardless, I am glad for this mod, and appreciate the work you have done.

Share this post


Link to post
Share on other sites

I made some tests and it looks like the mod work properly.

I downloaded it using CKAN and all was fine. Civilian are breeding and giving funds.

I will start a game using it to do more deep validation.

Let me know if you detect some problems, I will try to fix them.

I fear it also needs balancing, I play with TACLS and will check this out, if you play with other life support mods that needs balancing, let me know I will try to update it as soon as I can.

Share this post


Link to post
Share on other sites

Hi, I want to know if there is some way to use this mod without any life support mod

 

Also, I want to know is there is some tutorial more recent 

 

Thank you

Edited by Darks :v

Share this post


Link to post
Share on other sites

Of course you can !

There no more recent toturial as the mod did not change, if you have any question, feel free to ask.

2 hints :

- If you want contractors to deliver full grown civilian, you will need a "Civilian Contractor Dock" and allow delivery (contextual menu of the part).

- If you want young baby kerbals to be born, you will need any civilian part, at least 2 kerbals (one female, one male) and allow them to breed (contextual menu of the part).

Enjoy !

Share this post


Link to post
Share on other sites

I'm a little at a loss on how to recruit the civilians in the current version which doesn't seem to have the university part anymore. Is there a way to recruit the civilians into actual roles? 

Share this post


Link to post
Share on other sites

I think community resource pack is outdated or does it still work? (im 1.8 btw, this mod wrks but does CRP wrk for 1.8)

Edited by a_neat_slav

Share this post


Link to post
Share on other sites

Hello

Is there a way to run this mod in 1.8? I am missing some parts, if i try current version. But maybe im doing something wrong. It is the most important mod for my career.

Please help. Thanks in advance.

Share this post


Link to post
Share on other sites

Hello @Pamynx, please come back, and give life again, to this wonderful mod that, is very well indeed appreciated by the community.

Lets us know if you are stuck at a specific point or whatever might be missing to update it to 1.8.1....

Thanks!

 

Share this post


Link to post
Share on other sites

I used to play this mod in a previous version of KSP (1.6.something I think), and I have recently started to play it again in 1.8.1, and I have noticed that there are no longer substrate containers or the Netherdyne University. Are those supposed to no longer be in this mod? If so, what are the new alternatives to them?

Also, just making sure, those parts would usually be under Utility, right?

EDIT: Reading the above comments, when will these issues be fixed? Take your time, although I am still on hold for building a station. Also, would it be safe to send up the components of the station that include parts from this mod that I can send up now?

Edited by SlamduncAZ

Share this post


Link to post
Share on other sites
On 12/20/2019 at 10:18 PM, SlamduncAZ said:

I used to play this mod in a previous version of KSP (1.6.something I think), and I have recently started to play it again in 1.8.1, and I have noticed that there are no longer substrate containers or the Netherdyne University. Are those supposed to no longer be in this mod? If so, what are the new alternatives to them?

Also, just making sure, those parts would usually be under Utility, right?

EDIT: Reading the above comments, when will these issues be fixed? Take your time, although I am still on hold for building a station. Also, would it be safe to send up the components of the station that include parts from this mod that I can send up now?

The developer last visited on 24th oct 2019, although many developers only visit when new ksp version is released, with weeks after 1.8.x, he didn't show up yet, may I suggest an unofficial release with fixes until he comes back at his free time and take it over again?

Share this post


Link to post
Share on other sites

Finally got it!

Today I changed/updated this mod (Civilian Population) to compile and work in 1.8.1 :) took me the all day, but got it!

MDBkZGn.png

The first child born in 1.8.1 version: (12 days old... is big already!)

xIHhjiv.png

I don't want the responsibility of maintain the mod but I can share a zip link for now, if anyone is interested for the 1.8.1

@FreeThinker ,you also mentioned before this mod, in Alpha Centaury Challenge, let me know also what do you think.

 

Edited by pmborg

Share this post


Link to post
Share on other sites
44 minutes ago, pmborg said:

Finally got it!

Today I changed/updated this mod (Civilian Population) to compile and work in 1.8.1 :) took me the all day, but got it!

MDBkZGn.png

The first child born in 1.8.1 version: (12 days old... is big already!)

xIHhjiv.png

I don't want the responsibility of maintain the mod but I can share a zip link for now, if anyone is interested for the 1.8.1

@FreeThinker ,you also mentioned before this mod, in Alpha Centaury Challenge, let me know also what do you think.

 

Yes, I could adopt this.  For now, you need to share the source code and the license.  Easiest way would be to include the source in the same zip file as the released code.

Regarding the rebuild, what did you have to change to get it to compile?

Share this post


Link to post
Share on other sites
48 minutes ago, linuxgurugamer said:

 

Yes, I could adopt this.  For now, you need to share the source code and the license.  Easiest way would be to include the source in the same zip file as the released code.

Regarding the rebuild, what did you have to change to get it to compile?

Nothing specially, basically I updated the the:

The *.csproj files also I had to force a kick update the "nduniversity.cfg" and this was like the Colombo Egg to fix it.

About the license, can be the original one, of the mod correct?

Zip here:

https://www.dropbox.com/s/jn5ymulvoik3xch/CivilianPopulation.zip?dl=0

Also updated the file structure.

 (use "git restore <file>..." to discard changes in working directory)
        modified:   modules/src/main/cs/CivilianPopulation.csproj
        deleted:    modules/src/main/dll/Assembly-CSharp-firstpass.dll
        deleted:    modules/src/main/dll/Assembly-CSharp.dll
        deleted:    modules/src/main/dll/Assembly-UnityScript-firstpass.dll
        deleted:    modules/src/main/dll/Assembly-UnityScript.dll
        deleted:    modules/src/main/dll/Boo.Lang.dll
        deleted:    modules/src/main/dll/KSPAssets.dll
        deleted:    modules/src/main/dll/Mono.Cecil.dll
        deleted:    modules/src/main/dll/Mono.Security.dll
        deleted:    modules/src/main/dll/System.Core.dll
        deleted:    modules/src/main/dll/System.Xml.dll
        deleted:    modules/src/main/dll/System.dll
        deleted:    modules/src/main/dll/TrackIRUnity.dll
        deleted:    modules/src/main/dll/UnityEngine.Networking.dll
        deleted:    modules/src/main/dll/UnityEngine.UI.dll
        deleted:    modules/src/main/dll/UnityEngine.dll
        deleted:    modules/src/main/dll/UnityEngine.dll.mdb
        deleted:    modules/src/main/dll/UnityEngine.xml
        deleted:    modules/src/main/dll/UnityScript.Lang.dll
        deleted:    modules/src/main/dll/mscorlib.dll
        deleted:    plugin/references/KSP.1.3.0/Assembly-CSharp-firstpass.dll
        deleted:    plugin/references/KSP.1.3.0/Assembly-CSharp.dll
        deleted:    plugin/references/KSP.1.3.0/Assembly-UnityScript-firstpass.dll
        deleted:    plugin/references/KSP.1.3.0/Assembly-UnityScript.dll
        deleted:    plugin/references/KSP.1.3.0/Boo.Lang.dll
        deleted:    plugin/references/KSP.1.3.0/KSPAssets.dll
        deleted:    plugin/references/KSP.1.3.0/Mono.Cecil.dll
        deleted:    plugin/references/KSP.1.3.0/Mono.Security.dll
        deleted:    plugin/references/KSP.1.3.0/System.Core.dll
        deleted:    plugin/references/KSP.1.3.0/System.Xml.dll
        deleted:    plugin/references/KSP.1.3.0/System.dll
        deleted:    plugin/references/KSP.1.3.0/TrackIRUnity.dll
        deleted:    plugin/references/KSP.1.3.0/UnityEngine.Networking.dll
        deleted:    plugin/references/KSP.1.3.0/UnityEngine.UI.dll
        deleted:    plugin/references/KSP.1.3.0/UnityEngine.dll
        deleted:    plugin/references/KSP.1.3.0/UnityEngine.dll.mdb
        deleted:    plugin/references/KSP.1.3.0/UnityEngine.xml
        deleted:    plugin/references/KSP.1.3.0/UnityScript.Lang.dll
        deleted:    plugin/references/KSP.1.3.0/mscorlib.dll
        deleted:    plugin/references/KSP.1.3.1/Assembly-CSharp-firstpass.dll
        deleted:    plugin/references/KSP.1.3.1/Assembly-CSharp.dll
        deleted:    plugin/references/KSP.1.3.1/Assembly-UnityScript-firstpass.dll
        deleted:    plugin/references/KSP.1.3.1/Assembly-UnityScript.dll
        deleted:    plugin/references/KSP.1.3.1/Boo.Lang.dll
        deleted:    plugin/references/KSP.1.3.1/KSPAssets.dll
        deleted:    plugin/references/KSP.1.3.1/KSPTrackIR.dll
        deleted:    plugin/references/KSP.1.3.1/Mono.Cecil.dll
        deleted:    plugin/references/KSP.1.3.1/Mono.Security.dll
        deleted:    plugin/references/KSP.1.3.1/System.Core.dll
        deleted:    plugin/references/KSP.1.3.1/System.Xml.dll
        deleted:    plugin/references/KSP.1.3.1/System.dll
        deleted:    plugin/references/KSP.1.3.1/UnityEngine.Networking.dll
        deleted:    plugin/references/KSP.1.3.1/UnityEngine.UI.dll
        deleted:    plugin/references/KSP.1.3.1/UnityEngine.dll
        deleted:    plugin/references/KSP.1.3.1/UnityEngine.dll.mdb
        deleted:    plugin/references/KSP.1.3.1/UnityEngine.xml
        deleted:    plugin/references/KSP.1.3.1/UnityScript.Lang.dll
        deleted:    plugin/references/KSP.1.3.1/mscorlib.dll
        deleted:    plugin/references/KSP.1.4.1/Assembly-CSharp-firstpass.dll
        deleted:    plugin/references/KSP.1.4.1/Assembly-CSharp.dll
        deleted:    plugin/references/KSP.1.4.1/Assembly-UnityScript-firstpass.dll
        deleted:    plugin/references/KSP.1.4.1/Assembly-UnityScript.dll
        deleted:    plugin/references/KSP.1.4.1/UnityEngine.CoreModule.dll
        deleted:    plugin/references/KSP.1.4.1/UnityEngine.dll
        deleted:    plugin/references/KSP.1.4.2/Assembly-CSharp-firstpass.dll
        deleted:    plugin/references/KSP.1.4.2/Assembly-CSharp.dll
        deleted:    plugin/references/KSP.1.4.2/Assembly-UnityScript-firstpass.dll
        deleted:    plugin/references/KSP.1.4.2/Assembly-UnityScript.dll
        deleted:    plugin/references/KSP.1.4.2/UnityEngine.AnimationModule.dll
        deleted:    plugin/references/KSP.1.4.2/UnityEngine.CoreModule.dll
        deleted:    plugin/references/KSP.1.4.2/UnityEngine.IMGUIModule.dll
        deleted:    plugin/references/KSP.1.4.2/UnityEngine.dll
        deleted:    plugin/references/KSP.1.4.3-linux/Assembly-CSharp.dll
        deleted:    plugin/references/KSP.1.4.3-linux/UnityEngine.dll
        deleted:    plugin/references/KSP.1.4.3/Assembly-CSharp.dll
        deleted:    plugin/references/KSP.1.4.3/UnityEngine.AnimationModule.dll
        deleted:    plugin/references/KSP.1.4.3/UnityEngine.CoreModule.dll
        deleted:    plugin/references/KSP.1.4.3/UnityEngine.IMGUIModule.dll
        deleted:    plugin/references/KSP.1.4.3/UnityEngine.dll
        modified:   plugin/src/main/cs/Domain/Domain.csproj
        modified:   plugin/src/main/cs/Domain/Domain.csproj.user
        modified:   plugin/src/main/cs/GUI/GUI.csproj
        modified:   plugin/src/main/cs/GUI/GUI.csproj.user
        modified:   plugin/src/main/cs/Infra/Infra.csproj
        modified:   plugin/src/main/cs/Infra/Infra.csproj.user
        modified:   plugin/src/test/cs/GUITests/GUITests.csproj

 

Main Solution File:

CivilianPopulation\plugin\plugin.sln

Edited by pmborg

Share this post


Link to post
Share on other sites
46 minutes ago, pmborg said:

The *.csproj files also I had to force a kick update the "nduniversity.cfg" and this was like the Colombo Egg to fix it.

the csproj files are fine, but I don't understand what you mean about the nduniversity.cfg

47 minutes ago, pmborg said:

About the license, can be the original one, of the mod correct?

Yes, that's fine

Share this post


Link to post
Share on other sites
1 minute ago, linuxgurugamer said:

the csproj files are fine, but I don't understand what you mean about the nduniversity.cfg

Yes, that's fine

I had to update this file:

CivilianPopulation\GameData\CivilianPopulation\Parts\Science\nduniversity.cfg

    // node_stack_top = 0.0, 5.0, 0.0, 0.0, 1.0, 0.0, 3
    // node_stack_bottom = 0.0, -5.0, 0.0, 0.0, -1.0, 0.0, 3
    // node_attach = 0.0,-5.0, 0.0,  0.0, -1.0, 0.0, 2

    node_stack_top = 0.0, 2.75, 0.0, 0.0, 1.0, 0.0, 2
    node_stack_bottom = 0.0, -2.75, 0.0, 0.0, -1.0, 0.0, 2
    node_attach = 0.0, -2.75, 0.0, 0.0, -1.0, 0.0, 2

Maybe is not perfect but work..., this avoid a fatal exception that prevent all mod to work.

 

Share this post


Link to post
Share on other sites
3 minutes ago, pmborg said:

I had to update this file:

CivilianPopulation\GameData\CivilianPopulation\Parts\Science\nduniversity.cfg

    // node_stack_top = 0.0, 5.0, 0.0, 0.0, 1.0, 0.0, 3
    // node_stack_bottom = 0.0, -5.0, 0.0, 0.0, -1.0, 0.0, 3
    // node_attach = 0.0,-5.0, 0.0,  0.0, -1.0, 0.0, 2

    node_stack_top = 0.0, 2.75, 0.0, 0.0, 1.0, 0.0, 2
    node_stack_bottom = 0.0, -2.75, 0.0, 0.0, -1.0, 0.0, 2
    node_attach = 0.0, -2.75, 0.0, 0.0, -1.0, 0.0, 2

Maybe is not perfect but work..., this avoid a fatal exception that prevent all mod to work.

 

Looks like the scaling is off.

One question about compiling.  I see that there are a lot of subdirectories, each with it's own .csproj file.  Did you use them, or just build main csproj file and compile them all together?

Share this post


Link to post
Share on other sites
10 minutes ago, linuxgurugamer said:

Looks like the scaling is off.

One question about compiling.  I see that there are a lot of subdirectories, each with it's own .csproj file.  Did you use them, or just build main csproj file and compile them all together?

This is the main "Visual Studio Solution" file: (that will compile all those 3 projects)

"CivilianPopulation\plugin\plugin.sln"

Xq2aGuk.png

Edited by pmborg

Share this post


Link to post
Share on other sites

@linuxgurugamer

Basically with a setup like this:

  • Pointing directly to a KSP Installation directory
  • If you have a solution file with all your projects/mods
  • After a KSP update like near 1.9, with one click you can update/recompile all your mods at once, assuming no code change needed ofc. :)

Did you managed already to compile it?

 

Edited by pmborg

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.