Jump to content
  • 0

Crash and Curruped Savefile after Switching Vessel in Tracking Station KSP[1.3.0]

Marcel Kerman


Hello KSP Community,

I write/translate this post for my little brother because he doesn’t speak English at all.

My Brother has a corrupted save file and we don’t get it fixed completely.


His save game corrupted as he tried to switch to another vessel in the tracking station and the game crashed. After restarting the game he got the Error 


object reference not set to an instance of an object


And wasn’t able to lead the save game anymore. We both tried to play around by editing the savefile and deleting one vessel after the other we found the vessel which lead to the error (Name: GBM Fabber)

After removing it from the savefile the error was gone and he was able to hit the load button again.

But if you do so, the save game doesn’t load anyway. The Load button get grayed out for a few second while he tries to load the game. But after a few seconds the stops loading and goes back to the save game selection.

His game is not modded and besides a German Translation mod, which wasn’t installed at the time the error occurred it also was never modded.



He already tried to reinstall the game which didn’t helped because of that there is no output log file :(



I didn't figured out how to attach files so you can download them from my google drive

Original Corrupted savegame:                   presistant-non-edit.sfs.txt 

Edited File w/o the corrupted Ship:            presistent-edit.sfs.txt

Load Meta File:                                           presistent.loadmeta.txt

Addition Information:


KSP Version:                  1.3.0


OS:                                 Windows 10 1703 Build 15063.413 (Creators Update)


CPU:                               Intel Core i5 3350P @3.1GHz


RAM:                              12GB DDR3


Graphics:                        GTX750Ti



PS: If you can write your reply in german, I would appreciate it. Because than I won't have to translate it for my brother. But English is also okay :)

Link to comment
Share on other sites

3 answers to this question

Recommended Posts

  • 0


Having strange issue too, KPS (x64 Windows), unmodded/fresh installation:

Year 999 Day 499 - 05:59:59 when returning to vessel (the clock remains stucked at this time bcoz it's the maximum/limit I suppose).

To reproduce (KSP 1.3.0 x64 for Windows):

- Create a new sandbox game, any save name, any mission flag (keep default), no difficulty modification (staying as "Normal").

- From KSC, click on Launchpad, select stock Kerbal X spacecraft (or any stock spacecraft), then click "Launch vessel" (green) icon/button (but no takeoff, staying on launchpad).

- Return to Space Center by using the button above the altimeter: from KSC, date/time is Years 0 Day1- 0h 6m seems good but badly formatted (IMO) no space between Day and 1, no space between 1 and "-"...

- Returning to vessel from Tracking Station, or by clicking on vehicule icon on launchpad: date/time is corrupted as indicated above Year 999 Day 499...


Core i7 4790 @ 3.6 GHz, 32 GB RAM, GTX 660, Windows 7 Pro SP1 64-bit.

EDIT: this issue was reported in bug tracker (bug #15389) by another user (11 days ago). Video here.


Edited by DomiKamu
Link to comment
Share on other sites

  • 0

In the save folder, you should see a folder called "Backups" - if you take the latest of the files out of there and use it to replace the "persistent.sfs" file in the main save folder, it should restore the corrupted save.

Obviously he may lose a little progress, as it may not be completely up to date, but better that than starting again completely.

Edited by severedsolo
Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...