Kobymaru

[1.3.1-1.7.2] Trajectories v2.2.3 (2019-06-17) : atmospheric predictions

Recommended Posts

HELP!!  so I'm trying to use trajectories mod with KOS and I know there's a problem with it. As simply as possible how do I fix this. I've spent 50 minutes trawling through the Github page getting more and more confused. can someone give me step by step instructions on how to fix my problems. Thanks!

(If it helps I'm using CKAN on ksp version 1.4.1.2089, skan version 1.25.1, kos version 1.1.5.2, and trajectories version 2.2.0).

please help or my falcon9 is gonna keep landing in the ocean!!

Share this post


Link to post
Share on other sites

This is what I have running...

  1. Clone/download the kOS repo
  2. Merge the Trajectories PR branch into master
  3. Build (as per the contribution docs) and place the output in KSP/GameData
  4. Profit!

Share this post


Link to post
Share on other sites

Sorry if I missed discussion about this, but was the longitude drifting bug fixed? Also I'm having a bug where the trajectory becomes very inaccurate after timewarp . It's resolved by turning off the cache (I'll post more info later, I'm just wondering if it's been discussed yet)

Edited by dlrk

Share this post


Link to post
Share on other sites

@dlrk As far as I am aware the drifting bug has not been fixed yet. No discussions about inaccurate trajectory with timewarp yet, @Kobymaru will be best to quiz as he implemented the RK4 algorithm. 

Share this post


Link to post
Share on other sites

Ok. The timewarp issue isn't a big deal, performance is fine with cache off.

Share this post


Link to post
Share on other sites

IMHO this is a really performing setup (with multiple atmospheric brake entries around Kerbin):

hjnqsYf.png

Share this post


Link to post
Share on other sites
On 6/16/2018 at 1:33 PM, Gordon Dry said:

IMHO this is a really performing setup (with multiple atmospheric brake entries around Kerbin):

Could you explain why you think this is?  What do you mean by 'performing'?

Share this post


Link to post
Share on other sites
2 hours ago, Brigadier said:

Could you explain why you think this is?  What do you mean by 'performing'?

More fps, higher physics time delta ratio.

On my rig with a medium-part-amount vessel I can increase the fps from below 20 to ~30 and have the physics time delta ratio be mostly 100% compared to the default setting of Trajectories.

Share this post


Link to post
Share on other sites

Well here  I am with a problem.
I had the mod on 1.2.2 and it worked flawlessly. Now I switched to 1.3.1 and I simply cannot see the trajectory (have it ticked). Works only when I turn on the "Show complete" option and I know it worked without it back in old save. Current v.2.0.0
More info needed?

EDIT: aaand it somehow works now, at least on Kerbin. I did literally nothing.

EDIT2: nothing on Minmus though, so the problem remains.

Edited by The Aziz
???

Share this post


Link to post
Share on other sites

Deleted, installed that one and still

 

gbopBiK.jpg

jxh0b0w.jpg

 

The app button is also constantly yellow, like it was active all the time.

Not to mention I currently experience major problems with contracts and their requirements that somehow are not letting me complete them, but that's another story not for here

Edited by The Aziz

Share this post


Link to post
Share on other sites

@The Aziz Does the same thing happen when you don't use the Old Gui ?

Does the App Button colour change when you toggle Show trajectories ?

Can you post your output.log

Edited by PiezPiedPy

Share this post


Link to post
Share on other sites

New GUI, old GUI, stays the same. And yes the button deactivates when I turn off everything.

Log goes here: https://files.fm/f/p3eb3x7p couldn't put on pastebin, too large

Share this post


Link to post
Share on other sites

@The Aziz Does the trajectory appear if you zoom out? Also does the in-flight trajectory work?

Try without OpenGL, Trajectories has not been written with OpenGL in mind ;)

Edited by PiezPiedPy

Share this post


Link to post
Share on other sites

Aight. Disabled opengl (at least I think so, is there a way to tell for sure?)

No progress.

Zooming in/out gives no results, in flight trajectory seems to appear, however I don't know if it was there before since I never used that feature.

OT, really nobody else had that issue before me? Maybe it's mod conflict, but what do I have (okay I have a lot) that could cause this? No FAR, some utilities, visuals, career enhancers and part packs.

Share this post


Link to post
Share on other sites
2 hours ago, HeroBrian_333 said:

When will this update to 1.4.4

I'm running KSP 1.4.4 and Trajectories seems to be working fine for me.  Are you seeing something not working?

Share this post


Link to post
Share on other sites

Hey all, love the mod and really can't play without it. Great work to the developer(s).

As a kind of PSA, thought I'd share my recent experience figuring out why I couldn't see the Trajectories mod button on the Stock toolbar (hoping others don't make the same mistakes!). :P

When you set the mod to show on Blizzy's toolbar in the Trajectories settings: Remember what the little icon looks like...

So when you forget that and later decide to reconfigure your whole toolbar... and then wonder why you can't see the "Traj" button on the stock toolbar which you kinda remember ... but hey, where did that go anyway... it's installed right... then DON'T freak out and uninstall/re-install Trajectories trying to get it back again.

Eventually, I remembered what the button looked like. :confused:  And now I'm all good again.

Edited by scottadges

Share this post


Link to post
Share on other sites
1 hour ago, JackGruff said:

Would it be possible to show the in-flight trajectory only if it's sub orbital?

Thats exactly what it does... It will only kick in if your going to enter the atmosphere, and drag will cause you to land (i.e. sub-orbital) it will show your estimated trajectory and probable landing spot.

 

Now maybe you talking about, if your going to only do an Aero-Brake around a planet. You Don't want it to kick in?

But that is also part of its purpose. It will show you the projected new orbit after you aero-brake. If it did not kick in in this instance, you would have no idea if your aero-brake altitude was to deep (and thus you crash)  or to shallow (and thus you wont be captured into an orbit).

 

Edited by BlackHat

Share this post


Link to post
Share on other sites

Started KSP a few months ago. My life, as I knew it, is now pleasantly ruined. :lol:

I've been adapting NASA/JPL's idea of "screw orbiting, just land the thing" aerocapture--Entry, Descent and Landing.

I needed something to help me pinpoint a place where my rovers don't become submersibles on Eve or lithobrake, so thank you for this mod.

I have one problem so far (running 1.4.5): Starting the game up, clicking the mod's button (I use only the default toolbar) works fine. I can click it again to hide it. But after switching back and forth from the Tracking Station or switching to other ships, the button is unresponsive. If the window was not up, clicking the button does not open it. I have to reload the save or game to restore operation. If I had a trajectory plot already in work, the plot is still operating just fine. I just can't bring the mod window back into view.

Any thoughts or notes on a workaround or what to do?

Edited by OrbitsR4Sissies
typo

Share this post


Link to post
Share on other sites
17 hours ago, JackGruff said:

Would it be possible to show the in-flight trajectory only if it's sub orbital?

Turn off body-fixed mode.

On an unrelated note, any news/progress or whatever on the target drift bug? Also, is there a way to show the atmospheric trajectory after an SOI change?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.