Kobymaru

[1.3.1-1.7.2] Trajectories v2.2.3 (2019-06-17) : atmospheric predictions

Recommended Posts

17 hours ago, dlrk said:

Which part of the mode is PiezPiedPy?

Mainly the NewGui mode, all the other bits of mode I don't care about. You can search through the GitHub contributions :wink:

 

After discussion with other forum members, the Take2 EULA/TOS is about content created with KSP itself and not content created with 3rd Party tools like VS2017 etc. so at the end of the day I needn't of worried but at least I have now removed resale rights of my code which is something I had previously overlooked.

I can now sleep at night knowing I can still mod KSP without Take2 getting their fingers sticky :D

Edited by PiezPiedPy

Share this post


Link to post
Share on other sites

 

1.4 is out, looks like I'll have to add some more Languages to Trajectories :wink:

 Also I'm going to wait for 1.4.1 next week before starting work towards the next release. Hopefully there wont be too much to do. :D

Share this post


Link to post
Share on other sites
7 hours ago, savageshibainu said:

Screen flashes blue whenever I enable the trajectory

The mod isn't updated for 1.4 yet, if you would have read the post right above yours, you would have seen it.

Share this post


Link to post
Share on other sites
On 3/9/2018 at 4:57 PM, linuxgurugamer said:

The mod isn't updated for 1.4 yet, if you would have read the post right above yours, you would have seen it.

yeah I know, it's happened waay before 1.4 but I've never got around to posting here

Share this post


Link to post
Share on other sites
On 7/3/2018 at 3:08 AM, PiezPiedPy said:

 

1.4 is out, looks like I'll have to add some more Languages to Trajectories :wink:

 Also I'm going to wait for 1.4.1 next week before starting work towards the next release. Hopefully there wont be too much to do. :D

if you have time to take a look at those bugs I found before new release is out:

 

1. Activating waypoint from target window, give a wrong longitude value ( waypoint is added with scansat gui )

2. Targeting value with lat and lon as input drift over time ( only lon observed ), need to force them from time to time, the drifting stop when entrying in atmosphere

3. Prevent clickthrough

4. Remember window position when restarting ksp

 

I have made a video to better explain it: https://youtu.be/VyxhHvIK8Hk

Kerbal version 1.3.1

output_log https://drive.google.com/open?id=0B4kd548FeSEpTnRSSWtLVHVsNzA

Mod list:

Spoiler

AirPark.1.6.2.0_11242017
BetterBurnTime-1.6.1
Community_Resource_Pack-0.8.0.0
CTI.0.1.9
Decoupler_Shroud-0.3.1
DockRotate-1.3.1.5
EasyVesselSwitch_v1.5
EnvironmentalVisualEnhancements-1.2.2.1
IndicatorLights-1.2.12
KAS_v0.6.3
KerbalAlarmClock_3.8.5.0
KerbalEngineer-1.1.3.0
KerbalJointReinforcement_v3.3.3
KIS_v1.9
Malemute_0.4.0.0
ModuleManager.3.0.1.dll
NavBallDockingAlignmentIndicatorCE-1.0.3
Near_Future_Electrical-0.9.8
Near_Future_Solar-0.8.8
OSEWorkshop-1.2.3
ParaSciEVEPack120
Portrait_Stats-15.1
PreciseManeuver
SCANsat-v18.4
SimpleAdjustableFairings-KWRocketry-v1.0.1
SimpleLogistics-2.0.2
Snacks_1_8_7
Stockalike_Station_Parts_Expansion_Redux-1.0.2
Trajectories-v2.0.0
TransferWindowPlanner_1.6.2.0
UbioWeldContinued-2.5.2
USITools_0.10.1.0
VertVel132

 

Edited by brusura

Share this post


Link to post
Share on other sites

I can confirm the same longitude drifting bug as Brusura, if a 1.3.1 release for the fix could be released, I'd really appreciate it (:

EDIT: Also, the drift stops at atmospheric entry. This is odd

Also, got a feature request, if it's possible (or maybe it works in the current version, and I missed it?): Atmospheric trajectories aren't shown for a future SOI transition, would it be possible to add this?

Edited by dlrk

Share this post


Link to post
Share on other sites
On 9.3.2018 at 3:31 PM, savageshibainu said:

Screen flashes blue whenever I enable the trajectory

I need a lot more info than this. Please read this: https://github.com/neuoy/KSPTrajectories/blob/master/CONTRIBUTING.md#how-to-report-bugs

 

On 11.3.2018 at 8:24 AM, brusura said:

1. Activating waypoint from target window, give a wrong longitude value ( waypoint is added with scansat gui )

Weird. Please create a GitHub issue.

 

On 11.3.2018 at 8:24 AM, brusura said:

3. Prevent clickthrough

New GUI or old GUI? We had some restrictions with the old GUI that didn't allow proper click-through prevention. I don't know what the deal is with the new GUI.

 

On 11.3.2018 at 8:24 AM, brusura said:

4. Remember window position when restarting ksp

Please create a GitHub Issue.

 

On 11.3.2018 at 8:24 AM, brusura said:

2. Targeting value with lat and lon as input drift over time ( only lon observed ), need to force them from time to time, the drifting stop when entrying in atmosphere

15 hours ago, dlrk said:

I can confirm the same longitude drifting bug as Brusura, if a 1.3.1 release for the fix could be released, I'd really appreciate it (:

EDIT: Also, the drift stops at atmospheric entry. This is odd

I'm afraid this might be a restriction of how KSP does physics and Time warp and "orbital drift compensation". KSP's integrator is super weird sometimes. But if you could provide a quicksave and instructions (along with more info as described here: https://github.com/neuoy/KSPTrajectories/blob/master/CONTRIBUTING.md#how-to-report-bugs), if possible without mods, that would be great. Maybe this can be worked around, but no promises.

 

15 hours ago, dlrk said:

Also, got a feature request, if it's possible (or maybe it works in the current version, and I missed it?): Atmospheric trajectories aren't shown for a future SOI transition, would it be possible to add this?

This might be possible, yes, but takes a long time to implement. Please create a GitHub Issue.

Share this post


Link to post
Share on other sites

@Kobymaru

I'll provide a quicksave and reproduction steps (with probably just hyperedit and mechjeb) after work today. Just to be clear though, this bug is new with this version, and it's not the projected impact thats moving, it's the target itself. This didn't happen with early versions or Mechjeb/Scansat's targeting. I'll try later to see if manually entering the coordinates fixes the bug.

Share this post


Link to post
Share on other sites
7 hours ago, Kobymaru said:

New GUI or old GUI? We had some restrictions with the old GUI that didn't allow proper click-through prevention. I don't know what the deal is with the new GUI.

New GUI

Share this post


Link to post
Share on other sites
3 hours ago, dlrk said:

Just to be clear though, this bug is new with this version, and it's not the projected impact thats moving, it's the target itself.

Oh that's weird! One of these days I'll have to actually understand these weird coordinate systems in KSP.

3 hours ago, dlrk said:

This didn't happen with early versions or Mechjeb/Scansat's targeting. I'll try later to see if manually entering the coordinates fixes the bug.

Please do, I also suggest opening a GitHub issue and continuing the discussion there.

Share this post


Link to post
Share on other sites

@Kobymaru

I created a Github issue for the drift issue (https://github.com/neuoy/KSPTrajectories/issues/140), and made a new observation that should hopefully make debugging much easier (also I was wrong when I said the issue doesn't occur when MJ or ScanSat select the target, forget I said that).

Having tested the same craft on Kerbin, Mun, and Minmus, on all three bodies the drift ceases when the craft is below 100km.

 

 

Share this post


Link to post
Share on other sites
11 hours ago, dlrk said:

Having tested the same craft on Kerbin, Mun, and Minmus, on all three bodies the drift ceases when the craft is below 100km.

 

 

Now that you say that, I remember long time ago some dev saying that under a specific altitude things are not accurate, ie if you point your nose at a specific direction after some orbits the vessel accumulate drifting

here:

and here:

 

Edited by brusura

Share this post


Link to post
Share on other sites
4 hours ago, brusura said:

Now that you say that, I remember long time ago some dev saying that under a specific altitude things are not accurate, ie if you point your nose at a specific direction after some orbits the vessel accumulate drifting

I have noticed this is well before. This is actually a problem with KSP numerics, and is either part of the "Orbital Drift Compensation" fix that can be turned on/off in the Menu, or part of the Problem that it was supposed to fix.

Share this post


Link to post
Share on other sites

Dumb question...retrograde and progrande descent profile, refer to the navball markers in orbit or surface mode? :huh:

Edited by brusura

Share this post


Link to post
Share on other sites
5 hours ago, brusura said:

Dumb question...retrograde and progrande descent profile, refer to the navball markers in orbit or surface mode? :huh:

Surface mode. 

1 hour ago, willardy said:

Man, do you have plans to update to 1.4 and 1.4.1?

No, never.

Share this post


Link to post
Share on other sites
6 hours ago, Kobymaru said:
8 hours ago, willardy said:

Man, do you have plans to update to 1.4 and 1.4.1?

No, never.

LMAO :cool:

Share this post


Link to post
Share on other sites
On 3/14/2018 at 8:10 PM, Kobymaru said:

Surface mode. 

No, never.

Hmm. Strange. What caused this sudden shift in planning?  

...

What did jeb do this time....?

Share this post


Link to post
Share on other sites

Many people seem to think the mod is not precise but they just didn‘t set the orientation to retrograde. I suggest changing the default setting to retrograde as most craft enter the atmosphere in that orientation.

Share this post


Link to post
Share on other sites
4 hours ago, Human Person said:

Many people seem to think the mod is not precise but they just didn‘t set the orientation to retrograde. I suggest changing the default setting to retrograde as most craft enter the atmosphere in that orientation.

As of v2.0.0, Retrograde is the default :wink:

Share this post


Link to post
Share on other sites

@Kobymaru

Do you already have an idea, why the patches are not drawn anymore in KSP 1.4.1 when getting close with the camera? I am getting into coding and fiddling around a bit with the issue. Already looked at the issue, that the patches were not drawn when the navball ghost markers are  shown, but didn't got that solved. If you have an idea of direction, I maybe could help debugging here.

BR
JebsSY

Share this post


Link to post
Share on other sites

Shame about the timing of KSP 1.4.1 - I wanted to test and approve this PR for kOS with Trajectories today: https://github.com/KSP-KOS/KOS/pull/2220

But until there's a KSP 1.4.1 working release of Trajectories, I'm going to wait.  I want to do all new code kOS work on KSP 1.4.1 and only support KSP 1.3.1 through a backport, if at all.

Share this post


Link to post
Share on other sites

@Kobymaru

Was digging a little and I think I've found out, that maybe layer 31 will not be shown anymore when close... at least I got the patches back after setting mesh.layer to 24... but then they are not shown when far. :D:)
Found this here, too: https://forum.kerbalspaceprogram.com/index.php?/topic/84273-unity-layers-and-tags-updated-02-jan-2018/
Don't know which would be the best layer, but in worst case one could draw on 31 when camera is far and 24 when close depending on "MapView.Draw3DLines" ... but maybe another layer will be better, in any case.
 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.