Jump to content

[1.8-1.11.x] Trajectories v2.4.0 (2021-02-07) : atmospheric predictions


Recommended Posts

I'm having an issue with the Trajectories UI disappearing if I happened to pause the game by hitting escape, and no amount of fiddling with the toolbar button gets it come back up. I'm still able to see my trajectory in map view and I still get the nav markers, but I'm unable to access the GUI to turn it off or otherwise fiddle with it. Not sure if this is an issue already fixed and I'm just out of date or if its something new. 

 

Link to post
Share on other sites
16 minutes ago, G'th said:

I'm having an issue with the Trajectories UI disappearing if I happened to pause the game by hitting escape, and no amount of fiddling with the toolbar button gets it come back up. I'm still able to see my trajectory in map view and I still get the nav markers, but I'm unable to access the GUI to turn it off or otherwise fiddle with it. Not sure if this is an issue already fixed and I'm just out of date or if its something new. 

 

Read literally the previous message (and few more before).

Link to post
Share on other sites
  • 2 weeks later...
2 hours ago, dok_377 said:

Sadly enough the 1.8 update completely killed this mod. 

 

Not completely, no. It's not working by default, of course, but this little workaround will get it to work again until the proper rebuild and release happens:

cp GameData/Trajectories/Plugin/Trajectories17.bin GameData/Trajectories/Plugin/Trajectories18.bin

 

Good luck with your frogs!

Link to post
Share on other sites
On 10/18/2019 at 11:26 PM, yko said:
 

Not completely, no. It's not working by default, of course, but this little workaround will get it to work again until the proper rebuild and release happens:

cp GameData/Trajectories/Plugin/Trajectories17.bin GameData/Trajectories/Plugin/Trajectories18.bin

 

Good luck with your frogs!

Not completely, you are correct here. I totally forgot about this workaround. But this doesn't fix a storm of console errors. I would not want to use this mod like this, that's for sure. 

 

Edited by dok_377
I deleted images from imgur and now it's broken.
Link to post
Share on other sites
13 hours ago, dok_377 said:

Not completely, you are correct here. I totally forgot about this workaround. But this doesn't fix a storm of console errors. I would not want to use this mod like this, that's for sure. 

RUgYGl4.jpg9ecIIwk.png

It truly is a shame. We might have to wait some weeks before many of our beloved mods work again.

Link to post
Share on other sites
2 hours ago, BlondBoy2 said:

It truly is a shame. We might have to wait some weeks before many of our beloved mods work again.

On a major release and some of the minor ones, a wait of a month is usual.  Modders do this in their "time off".

Link to post
Share on other sites
6 hours ago, bigorangemachine said:

Add this to your Trajectories Mod Directory for KSP 1.8.

 

i.e. 

C:\Steam Games\SteamApps\common\Kerbal Space Program\GameData\Trajectories\Plugin

 

Whole patch here if you want to nuke your GameData/Trajectories.

Still getting a bunch of the same errors. But this time Trajectories is not even showing on the screen, only the GUI. 
qR3NaYZM9BY.jpg

Link to post
Share on other sites
4 hours ago, dok_377 said:

Still getting a bunch of the same errors. But this time Trajectories is not even showing on the screen, only the GUI. 
 

Hey Sorry I was sharing I rebuilt for 1.8.

I don't know what issue you are having :/ 

I'll check tonight to see if I get the same error; but I generally don't use 'in flight'.

Link to post
Share on other sites
26 minutes ago, bigorangemachine said:

Hey Sorry I was sharing I rebuilt for 1.8.

I don't know what issue you are having :/ 

I'll check tonight to see if I get the same error; but I generally don't use 'in flight'.

I am on 1.8.1 and this is the same errors I was getting when trying to use Trajectories from 1.7 with a renamed .bin file. If you scroll up a few messages you will see it, though the images do not work anymore. 

 

On 10/19/2019 at 7:02 AM, dok_377 said:

But this doesn't fix a storm of console errors. I would not want to use this mod like this, that's for sure. 

^ This. They were the same errors about matrix stack and some shader. I'm not sure if that's because I activated In-Flight mode, it happened as soon as I enabled Trajectories. 

Link to post
Share on other sites

No, it is due to In-Flight being enabled, actually. I just checked. Without it being enabled the mod doesn't throw a bunch of errors. It would be great if you or somebody else can fix this. This mod (as well as any other, probably) can't be considered fully operational if one of the core functions doesn't work properly. 

Update: Also, Trajectories WAS showing when I previously answered, I'm just a dummy who didn't even lower his periapsis into the atmosphere for it to appear properly. My apologies. @bigorangemachine

Edited by dok_377
Link to post
Share on other sites

I've created a pull request that fixes 1.8, but breaks earlier versions.  I suspect I can avoid the earlier version break.  It also fixes the ArgumentNullException

Until that fix is merged or superseded, a work around is to install 2.2.3 and then download the 18.bin from the pull request on github and place it in GameData\Trajectories\Plugin

https://github.com/neuoy/KSPTrajectories/blob/7c1ca247675d8bc4e649aaa63834d7f7fe9c682a/GameData/Trajectories/Plugin/Trajectories18.bin

 

Link to post
Share on other sites
5 hours ago, Devoblue said:

I've created a pull request that fixes 1.8, but breaks earlier versions.  I suspect I can avoid the earlier version break.  It also fixes the ArgumentNullException

Until that fix is merged or superseded, a work around is to install 2.2.3 and then download the 18.bin from the pull request on github and place it in GameData\Trajectories\Plugin

https://github.com/neuoy/KSPTrajectories/blob/7c1ca247675d8bc4e649aaa63834d7f7fe9c682a/GameData/Trajectories/Plugin/Trajectories18.bin

 

In-flight landing marker acts kind of strange. It disappears at a certain angle. Sometimes it disappears completely. Also, in map mode it shows above the terrain. No better way to show it than in a video: https://youtu.be/Sl415AoBYGc

Link to post
Share on other sites

I agree that looks weird. Not being a Unity guy this one is perhaps beyond my expertise.  I've tried a high and low graphics settings, looked at using other shaders, I can't reproduce the disappearing cross.

The cross being above the ground in map view is something that occurs in 1.7.3 with the released Trajectories 2.2.3, so nothing new here.

It might be worth you doing some testing yourself.  Does changing your graphics settings fix the problem?  Does an install without any visual enhancement mods have the problem?

Link to post
Share on other sites
6 hours ago, Devoblue said:

I agree that looks weird. Not being a Unity guy this one is perhaps beyond my expertise.  I've tried a high and low graphics settings, looked at using other shaders, I can't reproduce the disappearing cross.

The cross being above the ground in map view is something that occurs in 1.7.3 with the released Trajectories 2.2.3, so nothing new here.

It might be worth you doing some testing yourself.  Does changing your graphics settings fix the problem?  Does an install without any visual enhancement mods have the problem?

Deleted all the mods except Trajectories, same thing. Not a conflict. Tried changing the terrain shader quality and the render quality. Still nothing. 

Link to post
Share on other sites
  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...