Jump to content

[1.8-1.11.x] Trajectories v2.4.0 (2021-02-07) : atmospheric predictions


Recommended Posts

Just posting here to Confirm, but after upgrading my save to 1.11, this mod fails to show up and causes an error messsage when loading craft files of "Unknown Module" for TrajectoriesVesselSettings. I am guessing this is because the mod simply fails to load with 1.11, more than anything. 

Link to post
Share on other sites
11 minutes ago, SkyHook said:

Just posting here to Confirm, but after upgrading my save to 1.11, this mod fails to show up and causes an error messsage when loading craft files of "Unknown Module" for TrajectoriesVesselSettings. I am guessing this is because the mod simply fails to load with 1.11, more than anything. 

I'm having the exact same issue. It's also probably worth noting that I'm using FAR, but I'm not sure if it's related. 
I really hope this gets updated because this mod is amazing!

Link to post
Share on other sites

Related to the issue I posted about above, here is the log file: https://drive.google.com/file/d/1h9wN4o_7BHjIbudIMrxb1OE8BPUt2JfB/view?usp=sharing

I am running a fairly heavily modded game, so I wouldn't be surprised if a mod conflict is causing the issue. Although it seems other people are having the same issue, so maybe not. I looked through everywhere "trajectories" appears in the log file and it seems there are 3 interesting things: 

Line 3650: "[TrajectoriesBootstrap] ERROR: COULD NOT FIND TRAJECTORIES BIN FILE (Trajectories111.bin)! Ditching!"

Line 26665 (first appearance): "Cannot find a PartModule of typename 'TrajectoriesVesselSettings'" (this appears many times on many lines)

Line 42188 (and a few more): "Node 'TrajectoriesVesselSettings' found in loaded data, but 'LifeSupportModule' is defined in prefab.

Looking for TrajectoriesVesselSettings in other indices...
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

...no TrajectoriesVesselSettings module found on part definition. Skipping..."

Link to post
Share on other sites
48 minutes ago, SkyHook said:

Just posting here to Confirm, but after upgrading my save to 1.11, this mod fails to show up and causes an error messsage when loading craft files of "Unknown Module" for TrajectoriesVesselSettings.

 

36 minutes ago, JupiterJaeden said:

I'm having the exact same issue. It's also probably worth noting that I'm using FAR

I had it too, and don't use FAR so it's Trajectories probably all the way.

I found that if you remove and reattach the parts that give the error, you can then save and launch the craft.

So now the only problem is I don't know where I'm going to land :)

Link to post
Share on other sites

I can launch the craft and access it as normal, I just get the error in the "Open Craft" menu. Do you get the same thing?

1 hour ago, Superfluous J said:

 

I had it too, and don't use FAR so it's Trajectories probably all the way.

I found that if you remove and reattach the parts that give the error, you can then save and launch the craft.

So now the only problem is I don't know where I'm going to land :)

 

1 hour ago, Superfluous J said:

I found that if you remove and reattach the parts that give the error, you can then save and launch the craft.

I can launch the craft and access it as normal, I just get the error in the "Open Craft" menu. Do you get the same thing?

 
Link to post
Share on other sites
3 minutes ago, SkyHook said:

I can launch the craft and access it as normal, I just get the error in the "Open Craft" menu. Do you get the same thing?

No I couldn't launch it directly to the runway from the space center though that may have actually been a different issue.

The part affected for me was a radial parachute that I had put on in 1.10 for a part test contract that I'd not yet completed, and I think 1.11 made it so the parachute wasn't the same one as the one for the contract. So removing/replacing it fixed that. I never tried it again and now I'm away from my computer.

Link to post
Share on other sites

It's worth mentioning that with every major release of KSP you supposed to rename the .bin file for the mod to even show in game. For example, with KSP 1.11 the file name should be Trajectories111.bin, not Trajectories110.

Edited by dok_377
Link to post
Share on other sites
3 hours ago, dok_377 said:

It's worth mentioning that with every major release of KSP you supposed to rename the .bin file for the mod to even show in game. For example, with KSP 1.11 the file name should be Trajectories111.bin, not Trajectories110.

That worked for me! No issues loading or launching craft now. 

Link to post
Share on other sites
On 12/19/2020 at 12:41 AM, dok_377 said:

It's worth mentioning that with every major release of KSP you supposed to rename the .bin file for the mod to even show in game. For example, with KSP 1.11 the file name should be Trajectories111.bin, not Trajectories110.

I did this, but I still don't see the actual mod in the game for some reason. Any suggestions? Do you need to do something inside that file maybe?

Link to post
Share on other sites
2 hours ago, priles said:

I did this, but I still don't see the actual mod in the game for some reason. Any suggestions? Do you need to do something inside that file maybe?

No, nothing in the file itself. Did you rename the file that contains the version number in it or all of them? You only need to rename the one that contains numbers in the name.

Link to post
Share on other sites
On 12/21/2020 at 1:10 AM, dok_377 said:

No, nothing in the file itself. Did you rename the file that contains the version number in it or all of them? You only need to rename the one that contains numbers in the name.

I did, It restarted the whole computer and now it shows up. Not sure what happened the first time. Thank you!

Link to post
Share on other sites
Just now, dementatron21 said:

When will we be getting the 1.11 version?

Welcome to the forum, while it is not against the rules to ask for an update, so long as it is polite and non repetitive, our mod making community also have real life pressures and commitments to deal with as well as updating the great free content they create. It's best to be patient while we wait for our favourite mods to update.

Link to post
Share on other sites
7 minutes ago, dementatron21 said:

When will we be getting the 1.11 version?

the current version works in 1.11 if you do what the dok said just like 5 posts above yours. 

On 12/18/2020 at 3:41 PM, dok_377 said:

It's worth mentioning that with every major release of KSP you supposed to rename the .bin file for the mod to even show in game. For example, with KSP 1.11 the file name should be Trajectories111.bin, not Trajectories110.

 

Link to post
Share on other sites

Welcome to the forum @Dave7060, while it's not against the forum guidelines to request an update (so long as it is polite and not repetitive) please remember that our fantastic mod making community also have real life pressures and commitments so it's best just to be patient while awaiting updates.

Link to post
Share on other sites
8 hours ago, Dave7060 said:

hey the mod trajectories isn't working in ksp 1.11 plz fix it

Find Trajectories110.bin in Trajectories/Plugin, make a copy of it and rename to Trajectories111.bin. It is unsupported, and may miscalculate things for ultra-light crafts due to 1.11 specific changes to crewed parts. But it seems to work.

Link to post
Share on other sites
  • 2 weeks later...
56 minutes ago, petlahk said:

Trajectories does not seem to be working in 1.11.0. I've also noticed that there haven't been any new updates since July 2020? Is it still being maintained?

I'd suggest going to this thread:

 

Then go to the last page, read over the replies, see if anyone has reported the issue, and if there were any solutions mentioned.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...