JDP

[0.20] RemoteTech: Relay Network – V 0.5.0.1

Recommended Posts

Sorry to add to the growing list of questions here, but I can't get my joystick throttle to work on unmanned vessels.

No need to apologize. Thanks for the bug report though. I don't have a joystick and didn't really think about implementing axis controls in the fix. But now that you mention it, it's obvious to me that my fix excludes joystick users.

I've tried to rewrite the code a bit, though I have no way of knowing if it works now.

Would anyone happen to know a method to launch an unmanned but man-able vehicle...

I didn't, until a few hours ago when I finally found out how to do it. I've implemented the feature in V 0.3.5.1 :)

Share this post


Link to post
Share on other sites

Thx for your great update JDP!

One pseudo-bug reporting: I think you reset Remote Command crew requirement back to 5...

My Duna orbital mission command, which is occupied by 3 crew, ceased to work...

I quickly recognized this problem and changed .cfg crew requirement back to 3...

I think you should notify people about this!

Share this post


Link to post
Share on other sites
RemoteTech V 0.3.5.1 released

[*] Hopefully fixed compatability with axis controls for throttle.

I Don't currently have a way to test this, but I wrote a bit of code that hopefully restores axis compatability to RemoteTech vessels. Please provide any feedback as to whether it actually works now.

I tested it out with my throttle and it's reading the input now, but there's an issue with inverting it. My throttle needs to be inverted so I have the option checked in the input settings, but it's not inverted on unmanned vessels. Other than that, it works fine now.

Share this post


Link to post
Share on other sites

I haven't tested it yet but does the new version fix the problem where it doesn't recognize the mechjeb capsule version as being capable of local control?

I have a rocket that has a mechjeb capsule and two comsats with enough fuel to position both in geo syncronous orbits. Unfortunately I can't put the ship under local control so once it gets out of range of KSP, I lose control.

I haven't downloaded the new version yet to test since I am still at work but hoping someone else has run into this problem....

Share this post


Link to post
Share on other sites

Hey it seems that with a mechjeb pod andone of your command pods, mechjeb ascent autopilot wont auto throtle correctly

Share this post


Link to post
Share on other sites

Concurring with the posts above mine, the throttle is inverted for me, cannot accept my keyboard commands, and mechjeb has no idea how to use the throttle control. Workable none the less, I just have to do the legwork myself... well... handwork. Thanks for the mod, hope the bugs can be fixed.

Share this post


Link to post
Share on other sites
...I think you reset Remote Command crew requirement back to 5...

I don't think I did. Did you remember to delete the old config file from 0.35?

Concurring with the posts above mine, the throttle is inverted for me, cannot accept my keyboard commands, and mechjeb has no idea how to use the throttle control....

Unfortunately the throttle fix does break some MechJeb compatability. I basically had the choice between compatability with KSP or MechJeb. It might be possible to do som pseudo complex trickery to re-add MechJeb compatability though. But it would take quite a bit of work to do so.

I've taken another crack at implementing joystick controls for throttle and I think I should have fixed the issues of inverted controls (basically I guessed wrongly in 0.3.5.1) And I've done some work to make joystick-throttle controls work at the same time as keyboard-throttle controls.

I've attached the test-build here. Try it out and let me know if it works properly now. If it does, I'll release it in the OP.

Share this post


Link to post
Share on other sites
I don't think I did. Did you remember to delete the old config file from 0.35?

Unfortunately the throttle fix does break some MechJeb compatability. I basically had the choice between compatability with KSP or MechJeb. It might be possible to do som pseudo complex trickery to re-add MechJeb compatability though. But it would take quite a bit of work to do so.

I've taken another crack at implementing joystick controls for throttle and I think I should have fixed the issues of inverted controls (basically I guessed wrongly in 0.3.5.1) And I've done some work to make joystick-throttle controls work at the same time as keyboard-throttle controls.

I've attached the test-build here. Try it out and let me know if it works properly now. If it does, I'll release it in the OP.

I have found a work around, if you use the mk1 command as reinstated by this mod and put a mechjeb BELOW it, it will work.

Share this post


Link to post
Share on other sites

On the mechjeb front, I noticed that remote tech does not recognize the mechjeb pod as a command module.

local control is disabled if you don't actually have a manned pod on your rocket.

I just confirmed by replacing the mechjeb pod with the mk1 pod and local control was available.

Share this post


Link to post
Share on other sites

JDP, do you mind if I add some compatible parts to the M-209 SPHERE? Is there a limitation on dish and UHF you'd like me to impose for the system?

Share this post


Link to post
Share on other sites

Not sure if I'm being dense or something, but I think I've got a bug.

I'm attempting to launch a satellite off of a manned Mk 2 pod. I launch the satellite no problem, command from the pod works fine. However, once I jettison the remote command pod, I cease to be able to execute the remaining stages of the rocket (namely, the parachutes). When I attempted this with a 1-man pod (not noticing the 3-man requirement), I wasn't able to maneuver the pod whatsoever.

Share this post


Link to post
Share on other sites
JDP, do you mind if I add some compatible parts to the M-209 SPHERE? Is there a limitation on dish and UHF you'd like me to impose for the system?

No problem.

I'd recommend that you link to RemoteTech and not include the dll in your download. It isn't a requirement though.

Regarding limitations, I'd like some extra weight or drag on RemoteCommand and interplanetary range dishes. No omnidirectional antennae should have longer ranges.

Share this post


Link to post
Share on other sites
No problem.

I'd recommend that you link to RemoteTech and not include the dll in your download. It isn't a requirement though.

Regarding limitations, I'd like some extra weight or drag on RemoteCommand and interplanetary range dishes. No omnidirectional antennae should have longer ranges.

Thanks! I usually only link to plugins, but I'll also keep in mind the drag issue. I'm thinking 10k max for the whip.

Share this post


Link to post
Share on other sites

so i got a 95 % stable command system consisting of 4 manned comstations: Owl Overwatch 24, 25, 26 and 27.

now heres my question: is it possible that i mod the probedyne capsules into remotepods, send it into high kerbin orbit as an unmanned relay?

Share this post


Link to post
Share on other sites

I've taken another crack at implementing joystick controls for throttle and I think I should have fixed the issues of inverted controls (basically I guessed wrongly in 0.3.5.1) And I've done some work to make joystick-throttle controls work at the same time as keyboard-throttle controls.

I've attached the test-build here. Try it out and let me know if it works properly now. If it does, I'll release it in the OP.

Strange things are happening now. :) With my throttle inverted in the settings, any movement I make with it makes the gauge jump up a little and then go back to zero. When I don't have it inverted it works as if I had it inverted, but at about 90% on my joystick throttle the gauge reads 100%.

Share this post


Link to post
Share on other sites

Unfortunately the throttle fix does break some MechJeb compatability. I basically had the choice between compatability with KSP or MechJeb. It might be possible to do som pseudo complex trickery to re-add MechJeb compatability though. But it would take quite a bit of work to do so.

are we gonna get fix for mechjeb anytime soon? or is it hard work? :)

Share this post


Link to post
Share on other sites
Strange things are happening now. :) With my throttle inverted in the settings, any movement I make with it makes the gauge jump up a little and then go back to zero. When I don't have it inverted it works as if I had it inverted, but at about 90% on my joystick throttle the gauge reads 100%.

Dang! I think I'd need a joystick to properly implement and test this. Which is somewhat of a problem since I don't really have the money to buy one. I'll see what I can figure out.

are we gonna get fix for mechjeb anytime soon? or is it hard work? :)

Don't count on it hapenning anytime soon. It would be a whole new line of programming for me to get acquainted with and I don't simply want MechJeb to be able to activate local control. I'd want there to be signal delay for each MechJeb button press.

So basically I'll probably write a basic autopilot for RemoteTech before I make it fully MechJeb compatible. I think that would probably be easier.

Edited by JDP

Share this post


Link to post
Share on other sites
Dang! I think I'd need a joystick to properly implement and test this. Which is somewhat of a problem since I don't really have the money to buy one. I'll see what I can figure out.

Don't count on it hapenning anytime soon. It would be a whole new line of programming for me to get acquainted with and I don't simply want MechJeb to be able to activate local control. I'd want there to be signal delay for each MechJeb button press.

So basically I'll probably write a basic autopilot for RemoteTech before I make it fully MechJeb compatible. I think that would probably be easier.

can you solve my question to :D?

Share this post


Link to post
Share on other sites

Am i the only 1 to get weird behavior with stage seperation? i have as the main module the remotetech Grey control thing for my satelite, and another 1 on my rocket and whne i seperate both pods it automatically triggers all seperations to seperate effectivly screwing up my whole rocket.

Share this post


Link to post
Share on other sites

Dang! I think I'd need a joystick to properly implement and test this. Which is somewhat of a problem since I don't really have the money to buy one. I'll see what I can figure out.

I did a Google search and found this which could save you the trouble of buying a joystick: http://www.autohotkey.com/community/viewtopic.php?t=50596

I've never used it, but it's supposed to emulate a joystick using a mouse or keyboard. For testing purposes, this might work.

Share this post


Link to post
Share on other sites

A couple questions:

Does this plugin have the "range" for interplanetary communication?

Also, would this allow me to put a crew in a crew-able "strut" to control a rover that I could drop off?

Share this post


Link to post
Share on other sites
...I'm attempting to launch a satellite off of a manned Mk 2 pod. I launch the satellite no problem, command from the pod works fine. However, once I jettison the remote command pod, I cease to be able to execute the remaining stages of the rocket (namely, the parachutes). When I attempted this with a 1-man pod (not noticing the 3-man requirement), I wasn't able to maneuver the pod whatsoever.

Currently remote controlled vessels have to be one-stage. It shouldn't mess with the staging of your main vessel though.

Regarding your control issues. Have you remembered to add antennae to your vessels? or you might simply be out of range. I've had no luck trying to recreate your bug so I think it might be caused by your vessels not having a signal connection.

...is it possible that i mod the probedyne capsules into remotepods, send it into high kerbin orbit as an unmanned relay?

Sure. As long as the parts are not allready using a plugin you can freely edit the parts config file for it to be RemoteTech, RemotePod or RemoteSAS, depending on what function you want it to fulfill.

But remember that other variables are needed too. Look in the config files for the RemoteTech parts to see what variables you will need.

I did a Google search and found this which could save you the trouble of buying a joystick: http://www.autohotkey.com/community/viewtopic.php?t=50596

Thanks for the tip. I'll look into it as soon as I get the time.

...Does this plugin have the "range" for interplanetary communication?

Also, would this allow me to put a crew in a crew-able "strut" to control a rover that I could drop off?

The interplanetary class dish included in this plugin has more than enough range for interplanetary travel (hence the name :)).

You don't really need crew on your vessel in order to be able to control it. The only crew requirement I've set is that you have at least 3 for RemoteCommand to work and at least 1 in order to use local control. It doesn't matter if the crew are in a strut, pod or any other kind of part.

Share this post


Link to post
Share on other sites

I have a Problem! I startet A Sattelite with the 5000km Antenna! Then it was out of range! so i startet a second one with a 5000km antenna and a dish (this sattite is for Communication to the Mun!) So and i Startet a rover with a dish. but the dish dont get any connection, can someone tell me why? I dont get this Sattelites in radio range -.-

Share this post


Link to post
Share on other sites
I have a Problem! I startet A Sattelite with the 5000km Antenna! Then it was out of range! so i startet a second one with a 5000km antenna and a dish (this sattite is for Communication to the Mun!) So and i Startet a rover with a dish. but the dish dont get any connection, can someone tell me why? I dont get this Sattelites in radio range -.-

You probably don't have line-of-sight to the space centre. Radio doesn't work through the planet - you have to be able to see what you want to communicate with.

Share this post


Link to post
Share on other sites

So I have this, I have the satellite relay plugin, I have a bunch of debris with a signal to ksp, this debris has an RC module and engines and regular S.A.S, but I have no attitude control. All I can do is throttle up the engines. Both me and mechjeb are unable to actually make the debris turn. What am I missing?

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.