JDP

[0.20] RemoteTech: Relay Network – V 0.5.0.1

Recommended Posts

Cart.dll v1.34 is released. Verified to be compatible with RemoteTech v0.34.

Awww, driving with 4 seconds delay is hard :sticktongue:

Share this post


Link to post
Share on other sites
Cart.dll v1.34 is released. Verified to be compatible with RemoteTech v0.34.

Awww, driving with 4 seconds delay is hard :sticktongue:

I've just removed my modified Cart v1.32 plugin from the download. It's going to be very fun to play with all the new features in Cart :).

Share this post


Link to post
Share on other sites

Can someone make a tutorial? i cant seem to use it correctly...

Share this post


Link to post
Share on other sites
Guest butt head

1. Engines attached directly to the decoupler that controllable Debris is decoupled from break once focus is switched away from and back to the Debris

no all the decouplers disappear so you cant have staging :(

Share this post


Link to post
Share on other sites

This seems like a mod I could definitely get into... given I had the right tutorials to brush up on. As it stands right now, I'm only given the slightest clue as to how it works.

Share this post


Link to post
Share on other sites
This seems like a mod I could definitely get into... given I had the right tutorials to brush up on. As it stands right now, I'm only given the slightest clue as to how it works.

Yeah I've been playing with the idea of doing a video tutorial. Though it will have to wait a long time, since I'm currently way to busy to do any work on this plugin. For now, you will need to do some reading. the "which parts are needed for what" tab in the OP is a very good place to start. It gives you pretty much all the basic info you need.

Share this post


Link to post
Share on other sites

Love the mod, gives me a fun goal of setting up a sat network. Got a Interplanetary class sat in geosync over the KSC and 3 more in the same orbit at opposing sides, i never loose a signal :P

But I am having some trouble with the remote pods. I set-up a swarm launcher to send 5 sat's into orbit in one launch to save me some time, and I found an issue, the 4 other sat's equipped with remote pods, antennas, mechjeb, an advanced SAS module, Ion drive for positioning and plenty of RCS are 100% unstable. its impossible to control the direction they are facing to change my orbit, they just slowly flip about and no amount of RCS seems to slow them down, they lack SAS completely and are unresponsive to even crazy amounts of RCS.

my current save has 4 sat's in geosync so i don't need to launch more into orbit around kerbal, but I still would like help with the stability of this set up to launch a swarm around the mun and around Minmus.

Share this post


Link to post
Share on other sites
...they just slowly flip about and no amount of RCS seems to slow them down, they lack SAS completely and are unresponsive to even crazy amounts of RCS...

That sounds like the known MechJeb bug. try removing all MechJeb from your 4 secondary satellites and the problem should be gone. Remember to add a RemoteSas though, since it gives you'r debris gyro control and you won't have to rely on RCS.

Share this post


Link to post
Share on other sites

Hi Guys!

I installed the tool and it works properly, I have build a Kerbal Positioning System with many Satellites in polar orbits and some in geostationary orbits so they have always a connection to each other... It shows the Blue lines and looks very neat, but what the hell is the purpose? I don't know how to remotly control other vessels and see no need in it, because you can switch between them in the orbital view....

Not that anything in KSP has a real purpose, but I want this mod to have one, because it's FRIKKING AWESOME!

If I can't to anything special with them I keep on sending stuff into orbits to make a perfect Relay Network!

:-D

Share this post


Link to post
Share on other sites
...I don't know how to remotly control other vessels and see no need in it, because you can switch between them in the orbital view...

Whenever you control unmanned vehicles you are in fact remotely controlling them. Try flying an unmanned mission to minmus (for example use the RemotePod) and you will really start to feel the signal delay in the control signal.

The main purpose of this plugin is to make the game a bit more realisticy and a lot more challenging, by adding in unmanned vehicles that still cannot control themselves, but need kerbals somewhere at a command station. If you just want unmanned vehicles (and controllable debris), but don't want to worry about relay networks and control delays, I'd recommend MechJeb, which is indeed an awesome plugin.

Share this post


Link to post
Share on other sites

Question. Can this thing receive signals from the far side of Kerbin?

Basically, will the planet block the signal. Cos I launched the 5000KM antenna to be my main 'low orbit' antenna for a test... and... nothing. It's almost instantly out of contact with KSP.

Share this post


Link to post
Share on other sites

Ye gods. How does your program even RUN? I tried that with just mechjeb probes and it nearly had a heart attack! o.O

How many do you recommend, and with which antennae?

[edit] And, will they auto-acquire signal?

[edit] Is there any known conflict with MechJeb and this? o.O I can't engage my RCS systems after a certain point, and with no reason. Once I hit 'coasting to apoptosis' I can't engage RCS. I hit the button, it flickers briefly, and then turns RIGHT back off.

Edited by Tassyr

Share this post


Link to post
Share on other sites

damn. I guess that's it. I can't really function without mechjeb. There's no workarounds?

Share this post


Link to post
Share on other sites

IF you can deorbit any part that uses mechjeb before saving, you should be ok. what causes the most problems is having MJ and RT in the same persistence file as they tend to clash

as an alternative to MJ, you could look into Engineer, which gives you orbital information without having any command modes

Share this post


Link to post
Share on other sites
It could very well be a KSP bug, but since so many other plugins are involved it could just as easilly be one of those, or a cross-effect between any number of them or even KSP. It's very hard to diagnose with this many possible factors. Thankfully it seems as though it's a rare bug. Still, I think I might build in a little extra bit of exception handling in 0.4 just to be safe. Since one possibility is that the problem shows itself because something throws an unhandled exception.

A little more 0.4 news:

Debris activation: I've taken a look at Zools major contribution to my debris activation method and am looking into adding it in 0.4. He basically found a way of keeping the staging setup in decoupled debris, which is a huge leap forward.

Combined with Alchemist's idea for making crewable but uncrewed vessels remotecontrolled, this could be a great addition to RemoteTech. As it is right now, it will however not work with MechJeb. I'm looking into a way of disabling RemoteTech activation if there is a MechJeb present on the vessel, so I don't end up forcing you to chose between RemoteTech and MechJeb.

can not decide where i need to write this (Zools mod or Here)

i know its been asked before i read all pages on zools and here just wondering the progress...

heres my mission plan not work cause of loosing stages on lander;

missionplan.jpg

any idea for how to do this ? oke i can open lander parachute when decoupling but no more looks seems ? so lander cant saperate from its heatshield, covers or parachute ect while landing... :(

orbiter will stay at mun orbit and help to cominicate lander to mission control i know 1 orbiter not enugh but thats the same happened curiosity at landing they lost connection after orbiter go out of sight and regain after orbiter back... its not a problem adding some realism...

my spacecraft looks like this (at least inspired :P) http://en.wikipedia.org/wiki/File:Cassini-huygens_anim.gif both orbiter and lander unmanned

Edited by ashrutoraman

Share this post


Link to post
Share on other sites

A parachute on the mun? It won't even open without an atmosphere there...

Share this post


Link to post
Share on other sites

You don't need a Mun Orbiter relay sat if you land on the near-side of the Mun. The lander will always be in the line of site, whereas the relay sat will be behind the Mun half of the time. Just put a dish on the lander (instead of the parachute and heatshield which are useless).

Share this post


Link to post
Share on other sites
A parachute on the mun? It won't even open without an atmosphere there...

its not the point lol... (currently testing on kerbal itself)... adding stage retro rockets for actual mun mission not changing result... :)

You don't need a Mun Orbiter relay sat if you land on the near-side of the Mun. The lander will always be in the line of site, whereas the relay sat will be behind the Mun half of the time. Just put a dish on the lander (instead of the parachute and heatshield which are useless).

well i was thinking to land far side of the mun... actually its the main purpose of mission :D:P

Edited by ashrutoraman

Share this post


Link to post
Share on other sites
this does NOT play nice with mechjeb

Funny, I've been launching dozens of rockets with this addon both RC and crewed with no problems. MechJeb has some issues of its own that are still being resolved that might be exacerbated by the addon, but if you're just using a single MechJeb per rocket, I've not run into any problems.

Share this post


Link to post
Share on other sites
this does NOT play nice with mechjeb

I know the most current version of MechJeb has a lot of issues in it's debris activation method, which (I guess) might theoretically be exacerbated by my activation method.

I don't really use MechJeb myself and haven't really had the time to test my plugin with it. That being said, I'd for sure like my plugin to be compatible, since so many players rely on MechJeb.

I would be very thankful for a list of any and all bugs you may find. But make sure you tell me:

  • what happened
  • how it happened
  • and make sure the problem is not solely with MechJeb (I.e.: the bug goes away if you do exactly the same but have removed all RemoteTech parts from the vessel)

These kinds of bug reports are a huge help in development, as you guys are in essence all beta testers :D.

r4m0n will probably be changing debris activation quite a lot in v1.9.2 of MechJeb, fixing the current issues with MechJeb and, I expect, improving the current knowledge on how to do debris activation. so I will understandably be a bit cautious with doing too much compatibility work before then.

Regarding having the current version of RemoteTech be compatible with MechJeb 1.9.1, I'd advise you to follow CAPFlyer's advice. I'd add that the absolute safest place to put your single MechJeb is somewhere where you never decouple it from the main vessel. That way, MechJeb activation should never even try to run. This way, you will sadly loose any MechJeb functionality in your decoupled vessels. Personally, I can live with that, since my plugin is all about the challenge and the very punishing and exhilarating possibility of complete fantastic failure. :)

RemoteTech 0,4 status update:

...here's my mission plan[, it does] not work cause of loosing stages on lander...

Zools method is a planned feature for 0,4. The current version of RemoteTech only supports single-stage debris and will not work with Zools mod.

As of now, development of 0,4 is temporarily on hold. It will be some time before I can resume work on the plugin, as I've since summers end become an intern. This first period of the internship is very intensive and leaves me just about enough spare time to sleep, eat, and occasionally write some responses here. Once September draws to a close, I should have time to restart development on a part time basis. But for the time being, my patients must take precedence over this project. I hope you all understand :)

Share this post


Link to post
Share on other sites

I would be very thankful for a list of any and all bugs you may find. But make sure you tell me:

  • what happened
  • how it happened
  • and make sure the problem is not solely with MechJeb (I.e.: the bug goes away if you do exactly the same but have removed all RemoteTech parts from the vessel)

Here's what happened, essentially- and removal of RemoteTech parts did fix it. I had RCS thrusters mounted on my craft to assist in aiming/turning. I launch it. About the time that MechJeb starts its gravity turn it suddenly turned off RCS. Thinking this was odd, I let the thing run normally. When Mechjeb attempted to compensate so that it could circularize the orbit, it failed. Having checked things, the combination of RemoteTech and MechJeb seems to utterly disable RCS/SAS both, outside of atmosphere. I have no idea why.

Hope that's enough info.

Share this post


Link to post
Share on other sites
... for the time being, my patients must take precedence over this project.

Pfft. Pretty selfish attitude you have there ...

JOKING!!

:sticktongue:

Hope to see you back soon ad bring the goodness with you. :)

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.