• 0

Question

At first I thought it was my imagination, but it has now happened twice.  I have a long-duration unmanned space probe on an interplanetary trajectory (inwards, towards EVE) that simply disappeared!   It doesn't appear anymore on the Interplenatary Map view, nor as an object listed in the Tracking Station (which is now fully upgraded in my career).

The vehicle was a "Sentinal Class" space probe that I launched to fulfill one of my career mode missions - in this case to track/map asteriods.  It was a pretty basic interplanetary probe, though equipped with one of those large "Sentinal" camera/scanners.

I was so  concentrated on doing my first "kerballed" Duna flight I didn't notice exactly when it happened. 

So last night I relaunched my "Sentinal" mission, and had successfully sent it on an escape trajectory from Kerbal.   But, after switching to map mode and back to tracking station - this second Sentinal was also gone!

What's going on?  Is there a maximum number of objects that perhaps I exceeded?   Or is this some sort of bug/glitch in the Tracking Station mode?

I cleared out a few of my "debris" objects and will now re-launch a third mission.  But if there is some maximum count limit I should avoid, it would be good to know this.  Fortunately, the lost probes are un-manned.  It would be a shame to lose an actual crew this way!

Share this post


Link to post
Share on other sites

8 answers to this question

Recommended Posts

  • 1

Thanks for all your kind words and suggestions!   It turned out I did indeed hAve the Relay Sats display filtered OFF in Tracking Display.   Turning it back on revealed I now had all of my Sentinels back! And also another Duna-1 Unmanned probe which I thought was also lost a few weeks ago!

So all seems OK now.  

I did clean up some.of the assorted space junk floating around the Kerbol system though ;-)!

Share this post


Link to post
Share on other sites
  • 0

Welcome to the forums.

And yes, there are maximum part count and ship count limits, and the game does autodelete scrap. Look in your Main Settings, under "Max Persistent Debris." It is supposed to only delete things that are marked as "debris". But if you are running out of memory, it can get more aggressive about the autodeletions, AFAIK. And I have heard many anecdotal cases of people with hundreds of pieces of debris scattered around having unmanned ships disappear. Actually, if you have a savegame in your Backup folder from around the time you launched one of your Sentinel ships, I'd love to have it -- provided your game isn't modded. If it's modded, all bets are off.

 

Edited by bewing

Share this post


Link to post
Share on other sites
  • 0
57 minutes ago, linuxgurugamer said:

Make sure you aren't filtering it away.

Hi @JStevenson

I agree with what linuxgurugamer said.

It's a habit of mine to keep the relays hidden in map mode and tracking station, but if you launch an unmanned probe with a relay dish then it gets marked as a relay automatically. You won't see it if you have the filter for relays turned off on that bar at the top.

Edited by HvP

Share this post


Link to post
Share on other sites
  • 0
14 minutes ago, bewing said:

Welcome to the forums.

And yes, there are maximum part count and ship count limits, and the game does autodelete scrap. Look in your Main Settings, under "Max Persistent Debris." It is supposed to only delete things that are marked as "debris". But if you are running out of memory, it can get more aggressive about the autodeletions, AFAIK. And I have heard many anecdotal cases of people with hundreds of pieces of debris scattered around having unmanned ships disappear. Actually, if you have a savegame in your Backup folder from around the time you launched one of your Sentinel ships, I'd love to have it -- provided your game isn't modded. If it's modded, all bets are off.

 

I don't believe that, about the game deleting anything other than debris.

It's probably user error. I once experienced one of your anecdotal situations, where the game deleted an entire functional service module that I had left up in a parking orbit around Duna while I explored the surface. There was nothing wrong with it, it was a perfectly serviceable craft that was basically a huge tank of LF+O with an NTR (this was basically stock; no Real Fuels. Quite a while ago) and some solar panels, a monoprop tank and a Sr docking port. I totally did not think of it as debris but it was so marked because it didn't have any manned pods or a probe part or anything else to mark it as anything other than debris. And while I as on the surface, I exited to main menu and turned down the max allowable amount of debris. And eventually came back to my Duna mission, launched them into orbit and then starting hunting around for the service module so they could dock up and return to Kerbin.

And of course, it was gone. I too wondered if it had been some kind of bug and said to myself that maybe the game got too aggressive about garbage deletion. And I went into the VAB to spawn another ship to send to Duna to rescue the Kerbals there. And discovered after removing the crewed components that I couldn't control the craft at all. I had THOUGHT there was a large probe control part but of course there wasn't. It was just a Sr docking port, a large tank, some solar panels and an NTR engine. In other words: Debris.

Not to me of course, it was perfectly serviceable in the capacity that I had originally designed it for as it hadn't been originally designed for autonomous operation.

So that's probably where your anecdotal cases come from. It's just that I recognize the PEBCAK and own up to it.

 

 

Share this post


Link to post
Share on other sites
  • 0

If it wasn't hidden, then unfortunately, Kraken!  

It can happen even without alot of debris. I lost some of my mapping sats (SCANSAT mod) once for no discernible reason and they definitely

  • had probe control to get into the required polar orbit in the first place, nothing to stage oncein orbit
  • were nowhere near atmosphere, surface, other ships
  • <50 pieces of debris, it was early game and I was mapping Kerbin and the Mun

Use the debug menu to put the replacements into orbit if you feel it was completely unfair. Especially since it's a long way to get that Sentinal sat into correct position. Hyperedit has a graphical mode that might be better for what you might end up doing.

Share this post


Link to post
Share on other sites
  • 0
7 hours ago, bewing said:

... I have heard many anecdotal cases of people with hundreds of pieces of debris scattered around having unmanned ships disappear... 

 

6 hours ago, Starwaster said:

I don't believe that, about the game deleting anything other than debris.

It's probably user error. I once experienced one of your anecdotal situations... 

To make it clear: The only thing you both can say for sure is "I don't know" .  It may be anything,  but there is no evidence to support any hypothesis. 

If you are convinced that we don't know what happened,  now let's try to find it. 

@JStevenson did you left the craft alone long enough to give a chance to something bad happen?  (e.g inadvertently left in collision course with Mun)  

Save your game and try to reproduce it again.  This time with all attention in it. 

While you are in control of the vessel, check if its not tagged a different way than you expected (e.g rover; relay)  and if this type is set to be displayed. Check your trajectory if there's a chance of a celestial body(including Kerbin) disturb it.  Only after you are sure to get covered all possible mistakes from your part switch away from the vessel and look for it in the tracking station and/or map mod. 

 

Share this post


Link to post
Share on other sites
  • 0

Recently in my last career I suddenly lost about 1/3 of my ships, all over the system.  I'm career they did not all hit something at the same time,  and the Kerbals did not show as killed.   They were just.. gone.  Not even listed in the save files.   I could not figure it out,  so I took the opportunity to start a new career.

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.